1с после обновления не работает веб сервер

Веб-сервер. Не работает интернет-поддержка и сервисы в Рознице

В журнале две ошибки подряд появляются
При обращении по URL: https://update-api.1c.ru/update-platform/programs/update/ping
Подключение проводится из файловой базы на компьютере .
Сервер update-api.1c.ru не доступен по причине:
— неполадки у интернет-провайдера;
— подключение к серверу блокирует межсетевой экран,
антивирусная программа или другое программное обеспечение;
— сервер отключен или на техническом обслуживании.

Журнал диагностики:
Выполняется проверка доступности сервера.
Описание диагностируемой ошибки см. в следующем сообщении журнала.

Параметры прокси-сервера в ИБ: Не использовать прокси-сервер.
Соединение выполняется без использования прокси-сервера.

1) Удаленный сервер update-api.1c.ru не доступен:
> ping update-api.1c.ru -n 2 -w 500

Обмен пакетами с update-api.1c.ru [185.12.155.68] с 32 байтами данных:
Превышен интервал ожидания для запроса.
Превышен интервал ожидания для запроса.

Статистика Ping для 185.12.155.68:
Пакетов: отправлено = 2, получено = 0, потеряно = 2
(100% потерь)

2) Удаленный сервер 1c.com доступен:
> ping 1c.com -n 2 -w 500

Обмен пакетами с 1c.com [192.169.215.137] с 32 байтами данных:
Ответ от 192.169.215.137: число байт=32 время=255мс TTL=55
Ответ от 192.169.215.137: число байт=32 время=257мс TTL=55

Статистика Ping для 192.169.215.137:
Пакетов: отправлено = 2, получено = 2, потеряно = 0
(0% потерь)
Приблизительное время приема-передачи в мс:
Минимальное = 255мсек, Максимальное = 257 мсек, Среднее = 256 мсек

Источник

Как исправить ошибку запуска веб-сервера Apache после обновления платформы 1С

❓ Вопрос подписчика: « Как исправить ошибку запуска веб-сервера Apache после обновления платформы 1С на новую x64-версию? »

📝 Сообщение об ошибке:

« Syntax error on line 121 of C:/Program Files (x86)/Apache Software Foundation/Apache2.2/conf/httpd.conf: Cannot load C:/Program Files (x86)/1cv8/8.3.12.1790/bin/wsap22.dll into server »

Сообщение об ошибке из журнала Windows

Причина

Служба «Apache2.2» не стартует из-за того, что не загружается указанная в параметрах библиотека wsap22. Скорее всего, что устаревшая платформа удалена, а файл — отсутствует.

Решения

1. Сохраните файл с настройками httpd.conf и папку «Apache sharing», переустановите Apache на x64-версию.

Остановите службу веб-сервера, поменяйте путь к библиотеке на «C:\Program Files\1cv8\8.3.xx.xxxx\bin\wsap22.dll» и запустите сервис.

Проверьте пути к расположению каталогов, содержащих параметры подключения к базам (default.vrd).

2. Либо найдите x86-версию файла wsap22, скопируйте файл на ПК. Укажите в настройках Apache новый путь к расположению этой dll и заново запустите службу.

✅ Эти рекомендации помогут запустить веб-сервер Apache с теми опубликованными базами, которые были до обновления платформы.

⚡ Подписывайтесь на канал или задавайте вопрос на сайте — постараемся помочь всеми техническими силами. Безопасной и производительной работы в Windows и 1С.

Источник

После обновления не работают web-сервисы

(0) писать версию надо полностью, 188 релиз какой? 44? 43? в 43 тоже больше сотни было ревизий.

(1) Нет. Не эта ошибка.
У кого-нибудь автозаполнение кондрагента по ИНН работает .

У меня пишет так:

ИНН 6666666666:
по причине:
При вызове веб-сервиса произошла ошибка. Ошибка вызова операции сервиса: :RequisitesWebServiceEndpointImpl7Service:getCorporationRequisitesByINN()
по причине:
При вызове веб-сервиса произошла ошибка. Неизвестная ошибка. Ошибка работы с Интернет: Не могу установить соединение
по причине:
Ошибка работы с Интернет: Не могу установить соединение

Напишу сводно что нашел и как решил.

Читайте также:  Если сотрудник работал не полный месяц

(Главное меню — Все функции — Регистры сведений — Кэш программных интерфейсов).
В открывшемся списке необходимо найти и удалить запись со значением в колонке Идентификатор https://api.orgregister.1c.ru/orgregister/v7?wsdl.
После этого пользователи, у которых возникала ошибка при заполнении реквизитов, должны выйти из программы и войти снова.
2) По подписке ИТС:Проф или «1С:Контрагент 12 месяцев» — ограничение на количество заполнений по ИНН : 7200 операций.
3) адреса web-сервисов могут попасть в фильтр антивирусника
4) Для нормальной работы сервисов требуется, чтоб не только клиент смотрел в интернет, но и чтобы у сервера 1С предприятия была возможность.

У меня после смены сетевого железа выросла ошибка работы с 1С-Отчетностью и 1С-Контрагент — «Превышено время ожидания». При этом все настройки интернет-поддержки стояли «Прокси — системный; выход в инет с клиента». на сервере 1С прописали шлюз для выхода — все взлетело.

Источник

Настройка веб-сервера IIS

Большинство пользователей при работе в тонком или веб-клиенте используют в основном публикацию информационных баз на основании протокола HTTP. С одной стороны — это простой и быстрый способ дать доступ к информационной базе пользователю, у которого нет дистрибутива тонкого клиента, и он может работать только в веб-клиенте или у пользователя нет прямого доступа к серверу «1С:Предприятие». С другой стороны – информационные базы, опубликованным таким образом, категорически не рекомендуются публиковать в глобальной сети Интернет, так как в таком случае используется незащищенный канал, данные по которому могут быть перехвачены злоумышленниками. Например, распространенные виды атак это:

Решением этих проблем является использование расширения протокола HTTP и в данной статье рассмотрены публикации информационных баз с использование протокола с шифрованием (HTTPS) для веб-сервера IIS.

Внимание! В статье не рассматривается выпуск и получение сертификата проверенных поставщиков. Этот пункт должен быть выполнен самостоятельно на основании предпочтений выбора провайдера услуг. В статье предполагается что, пропуская шаг выпуска самоподписанных сертификатов, у пользователя или администратора он имеется в наличие и будет подставлен в настроечные файлы, вместо указанных в статье самоподписанных сертификатов.

План работ:

Включение компонент веб-сервера.

Windows Server 2012 R2, 2016 и 2019.

Выпуск самоподписанного сертификата (Необязательно).

1. Включение компонент веб-сервера

По умолчанию в операционной среде Windows компоненты веб-сервера не установлены. В зависимости от версии установка может несущественно различаться. Мы будем рассматривать два варианта – это распространенный дистрибутив Windows 10, если планируются использовать для пробного включения шифрования протокола и Windows Server 2016/2018, если уже планируется непосредственное разворачивание публикации в продуктивной зоне.

1.1. Windows 10

Включение компонентов веб-сервера IIS в операционной системе Windows 10 выполняется достаточно просто. Для начала нужно открыть раздел «Программы и компоненты» («Programs and Features») в панели управления (Control panel). Сделать можно это несколькими способами:

Нажать сочетание клавиш Win + R и в открывшемся окне ввести «appwiz.cpl» и нажать ОК.

Открыть панель управления (Control panel) и выбрать пункт меню Программы – Программы и компоненты (Programs – Programs and features).

В окне «Программы и компоненты» («Programs and Features») нажмите на кнопку «Включение и отключение компонентов Windows» («Turn Windows features on or off»).

Когда откроется окно «Компоненты Windows» («Windows features») в нем необходимо будет проставить флажки для следующих элементов:

Компоненты разработки приложений

Средства управления веб-сайтом

Консоль управления IIS

После этого нажимайте на кнопку «OK» и дождитесь завершения выполнения операции. После того как включение компонент будет выполнено, можно переходить к пункту «2. Публикация информационной базы».

1.2 Windows Server 2012 R2, 2016 и 2019

Настройка компонент для Windows Server 2012 R2, Windows Server 2016 и Windows Server 2019 одинаковая и все настройки производятся в диспетчере серверов (Server Manager).

Откройте диспетчер серверов (Server Manager) и нажмите Управление – Добавить роли и компоненты (Manage – Add Roles and Features).

В ответ на нажатие откроется окно мастера добавления ролей и компонентов (Add Roles and Features).

Читайте также:  Не работает миникарта вот

В этом окне нажмите два раза «Далее» («Next») пока мастер не переключится на страницу ролей сервера (Server Roles).

Во вкладке роли сервера (Server Roles) установите флажок «Web Server IIS». Так как эта роль зависит от другой роли ([Tools] IIS Management Console), то будет предложено установить ее дополнительно. Это можно сделать с помощью нажатия кнопки «Добавить компоненты» (Add Features) в открывшемся окне. После чего нажимаем кнопку «Далее» («Next») пока мастер не дойдет до вкладки «Роль веб-сервера IIS» («Web Server Role IIS»). На этой вкладке нажимайте кнопку «Далее» («Next») и попадете на вкладку «Службу ролей» («Role Services»). Во вкладке нужно найти пункт «Application Development» и выбрать в нем с помощью флажков пункты «ISAPI Extensions» и «ISAPI Filters». Как только закончите с установкой флажков нажимайте «Далее» («Next») и «Установить» («Install»).

На этом установка веб-сервера завершена. Можно переходить к настройкам сертификатов.

2. Выпуск самоподписанного сертификата

Выпуск самоподписанного сертификата для веб-сервера IIS максимально простой.

Для реальных систем не рекомендуем использовать самоподписанный сертификат.

Для начала процедуры выпуска откройте окно Диспетчера служб IIS (Internet Information Services (IIS) Manager) и выделите сервер в списке Подключений (Connections) . После этого нажмите на ссылку «Сертификаты сервера» («Server Certificates») .

Откроется окно доступных сертификатов сервера (Server Certificates) в котором нужно нажать «Создать самозаверенный сертификат…» («Create Self-Signed Certificate…»).

В окне мастера создания самоподписанного сертификата остается указать только произвольное название сертификата. В большинстве случаев, во избежание путаницы лучше явно указывать в качестве значения «Полное имя сертификата» («Specify a friendly name for the certificate») адрес сервера, на котором расположен сервер IIS. Как только имя сертификата будет задано нажимайте на кнопку OK и переходите к пункту привязки сертификата.

3. Привязка сертификата

Предполагается, что сертификат получен и добавлен в список сертификатов сервера. Если сертификат получен с помощью распространенного сертифицирующего центра, то его нужно предварительно импортировать в окне «Сертификаты сервера» («Server Certificates»).

Как только сертификат появится в списке, переходим непосредственно к его привязки к публикации сайта. Для этого выделяем «Default Web Site» и в окне «Действия» («Actions») нажимаем на пункт «Привязки…» («Binding…»).

В этом окне можно увидеть, что публикация работает только на порту 80, который относится к незащищенному протоколу HTTP. Чтобы его расширить, нажмите кнопку Добавить… (Add…) слева от списка привязок сайта и в открывшемся окне выберите Тип (Type) в качестве значения «https». Завершением настройки будет выбор ранее импортированного сертификата в списке «SSL-сертификат» («SSL certificate»). Нажимаем кнопку OK и закрываем мастер привязок сайта.

Можно переходить к публикации информационной и проверки его работоспособности.

4. Проверка публикации

Для публикации информационной базы нужно открыть конфигуратор конкретной базы от имени администратора и перейти в пункт меню «Администрирование». После этого выбрать «Публикация информационной базы».

В окне публикации указать имя публикации и по желанию определить каталог, где будут находиться настройки публикации. Его также можно оставить по умолчанию.

После этого требуется нажать кнопку «Опубликовать» и дождаться окончания операции.

Для проверки корректной работы нужно открыть страницу в браузере и перейти по ссылке, которая состоит из двух частей:

  • Имя вашего сервера (например, server1)
  • Имя публикации базы (которое было указано в окне настройки публикации)

Для таких параметров ссылка будет иметь вид:

Если все хорошо, то откроется страница с вашей информационной базой.

Источник

Публикация баз 1С на веб-сервере IIS и возможные ошибки

Использование веб-сервера и публикаций информационных баз — один из способов оптимизации 1С. Особенно при работе с ИБ в файловом варианте. Так безопаснее. Сотрудники подключаются к ИБ 1С через браузер или тонкий клиент , не имея прямого доступа к файлам.

В статье расскажем, как решали возникающие вопросы по настройкам Internet Information Services. Через призму своего опыта и коллег.

Как правило, ошибки повторяются. Например, ошибка 0x800700c1 в IsapiModule или HTTP 500.0 Internal Server Error.

I. Как перевести опубликованные базы 1С на HTTPS-протокол

Подробнее описано здесь . В проекте использовали бесплатный SSL-сертификат Let’s Encrypt. Но поспешили отключить внешние соединения на 80-й порт — что было ошибкой.

Сертификат выдается сроком на 90 дней. Для автоматического продления создается периодическое задание в Планировщике. При запуске задачи сайт должен быть доступен (пройти проверку домена) по 80-му порту.

Вопрос решили установкой переадресации на 443-й порт средствами IIS (301-й редирект с http на https). Использовали стандартный модуль URL Rewrite . Запросы http автоматически перенаправляются сайтом на защищенный https.

II. Типовая настройка и публикация информационных баз на IIS

На что обратить внимание:

1. Состав компонентов IIS — в Интернете полно инструкций и указаний. Повторяться не будем.

2. Установка 1С необходимой разрядности . Варианта 2: x86 (32-разрядное приложение) или x64. Обязательно выбираем «Модули расширения веб-сервера».

3. Права для встроенной группы /пользователю веб-сервера (IUSR) на папки:

  • с установленной платформой — на «чтение и выполнение» (для старта процессов);
  • самих расположений ИБ — на «изменение» (в случае файлового варианта).

4. Публикация базы через Конфигуратор 1С . Возможно потребуется открыть программу с повышенными правами — «Запуск от имени администратора».

5. Для 32-разрядного клиента 1С в диспетчере IIS включаем разрешение запуска ( DefaultAppPool — Дополнительные параметры — Разрешены 32-разрядные приложения = True ). Для 1C x64 — значение не меняем.

6. На странице сопоставления обработчиков для «1С Web-service Extension» потребуется указать путь к исполняемому модулю :

  • x86 — «C:\Program Files (x86)\1cv8\8.3.x.xx\bin\wsisapi.dll»;
  • x64 — «C:\Program Files\1cv8\8.3.x.xx\bin\wsisapi.dll».

Либо изменяем путь к библиотеке в файлах web.config через Блокнот (располагается, как правило, в c:\inetpub\wwwroot\ ).

Если в п. 2 все сделано правильно — по указанному пути должен присутствовать файл wsisapi.dll.

7. В частных случаях требуется перезапуск служб IIS . Выполните «Перезапустить» в оснастке управления или перезагрузите сервер.

✅ Соблюдаем соответствие разрядности: если запускаем и публикуем 64-разрядный клиент 1С:Предприятие, то dll также должна быть 64-битной версии.

Если публикуем 32-разрядную версию 1С, то ставим разрешение запуска 32-разрядных приложений на IIS и проверяем путь к wsisapi из каталога x86.

III. Если клиент 1С зависает при подключении к базе по web

Прежде посмотрите этот материал — там общие рекомендации.

Другой случай. Файловая ИБ опубликована на IIS. После авторизации зависает на эмблеме 1С. При открытии Конфигуратора — все нормально.

В журналах Windows ошибка «Процесс, обслуживающий пул приложений «1С», не ответил на команду ping».

  • проверьте права на папку с базой 1С для IUSR/IIS_IUSRS, уровень доступа — на «изменение»;
  • в оснастке IIS «Пулы приложений — — Дополнительные параметры — Модель процесса» задайте для « Максимальная задержка отклика при проверке связи » значение, превышающее 90 секунд;
  • посмотрите на поведение IIS при «Проверка связи включена» = False.

📝 Из справки: установка [pingingEnabled] (Проверка связи) в значение false не позволит IIS проверять, выполняется ли рабочий процесс, и таким образом сохранит его активным до остановки процесса отладки.

✅ Установка «Максимальное время отклика пинга» в большое значение позволит IIS продолжать наблюдение за рабочим процессом.

IV. Ошибка сервера в приложении ‘/AO_SSR’

Информационная база 1C опубликована на IIS. При работе через тонкий клиент, при нажатии на «Отчеты» вываливается ошибка.

« Ошибка сервера в приложении ‘/AO_SSR’. Обнаружено потенциально опасное значение Request.Path, полученное от клиента.

Описание: Необработанное исключение при выполнении текущего веб-запроса. Изучите трассировку стека для получения дополнительных сведений о данной ошибке и о вызвавшем ее фрагменте кода.

Сведения об исключении: System. Web. HttpException ».

✅ Откройте настройки пула приложений и проверьте «Режим управляемого конвейера» = «Classic».

Диспетчер служб IIS — Пулы приложений — DefaultAppPool — Дополнительные параметры — Общие ↴

Источник

Оцените статью