Импорт данных в XML
Не получается импортировать каталог на сайт в формате XML — если с помощью КОНТЕНТ / ИМПОРТ — процесс вроде как идет, но быстро прекращается без сообщений об ошибках.
Если с помощью МАГАЗИН / ИМПОРТ ДАННЫХ — просто тупо белую страницу выдает.
Не подскажете, что и где нужно вправить, чтобы заработало?
Read less, more TV
Evgeny Petrichenko,
тот, что вгружаю — 3 мега. Есть файл который выгрузили из 1С, немного другая структура (хотя вроде как по стандартам CML2 программист делал), весит — 1.5 мега.
То есть был сделан экспорт файла в XML, а потом пытаюсь его же импортнуть — и не выходит.
Рамиль Юналиев,
извините, немного не понял. дык ничего и не портилось — просто не импортнулся файлик
| Цитата |
|---|
| Ginner пишет: То есть был сделан экспорт файла в XML, а потом пытаюсь его же импортнуть — и не выходит. |
Произвольно структурированный файл не импортится, подумал что может в этом проблема
Рамиль Юналиев,
а, понятно нет, не получается не с файлом той структуры, что программист сделал, ни тот, что Битрикс сам предлагает
Просто может я что не то делаю. или.
| Цитата |
|---|
| Ginner пишет: Просто может я что не то делаю. или. |
Попробуйте начать с малого, создайте инфоблок, в нем 1 товар. Потом сделайте экспорт в xml и импорт. Если все получится, значит проблема в файле xml, а 3mb это мелочи. должно отрабатывать на пару сек.
Рамиль Юналиев,
нифига.. делаю 1 и-блок, 1 товар, экспорт, импорт — все проходит на ура!
потом пытаюсь делать тоже самое с основным каталогом, на 3 мега — и все. Проходит первые 2 шага, и стопорится на
* Чтение файла импорта во временные таблицы. Прочитано: 0%.
и все! потом эти надписи убирает и снова предлагает импортировать. Ставил и маленький шаг, и 0 — не помогает. Потом попробовал xml, который из 1С выгрузили — эффект тот же.
| Цитата |
|---|
| Рамиль Юналиев пишет: Если все получится, значит проблема в файле xml, а 3mb это мелочи. |
попробовал выгрузку из 1с 8 через интеграцию в битрикс — результат
Выгружено товаров: 1
Выгружено картинок: 0
Произошла ошибка на стороне сервера. Получен неизвестный статус импорта.
Обмен не выполнен
Ответ сервера:
|
Выгрузка товаров завершена с ошибками.
выгружал в созданный инфо-блок
| Цитата |
|---|
| Константин Соловьев пишет: Попробуй сделать Проверку БД |
| Цитата |
|---|
| Дмитрий Суслов пишет: Дмитрий Суслов |
| Цитата |
|---|
| b_adv_banner_2_day 6 120 [warning] Size of datafile is: 160 Should be: 120 [error] Record-count is not ok; is 8 Should be: 6 [warning] Found 8 parts Should be: 6 parts [error] Corrupt [Repair error] 17 when fixing table [Repair Error] Error on rename of ‘C:\Program Files\Bitrix Environment\mysql\data\bsm_demo\b_adv_banner_2_day.TMD’ to ‘C:\Program Files\Bitrix Environment\mysql\data\bsm_demo\b_adv_banner_2_day.MYD’ (Errcode: 17) [Repair status] Operation failed [Check warning] Table is marked as crashed and last repair failed [Check error] Size of datafile is: 80 Should be: 160 [Check error] Corrupt |
| Цитата |
|---|
| b_agent 21 2 436 [warning] 1 client is using or hasn’t closed the table properly [status] OK [Repair error] 17 when fixing table [Repair Error] Error on rename of ‘C:\Program Files\Bitrix Environment\mysql\data\bsm_demo\b_agent.TMD’ to ‘C:\Program Files\Bitrix Environment\mysql\data\bsm_demo\b_agent.MYD’ (Errcode: 17) [Repair status] Operation failed [Check warning] Table is marked as crashed and last repair failed [Check warning] Size of datafile is: 1896 Should be: 1660 [Check error] Keypointers and record positions doesn’t match [Check warning] Found 40 deleted space. Should be 0 [Check warning] Found 1 deleted blocks Should be: 0 [Check warning] Found 37 parts Should be: 21 parts [Check error] Corrupt |
| Цитата |
|---|
| MySQL Query Error: SELECT ‘x’ FROM b_agent WHERE ACTIVE=’Y’ AND NEXT_EXEC |
| Цитата |
|---|
| Алексей Абисфамилинный пишет: Ну видимо таблицу b_agent починить не удалось. |
| Цитата |
|---|
| Ginner написал: Рамиль Юналиев, нифига.. делаю 1 и-блок, 1 товар, экспорт, импорт — все проходит на ура! потом пытаюсь делать тоже самое с основным каталогом, на 3 мега — и все. Проходит первые 2 шага, и стопорится на * Чтение файла импорта во временные таблицы. Прочитано: 0%. |
и все! потом эти надписи убирает и снова предлагает импортировать. Ставил и маленький шаг, и 0 — не помогает. Потом попробовал xml, который из 1С выгрузили — эффект тот же.
Источник
Битрикс и ошибки с b_xml_tree
Если вы используете на своем сайте обмен между магазином и 1C, то скорее всего натыкались на ошибки связанные с таблицей b_xml_tree . Подробные коды бывают разные, но причины всегда одинаковые.
Таблица b_xml_tree
Сама таблица b_xml_tree в базе данных существует для обеспечения функционала обмена сайта с внешними системами, в 99% случаев это 1С. В оставшемся 1% прочее ПО использующее в своей работе принцип обмена заложенный для связи с 1С. Задействована таблица исключительно в процессе обмена.
В процессе обмена интернет-магазина с учетной системой, можно наткнуться на различные описания ошибки:
Причина всегда одна — обмен с 1С «наслоился» или «идет по кругу». И для решения проблемы нужно свести число обменов происходящих в одно время до одного!
Что делать?
Как обычно у вас есть два пути — писать в техническую поддержку вендора или разбираться самостоятельно. В случае написания в поддержку в первом (полезном) сообщении вам предложат:
После этого вам (возможно) ответят нужно сделать тоже самое, что написано на пару абзацев выше — проанализировать интенсивность и «наложение» обменов.
Теперь, для тех кто все делает сам, проанализируйте свои обмены и исключите лишние. В каких случаях это бывает и где искать параллельные выгрузки:
Ситуация 1.
Вы используете многосайтовую конфигурацию (несколько сайтов в одной админке битрикса) и осуществляете обмен с разными сайтами в одно время. Таким образом в базе данных происходит крах таблицы из-за наложения обменов. Просто разведите обмены по времени.
Ситуация 2.
В 1С используется регламентная выгрузка только изменений. При смене формата на «полная выгрузка» и последующем возвращении к режиму «только изменения» произошел «трабл» и полная выгрузка продолжает запускается в фоновом режиме. Проверьте узе обмена.
Ситуация 3.
Существует выгрузка по расписанию, которая обновляет остатки и цены в своем графике, но кто-то решил «толкнуть» полную выгрузку (или частичную выгрузку) вручную и потоки наложились вызвав ошибку.
Ситуация 4.
Вы используете несколько 1С и обновляете сайт то с одной то с другой. Это точное повторение ситуации 1 навыворот. Просто разведите обмены по времени.
Ситуация 5.
Характеризуется особенной ошибкой:
Возникает при существенных обновлениях самого движка или переезде с сервера на сервер. Причина в неверной кодировка таблицы. Просто запустите проверки сайта или выполните запрос:
P.S Если так произошло, что таблица разрушена (бывает при переносе сайта и мистических обстоятельствах) зачастую достаточно запустить проверку базы данных в админке и исправить ошибки, если инструмент ошибку не диагностирует, то физически удалить файлы таблиц базы данных на сервере:
Источник
Не могу импортировать данные в bitrix
Установил 1с-битрикс бизнес (демо) и 1с:предприятие 8.0
Захожу управление торговлей 10.2 (демо) Обмен данными — выгрузка данных — CML выделяю номенклатуру файл.xml
В битриксе захожу в магазин — торговый каталог — импорт данных — CML
Выбираю мой фаил xml, тип блока — каталог товаров 1с загружаю.
Операция успешно завершена.
Загрузка заняла 0 сек
Загружено 0 каталога(ов). Из них 0 новых каталога(ов) и 0 измененных.
Загружено 0 групп. Из них 0 новых групп и 0 измененных.
Загружено 0 свойств(а). Из них 0 новых свойств и 0 измененных.
Загружено 0 товара(ов). Из них 0 новых товара(ов) и 0 измененных.
Что я делаю не так?
При испльзовании стандартного обмена в УТ выгрузка каталога происходит нормально а загрузка нет.
Выгружено товаров: 87
Выгружено картинок: 0
Произошла ошибка на стороне сервера. Файл не отправлен (C:\TEMP\1cbitrix\import.xml).
Обмен не выполнен
Ответ сервера:
В CML не найдены заказы.
Выгрузка товаров завершена с ошибками.
При выгрузке в каталог создаются 2 файла:
import.xml
offers.xml
при попытке загрузить любой из них в битриксе выдает:
Операция успешно завершена.
Загрузка заняла 0 сек
Загружено 0 каталога(ов). Из них 0 новых каталога(ов) и 0 измененных.
Загружено 0 групп. Из них 0 новых групп и 0 измененных.
Загружено 0 свойств(а). Из них 0 новых свойств и 0 измененных.
Загружено 0 товара(ов). Из них 0 новых товара(ов) и 0 измененных.
Перерыл пол сайта и форума ответа так и не нашел.
Источник
Импорт каталога товаров — «import.xml: Произошла ошибка на стороне сервера»
Здравствуйте.
На протяжении недели при попытке выгрузки каталога товаров, выдается ошибка:
| Цитата |
|---|
| Процессор 16 ядер 2.66 ГГц Память RAM 4 ГБ SWAP 1 ГБ Скорость сети Внутренняя 1000 Мбит/с Внешняя 50 Мбит/с |
В чем может быть дело? Как решить проблему?
| Цитата |
|---|
| plns пишет: Может быть в настройках интеграции дело? |
Свободного места достаточно на сайте?
И все-таки советую проверить на другом хостере или выгружать порциями.
Данные методы не помогут решить вопрос?
| Цитата |
|---|
| http://distr.1c.ua/publications/8144/10148737/ Общие методы решения – это изменение настроек сервера. Во-первых, можно увеличить лимит времени и памяти в настройках PHP.
Во-вторых, часто помогает увеличение таймаута сервера. С этим лучше обратиться к хостеру, так как у вас, скорее всего, не будет на это прав доступа. Но если есть возможность сделать это самому, то нужно произвести следующую последовательность действий:
Другой вариант решения этой проблемы (если хостер не соглашается на увеличение таймаута) — сделать равным таймаут сервера и таймаут « 1С-Битрикс: Управление сайтом » (страница Магазин > Настройки магазина > Интеграция с 1С, поле Интервал одного шага в секундах ). В этом случае пошаговое выполнение будет идти синхронно. |
| Цитата |
|---|
| plns пишет: Промониторил выгрузку: ZIP архивы (269 шт. по 2 мб) попадают на сайт и все файлы успешно разархивируется в папку /upload/1c_catalog. Но затем при обработке import.xml (55 мб) вылетает, с ошибкой описанной выше. |
Да, они рассматривают проблему только, если импорт стандартный. У нас он кастомизирован.
Покопались вчера сами, выяснилось, что частично проблема была из-за лимита на количество импортируемых файлов. Увеличили до 400. Импорт прошел успешно.
Сегодня пробуем выгрузить, например, 1 товар, чтобы отловить ошибку. Через раз выдает туже ошибку.
В логах обнаружилось:
[Tue Apr 17 14:01:23 2012] [notice] Apache/2.2.3 (CentOS) configured — resuming normal operations
[Tue Apr 17 14:46:08 2012] [notice] child pid 2297 exit signal Segmentation fault (11)
Источник
Импорт каталога товаров — «import.xml: Произошла ошибка на стороне сервера»
Здравствуйте.
На протяжении недели при попытке выгрузки каталога товаров, выдается ошибка:
| Цитата |
|---|
| Процессор 16 ядер 2.66 ГГц Память RAM 4 ГБ SWAP 1 ГБ Скорость сети Внутренняя 1000 Мбит/с Внешняя 50 Мбит/с |
В чем может быть дело? Как решить проблему?
| Цитата |
|---|
| plns пишет: Может быть в настройках интеграции дело? |
Свободного места достаточно на сайте?
И все-таки советую проверить на другом хостере или выгружать порциями.
Данные методы не помогут решить вопрос?
| Цитата |
|---|
| http://distr.1c.ua/publications/8144/10148737/ Общие методы решения – это изменение настроек сервера. Во-первых, можно увеличить лимит времени и памяти в настройках PHP.
Во-вторых, часто помогает увеличение таймаута сервера. С этим лучше обратиться к хостеру, так как у вас, скорее всего, не будет на это прав доступа. Но если есть возможность сделать это самому, то нужно произвести следующую последовательность действий:
Другой вариант решения этой проблемы (если хостер не соглашается на увеличение таймаута) — сделать равным таймаут сервера и таймаут « 1С-Битрикс: Управление сайтом » (страница Магазин > Настройки магазина > Интеграция с 1С, поле Интервал одного шага в секундах ). В этом случае пошаговое выполнение будет идти синхронно. |
| Цитата |
|---|
| plns пишет: Промониторил выгрузку: ZIP архивы (269 шт. по 2 мб) попадают на сайт и все файлы успешно разархивируется в папку /upload/1c_catalog. Но затем при обработке import.xml (55 мб) вылетает, с ошибкой описанной выше. |
Да, они рассматривают проблему только, если импорт стандартный. У нас он кастомизирован.
Покопались вчера сами, выяснилось, что частично проблема была из-за лимита на количество импортируемых файлов. Увеличили до 400. Импорт прошел успешно.
Сегодня пробуем выгрузить, например, 1 товар, чтобы отловить ошибку. Через раз выдает туже ошибку.
В логах обнаружилось:
[Tue Apr 17 14:01:23 2012] [notice] Apache/2.2.3 (CentOS) configured — resuming normal operations
[Tue Apr 17 14:46:08 2012] [notice] child pid 2297 exit signal Segmentation fault (11)
Источник