Битрикс не работает маркет

Частые вопросы

Ошибки при установке и работе продукта

  • Почему не приходят на почту уведомления о заполнении веб-форм?
  • Не появляется нужная служба доставки при оформлении заказа
  • В файле экспорта в Yandex.Market ссылки на несуществующие страницы (ошибка 404)
  • В файловом менеджере продукта не отображаются файлы и папки.
  • После распаковки рез. копии на всём сайте форма авторизации.
  • Не все файлы попадают в архив резервной копии
  • Редактор сайта не может загрузить картинки на сайт.
  • Не работает экспорт в Yandex.Market(YML не принят), что делать?
  • После перехода с на компонент рассылки версии 2.0 выпуски расслыки не создаются, что делать?
  • Количество сообщений (тем, новостей и т.д.) на странице не совпадает с количеством, указанном в настройке компонента
  • При распаковке резервной копии происходит ошибка «ERROR 1062 (23000) at line 1247: Duplicate entry ‘2-?’ for key 2»
  • При установке демо версии происходит ошибка «Срок работы пробной версии продукта истек. «
  • Пропадает панель инструментов в публичной части.
  • Копирование элемента в форме редактирования не работает
  • Проблема : Увеличивается объём занимаемого места в папке /bitrix/cache/
  • Создал группу «Редакторы сайта», но при входе в административную часть выводится сообщение «Доступ запрещён».
  • На сайте обнаружен вирус
  • Поиск выдаёт ссылки на несуществующие страницы (404 — HTTP not found)
  • Не создаются автоматические выпуски рассылки
  • Ошибка при обновлении [SYS_ERROR_12]
  • При попытке обновления выдаётся ошибка «Ошибка соединения с сервером обновлений: [110] Connection timed out.»
  • Не работает AJAX в компонентах. не работает javascript в компонентах
  • В статистике дублируется информация посещениях
  • Не отправляется email из продукта. Что делать?
  • Вместо содержимого страницы: «500 Внутренняя ошибка сервера» или «500 Internal Server Error» или «502 Bad gateway»
  • При обращении к сайту открываются новые окна, которые не имею отношения к содержимому сайта
  • Не работает визуальный редактор
  • Инсталлятор пишет: «путь для сохранения параметров сессии не установлен». Как это исправить?
  • При загрузке изображения отображается ошибка: файл не является графическим
  • Использую многосайтовость. При добавлении второго сайта не применяются шаблоны к сайту
  • При попытке импортировать данные из файла csv не переносятся цены.
  • Пропадает авторизация пользователя
  • При оформлении заказа, графы о налоге нет
  • При удалении сайта возникает ошибка
  • Ошибка при обновлении [ERROR_WRONG_CODE]
  • Скачанная документация в формате .chm не работает: выдает справа страницу эксплорера с надписью «не могу отобразить страницу, проверьте настройки».
  • Диалог авторизации после публикации темы в премодерируемом форуме
  • Ошибка при работе с flash-файлами
  • Вместо содержимого страницы вижу белый экран
  • Под IIS не фиксируются хиты
  • Не фиксируются пользователи добавившие сайт в избранное
  • При переходе по баннеру запрашивается авторизация
  • Яндекс — нет даты последнего изменения
  • Не работает функция проверки орфографии (spell checker).
    Почему не приходят на почту уведомления о заполнении веб-форм?
    1. Проверьте, пожалуйста, настройки почтового события заполнения формы и его шаблона.

    Откройте Панель управления — Настройки — Настройки продукта — Почтовые события; выберите событие.

    На первой закладке, должны стоять галочки возле используемых на Вашем сайте кодов языка. На закладке «шаблоны» должна стоять галочка возле имени Вашего сайта, хотя бы у одного шаблона (обычно он там как раз один). Также, в настройках выбранного почтового шаблона (можно перейти прямо по ссылке со страницы «шаблоны», не забудьте только перед этим нажать «применить», если были сделаны какие-то настройки), должна стоять галочка «активен», и также должен быть выбран Ваш сайт. Также должны быть корректно заполнены поля «от кого» и «кому» (значения по-умолчанию #DEFAULT_EMAIL_FROM# и #EMAIL#, соответственно).

    2. Если все эти настройки соответствуют истине, то в настройках модуля веб-формы отключите флаг «использовать упрощенный режим», перейдите в настройки соответсвующей формы, вкладка дополнительно, убедитесь, что флаг привязки к почтовому шаблону проставлен. Если и здесь все в порядке, то перейдите, пожалуйста, в Настройки-Инструменты-SQL-запрос и выполните такой запрос:

    select * from b_event where event_name like ‘%form%’ order by date_insert desc

    Найдите событие заполнения формы, смотрите в поле SUCCESS_EXEC:

    стоит Y — письмо из продукта ушло, дальнейшую его судьбу попросите отследить администратора хостинга
    стоит N — зайдите в файл /bitrix/php_interface/dbconn.php и проверьте не определены ли у Вас константы
    BX_CRONTAB и BX_CRONTAB_SUPPORT, если да — убрать их определение вообще из этого файла. Если после этого SUCCESS_EXEC также N, то необходимо перейти в папку /bitrix/managed_cache/ и попытаться удалить содержимое (обязательно через модуль управления структурой, а не через FTP), если получите ошибку — значит необходимо исправить проблему с доступом продукта к папкам, чтобы Вы могли удалить файлы и папки из кеша.
    Стоит F — функция mail() по какой-то причине вернула False при отправке. Наиболее типичные проблемы:

    Наверх

    Не появляется нужная служба доставки при оформлении заказа
    Каждый обработчик службы доставки имеет свои нюансы и требования, при несоблюдении которых служба доставки не будет появляться при оформлении заказа.

    Наверх

    В файле экспорта в Yandex.Market ссылки на несуществующие страницы (ошибка 404)
    Проблема заключается в некорректно указанном «URL страницы детального просмотра элемента» в настройках информационного блока, которому принадлежат товары, экспортируемые в Yandex.Market.
    Данная проблема решается как и аналогичная проблема с поиском:
    Поиск выдаёт ссылки на несуществующие страницы (404 — HTTP not found)
    Наверх

    В файловом менеджере продукта не отображаются файлы и папки.
    У данного поведения продукта есть две причины:
    1. в настройках сайтов, значение поля «Путь к корневой папке веб-сервера для этого сайта» не соответствует реальному пути к DOCUMENT_ROOT.
    «Настройки»-> «Настройки продукта»-> «Сайты»-> «Список сайтов»

    2. На корневую папку сайта (DOCUMENT_ROOT) установлены права недостаточные для чтение её содержимого. В данном случае надо установить на папку наиболее полные права:
    http://dev.1c-bitrix.ru/support/faq/8366/#112853
    http://dev.1c-bitrix.ru/community/blogs/howto/387.php
    Наверх

    После распаковки рез. копии на всём сайте форма авторизации.
    Чтобы решить данную проблему надо обратить внимание на 2 аспекта:
    1. Проверить на корректность в настройках сайтов значение поля «Путь к корневой папке веб-сервера для этого сайта»:
    «Настройки»-> «Настройки продукта»-> «Сайты»-> «Список сайтов»

    2. Если перенос осуществлялся простым копированием файлов (FTP/SSH),мог не скопироваться файл /.access.
    В данном файле хранятся права групп пользователей к сайту, если данного файла нет, то для всех пользователей устанавливается право «Запрещено».

    Проблема решается одним из способов:
    А. Вам надо зайти через файловый менеджер продукта в свойства корневой папки сайта и на вкладке «Доступ» установить для группы «Неавторизованные пользователи» право «Чтение».

    Б. В корень сайта положить файл .access с содержимым:

    Наверх

    Не все файлы попадают в архив резервной копии
    При просмотре архива, созданного штатной системой резервного копирования, через WinRar видно, что файлов в архиве гораздо меньше, чем на сайте.

    Дело в том, что у tar есть несколько диалектов. Мы пакуем в формате GNU tar, как это делает по умолчанию tar в linux. WinRar понимает tar, но конкретно этот диалект поддерживает не полностью.

    Наш архив должен распаковываться нашим restore.php, скачанным со страницы резервного копирования. Если этого не происходит, проблему следует решать через техподдержку. Проблемы распаковки сторонними инструментами (WinRar в том числе) техподдержка не решает.
    Наверх

    Редактор сайта не может загрузить картинки на сайт.
    Описание:
    В визуальном редакторе у редактора сайта вкладка «Загрузить файл» неактивная, причём администартор сайта
    без проблем может загружать файлы.

    Решение:
    Вам надо создать новый уровень доступа к Главному модулю (Файл/Папка):
    «Настройки»-> «Пользователи»-> «Уровни доступа».
    http://dev.1c-bitrix.ru/learning/course/lesson.php?COURSE_ID=6&ID=1223

    В созданном уровне доступа выберите флажок «Загрузка файла на сервер (fm_upload_file)», сохраните.
    Затем Вам надо данный уровень доступа установить на корневую папку сайта, для требуемой группы пользователей.

    Это должно решить проблему.

    Наверх

    Не работает экспорт в Yandex.Market(YML не принят), что делать?
    При проверке файла экспорта в Yandex.Market ошибка вида:

    1.»YML не принят: Фид не разобран до конца — ошибка парсера XML (Error parsing XML feed) (line: 81 column: 5): Unterminated entity declaration, ‘ContentType'»

    Проблема в том, что по умолчанию в папке /upload не выполняются php скрипты.
    Для решения проблемы вам следует перенести файл экспорта в другую папку, отличную от /upload, и в папке разрешить выполнение php скриптов в файле .htaccess при помощи директивы AddType
    Можно прямо в папке /upload создать директории, переместить туда файл yandex.php, создать в этой директории файл .htaccess и переопределить в нём AddType:

    AddType application/x-httpd-php .php

    2. «Notice : Undefined index: referer1 in /var/www/alexey/data/www/telecamera.ru/upload/yandex.php on line 1»

    В файле .htaccess, папки в которой находится файл экспорта, вам следует отключить отображение замечаний(NOTICE).
    Уровень вывода ошибок задаётся директивой php_value error_reporting.
    Данную директиву можно определить также в настройках PHP.
    Например уровень:
    error_reporting = E_ALL &

    позволяет выводить все ошибки, за исключением замечаний.

    Наверх

    После перехода с на компонент рассылки версии 2.0 выпуски расслыки не создаются, что делать?
    Выпуск автоматической рассылки создаётся/не создаётся в зависимости от значения переменной $SUBSCRIBE_TEMPLATE_RESULT.

    Если используется компонент рассылки версии 1.0:

    $SUBSCRIBE_TEMPLATE_RESULT это глобальная переменная, её значение определяется внутри компонента.

    Поэтому в шаблоне рассылке достаточно просто вызвать компонент для определения значения $SUBSCRIBE_TEMPLATE_RESULT.

    Если используется компонент рассылки версии 2.0:

    $SUBSCRIBE_TEMPLATE_RESULT не является глобальной, поэтому просто вызвать компонент для определения значения этой переменной недостаточно(как это было с компонентом версии 1.0):

    IncludeComponent(
    «bitrix:subscribe.news»,
    «»,
    Array(
    «SITE_ID» => «s1»,
    «IBLOCK_TYPE» => «news»,
    «ID» => «»,
    «SORT_BY» => «ACTIVE_FROM»,
    «SORT_ORDER» => «DESC»
    )
    );?>

    Сам компонент возвращает количество элементов, которые попадают в следующий выпуск рассылки, соответственно переменной $SUBSCRIBE_TEMPLATE_RESULT следует присвоит значение, возвращаемое компонентом bitrix:subscribe.news:

    IncludeComponent(
    «bitrix:subscribe.news»,
    «»,
    Array(
    «SITE_ID» => «s1»,
    «IBLOCK_TYPE» => «news»,
    «ID» => «»,
    «SORT_BY» => «ACTIVE_FROM»,
    «SORT_ORDER» => «DESC»
    )
    );?>

    В этом случае $SUBSCRIBE_TEMPLATE_RESULT будет определена и выпуск будет сформирован по расписанию.

    Наверх

    Количество сообщений (тем, новостей и т.д.) на странице не совпадает с количеством, указанном в настройке компонента
    Скорее всего, в настройках используемого компонента отмечена опция «Использовать обратную постраничную навигацию».

    В данном режиме происходит обратный отсчёт страниц (последняя страница считается первой).

    Данный механизм используют, если при добавлении элемента инфоблока, он всегда попадает наверх списка (отсортированы по дате добавления сообщения по убыванию). Таким образом, меняется лишь последняя страница. Все предыдущие можно надолго закешировать.

    При данном типе постраничной навигации разбиение на страницы произойдёт, если остаток при делении количества сообщений на первой странице на число, указанное в настройках компонента, будет больше или равно двум.

    Например, если всего 170 сообщений в форуме, и в настройках компонента указано число сообщении на странице равное 20, будет образовано 8 страниц, на первой — 30 сообщений, на остальных — 20. При данных настройках в случае достижении количества сообщений равным 180, будут образованы 9 страниц по 20 сообщений.

    При обратной страничной навигации количество сообщений на странице либо равно числу, указанному в настройках компонента, либо больше его.

    Наверх

    При распаковке резервной копии происходит ошибка «ERROR 1062 (23000) at line 1247: Duplicate entry ‘2-?’ for key 2»
    Данная ошибка имеет место если кодировка, в которой сделан дамп отличается от той, которая используется на новом сервера баз данных.

    Тут важно знать 2 аспекта:

    a. Кодировка дампа устанавливается в зависимости от содержимого файла /bitrix/php_interface/after_connect.php, например:

    Query(«SET NAMES ‘utf8′»);
    ?>

    т.е дамп будет создаваться в кодировке «utf8».

    b. Кодировку сервера баз данных можно увидеть в параметре «character_set_server» после выполнения SQL-запроса:

    show variables where Variable_name = ‘character_set_server’;

    Ошибка происходит если данные кодировки (п.1 и п.2) различаются.

    Обойти или устранить эту ошибку можно двумя способами:

    1. В настройках сервера изменить кодировку в параметре «character_set_server» (b) на ту, в которой сделан дамп (a).

    Важно: данную операцию делаете или Вы или администратор сервера в зависимости от прав, которыми Вы обладаете.

    2. Можно открыть дамп в текстовом редакторе и в самое начало вставить строку:

    SET NAMES `utf8`;

    Кодировка выбирается в зависимости от кодировки, в которой сделан дамп (a).

    Важно: Данный способ работает только на небольшие дампы (которые успевают импортировать за один шаг)

    Наверх

    При установке демо версии происходит ошибка «Срок работы пробной версии продукта истек. «
    Возможные причины:

    1. В большинстве случаев данная ошибка наблюдается из-за того, что дистрибутив продукта (архив) был не до конца скачан с нашего сайта.

    2. Также проблема может быть из-за большой разности времени, которое установлено, на веб-сервере и времени на сервере базы. Т.е. Пробная версии создалась для одной даты, а при сравнении с базой данных, дата уже совсем другая. Если это так, то время надо синхронизировать.

    3. Возможно база данных, в которую выполняется установка продукта, не пуста и время действия продукта берётся со старой установки.

    Ниже приведены рекомендации, при выполнении которых данная ошибка точно не появится:

    1. Перед установкой продукта очистите корневую папку сайта от всех файлов (оставить надо только файлы, относящиеся к данной установке продукта).

    2. Выполняйте установку только в пустую базу данных или создавайте её нашим мастером установки (можно также воспользоваться и phpMyAdmin).

    3. Настоятельно рекомендуем пользоваться специальным скриптом bitrixsetup.php для скачивания и установки дистрибутива последней версии:

    4. Во время установки никогда не нажимайте кнопку F5 в браузере, для навигации по мастеру установки существуют специальные кнопки на странице.

    5. Также возможно, что в процессе распаковки дистрибутива произошёл сбой и не все файлы распаковались. Рекомендуем повторно распаковать продукт.

    Скачать скрипт можно здесь:

    Инструкция по установке продукта:

    Учебный курс по установке продукта:

    Наверх

    Пропадает панель инструментов в публичной части.
    Панель не выводится для пользователей, которым не хватает прав ни на одну операцию, задаваемую кнопками административной панели.

    Например, группе пользователей дано право «Изменение» для определённого инфоблока. Компоненты для работы с инфоблоками добавляют кнопки только на вкладку «Редактирование», поэтому вкладка «Просмотр» не доступна пользователям с данными правами.

    Если вам необходимо вывести панель в обязательном порядке, воспользуйтесь одним из следующих вариантов решения:

    1. Дать группе пользователей право на управление кешем страницы (данная возможность появится на вкладке «Просмотр»).

    Для этого создайте новый уровень доступа для Главного модуля с привязкой «Модуль», и доступной операцией «Управление кешем (cache_control)» (подробнее об уровнях доступа в учебном курсе «Администрирование системы»:

    В настройках группы пользователей, для которой требуется вывод панели, в качестве доступа к Главному модулю укажите созданный уровень.

    2. Выводить панель программно для определённой группы пользователей.

    Для этого в шаблон сайта вставьте проверку:

    GetUserGroupArray();
    if (in_array( , $arGroups ))
    $APPLICATION->ShowPanel = true;
    ?>

    где номер_группы — ID группы, для которой требуется вывод панели.

    Источник

    Читайте также:  Что делать если сломалась ручка у железной двери
    Оцените статью