Частые вопросы
Ошибки при установке и работе продукта
| Почему не приходят на почту уведомления о заполнении веб-форм? | |
| 1. Проверьте, пожалуйста, настройки почтового события заполнения формы и его шаблона. Откройте Панель управления — Настройки — Настройки продукта — Почтовые события; выберите событие. На первой закладке, должны стоять галочки возле используемых на Вашем сайте кодов языка. На закладке «шаблоны» должна стоять галочка возле имени Вашего сайта, хотя бы у одного шаблона (обычно он там как раз один). Также, в настройках выбранного почтового шаблона (можно перейти прямо по ссылке со страницы «шаблоны», не забудьте только перед этим нажать «применить», если были сделаны какие-то настройки), должна стоять галочка «активен», и также должен быть выбран Ваш сайт. Также должны быть корректно заполнены поля «от кого» и «кому» (значения по-умолчанию #DEFAULT_EMAIL_FROM# и #EMAIL#, соответственно). 2. Если все эти настройки соответствуют истине, то в настройках модуля веб-формы отключите флаг «использовать упрощенный режим», перейдите в настройки соответсвующей формы, вкладка дополнительно, убедитесь, что флаг привязки к почтовому шаблону проставлен. Если и здесь все в порядке, то перейдите, пожалуйста, в Настройки-Инструменты-SQL-запрос и выполните такой запрос:
Найдите событие заполнения формы, смотрите в поле SUCCESS_EXEC: стоит Y — письмо из продукта ушло, дальнейшую его судьбу попросите отследить администратора хостинга Наверх |
| Не появляется нужная служба доставки при оформлении заказа |
| Каждый обработчик службы доставки имеет свои нюансы и требования, при несоблюдении которых служба доставки не будет появляться при оформлении заказа. Наверх |
| В файле экспорта в Yandex.Market ссылки на несуществующие страницы (ошибка 404) |
| Проблема заключается в некорректно указанном «URL страницы детального просмотра элемента» в настройках информационного блока, которому принадлежат товары, экспортируемые в Yandex.Market. Данная проблема решается как и аналогичная проблема с поиском: Поиск выдаёт ссылки на несуществующие страницы (404 — HTTP not found) Наверх |
| В файловом менеджере продукта не отображаются файлы и папки. |
| У данного поведения продукта есть две причины: 1. в настройках сайтов, значение поля «Путь к корневой папке веб-сервера для этого сайта» не соответствует реальному пути к DOCUMENT_ROOT. «Настройки»-> «Настройки продукта»-> «Сайты»-> «Список сайтов» 2. На корневую папку сайта (DOCUMENT_ROOT) установлены права недостаточные для чтение её содержимого. В данном случае надо установить на папку наиболее полные права: |
| После распаковки рез. копии на всём сайте форма авторизации. |
| Чтобы решить данную проблему надо обратить внимание на 2 аспекта: 1. Проверить на корректность в настройках сайтов значение поля «Путь к корневой папке веб-сервера для этого сайта»: «Настройки»-> «Настройки продукта»-> «Сайты»-> «Список сайтов» 2. Если перенос осуществлялся простым копированием файлов (FTP/SSH),мог не скопироваться файл /.access. Проблема решается одним из способов: Б. В корень сайта положить файл .access с содержимым: Наверх |
| Не все файлы попадают в архив резервной копии |
| При просмотре архива, созданного штатной системой резервного копирования, через WinRar видно, что файлов в архиве гораздо меньше, чем на сайте. Дело в том, что у tar есть несколько диалектов. Мы пакуем в формате GNU tar, как это делает по умолчанию tar в linux. WinRar понимает tar, но конкретно этот диалект поддерживает не полностью. Наш архив должен распаковываться нашим restore.php, скачанным со страницы резервного копирования. Если этого не происходит, проблему следует решать через техподдержку. Проблемы распаковки сторонними инструментами (WinRar в том числе) техподдержка не решает. |
| Редактор сайта не может загрузить картинки на сайт. |
| Описание: В визуальном редакторе у редактора сайта вкладка «Загрузить файл» неактивная, причём администартор сайта без проблем может загружать файлы. Решение: В созданном уровне доступа выберите флажок «Загрузка файла на сервер (fm_upload_file)», сохраните. Это должно решить проблему. Наверх |
| Не работает экспорт в Yandex.Market(YML не принят), что делать? |
| При проверке файла экспорта в Yandex.Market ошибка вида: 1.»YML не принят: Фид не разобран до конца — ошибка парсера XML (Error parsing XML feed) (line: 81 column: 5): Unterminated entity declaration, ‘ContentType'» Проблема в том, что по умолчанию в папке /upload не выполняются php скрипты. AddType application/x-httpd-php .php 2. «Notice : Undefined index: referer1 in /var/www/alexey/data/www/telecamera.ru/upload/yandex.php on line 1» В файле .htaccess, папки в которой находится файл экспорта, вам следует отключить отображение замечаний(NOTICE). позволяет выводить все ошибки, за исключением замечаний. Наверх |
| После перехода с на компонент рассылки версии 2.0 выпуски расслыки не создаются, что делать? | ||
| Выпуск автоматической рассылки создаётся/не создаётся в зависимости от значения переменной $SUBSCRIBE_TEMPLATE_RESULT. Если используется компонент рассылки версии 1.0: $SUBSCRIBE_TEMPLATE_RESULT это глобальная переменная, её значение определяется внутри компонента. Поэтому в шаблоне рассылке достаточно просто вызвать компонент для определения значения $SUBSCRIBE_TEMPLATE_RESULT. Если используется компонент рассылки версии 2.0: $SUBSCRIBE_TEMPLATE_RESULT не является глобальной, поэтому просто вызвать компонент для определения значения этой переменной недостаточно(как это было с компонентом версии 1.0):
Сам компонент возвращает количество элементов, которые попадают в следующий выпуск рассылки, соответственно переменной $SUBSCRIBE_TEMPLATE_RESULT следует присвоит значение, возвращаемое компонентом bitrix:subscribe.news:
В этом случае $SUBSCRIBE_TEMPLATE_RESULT будет определена и выпуск будет сформирован по расписанию. Наверх |
| Количество сообщений (тем, новостей и т.д.) на странице не совпадает с количеством, указанном в настройке компонента |
| Скорее всего, в настройках используемого компонента отмечена опция «Использовать обратную постраничную навигацию». В данном режиме происходит обратный отсчёт страниц (последняя страница считается первой). Данный механизм используют, если при добавлении элемента инфоблока, он всегда попадает наверх списка (отсортированы по дате добавления сообщения по убыванию). Таким образом, меняется лишь последняя страница. Все предыдущие можно надолго закешировать. При данном типе постраничной навигации разбиение на страницы произойдёт, если остаток при делении количества сообщений на первой странице на число, указанное в настройках компонента, будет больше или равно двум. Например, если всего 170 сообщений в форуме, и в настройках компонента указано число сообщении на странице равное 20, будет образовано 8 страниц, на первой — 30 сообщений, на остальных — 20. При данных настройках в случае достижении количества сообщений равным 180, будут образованы 9 страниц по 20 сообщений. При обратной страничной навигации количество сообщений на странице либо равно числу, указанному в настройках компонента, либо больше его. Наверх |
| При распаковке резервной копии происходит ошибка «ERROR 1062 (23000) at line 1247: Duplicate entry ‘2-?’ for key 2» | |||
| Данная ошибка имеет место если кодировка, в которой сделан дамп отличается от той, которая используется на новом сервера баз данных. Тут важно знать 2 аспекта: a. Кодировка дампа устанавливается в зависимости от содержимого файла /bitrix/php_interface/after_connect.php, например:
т.е дамп будет создаваться в кодировке «utf8». b. Кодировку сервера баз данных можно увидеть в параметре «character_set_server» после выполнения SQL-запроса:
Ошибка происходит если данные кодировки (п.1 и п.2) различаются. Обойти или устранить эту ошибку можно двумя способами: 1. В настройках сервера изменить кодировку в параметре «character_set_server» (b) на ту, в которой сделан дамп (a). Важно: данную операцию делаете или Вы или администратор сервера в зависимости от прав, которыми Вы обладаете. 2. Можно открыть дамп в текстовом редакторе и в самое начало вставить строку:
Кодировка выбирается в зависимости от кодировки, в которой сделан дамп (a). Важно: Данный способ работает только на небольшие дампы (которые успевают импортировать за один шаг) Наверх |
| При установке демо версии происходит ошибка «Срок работы пробной версии продукта истек. « |
| Возможные причины: 1. В большинстве случаев данная ошибка наблюдается из-за того, что дистрибутив продукта (архив) был не до конца скачан с нашего сайта. 2. Также проблема может быть из-за большой разности времени, которое установлено, на веб-сервере и времени на сервере базы. Т.е. Пробная версии создалась для одной даты, а при сравнении с базой данных, дата уже совсем другая. Если это так, то время надо синхронизировать. 3. Возможно база данных, в которую выполняется установка продукта, не пуста и время действия продукта берётся со старой установки. Ниже приведены рекомендации, при выполнении которых данная ошибка точно не появится: 1. Перед установкой продукта очистите корневую папку сайта от всех файлов (оставить надо только файлы, относящиеся к данной установке продукта). 2. Выполняйте установку только в пустую базу данных или создавайте её нашим мастером установки (можно также воспользоваться и phpMyAdmin). 3. Настоятельно рекомендуем пользоваться специальным скриптом bitrixsetup.php для скачивания и установки дистрибутива последней версии: 4. Во время установки никогда не нажимайте кнопку F5 в браузере, для навигации по мастеру установки существуют специальные кнопки на странице. 5. Также возможно, что в процессе распаковки дистрибутива произошёл сбой и не все файлы распаковались. Рекомендуем повторно распаковать продукт. Скачать скрипт можно здесь: Инструкция по установке продукта: Учебный курс по установке продукта: Наверх |
| Пропадает панель инструментов в публичной части. | |
| Панель не выводится для пользователей, которым не хватает прав ни на одну операцию, задаваемую кнопками административной панели. Например, группе пользователей дано право «Изменение» для определённого инфоблока. Компоненты для работы с инфоблоками добавляют кнопки только на вкладку «Редактирование», поэтому вкладка «Просмотр» не доступна пользователям с данными правами. Если вам необходимо вывести панель в обязательном порядке, воспользуйтесь одним из следующих вариантов решения: 1. Дать группе пользователей право на управление кешем страницы (данная возможность появится на вкладке «Просмотр»). Для этого создайте новый уровень доступа для Главного модуля с привязкой «Модуль», и доступной операцией «Управление кешем (cache_control)» (подробнее об уровнях доступа в учебном курсе «Администрирование системы»: В настройках группы пользователей, для которой требуется вывод панели, в качестве доступа к Главному модулю укажите созданный уровень. 2. Выводить панель программно для определённой группы пользователей. Для этого в шаблон сайта вставьте проверку:
где номер_группы — ID группы, для которой требуется вывод панели. Источник |