Битрикс24 push and pull не работает

Не работает Push&Pull

Добрый день! у меня такая же проблема.

Стоит VA Bitrix 7.4.0 с NodeJS.
Подскажите что надо донастроить.
Вот вывод системы:

2019-Jul-20 23:33:42 Бизнес-чат в реальном времени (check_pull_stream): Fail

Server version: 3 (Bitrix Push server)

Connection to 91.122.44.199:80 Success
Connection to 127.0.0.1:8895 Success
== Request ==

HTTP/1.0 Host: 127.0.0.1

Content-Length: 32 0c90fbcedbe6d53da456242bdb3a39f5

HTTP/1.1 301 Moved Permanently
========== == Request ==

GET /bitrix/sub/?CHANNEL_ID=e20b54efd37c812a50d90d4850eac75b.7d3ec15559d6dee3fdb16821e3955f317cd908b9
HTTP/1.0 If-Modified-Since: Fri, 19 Jul 2019 23:33:02 +0300

Host: 91.122.44.199
== Response ==
== Body ==

HTTP/1.1 304 Not Modified
Server: nginx/1.16.0

Date: Sat, 20 Jul 2019 20:33:42 GMT

Content-Type: text/plain
Connection: close
Access-Control-Allow-Origin: *
Access-Control-Expose-Headers: Last-Message-Id
Last-Message-Id:

Expires: Thu, 01 Jan 1973 11:11:01 GMT

==========
Connection to 127.0.0.1:8895 Success

Ошибка! Модуль nginx-push-stream работает некорректно 2019-Jul-20 23:33:42
Живые комментарии в ленте сообщений (check_pull_comments): Fail

Ошибка! Не настроен модуль nginx push-stream, который необходим для отображения комментариев в живой ленте в реальном режиме времени

2019-Jul-20 23:33:42 Видеозвонки (check_turn): Fail

Ошибка! Не настроен модуль nginx push-stream, который необходим для осуществления видеозвонков

2019-Jul-20 23:33:43 Мобильное приложение Битрикс24 (check_access_mobile): Ok

Источник

Не работает Push&Pull

Добрый день! у меня такая же проблема.

Стоит VA Bitrix 7.4.0 с NodeJS.
Подскажите что надо донастроить.
Вот вывод системы:

2019-Jul-20 23:33:42 Бизнес-чат в реальном времени (check_pull_stream): Fail

Server version: 3 (Bitrix Push server)

Connection to 91.122.44.199:80 Success
Connection to 127.0.0.1:8895 Success
== Request ==

HTTP/1.0 Host: 127.0.0.1

Content-Length: 32 0c90fbcedbe6d53da456242bdb3a39f5

HTTP/1.1 301 Moved Permanently
========== == Request ==

GET /bitrix/sub/?CHANNEL_ID=e20b54efd37c812a50d90d4850eac75b.7d3ec15559d6dee3fdb16821e3955f317cd908b9
HTTP/1.0 If-Modified-Since: Fri, 19 Jul 2019 23:33:02 +0300

Host: 91.122.44.199
== Response ==
== Body ==

HTTP/1.1 304 Not Modified
Server: nginx/1.16.0

Date: Sat, 20 Jul 2019 20:33:42 GMT

Content-Type: text/plain
Connection: close
Access-Control-Allow-Origin: *
Access-Control-Expose-Headers: Last-Message-Id
Last-Message-Id:

Expires: Thu, 01 Jan 1973 11:11:01 GMT

==========
Connection to 127.0.0.1:8895 Success

Ошибка! Модуль nginx-push-stream работает некорректно 2019-Jul-20 23:33:42
Живые комментарии в ленте сообщений (check_pull_comments): Fail

Ошибка! Не настроен модуль nginx push-stream, который необходим для отображения комментариев в живой ленте в реальном режиме времени

2019-Jul-20 23:33:42 Видеозвонки (check_turn): Fail

Ошибка! Не настроен модуль nginx push-stream, который необходим для осуществления видеозвонков

2019-Jul-20 23:33:43 Мобильное приложение Битрикс24 (check_access_mobile): Ok

Источник

Читайте также:  Как настроить правила чата твич

Не работает Push&Pull

Развернули виртуальную машину BitrixVM7.2.0 для VirtualBox. Словили проблемы с Push&Pull — постоянно выходит сообщение, что отсутствует связь с сервером, тормоза в чатах, а главное, не работает телефония. Проверка системы выдает следующие ошибки:

[IMG WIDTH=772 HEIGHT=367][/IMG]

Bitrix NodeJS RTC включен по инструкции из учебного курса.
Поддержка ничего вразумительного не отвечает. Все свелось к «обратитесь с администратору хостинга».
При чем тут хостинг, если мы используем готовую настроенную виртуалку, но на своем железе?

Цитата
юрий белов написал:
При чем тут хостинг, если мы используем готовую настроенную виртуалку, но на своем железе?

лог проверки (в спойлер засунуть не получилось)

2018-Apr-16 11:56:21 Выполнение агентов на cron (check_bx_crontab): OkУспешно
2018-Apr-16 11:57:02 Бизнес-чат в реальном времени (check_pull_stream): Fail
Server version: 3 (Bitrix Push server)
Connection to ssl://bitrix.dsystem.ru:443 Success
Connection to bitrix.localhost:8895 Success
== Request ==
POST /bitrix/pub/?CHANNEL_ID=669b9725e967266ae55f22b0a9bfc2c7.c6ac55946059679826b84901d1c1c96e2ce0cb8d HTTP/1.0
Host: bitrix.localhost
Content-Length: 32

== Body ==
HTTP/1.1 200 OK

==========
== Request ==
GET /bitrix/sub/?CHANNEL_ID=669b9725e967266ae55f22b0a9bfc2c7.c6ac55946059679826b84901d1c1c96e2ce0cb8d HTTP/1.0
If-Modified-Since: Sun, 15 Apr 2018 11:56:22 +0300
Host: bitrix.dsystem.ru

== Body ==
HTTP/1.0 304 Not Modified
Server: nginx/1.12.2
Date: Mon, 16 Apr 2018 08:57:02 GMT
Content-Type: text/plain
Access-Control-Allow-Origin: *
Access-Control-Expose-Headers: Last-Message-Id
Expires: Thu, 01 Jan 1973 11:11:01 GMT
Last-Message-Id:
X-Content-Type-Options: nosniff
X-Frame-Options: SAMEORIGIN
Connection: close

==========
Connection to bitrix.localhost:8895 Success

Ошибка! Модуль nginx-push-stream работает некорректно
2018-Apr-16 11:57:02 Живые комментарии в ленте сообщений (check_pull_comments): Fail
Ошибка! Не настроен модуль nginx push-stream, который необходим для отображения комментариев в живой ленте в реальном режиме времени
2018-Apr-16 11:57:02 Видеозвонки (check_turn): Fail
Ошибка! Не настроен модуль nginx push-stream, который необходим для осуществления видеозвонков
2018-Apr-16 11:57:13 Мобильное приложение Битрикс24 (check_access_mobile): Warning
Connection to checker.internal.bitrix24.com:80 Success
== Request ==
GET /check/?license_hash=ee054a156a095bf850f0e0539a11dc45&host=bitrix.dsystem.ru&port=443&https=Y HTTP/1.1
host: checker.internal.bitrix24.com

== Response ==
HTTP/1.0 200 OK
Content-Type: text/plain
Date: Mon, 16 Apr 2018 08:57:04 GMT
Server: nginx/1.8.1
X-Powered-By: PHP/5.3.3
Content-Length: 35
X-Cache: MISS from shield.ds
X-Cache-Lookup: MISS from shield.ds:3128
Via: 1.1 shield.ds:3128 (squid/2.7.STABLE9)
Connection: close

== Body ==
Check: OK
Status: 200
Connection:

==========
Connection to checker.internal.bitrix24.com:80 Success
== Request ==
GET /check/?license_hash=ee054a156a095bf850f0e0539a11dc45&host=bitrix.dsystem.ru&port=8894&https=Y HTTP/1.1
host: checker.internal.bitrix24.com

== Response ==
HTTP/1.0 200 OK
Content-Type: text/plain
Date: Mon, 16 Apr 2018 08:57:15 GMT
Server: nginx/1.8.1
X-Powered-By: PHP/5.3.3
Content-Length: 33
X-Cache: MISS from shield.ds
X-Cache-Lookup: MISS from shield.ds:3128
Via: 1.1 shield.ds:3128 (squid/2.7.STABLE9)
Connection: close

== Body ==
Check: OK
Status: 0
Connection:

Источник

не работает чат (и кое-что ещё) в мобильном приложении. Подозрение на Push and Pull

Добрый день. Пользовались облачной версией bitrix24. Перешли на коробочную. Развернул BitrixWM. Развернул предоставленный бэкап, с помощью скрипта restore.php. Была огромная куча ошибок в Настройки -> Инструменты -> Проверка системы. Сейчас проверки выполняются, есть замечания в «Отправка почтовых уведомлений», однако сообщения на почту отправляются.
И дело совсем не в почте, а в мобильном приложении, которое при подключении, не может загрузить чаты, задачи и т.п. Просто появляется «подождите немного» и висит.
По скольку описание ошибок связанных с «Бизнес Чатом в реальном времени» и «Мобильном приложении» всегда ссылаются на некорректную настройку Push&Pullб, думаю, что проблема связанна с этим модулем.

Так же после развёртывания бэкапа на ВМ провёл этапы настройки из menu.sh. В том числе активировал NodeJS-PushServer. Однако тесты не проходили, тогда
в веб админке дополнительно указал следующие настройки модуля:
— Виртуальная машина 7.3 и новее (Bitrix Push server 2.0)
— http://[реальное_доменное_имя]:8895/bitrix/pub/
— ключ указал из команды grep SECURITY_KEY /etc/sysconfig/push-server-multi

Над BitrixWM стоит apache2, на котором настроено проксирование доменного имени и портов 80, 443 (сертификаты Lets Encrypt лежат на apache2), а так же 8890, 8891, 8893, 8894, 8895, 5222, 5223, 8070 — эти порты были указаны в различных мануалах по настройке Push&Pull. Все ли порты эти нужны?

п.с.: ТП в чате со мной общаться перестали. Даже «Здравствуйте! Передаю ваш диалог техническому специалисту, который. » не отвечают. По телефону ТП не осуществляется. Форум читал.

Источник

Настройка сервера очередей Push and Pull

Сервер очередей Push and Pull служит для мгновенного взаимодействия между собой многих инструментов Битрикс24. Он используется в Задачах, в Календарях, в ленте Новостей, в Группах, в RPA, в мобильном приложения Битрикс24, в чатах, в генераторе документов, в Телефонии, в Центре продаж и в других сервисах Битрикс24.

В весной 2021 года будет выпущено обновление модуля Веб-мессенджера (im) 20.400.0. После установки данного обновления поддержка работы чатов без настроенного сервера очередей модуля Push and Pull будет прекращена.

Осенью 2021 года будет прекращена поддержка старых версий локальных серверов очередей Nginx-PushStreamModule 0.3.4/0.4.0 и Bitrix Push server 1.0.

Поэтому мы рекомендуем вам заранее настроить сервер очередей – облачный сервер «1С-Битрикс» или локальный Bitrix Push server 2.0.

Облачный сервер очередей «1С-Битрикс»

Самый простой вариант, требует только активную лицензию на продукт «1С-Битрикс». Также удобен, если продукт «1С-Битрикс» установлен на shared-хостинге или вместо виртуальной машины VMBitrix используется собственное серверное окружение.

Перейдите в административном разделе: Настройки > Настройки продукта > Настройки модулей > Push and Pull, выберите вариант Облачный сервер «1С-Битрикс» и географическое расположение сервера по желанию (можно оставить автоматический выбор). Остается только нажать на кнопку Зарегистрироваться:

Все готово, облачный сервер очередей «1С-Битрикс» настроен и активен:

Локальный Bitrix Push server

Есть случаи, когда нельзя использовать в качестве сервера очередей облачный сервер «1С-Битрикс», например закрытый контур на предприятии, без доступа сервера в интернет. Для такого случая есть возможность установить локальный сервер очередей.

Так как в скором времени будет отключена поддержка старых версий сервера очередей, то мы будем устанавливать сразу Bitrix Push server 2.0.

1. Обновление VMBitrix

Обновите виртуальную машину VMBitrix до последней стабильной версии: 2. Configure localhost settings > 6. Update server.

2. Установка Bitrix Push server 2.0

По умолчанию в виртуальной машине VMBitrix версии 7.4.4 и ниже в качестве сервера очередей используется Nginx-PushStreamModule.

В главном меню виртуальной машины VMBitrix: 9. Configure Push/RTC service for the pool смотрим, какой сервер используется в качестве сервера очередей. В данном примере видим, что это действительно Nginx-PushStreamModule:

Выбираем пункт меню 1. Install/Update NodeJS RTC service, вводим название хоста Hostname и подтверждаем установку:

Дожидаемся, пока задача по установке и запуску службы NodeJS-PushServer будет закончена:

3. Bitrix Push server 2.0 в продуктах «1С-Битрикс»

Перед установкой Bitrix Push server 2.0 вам нужно предварительно сбросить настройки сервера очередей. Для этого нажмите на кнопку По умолчанию:

Далее в опции Использовать «Push server»: установленный локально выберите Виртуальная машина 7.3 и новее (Bitrix Push server 2.0) и сохраните настройки:

Все готово. Как правило, никаких настроек больше не требуется.

4. Ошибки Bitrix Push server 2.0

При установке и первом запуске Bitrix Push server 2.0 создается уникальный секретный код в файле настроек сервера очередей /etc/push-server/push-server*.json в секции security в параметре key :

В виртуальной машине BitrixVM при первом запуске Bitrix Push server 2.0 этот код автоматически прописывается в файл настроек ядра системы /bitrix/.setting.php и в базу данных, а также он виден в административном интерфейсе в поле Код-подпись для взаимодействия с сервером:

Бывают ситуации, когда по каким-либо причинам в файле настроек ядра /bitrix/.setting.php и в базе данных секретный код отличается от того, который прописан в настройках сервера очередей. Из-за этого сервер очередей работает некорректно, сообщения не доставляются.

Чтобы решить эту проблему, необходимо в меню виртуальной машины BitrixVM пересоздать роль NodeJS-PushServer: 9. Configure Push/RTC service for the pool > 1. Install/Update NodeJS RTC service

Если у вас свое серверное окружение, то можно сделать это вручную:

  1. Скопировать ключ из файла настроек сервера очередей /etc/push-server/push-server*.json.
  2. Перейти в административном интерфейсе продукта «1С-Битрикс»: Настройки > Настройки продукта > Настройки модулей > Push and Pull и сбросить настройки сервера очередей кнопкой По умолчанию.
  3. Скопированный ключ вставить в поле Код-подпись для взаимодействия с сервером и сохранить настройки.

После этого работа сервера очередей будет восстановлена.

Источник

Оцените статью