- Dkim подпись не работает
- Не работает DKIM
- Не работает DKIM
- Re: Не работает DKIM
- Re: Не работает DKIM
- Re: Не работает DKIM
- Re: Не работает DKIM
- Re: Не работает DKIM
- Re: Не работает DKIM
- Re: Не работает DKIM
- Re: Не работает DKIM
- Re: Не работает DKIM
- Тема: DKIM не работает (dkim=temperror)
- DKIM не работает (dkim=temperror)
Dkim подпись не работает
- Список форумов‹Технические вопросы‹Вопросы о работе сервера
- Изменить размер шрифта
- Для печати
- FAQ
- Вход
Не работает DKIM
Модераторы: Art.i, garry
Не работает DKIM
Flector » Ср ноя 23, 2016 1:41 pm
В настройках панели включен:
в почтовом домене включен:
в записях домена прописался:
проверку проходит:
а вот письма приходят без строчек DKIM-Filter и DKIM-Signature, в результате гугл помечает их как ненадежные.
гуглил, гуглил и не нашел причину.
вроде как в ISPManager5 был раньше баг, но его вроде бы исправили.
поэтому мне непонятно в какую сторону копать.
Re: Не работает DKIM
Mikanoshi » Ср ноя 23, 2016 2:54 pm
Re: Не работает DKIM
Flector » Ср ноя 23, 2016 3:01 pm
так что проверять то?
для меня конфиг это книга на китайском.
поэтому, собственно, панелью и пользуюсь.
вот конфиг:
Код: выделить все DKIM_ENABLE = yes
SA_SPAMD_USER = __ISP_SPAMD_USER__
SA_SCORE_REJECT = 50
SA_ABUSE_ADDR = The System Administrator
log_selector = \
+all_parents \
+lost_incoming_connection \
+received_sender \
+received_recipients \
+tls_cipher +tls_peerdn +tls_sni \
+smtp_confirmation \
+smtp_syntax_error \
+smtp_protocol_error
.ifdef SA_ENABLE
spamd_address = 127.0.0.1 783
.endif
trusted_groups = mgrsecure
trusted_users = apache
domainlist local_domains = lsearch;/etc/exim/domains
domainlist dummy_domains =
hostlist relay_from_hosts = 127.0.0.1 : 213.159.208.94
domainlist relay_to_domains = lsearch;/etc/exim/domains
exim_user = exim
exim_group = exim
.ifdef VIRUS_SCAN
av_scanner = clamd:__CLAMAV_SOCKET__
.endif
never_users = root
host_lookup = *
rfc1413_hosts = *
rfc1413_query_timeout = 0s
ignore_bounce_errors_after = 2d
timeout_frozen_after = 7d
acl_smtp_rcpt = acl_check_rcpt
acl_smtp_data = acl_check_data
acl_not_smtp = acl_check_not_smtp
.ifdef DKIM_ENABLE
acl_smtp_dkim = acl_check_dkim
.endif
acl_check_not_smtp:
# check ratelimits by local user
warn condition = $
set acl_c9 = $sender_ident
warn condition = $
set acl_c9 = $sender_address
deny condition = $
set acl_c8 = $
ratelimit = $acl_c8 / 1h / strict / $acl_c9
message = Sender rate overlimit — $sender_rate / $sender_rate_period / $acl_c9
.ifdef DEFAULT_RATELIMIT
# check ratelimits by default
warn set acl_c7 = $sender_ident
warn condition = $
set acl_c7 = $sender_address
deny condition = $
ratelimit = DEFAULT_RATELIMIT / 1h / strict / $acl_c7
message = Sender rate overlimit — $sender_rate / $sender_rate_period / $acl_c7
.endif
.ifdef VIRUS_SCAN
warn
set acl_m3 = no
warn
condition = $
set acl_m3 = ok
.endif
accept hosts = +relay_from_hosts
!authenticated = *
set acl_m6 = whitelisted
accept domains = +local_domains : +relay_to_domains
condition = $
set acl_m6 = whitelisted
logwrite = Accepted from $sender_address to $local_part@$domain by whitelist.
accept domains = +local_domains : +relay_to_domains
hosts = net-lsearch;/etc/exim/whitelist
set acl_m6 = whitelisted
logwrite = Accepted from $sender_address to $local_part@$domain by whitelist.
deny condition = $
set acl_m6 = blacklisted
logwrite = Rejected from $sender_address to $local_part@$domain by blacklist.
deny hosts = net-lsearch;/etc/exim/blacklist
set acl_m6 = blacklisted
logwrite = Rejected from $sender_address to $local_part@$domain by blacklist.
deny message = Restricted characters in address
domains = +local_domains
local_parts = ^[.] : ^.*[@%!/|]
deny message = Restricted characters in address
domains = !+local_domains
local_parts = ^[./|] : ^.*[@%!] : ^.*/\\.\\./
accept local_parts = postmaster
verify = recipient
domains = +local_domains
require verify = sender
# check ratelimits by emails
warn authenticated = *
set acl_c0 = group$
set acl_c1 = $
ratelimit = $
ratelimit = $acl_c1 / 1h / strict / $authenticated_id
log_message = Sender rate overlimit — $sender_rate / $sender_rate_period / $authenticated_id
condition = $
deny authenticated = *
set acl_c1 = $
ratelimit = $acl_c1 / 1h / leaky / $authenticated_id
message = Sender rate overlimit — $sender_rate / $sender_rate_period / $authenticated_id
condition = $
# check ratelimits by group
warn authenticated = *
set acl_c0 = group$
ratelimit = $
log_message = Sender rate overlimit — $sender_rate / $sender_rate_period / $acl_c0
condition = $
deny authenticated = *
set acl_c0 = group$
ratelimit = $
message = Sender rate overlimit — $sender_rate / $sender_rate_period / $acl_c0
condition = $
.ifdef DEFAULT_RATELIMIT
# check ratelimits by default
deny authenticated = *
ratelimit = DEFAULT_RATELIMIT / 1h / strict / $authenticated_id
message = Sender rate overlimit — $sender_rate / $sender_rate_period / $authenticated_id
condition = $
.endif
accept hosts = +relay_from_hosts
!authenticated = *
control = submission/sender_retain
deny message = rejected because $sender_host_address is in a black list at $dnslist_domain\\n$dnslist_text
dnslists = $
require message = relay not permitted
domains = +local_domains : +relay_to_domains
require verify = recipient
.ifdef POSTGREY_SOCKET
defer log_message = greylisted host $sender_host_address
set acl_m0 = request=smtpd_access_policy\nprotocol_state=RCPT\nprotocol_name=$
set acl_m0 = $
message = $
condition = $
.endif
accept
condition = $
logwrite = Accept message without spamd and antivirus check because LA > 3.
.ifdef VIRUS_SCAN
accept
condition = $
logwrite = Accept message without antivirus check because body size $message_body_size not critical
deny
message = This message contains virus ($malware_name)
hosts = *
demime = *
malware = *
log_message = Rejected: this message contains virus ($malware_name)
condition = $
.endif
.ifdef SA_ENABLE
warn
!authenticated = *
hosts = !127.0.0.1/24
condition = $
message = Content analisis tool detect spam (from $sender_address to $recipients). Contact SA_ABUSE_ADDR.
.endif
.ifdef DKIM_ENABLE
acl_check_dkim:
warn
dkim_status = fail
logwrite = DKIM test failed: $dkim_verify_reason
add_header = X-DKIM-FAIL: DKIM test failed: (address=$sender_address domain=$dkim_cur_signer), signature is bad.
warn
dkim_status = invalid
add_header = :at_start:Authentication-Results: $dkim_cur_signer ($dkim_verify_status); $dkim_verify_reason
logwrite = DKIM test passed (address=$sender_address domain=$dkim_cur_signer), but signature is invalid.
accept
dkim_status = pass
add_header = :at_start:Authentication-Results: dkim=$dkim_verify_status, header.i=@$dkim_cur_signer
logwrite = DKIM test passed (address=$sender_address domain=$dkim_cur_signer), good signature.
begin routers
dnslookup:
driver = dnslookup
domains = !+dummy_domains
transport = remote_smtp
ignore_target_hosts = 0.0.0.0 : 127.0.0.0/8
self = pass
no_more
disabled_domains:
driver = redirect
condition = $
allow_fail = yes
data = :fail: Domain disabled
no_more
disabled_users:
driver = redirect
condition = $
allow_fail = yes
data = :fail: User disabled
no_more
catchall_for_domains:
driver = redirect
headers_add = X-redirected: yes
data = $
file_transport = local_delivery
redirect_router = dnslookup
unknown_users:
driver = redirect
allow_fail = yes
data = :fail: Unknown user
no_more
remote_smtp:
driver = smtp
begin retry
* * F,2h,15m; G,16h,1h,1.5; F,4d,6h
auth_plain:
driver = dovecot
public_name = PLAIN
server_socket = /var/run/dovecot/auth-client
server_set_id = $auth1
auth_login:
driver = dovecot
public_name = LOGIN
server_socket = /var/run/dovecot/auth-client
server_set_id = $auth1
auth_cram_md5:
driver = dovecot
public_name = CRAM-MD5
server_socket = /var/run/dovecot/auth-client
server_set_id = $auth1
что в нем не так?
Re: Не работает DKIM
Mikanoshi » Ср ноя 23, 2016 4:03 pm
Re: Не работает DKIM
Flector » Ср ноя 23, 2016 4:11 pm
Re: Не работает DKIM
Flector » Чт ноя 24, 2016 10:52 am
удалил все почтовые домены, удалил в возможностях почтовый сервер — установил его заново, заново добавил почтовый домен — опять подписей DKIM в письмах нет.
Re: Не работает DKIM
Mikanoshi » Чт ноя 24, 2016 3:11 pm
Re: Не работает DKIM
Flector » Чт ноя 24, 2016 3:34 pm
существует.
в процессах не висит, но для exim это вроде как нормально.
плин, шаблон сервера то по умолчанию, а не работает.
Re: Не работает DKIM
Flector » Чт ноя 24, 2016 7:06 pm
Re: Не работает DKIM
Flector » Чт ноя 24, 2016 11:10 pm
Источник
Тема: DKIM не работает (dkim=temperror)
Опции темы
Поиск по теме
DKIM не работает (dkim=temperror)
Нужна помощь. По моему я не сделал какой-то шаг. Хотя что мог найти в документации выполнил.
1) В ISP manager во вкладке Почтовые домены открыл требуемый домен, включил DKIM и написал свой селектор life
2) Через менеджер фалов в панели по адресу /etc/exim/ssl/ открыл файл хх.life.txt Исправил его до такого вида:
life._domainkey IN TXT «v=DKIM1; k=rsa; s=email; p=MIGfMA0GCSqGSIb3DQEB-удалено за-ненадобностью-SA3lXvIh7zHCOJSb3g2xswIDAQAB»;
3). Вставил DNS запись на сервер такого вида (см. выше). И проверил ее https://www.mail-tester.com/spf-dkim-check Все видно. Открытый ключ совпадает.
4). Проверил запись в DNS _domainkey.ru.life. TXT t=s; o=
; и _dmarc.xx.life. TXT v=DMARC1; p=none Есть, вроде все нормально. С acy._domainkey.хх.life. эти записи и DKIM работает
5). Открываю почтовый клиент Outlook и шлю письмо с почтового адреса на эл. почту в Google и вижу в оригинале сообщения следующее:
Received: from хх.life (хх.life. [2a04:ac00:1:7502:5054:ff:fe00:b0f1])
by mx.google.com with ESMTPS id p1si901782lje.420.2017.09.21.12.49.38
for
(version=TLS1_2 cipher=ECDHE-RSA-AES128-GCM-SHA256 bits=128/128);
Thu, 21 Sep 2017 12:49:38 -0700 (PDT)
Received-SPF: pass (google.com: domain of postmaster@хх.life designates 2a04:ac00:1:7502:5054:ff:fe00:b0f1 as permitted sender) client-ip=2a04:ac00:1:7502:5054:ff:fe00:b0f1;
Authentication-Results: mx.google.com;
dkim=temperror (no key for signature) header.i=@хх.life header.s=dkim header.b=hD3Ylcuh;
spf=pass (google.com: domain of postmaster@хх.life designates 2a04:ac00:1:7502:5054:ff:fe00:b0f1 as permitted sender) smtp.mailfrom=postmaster@хх.life;
dmarc=pass (p=NONE sp=NONE dis=NONE) header.from=хх.life
DKIM-Signature: v=1; a=rsa-sha256; q=dns/txt; c=relaxed/relaxed; d=хх.life; s=dkim; h=Content-Type:MIME-Version:Message-ID
Received: from [188.242.251.72] (helo=DESKTOPR47SRN6) by хх.life with esmtpsa (TLSv1.2
) id 1dv7Td-0000o5-QH for ****personal@gmail.com; Thu, 21 Sep 2017 22:49:37 +0300
From:
To:
Subject: Проверка
DomainKeys Identified Mail (DKIM) представляет собой метод создания соответствия доменного имени в сообщении электронной почты, что позволяет человеку, роли или организации требовать определенную ответственность за это сообщение.
Подпись DKIM Вашего письма:
v=1;
a=rsa-sha256;
q=dns/txt;
c=relaxed/relaxed;
d=xx.life;
s=dkim;
h=Content-Type:MIME-Version:Message-ID
bh=SQI6Tw7iZx5MPotx9HjwYgmJ6EbAVP9QS05e+DsnqOg=;
b=omzfn9RDmufA5C2odDUvHDv4sYGfJcX80rUJGGCNhge+IK3h OVIuKJwUpwOjJnJjNNXa9TnyYPr8M7rOe53kbPqtjnaHikdb7H vpP6x+U1kpdO7z0Moj2wbC2LARLLjH2DQMAsDBO63adKRTTHGi f57VLY5Ua5W7AqQdEEwyKow=;
Нам не удалось получить Ваш открытый ключ.
Пожалуйста, убедитесь, что Вы добавили в DNS своего домена ru.life DKIM-подпись как запись TXT с помощью селектора dkim.
Если Вы недавно изменили свой DNS, пожалуйста, будьте терпеливы и повторите тест Вашей рассылки. На распространение изменений, внесенные в DNS, может потребоваться от 12 до 48 часов.
Последний раз редактировалось Виктор С.; 22.09.2017 в 06:04 .
Источник