- Ошибка Hyper-V «Не удаётся запустить виртуальную машину, поскольку не выполняется низкоуровневая оболочка»
- Системные требования
- Хранилище BCD
- AMD Bulldozer
- Технологии виртуализации
- Устранение неполадок с Hyper-V в Windows 10
- После обновления до Windows 10 не удается подключиться к узлу нижнего уровня (Windows 8.1 или Server 2012 R2)
- Создается неправильный тип контрольной точки даже после его изменения
- При попытке создать виртуальный жесткий диск на устройстве флэш-памяти отображается сообщение об ошибке
- При попытке установки появляется сообщение: «Не удается установить Hyper-V: процессор не поддерживает преобразование адресов второго уровня (SLAT)».
- Виртуальная машина Hyper-V 2016 не запускается из-за ошибки диспетчера RemoteFX?
- Приложения виртуализации не работают вместе с Hyper-V, device Guard и Credential Guard
- Определите, запущен ли Hyper-V гипервизор
- Причина
- Отключение Hyper-V
- Отключение Hyper-V панели управления
- Отключение Hyper-V в PowerShell
- Отключение охраны устройств и охраны учетных данных
- Дополнительная информация
- Драйвер инфраструктуры виртуализации vid не работает hyper v
- Вопрос
- Ответы
- Все ответы
Ошибка Hyper-V «Не удаётся запустить виртуальную машину, поскольку не выполняется низкоуровневая оболочка»
Hyper-V , родная для систем Windows – в её серверных выпусках, а также в некоторых десктопных версиях и редакциях – среда для работы с виртуальными машинами и их гостевыми ОС не всегда работает без проблем. Одной из таких проблем может быть выскакивающее при запуске виртуальной машины уведомление, что, мол, Hyper-V не удаётся её запустить, поскольку не выполняется некая низкоуровневая оболочка.
Что это за ошибка, и как её исправить.
Окно с такой ошибкой является универсальной трактовкой, причина может крыться в нескольких вещах.
Системные требования
Если сама Windows не соответствует требованиям для работы с Hyper-V, а десктопные выпуски не все позволяют работать с этим компонентом, он попросту не активируется в системе. Но есть ещё аппаратные требования. Их несоответствие может не влиять на активацию гипервизора, но в дальнейшем стать причиной появления такой ошибки.
Для работы Hyper-V необходимо:
• Не менее 4 Гб RAM;
• 64-битный процессор с поддержкой SLAT и технологии виртуализации.
Хранилище BCD
Рассматриваемая ошибка может говорить о неверной конфигурации данных хранилища BCD . Компонент Hyper-V глубоко интегрирован в Windows и стартует до запуска ядра системы. Если в хранилище BCD вносились изменения для модификации запуска гипервизора, они могут быть неверными. Либо же запуск Hyper-V и вовсе был ранее намеренно отключён с целью временной оптимизации использования ресурсов компьютера. В таком случае конфигурацию BCD в части запуска гипервизора необходимо либо подкорректировать, либо вернуть дефолтное значение путём установки автозапуска Hyper-V. Для установки автозапуска открываем CMD от имени администратора (обязательно) , вводим:
bcdedit /set hypervisorlaunchtype auto
После этого осуществляем перезагрузку.
AMD Bulldozer
Hyper-V не работает с процессорами компании AMD с архитектурой Bulldozer.
Технологии виртуализации
Для обеспечения жизнедеятельности среды виртуализации посредством любого гипервизора процессор должен быть обустроен технологией, обеспечивающей виртуализацию – Intel Virtualization, либо же AMD-V. О поддержке этих технологий можно узнать на страничке спецификаций процессора на сайтах, соответственно, Intel и AMD . И технология виртуализация, естественно, должна быть включена в BIOS .
Ещё один важный нюанс: для процессоров Intel в BIOS должны быть отключены специфические технологии Intel VT-d и Trusted Execution. С ними встроенный в Windows гипервизор не дружит. Вот примерно так должны выглядеть настройки BIOS для работы с Hyper-V: технология виртуализации включена, а специфические технологии – выключены.
Источник
Устранение неполадок с Hyper-V в Windows 10
После обновления до Windows 10 не удается подключиться к узлу нижнего уровня (Windows 8.1 или Server 2012 R2)
В Windows 10 диспетчер Hyper-V перемещен в WinRM для удаленного управления. Это значит, что теперь для управления удаленным узлом Hyper-V с помощью диспетчера Hyper-V на нем необходимо включить удаленное управление.
Создается неправильный тип контрольной точки даже после его изменения
При создании контрольной точки в программе «Подключение к виртуальной машине» используется тип, который был указан на момент ее открытия, даже если вы изменили его в диспетчере Hyper-V.
Закройте и снова откройте программу «Подключение к виртуальной машине», чтобы она создала правильный тип контрольной точки.
При попытке создать виртуальный жесткий диск на устройстве флэш-памяти отображается сообщение об ошибке
Hyper-V не поддерживает диски в формате FAT или FAT32, так как эти файловые системы не предоставляют списки управления доступом (ACL) и не поддерживает файлы размером более 4 ГБ. Диски в формате ExFAT имеют ограниченную функциональность ACL, поэтому также не поддерживаются из соображений безопасности. В PowerShell отображается сообщение об ошибке «Системе не удалось создать «[путь к VHD]»: запрошенная операция не может быть завершена из-за ограничения файловой системы (0x80070299)».
Используйте диск с файловой системой NTFS.
При попытке установки появляется сообщение: «Не удается установить Hyper-V: процессор не поддерживает преобразование адресов второго уровня (SLAT)».
Для запуска виртуальных машин с помощью Hyper-V требуется поддержка SLAT. Если ваш компьютер не поддерживает SLAT, размещение на нем виртуальных машин невозможно.
Если вы просто хотите установить средства управления, снимите флажок Платформа Hyper-V в разделе Программы и компоненты > Включение или отключение компонентов Windows.
Источник
Виртуальная машина Hyper-V 2016 не запускается из-за ошибки диспетчера RemoteFX?
Я сделал чистую установку роли Server 2016 + Hyper-V на новом сервере с Xeon v4, 100 ГБ+ ОЗУ и картой Nvidia Quadro с поддержкой RemoteFX с 6 ГБ GDDR. (если он работает, я буду использовать голый Hyper-V server 2016, это для тестирования так полный сервер + роль в порядке).
установка прошла нормально. Я включил роли и функции, что тоже было хорошо, а затем установил драйверы Quadro. Менеджер Hyper-V сразу распознал и принял Quadro и сообщает, что может предоставить Службы RemoteFX для виртуальных машин с ним. Поэтому я создал простую виртуальную машину Gen2, чтобы проверить ее. ISO-образ установщика виртуальных машин-Win 8.1 Enterprise, совместимый с RemoteFX.
виртуальная машина отказывается запускаться, если я включаю 3D-адаптер RemoteFX в оборудование. Он пытается в течение 1-3 минут, а затем сообщает об ошибке 32788 во всплывающем окне графического интерфейса, что он не мог начать. Если я удалю виртуальный адаптер RemoteFX он начинает нормально.
Hyper-V VMMS и журналы событий работника показать различные ошибки:
- ошибка 32613 «службе управления виртуальными машинами не удалось запустить Диспетчер RemoteFX. Попробуйте перезапустить службу управления виртуальными машинами. Сообщение об ошибке: предпринята попытка сослаться на маркер, который не существует. Код Состояния 20.».
- ошибка 4120 «описание не найдено. Locale конкретного ресурса для нужного сообщения нет. Базовый XML для сообщения не очень хорошо сформирован»
- ошибка 32607 » не удалось получить доступ к необходимым ресурсам GPU. Этот сервер не может работать как узел RemoteFX без графического процессора. Убедитесь, что графический процессор установлен правильно»
- ошибка 15350 «драйвер инфраструктуры виртуализации (VID) не запущен»
- ошибки 12010 «описание не найдено. Locale конкретного ресурса для нужного сообщения нет.»
- ошибка 12018 «синтетическая 3D-дисплей контроллер: Не вкл . поскольку не удалось создать рабочий сеанс»
Я исключил обычные причины (дисковое пространство, несовместимый процессор/карта) и не может найти какой-либо ресурс для устранения неполадок дальше. Ошибки устройств не отображаются на страницах параметров виртуальной машины или гипервизора. На сервере включены все применимые роли для виртуализации Hyper-V и настольных компьютеров. Все устройства в «Диспетчере устройств» (включая драйвер MS Hyper-VID в разделе «Система») сообщают, что работают правильно, поэтому не похоже, чтобы быть ошибка запуска драйвера. Вся моя деятельность в значительной степени была: установка обновлений Server 2016+, включение функций виртуализации ролей Hyper-V/desktop+, установка драйвера Quadro, настройка Hyper-V и создание виртуальной машины, поэтому для странных вещей не так много возможностей.
некоторые веб-страницы ссылаются на проблемы с разрешениями RemoteFX, которые могут привести к тому, что виртуальные машины не запустятся, но обычно, если это так, это указано явно (согласно страницам, которые я видел). В моем случае нет явного утверждение о проблеме разрешений, хотя «маркер» и утверждение о том, что ресурсы «не могут быть доступны» настоятельно предполагает, что какая-то проблема маркера разрешений может происходить. Но ни намека на что, если это так.
Я не могу найти больше информации, и нет никаких других ссылок на эту ошибку в интернете, которые кажутся релевантными. Я понятия не имею, где искать, чтобы исправить это, или проследить, что вызвало отказ.
Источник
Приложения виртуализации не работают вместе с Hyper-V, device Guard и Credential Guard
Многие сторонние приложения виртуализации не работают вместе с Hyper-V. Затронутые приложения включают рабочие станции VMware и VirtualBox. Эти приложения могут не запускать виртуальные машины или возвращаться в более медленный, эмулированный режим.
Эти симптомы вводятся при Hyper-V гипервизора. Некоторые решения безопасности также зависят от гипервизора, например:
- Device Guard
- Credential Guard
Применяется к: Windows 10 — все выпуски
Исходный номер КБ: 3204980
Определите, запущен ли Hyper-V гипервизор
Чтобы определить, запущен ли Hyper-V гипервизор, выполните следующие действия:
В поле поиска введите msinfo32.exe.
Выберите Сведения о системе.
В окне детализации найдите следующую запись:
Обнаружен гипервизор. Функции, необходимые для Hyper-V, не будут отображаться.
Причина
Такое поведение происходит по проекту.
Многие приложения виртуализации зависят от расширений виртуализации оборудования, доступных на большинстве современных процессоров. В нее входят Intel VT-x и AMD-V. Только один компонент программного обеспечения может использовать это оборудование одновременно. Оборудование не может быть общим между приложениями виртуализации.
Чтобы использовать другое программное обеспечение для виртуализации, необходимо отключить Hyper-V, device Guard и Credential Guard. Если вы хотите отключить Hyper-V Hypervisor, выполните действия в следующих двух разделах.
Отключение Hyper-V
Вы можете отключить Hyper-V в панели управления или с помощью Windows PowerShell.
Отключение Hyper-V панели управления
Чтобы отключить Hyper-V панели управления, выполните следующие действия:
В панели управления выберите программы и функции.
Выберите функции Windows включите или отключите.
Расширйте Hyper-V, Hyper-V платформу, а затем расчистим Hyper-V гипервизора.
Отключение Hyper-V в PowerShell
Чтобы отключить Hyper-V с помощью Windows PowerShell, выполните следующие действия:
Откройте окно PowerShell с повышенными уровнями.
Выполните следующую команду:
Отключение охраны устройств и охраны учетных данных
Вы можете отключить службу device Guard и Credential Guard с помощью ключей реестра или групповой политики. Чтобы сделать это, см. в Защитник Windows Credential Guard.
Дополнительная информация
Заявление об отказе от ответственности за сведения о продуктах сторонних производителей
В этой статье упомянуты программные продукты независимых производителей. Корпорация Майкрософт не дает никаких гарантий, подразумеваемых и прочих, относительно производительности и надежности этих продуктов.
Источник
Драйвер инфраструктуры виртуализации vid не работает hyper v
Вопрос
Adaptec RAID 6405
Устанавливаем Windows Server 2012 r2 как Hyper-V
Обновления все установлены, NUMA disable, в BIOS все настройки проставлены.
Вот какую ошибку мы видим при старте:
Hypervisor launch failed; Processor does not provide the features necessary to run the hypervisor (leaf 0x80000001, register 0x3: features needed 0x2C100800, features supported 0x2C000800).
Драйвер инфраструктуры виртуализации (VID) не работает.
Как это можно решить?
Ответы
Adaptec RAID 6405
Устанавливаем Windows Server 2012 r2 как Hyper-V
Обновления все установлены, NUMA disable, в BIOS все настройки проставлены.
Вот какую ошибку мы видим при старте:
Hypervisor launch failed; Processor does not provide the features necessary to run the hypervisor (leaf 0x80000001, register 0x3: features needed 0x2C100800, features supported 0x2C000800).
Драйвер инфраструктуры виртуализации (VID) не работает.
Как это можно решить?
Судя по информации из ошибке у вас не включена аппаратная поддержка предотвращения выполнения данных (NX bit, его поддержка указывается отсутствующим у вас битом 0x00100000 в регистре DX после вызова команды CPUID с AX=0x80000001). Для виртуализации включение этой поддержки необходимо. Проверьте в настройках BIOS.
PS После включения в BIOS виртуализации обычно бывает необходимо не просто перезагрузить систему, а выключить и снова включить её питание.
- Изменено M.V.V. _ 8 октября 2014 г. 9:20
- Помечено в качестве ответа Petko Krushev Microsoft contingent staff, Moderator 15 октября 2014 г. 8:02
Все ответы
Думаю у Вас проблема на уровне компонентов(hardware), но на всякий случай, посмотрите тему внизу, возможно как нибудь поможет:
Мнения, высказанные здесь, являются отражением моих личных взглядов, а не позиции корпорации Microsoft. Вся информация предоставляется «как есть» без каких-либо гарантий. Не забывайте помечать сообщения как ответы и полезные, если они Вам помогли.
Проблему решили след. образом:
1. Обесточили сервер
2. Обновили BIOS до последней версии
3. Обесточили сервер
4. Сбросили BIOS к заводским настройкам
5. Обесточили сервер
Причем NUMA enable, хотя Supermicro рекомендует ставит в disable.
Adaptec RAID 6405
Устанавливаем Windows Server 2012 r2 как Hyper-V
Обновления все установлены, NUMA disable, в BIOS все настройки проставлены.
Вот какую ошибку мы видим при старте:
Hypervisor launch failed; Processor does not provide the features necessary to run the hypervisor (leaf 0x80000001, register 0x3: features needed 0x2C100800, features supported 0x2C000800).
Драйвер инфраструктуры виртуализации (VID) не работает.
Как это можно решить?
Судя по информации из ошибке у вас не включена аппаратная поддержка предотвращения выполнения данных (NX bit, его поддержка указывается отсутствующим у вас битом 0x00100000 в регистре DX после вызова команды CPUID с AX=0x80000001). Для виртуализации включение этой поддержки необходимо. Проверьте в настройках BIOS.
PS После включения в BIOS виртуализации обычно бывает необходимо не просто перезагрузить систему, а выключить и снова включить её питание.
- Изменено M.V.V. _ 8 октября 2014 г. 9:20
- Помечено в качестве ответа Petko Krushev Microsoft contingent staff, Moderator 15 октября 2014 г. 8:02
Adaptec RAID 6405
Устанавливаем Windows Server 2012 r2 как Hyper-V
Обновления все установлены, NUMA disable, в BIOS все настройки проставлены.
Вот какую ошибку мы видим при старте:
Hypervisor launch failed; Processor does not provide the features necessary to run the hypervisor (leaf 0x80000001, register 0x3: features needed 0x2C100800, features supported 0x2C000800).
Драйвер инфраструктуры виртуализации (VID) не работает.
Как это можно решить?
Судя по информации из ошибке у вас не включена аппаратная поддержка предотвращения выполнения данных (NX bit, его поддержка указывается отсутствующим у вас битом 0x00100000 в регистре DX после вызова команды CPUID с AX=0x80000001). Для виртуализации включение этой поддержки необходимо. Проверьте в настройках BIOS.
PS После включения в BIOS виртуализации обычно бывает необходимо не просто перезагрузить систему, а выключить и снова включить её питание.
Источник