Iis не работает http

Подключения HTTPS сбой и привязки SSL удаляются для веб-сайта в IIS 7.0 и 7.5

В этой статье помогают устранить проблему с сбойом подключений HTTPS и удалением привязки SSL для веб-сайта в службы IIS (IIS) 7.0 и 7.5.

Оригинальная версия продукта: службы IIS
Исходный номер КБ: 2025598

Симптомы

Рассмотрим следующий сценарий.

  • У вас есть веб-приложение, которое работает в Internet IIS 7.0 или выше, которое настроено с привязкой SSL.
  • Периодически подключение к веб-сайту через HTTPS не удается.
  • Пользователи по-прежнему могут получать доступ к сайту через HTTP, если сайт не настроен на подключение SSL.

Когда возникает проблема, пользователи, пытающиеся просмотреть веб-сайт через HTTPS, могут видеть предупреждающие сообщения о том, что срок действия сертификата SSL истек или еще не действителен, или что имя веб-сайта неверно. Если администратор сайта открывает диспетчер IIS для просмотра параметров SSL сайта, он может обнаружить, что привязки SSL для веб-сайта были удалены или заменены недействительными сведениями о привязке сертификата. Наконец, событие, аналогичное следующему, регистрируется в журнале событий System:

Имя журнала: System
Источник: Microsoft-Windows-HttpEvent
Дата: 3/31/2010 14:43:28
ID события: 15300
Категория задач: Нет
Уровень: предупреждение
Ключевые слова: Классический
Пользователь: N/A
Компьютер: IISServer
Описание:
Сертификат SSL Параметры для порта: x.x.x:443

Причина

Привязка SSL для веб-сайта была удалена и не заменена или удалена и заменена недействительными сведениями сертификата. Проблема возникает из-за того, что устаревшее свойство hash сертификата SSL вмешивается в текущую привязку SSL, что приводит к удалению правильной привязки.

Решение

Найдите следующее свойство в разделеapplicationHost.config и удалите его:

Это свойство является устаревшей функцией IIS 6.0 и больше не требуется.

Источник

ОШИБКА HTTP 500.19 — ошибка внутреннего сервера при открываемой веб-странице IIS

В этой статье решается проблема, при которой вы получаете сообщение об ошибке HTTP 500.19 в веб-приложении в службы IIS (IIS) 7.0 и более поздних версиях.

Оригинальная версия продукта: службы IIS версии 7.0 и более поздних версий
Исходный номер КБ: 942055

Чтобы устранить эту ошибку, ознакомьтесь со следующими разделами для получения соответствующих сведений о коде ошибки.

Код HRESULT 0x8007000d

Сообщение об ошибке:

Ошибка сервера в приложении «имя приложения»
ОШИБКА HTTP 500.19 — ошибка внутреннего сервера
HRESULT: 0x8007000d
Описание HRESULT
Запрашиваемая страница не может быть доступом, так как связанные данные конфигурации для страницы недействительны.

Эта проблема возникает из-за того, что ApplicationHost.config или Web.config содержит неопознанный или неопознанный элемент XML. IIS не может определить XML-элементы не установленных модулей. Например, модуль переписать URL-адрес IIS.

Читайте также:  Не работает печка volkswagen golf

Используйте один из следующих методов:

  • Удаление неправильного XML-элемента из ApplicationHost.config или Web.config файла.
  • Проверьте неопознанный элемент XML и установите соответствующие модули IIS.

Код HRESULT 0x80070021

Сообщение об ошибке:

Ошибка сервера в приложении «имя приложения»
ОШИБКА HTTP 500.19 — ошибка внутреннего сервера
HRESULT: 0x80070021
Описание HRESULT
Запрашиваемая страница не может быть доступом, так как связанные данные конфигурации для страницы недействительны.

Эта проблема может возникнуть, если указанная часть файла конфигурации IIS заблокирована на более высоком уровне конфигурации.

Разблокировать указанный раздел или не использовать его на более высоком уровне. Дополнительные сведения о блокировке конфигурации см. в дополнительных сведениях об использовании блокировки в конфигурации IIS 7.0.

Код HRESULT 0x80070005

Сообщение об ошибке:

Ошибка сервера в приложении «имя приложения»
ОШИБКА HTTP 500.19 — ошибка внутреннего сервера
HRESULT: 0x80070005
Описание HRESULT
Запрашиваемая страница не может быть доступом, так как связанные данные конфигурации для страницы недействительны.

Эта проблема может возникать по одной из следующих причин:

  • Вы используете IIS на компьютере, который работает Windows. Кроме того, вы настраивает веб-сайт для использования сквозной проверки подлинности Универсальной конвенции имен (UNC) для доступа к удаленной совместной акции UNC.
  • Группа IIS_IUSRS не имеет соответствующих разрешений для ApplicationHost.config, Web.config или виртуальных или каталогов приложений IIS.

Используйте один из следующих методов:

Не настраивайте веб-сайт для использования сквозной проверки подлинности UNC для доступа к удаленной совместной акции UNC. Вместо этого укажите учетную запись пользователя, которая имеет соответствующие разрешения для доступа к удаленной совместной акции UNC.

Разрешить чтение группе IIS_IUSRS для ApplicationHost.config или Web.config. Для этого выполните следующие действия:

В Windows Explorer найдите папку, содержаную файл ApplicationHost.config, связанный с веб-сайтом, или найдите виртуальные каталоги или каталоги приложений, содержащие файл Web.config, связанный с веб-сайтом.

Файл Web.config не может быть в виртуальных каталогах или каталогах приложений в IIS. Даже в этой ситуации необходимо следовать этим шагам.

Щелкните правой кнопкой мыши папку, в которую ApplicationHost.config файл, или щелкните правой кнопкой мыши виртуальные или каталоги приложений, которые могут содержать Web.config файл.

Выбор свойств.

Выберите вкладку Безопасность, а затем выберите изменить.

Нажмите Добавить.

В введите имена объектов, чтобы выбрать поле, введите имя \IIS_IUSRS, выберите Check Names, а затем выберите ОК.

является местообнамерщиком имени компьютера.

Выберите поле Чтение и выберите ОК.

В диалоговом окне Свойства для папки выберите ОК.

Убедитесь, что свойства папок наследуются файлами ApplicationHost.config и Web.config, чтобы IIS_IUSRS было разрешение на чтение для этих файлов.

Код HRESULT 0x800700b7

Сообщение об ошибке:

Ошибка сервера в приложении «имя приложения»
ОШИБКА HTTP 500.19 — ошибка внутреннего сервера
HRESULT: 0x800700b7
Описание HResult
Запрашиваемая страница не может быть доступом, так как связанные данные конфигурации для страницы недействительны.

Эта проблема может возникнуть, если в иерархии конфигурации имеется дублирующая запись для указанного параметра раздела конфигурации на более высоком уровне (например, ApplicationHost.config или Web.config файл на родительском сайте или папке). Само сообщение об ошибке указывает расположение дублирующих записей.

Изучите указанный файл конфигурации и сравните его с родительским ApplicationHost.config или Web.config для проверки на повторяющиеся записи, как это предлагает сообщение об ошибке. Удалите дубликат записи или сделайте запись уникальной. Например, эта проблема может возникнуть, поскольку ApplicationHost.config файл имеет дубликат записи для следующего кода:

Читайте также:  Ноутбук асус не работает мышка тачпад

Чтобы устранить эту проблему, удалите дубликат записи ApplicationHost.config файла для правила авторизации. Для этого выполните следующие действия:

Выберите Начните, введите Блокнот в поле Начните поиск, щелкните правой кнопкой мыши Блокнот, а затем выберите Выполнить в качестве администратора.

Если вам предложен пароль администратора или подтверждение, введите пароль или выберите Продолжить.

В меню File выберите Open, введите %windir%\System32\inetsrv\config\applicationHost.config в поле Имя файла, а затем откройте.

В файле ApplicationHost.config удалите дубликат записи, напоминаемой следующему коду:

Код HRESULT 0x8007007e

Сообщение об ошибке:

Ошибка сервера в приложении «имя приложения»
ОШИБКА HTTP 500.19 — ошибка внутреннего сервера
HRESULT: 0x8007007e
Описание HResult
Запрашиваемая страница не может быть доступом, так как связанные данные конфигурации для страницы недействительны.

Эта проблема возникает изApplicationHost.config или Web.config ссылается на модуль или DLL, которые недействительны или не существуют.

В файле ApplicationHost.config или Web.config найдите ссылку модуля или ссылку DLL, которая является недействительной, а затем исправьте ссылку. Чтобы определить, какая ссылка модуля неверна, введи трассировку неудатного запроса, а затем воспроизведи проблему.

Код HRESULT 0x800700c1

Сообщение об ошибке:

Ошибка сервера в приложении «имя приложения»
ОШИБКА HTTP 500.19 — ошибка внутреннего сервера
HRESULT: 0x800700c1
Описание HRESULT
Запрашиваемая страница не может быть доступом, так как связанные данные конфигурации для страницы недействительны.

Эта проблема может возникнуть, если битность указанного модуля отличается от уровня пула приложений, на который размещено приложение. Например, вы пытаетесь загрузить 32-битный компонент в 64-битный пул приложений. Эта проблема также может возникнуть, если указанный модуль поврежден.

Убедитесь, что битность указанного модуля будет такой же, как и у пула хостинговых приложений. Кроме того, убедитесь, что модуль не поврежден.

Код HRESULT 0x8007010b

Сообщение об ошибке:

Ошибка сервера в приложении «имя приложения»
ОШИБКА HTTP 500.19 — ошибка внутреннего сервера
HRESULT: 0x8007010b
Описание HRESULT
Запрашиваемая страница не может быть доступом, так как связанные данные конфигурации для страницы недействительны.

Эта проблема может возникнуть, если не удается получить доступ к указанному каталогу контента.

  • Убедитесь, что путь файла существует.
  • Убедитесь, что путь файла правильно назван.
  • Убедитесь, что путь файла имеет правильный набор разрешений на уровне файлов.
  • Убедитесь, что путь файла указывают на допустимый тип файловой системы.

Если вы не уверены в том, что такое путь к файлу, для его идентификации используйте средство отслеживания процесса или отслеживания неудающихся запросов.

Код HRESULT 0x8007052e

Сообщение об ошибке:

Ошибка сервера в приложении «имя приложения»
ОШИБКА HTTP 500.19 — ошибка внутреннего сервера
HRESULT: 0x8007052e
Описание HRESULT
Запрашиваемая страница не может быть доступом, так как связанные данные конфигурации для страницы недействительны.

Удостоверение процесса по умолчанию в IIS не имеет достаточных разрешений для открытия файла Web.config удаленной доли.

Убедитесь, что учетная запись пула приложений этого веб-приложения имеет достаточно разрешений для открытия Web.config файла.

Читайте также:  Как настроить смартфон redmi 9c nfc

Код HRESULT 0x80070003

Сообщение об ошибке:

Ошибка сервера в приложении «имя приложения»
ОШИБКА HTTP 500.19 — ошибка внутреннего сервера
HRESULT: 0x80070003
Описание HRESULT
Не удается прочитать файл конфигурации.

Эта ошибка вызвана отсутствием разрешения или физическим путем, который не соответствует пути для виртуального каталога. Например, в Web.configвеб-приложения физический корневой путь не существует.

  • Убедитесь, чтоWeb.config существует и имеет правильный набор разрешений.
  • Сбор журналов монитора процессов, чтобы получить дополнительные сведения об ошибке.

Устранение проблемы с файлом конфигурации IIS при обновлении windows

Как правило безопасности, все файлы конфигурации (не ограниченные IIS) должны быть резервными перед установкой какого-либо обновления. Если вы используете виртуальные машины, перед обновлением снимок виртуальной машины. Этот совет не ограничивается Windows обновлениями.

Источник

HTTP Error 403.14 — Запрет при открываемой веб-странице IIS

В этой статье помогают устранить ошибку HTTP 403.14 — Запрещенная . Веб-сервер настроен на то, чтобы не перечислять содержимое этого каталога, которая возникает при службы IIS (IIS).

Оригинальная версия продукта: службы IIS версии 7.0 и более поздних версий
Исходный номер КБ: 942062

  • Целевая аудитория этой статьи — администраторы веб-сайтов и веб-разработчики.
  • Эта статья применяется только к традиционным приложениям ASP.Net form.

Симптомы

При посещении веб-сайта, на сайте IIS 7.0 или более поздней версии, вы получаете сообщение об ошибке, напоминаемом следующее:

Ошибка сервера в приложении «имя приложения»
Http Error 403.14 — Запрет
HRESULT: 0x00000000
Описание HRESULT: Веб-сервер настроен, чтобы не перечислять содержимое этого каталога.

Разрешение для пользователей

Если вы пользователь, обратитесь к администраторам веб-сайтов, чтобы уведомить их о том, что эта ошибка произошла для этого веб-адреса.

Разрешение для администраторов сайтов

Эта проблема возникает из-за того, что на веб-сайте не включена функция просмотра каталогов. Кроме того, документ по умолчанию не настроен. Чтобы устранить эту проблему, используйте один из следующих методов:

Метод 1. Включить функцию просмотра каталогов в IIS (рекомендуется)

Чтобы устранить эту проблему, выполните следующие действия:

  1. Запустите диспетчер IIS. Чтобы сделать это, выберите Начните, выберите Выполнить,введитеinetmgr.exe, а затем выберите ОК.
  2. В диспетчере IIS расширим имя сервера, расширим веб-сайты, а затем выберите веб-сайт, который необходимо изменить.
  3. В представлении Features дважды щелкните Просмотр каталога.
  4. В области Действия выберите Включить.

Метод 2. Добавление документа по умолчанию

Чтобы устранить эту проблему, выполните следующие действия:

  1. Запустите диспетчер IIS. Чтобы сделать это, выберите Начните, выберите Выполнить,введитеinetmgr.exe, а затем выберите ОК.
  2. В диспетчере IIS расширим имя сервера, расширим веб-сайты, а затем выберите веб-сайт, который необходимо изменить.
  3. В представлении Features дважды щелкните документ по умолчанию.
  4. В области Действия выберите Включить.
  5. В поле Имя файла введите имя документа по умолчанию и выберите ОК.

Метод 3. Включить функцию просмотра каталогов в IIS Express

Этот метод используется для веб-разработчиков, которые испытывают эту проблему при использовании IIS Express.

Откройте окно Командная подсказка и перейдите в IIS Express папку на компьютере. Например, введите следующую команду в командной подсказке и нажмите кнопку Ввод:

Введите следующую команду и нажмите клавишу ВВОД:

Источник

Оцените статью