- Не открывается сайт, но работает админка
- Спасибо сказали:
- Спасибо сказали:
- Спасибо сказали:
- Спасибо сказали:
- Спасибо сказали:
- Joomla пустая главная страница. Почему?
- Joomla пустая главная страница. Почему?
- joomla не открывается админка
- Вариант #1. Измените режим сообщения об ошибках на Максимум
- Вариант #2. Отредактируйте файл .htaccess
- Вариант #3. Отредактируйте файл index.php
- Вариант #4. Отредактируйте файл php.ini
- Вариант #5. Проверьте логи сервера
- Вы нашли сообщение об ошибке. И что теперь?
- Проблемы с расширением? Отключите его.
- Проблемы с файлами Joomla? Закачайте их заново.
- Ничего не помогает? Время обратиться за помощью!
- Вариант 1
- Вариант 2
- Вариант 3
- Вариант 4
Не открывается сайт, но работает админка
Опции темы
Версия джумлы 1 5 22
Ни с того, ни с сего, перестал работать сайт. При открытии страниц — белый экран — исх код пустой.
При открытии админки — логинится, но редактировать что-либо не выходит — кнопки тупо не работают, меню админки не реагирует.
В чем причина?
- 0
| |
Спасибо сказали:
| |
Спасибо сказали:
| |
|
| |
Спасибо сказали:
| |
| 1. _http://joomlaforum.ru/index.php/topic,178109.msg1164591.html#msg1164591 И да, постарайтесь вспомнить, что делали на сайте последнее. Или смотрите логи. Так же вполне возможно, что хостер обновил версию PHP до последней, а старая Joomla будет на ней тупить.
| |
Спасибо сказали:
| |
Спасибо сказали:
Источник Joomla пустая главная страница. Почему?И так, Вы только что установили новый компонент Joomla, модуль или плагин, или произвели некоторые изменения в коде PHP. Затем Вы зашли на главную страницу сайта и обнаружили что она пуста, белый экран и ничто иное. Не паникуйте! У Вас просто ошибка в PHP коде. Почему чистая страница? Включите отображение ошибок, чтобы выяснить это. После устранения ошибки, верните значение «Сообщения об ошибках» на «Система, по умолчанию». Обязательно сделайте это, иначе PHP предупреждения могут сломать дизайн вашего сайта. К тому же это делает Ваш сайт более уязвимым для хакерской атаки. Источник Joomla пустая главная страница. Почему?И так, Вы только что установили новый компонент Joomla, модуль или плагин, или произвели некоторые изменения в коде PHP. Затем Вы зашли на главную страницу сайта и обнаружили что она пуста, белый экран и ничто иное. Не паникуйте! У Вас просто ошибка в PHP коде. Почему чистая страница? Включите отображение ошибок, чтобы выяснить это. После устранения ошибки, верните значение «Сообщения об ошибках» на «Система, по умолчанию». Обязательно сделайте это, иначе PHP предупреждения могут сломать дизайн вашего сайта. К тому же это делает Ваш сайт более уязвимым для хакерской атаки. Источник joomla не открывается админкаВ случае, если вас Joomla! не пускает в административную часть сайта, хотя логин и пароль верный, а просто перезагружает страницу, то вам следует проверить все параметры указанные ниже. Важно! После каждого пункта пробуйте произвести авторизацию, так как причин много и какая из них подходит именно под ваш случай сказать точно сложно. Просто проверяйте всё. Для начала просто убедитесь, что вы вводите пароль в нужной раскладке (русский/английский), банально, но так бывает часто.
Если все вышеперечисленное не поможет, обращайтесь за помощью к вашему хостинг-провайдеру. Наверное, с каждым такое случалось – что-то изменили в коде, установили расширение или просто сделали обновление, потом обновили страничку, а сайт пропал и вместо него вы видите пустой белый экран. Главное — без паники. Первым делом необходимо найти ошибку. Предлагаем вам пять вариантов для поиска сообщения об ошибке. Вариант #1. Измените режим сообщения об ошибках на МаксимумПопробуйте залогиниться в админку. Если вы смогли это сделать, то зайдите в Общие настройки – закладка Сервер – Сообщения об ошибках и установите значение на Максимум. Если зайти в админку не удалось, то откройте файлы вашего Joomla сайта через FTP и найдите в корне файл configuration.php . Далее откройте его и измените значение переменной $error_reporting на maximum: Вариант #2. Отредактируйте файл .htaccessОткройте файлы вашего Joomla сайта через FTP. Найдите файл .htaccess , который расположен в корне вашего сайта (если такого файла нет, то переименуйте htaccess.txt) и добавьте следующую строку в этот файл (в начало или конец, без разницы): Вариант #3. Отредактируйте файл index.phpОткройте файлы вашего Joomla сайта через FTP. Найдите файл index.php , который расположен в корне вашего сайта и добавьте этот код непосредственно после первой строки файла: Вариант #4. Отредактируйте файл php.iniОткройте файл конфигурации php.ini и измените значения двух параметров: Установите отображение ошибок в On: Установите отчет об ошибках: Если вы не знаете, где расположен файл php.ini , то создайте файл phpinfo.php со следующим кодом: Закачайте этот файл в директорию установки Joomla. Далее получите доступ к файлу по адресу вашадрес.ру/phpinfo.php и вы увидите список всех настроек PHP, в том числе месторасположение файла php.ini . Вариант #5. Проверьте логи сервераПроверьте файл ошибок сервера error.log на наличие ошибок. Если вы не уверены, как получить доступ к этому файлу, то обратитесь к вашему хостеру. Если вы работаете на локальной машине, то обычно этот файл находится в директории «logs» установки вашего сервера. Вы нашли сообщение об ошибке. И что теперь?Когда вы выяснили, что вызывает ошибку, то проанализируйте её. Скорее всего, вы увидите что-то похожее на это: В этом примере ошибки идут от компонентов sh404SEF и Xmap. И даже если вы не понимаете этой ошибки, вы уже знаете, какое расширение её вызывает. Если же имя расширения не может быть найдено, то возможно вы увидите что-то похожее на это: Это может означать, что есть проблема в файлах ядра Joomla. Что вы можете сделать в данных случаях? Проблемы с расширением? Отключите его.Если это плагин, то достаточно отключить его. Если это модуль, то просто снимите его с публикации. Если доступа в админку нет, то отключение можно сделать напрямую в базе. Для этого можете воспользоваться такой программой как phpMyAdmin. Откройте вашу базу данных, выберите таблицу #__extensions и в ней найдите имя модуля или плагина, который хотите отключить. Далее выставьте поле enabled в значение 0 . С компонентом все немного сложнее, так как его невозможно просто отключить. Для отключения вам необходимо зайти по FTP в папку /components и переименовать папку расширения. Например, измените /com_sh404SEF на /com_sh404SEF_disabled . Возможно, вам придется переименовать папку расширения и в /administrator/components . Проблемы с файлами Joomla? Закачайте их заново.Если вы не устанавливали никаких расширений, то причиной может быть битый файл Jooma. Для устранения этой проблемы просто еще раз закачайте необходимые файлы инсталляции по FTP. Ничего не помогает? Время обратиться за помощью!Если вы не смогли исправить белый экран смерти, то стоит обратиться за помощью: Joomla, как и любая бесплатная CMS, имеет свои подводные камни и баги, которые могут создать немало проблем начинающим пользователям и даже разработчикам. Вариант 1Возможная причина Вариант 2Возможная причина Вариант 3Возможная причина Проблемы с файлом configuration.php Вариант 4Неправильно работает файл session.php Вот и все Если не помогло, пишите в комментарии, попробуем разобрать вашу проблему Источник | |