Lync не работает поиск контактов
Вопрос
Часто в клиенте Lync не получается воспользоваться поиском. Обычно это замечается у свежедобавленного на сервере Lync пользователя.
Подскажите, пожалуйста, почему так часто возникает эта проблема. Какое сообщение в логе сервера свидетельствует о том, что синхронизация адресной книги завершена и можно пользоваться поиском? Какая периодичность синхронизации книги установлена, и каково нормальное время синхронизации (может быть у нас синхронизация тормозит)?
Ответы
Добрый день. Это известное поведение клиента Lync 2010. Адресная книга Lync Server формируется раз в сутки в одно и то же время, которое выможете узнать, выполнив Get-CsAddressBookConfiguration. Таким образом, сведения о вновь добавленном пользователе Lync попадут в адресную книгу только после ее обновления. Далее. Клиент скачивает адресную книгу (если у вас не настроено ее распростанение только через WEB) в промежуток времени от 5 до 60 минут после запуска клиента. Учитывая, что имеется два «полных» файла адресной книги в шаре сервера Lync, то вероятность того, что клиент получит самую последнюю версию составляет 50%. Но в любом случае, на следующий день, будет получена правильная версия. Как вариант, чтобы не ждать так долго, после добавления пользователя Lync выполните в LSMS Update-CsAddressBook и через 5-7 минут после этого запускайте клиента нового пользователя. В течение часа актуальная адресная книга попадет на клиента в профиль пользователя Lync и можно будет пользоваться поиском.
Как вариант, можно ускорить процесс получения клиентом адресной книги. Для этого найдите профиль пользователя Lync в LocalSetting (для XP) или AppData (Windows 7,8). Профиль имеет вид папки с названием типа sip_user@domain.com. Завершив работу приложения Lync удалите эту папку, затем выполните в командной строке:
reg add HKLM\Software\Policies\Microsoft\Communicator /v GalDownloadInitialDelay /t REG_DWORD /d 0 /f
после чего запустите Lync. В результате загрузка адресной книги произойдет сразу после подключения клиента к серверу.
Do not multiply entities beyond what is necessary
Источник
Lync не работает поиск контактов
Общие обсуждения
Клиент Lync 2013 Не видит странным образом контакты.
Допустим есть 3 учетных записи. Юзер1, Юзер2 и Юзер3(свежеозданный)
так вот. Юзер1 в Линке находит Юзер2,3
Юзер2 находит Юзер1 но не находит Юзер3 но может добавить его через Outlook или по адресу эл почты.
прошла уже неделя с момента создания Юзер3
ошибок вроде ни каких на серверах нет.. политики действуют одинаковые на пользователей.
PS в компании в в данном пуле более 150 человек. и вот у кого-то всё работает, а кто-то не может найти новых сотрудников. даже через месяц.
в каккую сторону смотреть? что копать?
- Изменено Zarj 29 ноября 2017 г. 3:29
- Изменен тип Vasilev Vasil Microsoft contingent staff 5 декабря 2017 г. 8:37 давность
Все ответы
Давайте по порядку. Пул один? И все данные пользователи в одном этом пуле?
для начала — откройте на проблемном клиенте сведения о конфигурации и найдите пункт «состояние глобального списка адресов». Там должен быть URL вида: https://LyncPool.contoso.com:443/abs/handler
Сравните его с URL’ом на рабочей машинке. Отличаются или нет? Может так получиться — что используется внешний URL.
Попробуйте зайти по этой ссылке. Есть ли отклик от сервера? Может быть ссылка просто недоступна (проблемы с DNS, или лезет через прокси сервер). Валидный ли сертификат?
И покажите вывод для проблемного клиента: get-csuser User2
https://prnt.sc/hgmal4 в скриншотах видно что все настройки одинаковы. разницы нет..
get-csuser сделаю чуть позже жо компа рабочего доберусь.
Вот нормальный пользователь у которого всё работает:
А вот пользователь у которого не работает:
если писать сервер https://***-srv-lync01.***.***.ru:443/abs/handler то открывается Access is denied
сертификат на сервере валидный
У Вас по какой-то причине не скачивается свежая версия адресной книги через клиент.
Для начала попробуйте удалить у сбоящего файлы GalContacts (2 штуки) и ABS_[sipaddress] в профиле клиента
C:\Users\username\AppData\Local\Microsoft\Office\16.0\Lync (отличается немного в зависимости от версии ОС и Офиса).
При это исчезнет вообще поиск по всем у пользователя, но через некоторое время (до часа после запуска, но как правило минут 10) должна скачаться свежая адресная книга и все будет работать.
Это на первый шаг, если не поможет — 2. смотрим логи, 3. пробуем переключить адресную книгу в WebSearchOnly
если писать сервер https://***-srv-lync01.***.***.ru:443/abs/handler то открывается Access is denied
Не должно быть такого поведения. Тут или запрос аутентификации должен вылезти, или IIS ответит с 500 ошибкой.
Если используется прокси — отключите его на клиенте. Очень может быть, что трафик заворачивается на прокси.
Проверьте на клиентской системе в администрировании учетных записей — нет ли случайно сохранённого пароля к нужному ресурсу. Может когда-то был запрос на ввод пароля — пользователь его ввел и сохранил.
Проверьте, что https://*. .ru добавлен в местную интрасеть в настройках браузера. И переоткройте страничку.
Если всё ещё AccessDenied — возможно слетели настройки IIS на каком-то FE-сервере из пула. Запустите на всех FrontEnd-серверах в вашем пуле — DeploymentWizard и пройдите 1 и 2 шаги в разделе «Install or Update Lync Server».
Ну и для дебага запускайте Fiddler — и смотрите что и куда лезет. С наступающим))
если писать сервер https://***-srv-lync01.***.***.ru:443/abs/handler то открывается Access is denied
Не должно быть такого поведения. Тут или запрос аутентификации должен вылезти, или IIS ответит с 500 ошибкой.
Если используется прокси — отключите его на клиенте. Очень может быть, что трафик заворачивается на прокси.
Проверьте на клиентской системе в администрировании учетных записей — нет ли случайно сохранённого пароля к нужному ресурсу. Может когда-то был запрос на ввод пароля — пользователь его ввел и сохранил.
Проверьте, что https://*. .ru добавлен в местную интрасеть в настройках браузера. И переоткройте страничку.
Если всё ещё AccessDenied — возможно слетели настройки IIS на каком-то FE-сервере из пула. Запустите на всех FrontEnd-серверах в вашем пуле — DeploymentWizard и пройдите 1 и 2 шаги в разделе «Install or Update Lync Server».
Ну и для дебага запускайте Fiddler — и смотрите что и куда лезет. С наступающим))
Источник
Lync не работает поиск контактов
Вопрос
У большинства пользователей, перестал работать поиск контактов в Lync. Ни по-русски ни по-английски поиск имен не работает (пишет нет результатов). Единственный способ это вводить полный E-mail.
Когда только поставил Lync server 2013 такой проблемы не было.
p.s. менять AddressBookPolicy Пробовал, ни WebSearchOnly ни WebSearch&download не работают.
p.p.s Удаление профиля из \AppData\Local\Microsoft\Office\15.0\Lync Так же не принесло успехов.
Все ответы
Do not multiply entities beyond what is necessary
Вот, то что я вижу исполняя команду Debug-CsAddressBookReplicationn
т.е. вроде как нет не проиндексированых объектов. Но поиск от этого, к сожалению лучше работать не стал =(
Pool Fqdn : pool.domain.ru
Replication State : NotTested
Task Owner Fqdn : pool.domain.ru
Backup Fqdn :
Server Heartbeats :
Indexed Object Count : 110
Objects not indexed that should be : 0
Abandoned objects : 0
Normalization Failure Count : Not checked
Normalization Failures :
Do not multiply entities beyond what is necessary
ну там та же инфа.
Synchronization Pass Summary.
Sync pass completed with 109 contacts processed
Number of separate AD partitions: 1
Number of valid contacts: 109
Number of empty contacts: 0
Number of invalid contacts: 0
Number of cached photos deleted: 0
Number of stale OC files deleted: 13
1) если пользователей не тысячи то:
Set-CsClientPolicy -Identity Global -AddressBookAvailability WebSearchOnly
так будет меньше проблем с адресной книгой, могу по опыту сказать что при 150-и пользователях поиск работает отлично.
2) поставь все обновления для Lync на сервер и компы пользователей.
3) у пользователей которым не помогло, решил эту проблему полным удалением профиля пользователя Windows (\Users\»Пользователь») а не профиля Lync ( \AppData\Local\Microsoft\Office\15.0\Lync ) и настройкой заново.
4) после интеграции Lync с exchange, сбоев при поиске не было.
Источник
Lync не работает поиск контактов
Вопрос
в организации развернут Lync Server 2013.
По ряду причин часть пользователей не может использовать Microsoft Lync 2013, поэтому они используют Microsoft Lync 2010.
Недавно столкнулись с проблемой что версия 2010 не находит некоторых пользователей, причем версия 2013 находит именно этого пользователя. Пробовал с одной учетной записи искать этого пользователя.
Пробовал удалять папку sip_username@domain , не помогло.
Уже не знаю что делать.
Ответы
на сервере стоят апдейты?
— полное доменное имя сервера SQL.
потом запустите установщик еще раз и выполните установку компонентов еще раз.
- Помечено в качестве ответа Vasilev Vasil Microsoft contingent staff 21 февраля 2018 г. 7:18
Все ответы
а вы опишите процесс как вы ищете.
а если адрес вбить?
поиск у вас веб или с загрузкой адресной книги?
обновления на клиенте стоят?
И через фамилию пробовал и через имя, пробовал и в формате sip@domain
Поиск стоит стандартный, загружается адресная книга.
На счет обновлений не уверен, но кажется проблема не в них.
обновления нужно поставить точно.
у вас файлы GalContacts.db и GalContacts.db.idx присутствуют в папке?
можно попробовать включить websearchonly, чтобы он напрямую искал на сервере.
Можете подсказать какие именно обновления нужны?
Да у клиента эти файлы есть, на сервере нет.
Я думал на счет WebSearchOnly, интересно только на сколько изменится нагрузка.
Можете подсказать какие именно обновления нужны?
Да у клиента эти файлы есть, на сервере нет.
Я думал на счет WebSearchOnly, интересно только на сколько изменится нагрузка.
сложно сказать насколько точно изменится, но незначительно.
в office365 websearch и в крупных организациях часто так делают.
апдейты желательно иметь всегда свежие на клиенте и сервере и с этого можно начинать решать проблему.
сложно сказать насколько точно изменится, но незначительно.
в office365 websearch и в крупных организациях часто так делают.
апдейты желательно иметь всегда свежие на клиенте и сервере и с этого можно начинать решать проблему.
Поставил WebSearchOnly, поставил все обновления.
Сразу решил проверить, вручную удалил на пользовательской машине папку sip, перезагрузился, и оно ее снова скачало, так должно быть? По прежнему не ищет.
Правда в просмотре событий на линк сервере есть событие с сообщением:
Служба подбора группы использует неправильную версию базы данных.
Неправильная версия базы данных:
Подключение: Data Source=(local)\rtc;Initial Catalog=cpsdyn;Integrated Security=True
Ожидаемая. версия схемы: 1, версия процедуры: 1, версия обновления: 2
Текущая. версия схемы: 0, версия процедуры: 0, версия обновления: 0
Причина: база данных не обновлена.
Решение:
обновите базу данных до версии CU1.
Не удалось подключиться к серверной базе данных подбора группы.
Не удалось получить доступ к серверу SQL:
Подключение: Data Source=(local)\rtc;Initial Catalog=cpsdyn;Integrated Security=True
Сообщение: The EXECUTE permission was denied on the object ‘DbpGetVersionSchema’, database ‘cpsdyn’, schema ‘dbo’.
Код ошибки: -2146232060
Номер ошибки: 229
Причина: это может быть вызвано проблемами подключения к серверной базе.
Решение:
убедитесь, что сервер SQL работает и принимает подключения от службы подбора группы.
Источник