Making плагин не работает
Шаг 1) Для примера возьмем плагин StatsX RBS. C начала нужно посмотреть, запустился ли плагин. Для этого в консоль сервера(в панеле хостинга) нужно ввести команду: amxx plugins
Сервер выдаст примерно следующее:
Как видим, статус плагина «stopped», это значит что он не запущен. Вместо «stopped» может быть написано: «paused», «unknown» или «bad load», это так же означает, что плагин не работает.
Работающий плагин имеет статус: «running» или «debug»
Шаг 2) Почему же плагин не запустился? В логах 99% будет ответ! Заходим в папку amxmodx/logs/
Там может быть много файлов и старых логов, которые в данный момент нам не нужны. Удалите все старое(или сохраните себе на комп, если вдруг они вам нужны), сделайте рестарт сервера(достаточно смены карты). После этого появятся новые логи, они то нам и нужны.
Не забудьте в фтп клиенте обновить папку. Нажать на клавишу F5.
Скорее всего Вы увидите два файла: L20180101.log и error_20180107.log(цифры могут отличаться)
Сразу откроем error_ лог. Видим:
Вот и проблема. Забыли загрузить файл стилей от плагина на сервер, или загрузили не туда. Скачиваем архив с плагином из личного кабинета и загружаем необходимые файлы
Шаг 3) Удаляем опять логи, делаем рестарт и смотрим новые логи. Видим снова error_ лог. Открываем:
Тут тоже все ясно, плагин говорит что отключил аналогичный плагин статистики. Заходим в plugins.ini и отключаем то что просит плагин.
Опять удалим логи и сделаем рестарт. Новых error_ логов нет, пишет amxx plugins
Все, видим «running», значит плагин работает. Можно зайти на сервер и проверить.
Нет логов! Плагин не работает!
Нету логов, а плагин все равно пишет статус «unknown» или другие описанные выше?
1 Вариант Повторюсь, в 99% логи будут! Если нет файла error_20180107.log, то откроем лог L20180101.log, в нем тоже могут писаться ошибки!
Вот она и ошибка. Многие в этот файл не заглядывают, а зря. Ошибка говорит о том, что плагин юзает функции модуля, которого нет на сервере.
В данном случае был удален модуль csx_amxx_i386.so. Тут могут быть и другие ошибки, смотрите их в Основной документации по плагинам
2 Вариант Логов нету? Точно? Уверены? Не верим! Проверьте лучше!
Вы точно нажимали в FileZilla(фтп клиент) клавишу F5, чтобы обновить папку логов?
Вы загружаете новый файл логов? Смотрите скрин:
Делали рестарт? Сделайте на всякий случай жесткий рестарт(выключить и включить сервер)
3 Вариант Ну нету логов. Вы попали в этот 1%, логов действительно нет!
Проверьте файл amxmodx/configs/core.ini
Стоит значение «0», это значит AMXX не ведет логи! Срочно нужно исправить. Поставьте: amxx_logging 1
Сделайте рестарт, и теперь увидите логи.
4 Вариант Единственный последний вариант, почему плагин не работает и не пишет логов, и его статус не «running»:
Открываем файл amxmodx/configs/pausecfg.ini
Кто то поставил плагин на паузу и снял с нее. Если это были не Вы, то могли сделать другие админы. Не нужно им давать доступ к меню плагина pausecfg.amxx(стандартный плагин amxx)
Поставить на паузу этот плагин мог какой ни будь другой плагин, нужно проверять. В общем чтобы снять плагин с паузы, достаточно удалить эту строку из файла.
К стати если плагин стоит на паузе, то в amxx plugins его статус будет «paused», но не всегда виной тому может быть pausecfg.amxx, нужно сначала смотреть логи
Логи есть, но слишком много и ничего не понятно
Перестали работать сразу несколько плагинов. В логах много ошибок на непонятном английском языке. Что же делать?
Вывод amxx plugins:
Ошибка в файле error_20180107.log:
Мы видим много ошибок от разных плагинов, но всему виной плагин CsStats MySQL, который судя по ошибке, не смог подключиться к базе данных.
В переводе с английского, ошибка говорит, что у юзера amxmodx@123.123.123.123 нет доступа к базе данных. Нет доступа может по причинам:
1) Не верный пароль, чаще всего так и происходит.
2) Не верные данные. Айпи, имя базы, или имя юзера. Все эти данные брать нужно у хостинга.
3) Нет удаленного доступа к базе данных. Если у Вас ISP Manager, то должна стоять галочка:
4) Нет доступа. Об этом может знать только хостер, но скорее всего проблема в причинах выше.
Почему же другие плагины перестали работать спросите Вы?
Так как много наших плагинов синхронизируются, и юзают у друг друга функции, они зависят друг от друга.
Если их включать по отдельности, то они будут работать нормально, но давайте рассмотрим данный случай:
• Отключился плагин CsStats MySQL так как потерял связь с базой
• Плагин Army Ranks Ultimate юзает функцию плагина CsStats MySQL для получения статистики игрока, вот эту: «csstats_get_user_stats». Но плагин ксстатс отключился и арми ранкс не может использовать его функцию, поэтому выдает ошибку и тоже вырубается
• Дальше плагин AR Pogony использует «ar_get_user_level», который говорит плагину звание игрока и он в свою очередь ставит нужные погоны. Так как арми ранкс упал, и этот плагин тоже остановился и выдал ошибку
Бывают и другие логи, но решать проблему нужно по тому же принципу. Исправить сначала одну ошибку, а потом смотреть другие и тоже исправлять, пока не будут чистые логи.
Падает сервер!
Как узнать причину падения сервера? Вопрос достаточно сложный, ведь сервер не указывает нам конкретно причину, но обычно падения происходят из-за плагинов или модулей
Вариант 1) Консоль сервера. При падении сервер в любом случае напишет в консоль какую ни будь причину. В большинстве случаев от нее мало пользы, но не проверить нельзя.
Как видим, сервер упал, потому что нет необходимой модели. В наших плагинах на этот случай есть проверки, и сервер не упадет, а просто остановится плагин. Но тут можно увидеть и другую важную информацию для диагностики.
Вариант 2) Если информации в консоли нет, или от нее мало пользы, то придется отключать плагины.
• Отключим абсолютно все amxx плагины, сделаем рестарт и проверим работу сервера. Если сервер так же падает, то проблема в модулях metamod’а, отключать нужно их и так же смотреть работу.
• Если все работает хорошо, то включим 1-ую половину любых плагинов, и посмотрим работу. Если после рестарта сервер не падает, значит проблема кроется во 2-ой половине плагинов.
• Включаем половину 2-ой половины плагинов и смотрим работу. Думаю принцип ясен, так делаем до тех пор, пока не найдем плагин, из-за которого падает сервер. Так же делать и с модулями, если падает из-за них.
Вариант 3) Если падает сервер из-за нашего плагина(Вы убедились в этом проверив 2-ым Вариантом), то не всегда проблема может быть в нем.
В интернете куча плагинов, которые могут друг с другом конфликтовать. Возможно какой то другой плагин тому виной. Отключите ВСЕ плагины кроме нашего, из-за которого проблема. Скорее всего сервер будет работать без проблем. Чтобы вычислить из-за чего конфликт, включайте плагины по 2-му Варианту и найдете виновника.
Если у Вас не включается сервер из-за наших плагинов, прочтите 3-ий Вариант следующий главы
Вариант 4)
ВОПРОС: Вижу в логах amxmodx/logs/ ошибки от плагина, наверное поэтому и падает сервер.
ОТВЕТ: Вряд ли. Если сервер падает, то скорее всего amxx не успеет написать лог. Вы можете это легко проверить, сравните время падения в файле debug.log(находится в корне сервера, или можно найти в панеле хостинга) и время ошибки в amxx логах
Как видим время разное, значит ошибка делу не поможет
Вариант 5) Может сервер виснет? Прочтите следующую главу.
Не запускается сервер!
Вариант 1) Скорее всего сервер не виснет, а падает. Про падение сервера прочтите заголовок выше.
Вариант 2) Не запускаться сервер может, если долго пытается соединиться с MySQL. Возьмем для примера плагин AMXBans RBS.
Откройте консоль сервера и посмотрите что там пишет. Подождите минимум 60 секунд после старта, если сервер одуплится, то в консоли побегут новые строчки и скорее всего Вы получите ошибку в логах, что нет соединения с БД
Вариант 3) Может быть виновата проверка лицензии. Такое бывает, если хостинг блокирует наши зеркала в связи с ддосом или еще по каким то причинам.
- Для начала откройте файл amxmodx/data/fg_settings.ini, убедитесь, что он выглядит примерно так:
Обратите внимание на указанные параметры, если их нет в Вашем fg_settings.ini, то необходимо сделать следующее:- Обновите все плагины до последней версии
- Удалите fg_settings.ini
- Сделайте рестарт сервера или смену карты(только не отключайте наши плагины)
- Новый fg_settings.ini должен создаться сам. Если он не появился, нажмите F5 в FileZilla, чтобы обновить список файлов в директории
- Откройте файл, убедитесь, что он выглядит примерно так как на скрине. Если это не так, то скорее всего присутствует на сервере плагин старой версии, обновите его, и по новой удалите fg_settings.ini
- Установите async «2» и включите debug «1». async 2 это альтернативный метод проверки лицензии, имеет смысл его изменить, только если испытываете проблемы с сокетами
- Зайдите в консоль сервера, и посмотрите при его старте, на каком месте идет зависание
Если после последней строчки ничего не идет, то скорей всего виновата привязка. Отключите все наши плагины чтобы в этом окончательно убедиться. И если подтвердилось, то напишите хостеру, скорее всего идет ддос, и система антиддоса заблокировала все наши зеркала. Так же напишите нам в ТП, маловероятно что проблемы у нас, но вместе мы ее решим.- Мы имеем 6 серверов для проверки лицензии, которые находятся в разных странах мира: Россия, Украина, Беларусь, Казахстан, Германия, США. У каждого сервера разный хостер, разный провайдер, айпи и т.д. Если плагин не может соединиться с одним, он пытается соединиться с другим. То есть недоступность сервера проверки лицензий сведен к минимуму. Нет необходимости менять зеркало вручную в fg_settings.ini, плагин сам пропишет в него доступное зеркало
Вариант 4) Нужно узнать какой из плагинов виноват в этом, для этого нужно воспользоваться методом отключения плагинов, как описано в предыдущей главе в Варианте 2.
Глюки плагина
Если плагин глючит, криво что то отображает, выдает бонус не тому игроку и прочее.
Вариант 1) Убедитесь что у Вас стоят последние версии наших плагинов. Введите в консоль сервера(что в панеле хостинга) команду: amxx plugins
Версии наших плагинов расшифровываются так: ГОД.МЕСЯЦ.ДЕНЬ. Удобно, всегда можно определить, когда вышло обновление.
Узнать номер последней версии плагинов можно в личном кабинете.
Всегда используйте свежие версии плагинов, так как в них исправляется много ошибок.
Вариант 2) Не верная настройка. Убедитесь в том, что Вы правильно настроили плагин. В конфигах наших плагинов есть подробнейшее описание к каждой настройке. Достаточно часто люди просто не читают, а проблема решается изменением какого ни будь квара.
Вариант 3) Конфликт с каким то другим плагином. Как вычислить этот конфликтующий плагин, смотрите в 3-ем варианте главы Падение сервера.
Вариант 4) Возможно в плагине баг. Ничто не идеально, но мы стремимся к этому. Опишите его подробно на страничке Баги и предложения.
Источник
Making плагин не работает
Шаг 1
Перейдите по ссылке:
Согласитесь со всеми всплывающими окнами, если таковые будут.
Вы должны увидеть страницу такого вида:
Если Вы видите такое окно, то переходите к шагу 2, если нет, то читайте дальше.
Если Вы видите такое окно, значит не установлен или не доступен КриптоПро CSP, см. пункт как проверить установку или установить КриптоПро CSP.
Если Вы видите такое окно, значит CAdESBrowserPlug-in не установлен или не доступен, см. пункт как проверить установлен ли плагин, Как убедиться, что правильно настроен браузер.
Шаг 2
В поле Сертификат выделите нужный сертификат и нажмите Подписать.
Примечание: В поле Сертификат отображаются все сертификаты, установленные в хранилище Личное текущего пользователя, и сертификаты, записанные в ключевые контейнеры. Если в списке нет сертификатов или отсутствует нужный, значит необходимо вставить ключевой носитель с закрытым ключом и установить сертификат в хранилище Личное текущего пользователя.
Если после нажатия кнопки Подписать Вы видите такой результат, значит Вы успешно выполнили подпись и КриптоПро ЭЦП Browser plug-in работает в штатном режиме.
Если Вы получили ошибку, то смотрите раздел Информация об ошибках.
Как проверить установлен ли КриптоПро CSP
Проверить установлен ли КриптоПро CSP можно зайдя в панель управления Программы и компоненты (Установка и удаление программ). Там же можно увидеть версию установленного продукта:
Если КриптоПро CSP не был установлен, то пробную версию (на 3 месяца) можно скачать у нас на сайте (для загрузки файла необходима действующая учетная запись на нашем портале): https://www.cryptopro.ru/sites/default/files/private/csp/40/9944/CSPSetup.exe
После загрузки .exe файла запустите его и выберите пункт «Установить (рекомендуется)». Установка произойдет в автоматическом режиме.
Как проверить установлен ли КриптоПро ЭЦП Browser plug-in
Проверить установлен ли КриптоПро ЭЦП Browser plug-in можно зайдя в панель управления Программы и компоненты (Установка и удаление программ). Там же можно увидеть версию установленного продукта.
Если КриптоПро ЭЦП Browser plug-in не установлен, то дистрибутив можно скачать у нас на сайте: https://www.cryptopro.ru/products/cades/plugin/get_2_0
Инструкция по установке плагина доступна здесь.
Как убедиться, что включено расширение в браузере
Если Вы используете Google Chrome, то Вы должны включить расширение. Для этого в правом верхнем углу браузера нажмите на значок Настройка и управление Google Chrome (три точки)- Дополнительные инструменты –Расширения.
Убедитесь, что расширение CryptoPro Extension for CAdES Browser Plug-in присутствует и включено. При отсутствии расширения, переустановите КриптоПро ЭЦП Browser plug-in или скачайте расширение через Интернет магазин Chrome: https://chrome.google.com/webstore/detail/cryptopro-extension-for-c/iifchhfnnmpdbibifmljnfjhpififfog?hl=ru
Если Вы используете Mozilla Firefox версии 52 и выше, то требуется дополнительно установить расширение для браузера.
Для начала перейдите по ссылке : скачать расширение.
Разрешите его установку:
Перейдите Инструменты-Дополнения-Расширения и убедитесь, что расширение включено:
Если Вы используете Internet Explorer, то при переходе на страницу, в которую встроен CAdESBrowserPlug-in, Вы увидите внизу страницы следующее сообщение:
В окне Подтверждение доступа нажмите Да:
Если Вы используете Opera, то необходимо установить расширение из каталога дополнений Opera:
И во всплывающем окне нажать – Установить расширение:
В следующем окне нажмите – Установить:
Либо перейдите Меню-Расширения-Расширения:
Нажмите Добавить расширения и в строке поиска введите CryptoPro, выберите наш плагин и нажмите Добавить в Opera. После этого перезапустите браузер.
Проверить включен ли плагин можно в Меню-Расширения-Расширения:
Если Вы используете Яндекс Браузер, то необходимо перейти Опции-Настройки-Дополнения и убедиться, что КриптоПро ЭЦП есть и включен. Если расширение отсутствует, то Вы можете скачать его Каталога расширений для Яндекс Браузера, используя поиск по слову КриптоПро.
Информация об ошибках
1) Появляется окно КриптоПро CSP Вставьте ключевой носитель
Появление данного окна значит, что у Вас не вставлен носитель с закрытым ключом для выбранного Вами сертификата.
Необходимо вставить ключевой носитель. Убедится что ОС его «видит» и попробовать заново.
Если предыдущие действия не помогли, необходимо переустановить сертификат в хранилище Личное текущего пользователя с привязкой к закрытому ключу. См статью.
2) Не удалось создать подпись из-за ошибки: Не удается построить цепочку сертификатов для доверенного корневого центра. (0x800B010A)
Эта ошибка возникает, когда невозможно проверить статус сертификата (нет привязки к закрытому ключу, нет доступа к спискам отзыва или OCSP службе), либо не установлены корневые сертификаты.
Выполните привязку сертификата к закрытому ключу:
Проверьте строится ли цепочка доверия: откройте файл сертификата (можно его открыть через Пуск-Все программы-КриптоПро- Сертификаты-Текущий Пользователь-Личное-Сертификаты), перейдите на вкладку Путь сертификации. Если на этой вкладке присутствуют красные кресты, или вообще нет ничего кроме текущего сертификата (кроме тех случаев если сертификат является самоподписанным)
Скриншоты с примерами сертификатов, у которых не строится цепочка доверия.
Чтобы цепочка доверия построилась необходимо скачать и установить корневые и промежуточные сертификаты. Скачать их можно с сайта УЦ, издавшего сертификат.
Если вы используете квалифицированный сертификат, то попробуйте установить в доверенные корневые эти 2 сертификата (это сертификаты Головного УЦ Минкомсвязи и от них, при наличии интернета должна построится цепочка доверия у любого квалифицированного сертификата), если не поможет, то обращайтесь в УЦ, выдавший Вам сертификат.
Чтобы установить скачанный сертификат в доверенные корневые центры сертификации, нажмите по нему правой кнопкой-Выберите пункт –Установить сертификат- Текущий пользователь- Поместить все сертификаты в следующие хранилище-Обзор-Доверенные корневые центры сертификации-Ок- Далее- Готово- когда появится предупреждение системы безопасности об установке сертификата- нажмите Да-Ок. если Вы устанавливаете сертификат промежуточного центра сертификации то выбирайте хранилище- промежуточные центры сертификации.
Важно: Если вы создаете CAdES-Tили CAdES-XLongType 1, Ошибка может возникать если нет доверия к сертификату оператора TSP службы, в этом случае необходимо установить в доверенные корневые центры сертификации корневой сертификат УЦ его издавшего.
3) Если подпись создается, но ошибка при проверке цепочки сертификатов горит, это значит, что нет доступа к спискам отозванных сертификатов.
Списки отозванных сертификатов можно скачать на сайте УЦ, выдавшем сертификат, после получения списка его необходимо установить, процедура идентична процедуре установки промежуточного сертификата ЦС.
4) Ошибка: 0x8007064A/0x8007065B
Причина ошибки истек срок действия лицензий на КриптоПро CSP и/или КриптоПро TSP Client 2.0 и/или Криптопро OCSP Client 2.0.
Для создания CAdES-BES подписи должна быть действующая лицензия на КриптоПро CSP
Для создания XLT1 должны быть действующими лицензии на следующие программные продукты: КриптоПро CSP, КриптоПро TSP Client 2.0, КриптоПро OCSP Client 2.0
Посмотреть статус лицензий можно через: Пуск- Все программы- КРИПТО-ПРО- Управление лицензиями КриптоПро PKI.
Решение: Приобрести лицензию на нужный программный продукт и активировать её:
Пуск- Все программы- КРИПТО-ПРО- Управление лицензиями КриптоПро PKI -выбрать нужный программный продукт- открыть контекстное меню (щелкнуть правой кнопкой мыши) -выбрать пункт Все задачи выбрать пункт Ввести серийный номер. -ввести серийный номер лицензии -нажать кнопку OK
5) Набор ключей не существует (0x80090016)
Причина ошибки: У браузера не хватает прав для выполнения операции- добавьте наш сайт в доверенные
6) Отказано в доступе (0x80090010)
Причина ошибки: Истек срок действия закрытого ключа. Проверьте срок действия Зайдите в Пуск->Все программы(все приложения)->КриптоПро->Крипто-Про CSP. Перейдите на вкладку Сервис. Выберите пункт Протестировать, выберите контейнер с закрытым ключом и в результатах тестирования Вы сможете увидеть срок его действия. Рекомендуется получить новый ключ.
7) Ошибка: Invalid algorithm specified. (0x80090008)
Данная ошибка возникает, если Вы используете сертификат, алгоритм которого не поддерживается Вашим криптопровайдером.
Пример: У вас установлен КриптоПро CSP 3.9 а сертификат Выпущен по ГОСТ 2012.
Или если используется алгоритм хеширования, не соответствующий сертификату.
Так же проверьте актуальность версии КриптоПро CSP.
Источник