- Ошибка при создании объекта V83.COMConnector, или класс не зарегистрирован
- Ошибка при вызове конструктора (COMОбъект) на 32 и 64 битных системах
- ПолучитьCOMОбъект не работает на сервере.
- Устранение ошибки при подключении к базе данных 1С через COM-соединение
- Специальные предложения
- См. также
- Как я начал администрировать сервер 1С: Предприятие 8.3 с телефона Промо
- Свернуть базу и не свернуть себе шею
- Полнотекстовый поиск в 1С. №2 Самое основное для разработчика
- Ускоряем полнотекстовый поиск в динамических списках
- Копирование числовых ячеек из 1С в Excel Промо
- Полнотекстовый поиск в 1С. №1 Грабли в динамических списках
- Как настроить сервер 1С по умолчанию для ПРОФ лицензии после 10.09.2019
- Использование Zabbix для сбора информации о серверных вызовах и управляемых блокировках с сервера 1С Предприятия, работающего на платформе GNU/Linux
- Отчет по размерам таблиц в базе данных как одно из средств анализа проблем Промо
- Нарушение целостности системы
- Быстрое копирование таблиц большого размера и/или с большим числом строк, на примере регистра сведений (для MS SQL)
- Уверенное обновление
- Чем PostgreSQL может быть полезен разработчику 1С Промо
- Почему Вы не обслуживаете итоги?
- За 5 шагов добавляем мониторинг счетчиков производительности серверов MS SQL и 1С
- Опыт обновления до 8.3.14 — лицензии и утилита ring
- Зачем в 1С нужно периодически пересчитывать итоги по регистрам? Промо
- Практика перехода на Linux и Postgres в небольшой компании (10 пользователей)
- Переход на 64-х разрядный сервер 1С
- Cannot insert duplicate key. Кто виноват и что делать
- Создание пользователя СУБД MS SQL Промо
- Скорость работы 1С: Предприятие с разными СУБД: MS SQL и с PostgreSQL
- Восстановление файловой базы с помощью tools 1cd
- Debian 9.7 + PostgreSQL для 1С. Как завести с пол-оборота
- Все, что надо знать о технологической платформе 1С:Предприятие: компоненты, архитектуры, операционные системы, лицензии Промо
- 1С и Яндекс.Облако Compute Cloud. Вдоль и поперек
- Малоизвестная хитрость определения модуля и номера строки при возникновении исключения (без запуска отладки и конфигуратора). Несколько очень удобных, но малоиспользуемых возможностей работы в конфигураторе
- Восстановление базы 1С, ошибка источника потока
- 1С и Windows Script Host (WSH) и Windows Management Instrumentation (WMI). ОТ ТЕОРИИ К ПРАКТИКЕ. Часть I Промо
- Сервер 1С:Предприятие на Ubuntu 16.04 и PostgreSQL 9.6, для тех, кто хочет узнать его вкус. Рецепт от Капитана
- Проверка COM-соединения
- Заметки про лицензии 1С
- Не работают регламентные задания? Промо
- Установка клиента 1С:Предприятие 8.3 на Debian / Ubuntu
- Когда 1С падает в дамп
- Мониторинг активности пользователя
- Часто встречающиеся ошибки 1С и общие способы их решения Промо
- [Шпаргалка] Несколько версий сервера 1С на одном сервере (компьютер)
- Несколько версий сервера 1С на одном компьютере
- Запуск Apache 2.4 с модулем 1С внутри Docker контейнера
- Технология обновления нетиповых конфигураций 1С:Предприятия 8 (редакция 12.04.2012) Промо
Ошибка при создании объекта V83.COMConnector, или класс не зарегистрирован
При смене версии платформы 1С или изменении её разрядности, нет нет да натыкаешься на отказ в работе com объекта. И сообщество нам предлагает в основном два пути решения этой проблемы.
1. Регистрация dll библиотеки (вызвать в cmd regsvr32 «C:\Program Files\1cv8\[номер платформы]\bin\comcntr.dll» )
По моему опыту практически никогда не помогает.
2. Регистрация объекта вручную через Панель управления=> Администрирование => Службы компонентов
Не буду описывать подробно (довольно легко найти например здесь //infostart.ru/1c/articles/400951/)
Этот метод рабочий, сам им пользовался и успешно. Но требует внимательности и большого количества телодвижений. А также после создания компонента мне приходилось поработать над разрешениями для пользователей, на стороне которых он будет использоваться. Для этих пользователей добавлял роли. (Можно конечно это делать и для группы пользователей, если вам так удобнее)
3. И еще один способ, которым собственно и хочу поделиться. И на мой взгляд он самый простой и эффективный из всех описанных выше . В разделе технологической платформы 8.3 на сайте поддержки пользователей системы 1с: Предприятие 8 скачиваем дистрибутив сервера 64 бит.
При установке, среди прочего видим как раз то, что нам нужно. Просто выбираем его (по умолчанию отключен) и устанавливаем.
Источник
Ошибка при вызове конструктора (COMОбъект) на 32 и 64 битных системах
На эту тему уже есть статья //infostart.ru/public/97085/, но она не раскрывает особенностей работы в ОС Windows выше XP и не затрагивает тонкости регистрации под 64 разрядной системой. Для кого-то здесь описаны очевидные вещи, а кто-то слаб в администрировании и статья пишется прежде всего на последнюю категорию.
Итак, приступим. Если у вас при работе в 1С появилась ошибка вида: «-2147221164(0x80040154): Класс не зарегистрирован» или «Ошибка при вызове конструктора (COMОбъект): Недопустимая строка с указанием класса»
тогда делаем следующее:
1) Запускаем командную строку от имени Администратора. Если в командной строке прописан путь, отличный от «c:\windows\system32», то необходимо выполнить команду «cd c:\windows\system32» для 32-х разрядных систем или «cd \windows\syswow64» для 64-х(у меня 64, поэтому пришлось в примере путь изменить). В итоге корневой путь для х64 должен выглядеть как на этом скрине:
Источник
ПолучитьCOMОбъект не работает на сервере.
При использование ПолучитьCOMОбъект() на файловой базе прекрасно работает, при запуске на серверной базе выдает ошибку
<Документ.ИсходящиеПисьма.Форма.ФормаДокумента.Форма(571)>: Ошибка при вызове метода контекста (ПолучитьCOMОбъект): Ошибка получения объекта COM: -2147467259(0x80004005): Неопознанная ошибка
Windows 2008 R2, MS SQL 2008, 1c 8.3.4.437. Агент запускается от пользователя USR1CV который имеет права администратора. Установлен MS office 2010.
Если использовать:
Файл = Новый Файл(ВремФайл);
Файл.Удалить();
Не находить процедуру Удалить().
Видимо дело в правах и доступе, но не пойму, где забыл открыть доступ.
ОболочкаActiveDocument.Записать (ActiveDocumentShell.Write)
ОболочкаActiveDocument (ActiveDocumentShell)
Записать (Write)
Синтаксис:
Тип: Строка.
Имя файла, в который необходимо записать Active document. Если файл существует, он будет перезаписан, иначе — создан.
Описание:
Записывает Active document в файл.
(16) tiz7, Воспользуйтесь другой функцией работы с COM объектом
О = Новый COMОбъект()
O.Open
.
И второе вынесете код работы с COM объектом во внешний модуль
Если работа идёт в режиме управляемых форм, то перед началом функции, которая вызывает ПолучитьCOMОбъект() должно стоять НаСервере.
Файл = Новый Файл(ВремФайл);
Файл.Удалить();
Такой файл удалить нельзя, так как он не сохранён. Его можно только Файл.Закрыть();
Часть кода.
&НаСервере
Функция ПолучитьМакетНаСервереИП()
ВремФайл = ПолучитьИмяВременногоФайла(«doc»);
Попытка
КомОбъект = ПолучитьCOMОбъект(ВремФайл);
Исключение
Сообщить(ОписаниеОшибки(), СтатусСообщения.ОченьВажное);
Сообщить(«Ошибка создания»);
Возврат неопределено;
КонецПопытки;
//.
КонецФункции
Все это работало до на другом сервере и в серверной базе. Просто видимо забыл про какие то права пользователя(
Да как-бы пофиг. Главное под какой учеткой сервер 1С крутится.
Околосабж:
Я так понял нужно MS Office документы создавать? С моей точки зрения не очень хорошо ставить офисный пакет на сервер БД.
Можно и без офиса документы то создавать, вот вордовский http://infostart.ru/public/16215/ так-же и с экселем легко найти. Лицензия жеж, деньги жеж. Кстати чтение из excel «летаить», если читать драйвером ODBC.\ и SQL запросы можно ! Ня!
Загружаем данные из Excel
Все работает великолепно. Но сжирает лицензии. После этой обработки уже никто не может зайти в подсистему. Приходится перегружать сервер. Подскажите, как с этим можно бороться?
ЗЫ. Обработка работает 1 раз в неделю. Пользователи могут быть разными.
Источник
Устранение ошибки при подключении к базе данных 1С через COM-соединение
Специальные предложения
Такой чисто админский подход.
У меня проще.
1. Идем в каталог с установленной версией 1С.
2. Находим нужный нам файл comcntr.dll.
3. Нажимаем на нем правой кнопкой мыши
4. Появляется контекстное меню — выбираем отправить ярлык на рабочий стол.
5. Находим ярлык.
6. Нажимаем на нем правой кнопкой мыши- выбираем свойства
7. В новом окне в поле «Объект» дописываем строку перед основным текстом, т.е. в начало текста
regsvr32.exe пробел.
8. Нажимаем «ОК».
9. Запускаем ярлык от имени Админа.
10. Получаем окно об успешной регистрации.
Обновление 27.11.17 12:22
См. также
Как я начал администрировать сервер 1С: Предприятие 8.3 с телефона Промо
Развитие инструментов управления кластером серверов 1С:Предприятие 8.3.
14.04.2017 67225 user700211_a.straltsou 30
Свернуть базу и не свернуть себе шею
Текст из серии «Письма клиентам», на тему «Свёртка информационной базы»
18.08.2021 5579 1c-intelligence 70
Полнотекстовый поиск в 1С. №2 Самое основное для разработчика
Полнотекстовый поиск в 1С и все что с этим связано. Часть №2: программное использование и некоторые нюансы при разработке.
02.09.2020 19297 YPermitin 5
Ускоряем полнотекстовый поиск в динамических списках
Сам являюсь пользователем УТ 11.4 и при обращении пользователей пользуюсь поиском, и как многие пользователи, сталкиваюсь с медленным поиском в динамических списках. В статье приведу пример кода, который поможет исключить из поиска лишние колонки, ускорит поиск и освободит кучу ресурсов у сервера.
20.07.2020 7333 PRO100_NigGaZ 11
Копирование числовых ячеек из 1С в Excel Промо
Решение проблемы, когда значения скопированных ячеек из табличных документов 1С в Excel воспринимаются последним как текст, т.е. без дополнительного форматирования значений невозможно применить арифметические операции. Поводом для публикации послужило понимание того, что целое предприятие с более сотней активных пользователей уже на протяжении года мучилось с такой, казалось бы на первый взгляд, тривиальной проблемой. Варианты решения, предложенные специалистами helpdesk, обслуживающими данное предприятие, а так же многочисленные обсуждения на форумах, только подтвердили убеждение в необходимости описания способа, который позволил мне качественно и быстро справиться с ситуацией.
15.01.2019 34699 itriot11 27
Полнотекстовый поиск в 1С. №1 Грабли в динамических списках
Полнотекстовый поиск в 1С и все что с этим связано. Часть №1: особенности работы в динамических списках.
18.07.2020 12671 YPermitin 21
Как настроить сервер 1С по умолчанию для ПРОФ лицензии после 10.09.2019
Здесь мы собираем все данные по настройкам сервера для работы ПРОФ лицензии.
11.09.2019 107615 Infostart 90
Использование Zabbix для сбора информации о серверных вызовах и управляемых блокировках с сервера 1С Предприятия, работающего на платформе GNU/Linux
Описанные в данном опусе механизмы ни в коей мере не противопоставляются тому, что реализует КИП от 1С или какие-либо другие инструменты (решения)! Это всего лишь еще один взгляд на «проблему», который может быть полезен в некоторых ситуациях.
10.09.2019 22477 Sloth 48
Отчет по размерам таблиц в базе данных как одно из средств анализа проблем Промо
Зачастую, когда пользователи обращаются с жалобами на производительность, бывает полезно посмотреть на отчет по размерам таблиц базы данных. Он может отчетливо показать ряд распространенных проблем, устранение которых даст существенный эффект. Приведенная информация вряд ли покажется чем-то новым для опытных специалистов.
21.07.2015 37721 Aleksey.Bochkov 15
Нарушение целостности системы
Причины возникновения ошибки «Обнаружено нарушение целостности системы» и способы ее устранения.
07.09.2019 52987 Rain88 27
Быстрое копирование таблиц большого размера и/или с большим числом строк, на примере регистра сведений (для MS SQL)
Моментальное восстановление затертого регистра сведений из бекапа посредством SQL.
11.08.2019 8247 Zlohobbit 25
Уверенное обновление
Уверенное обновление. Анализ файла ОтчетОСравнении.txt. Bash
18.07.2019 13125 vasilev2015 36
Чем PostgreSQL может быть полезен разработчику 1С Промо
В статье будут рассмотрены примеры, которые могут оказаться полезными в повседневной работе разработчика 1С и не только: как можно сделать снимок рабочей базы без файла резервной копии, как можно эффективно использовать табличные пространства СУБД PostgreSQL, а также как организовать простой и удобный доступ к админке СУБД посредством мобильных устройств.
20.12.2018 24908 Shmell 40
Почему Вы не обслуживаете итоги?
Небольшая заметка по обслуживанию итогов. Все ли Вы делаете правильно?
04.07.2019 25408 YPermitin 34
За 5 шагов добавляем мониторинг счетчиков производительности серверов MS SQL и 1С
Мы расскажем и покажем, как добавить данные счетчиков производительности серверов 1С и MS SQL в нашу базу мониторинга за 15 минут. Приведем список наиболее важных из них, опишем основные особенности.
28.05.2019 25636 ivanov660 19
Опыт обновления до 8.3.14 — лицензии и утилита ring
На выходных было скучно, поэтому решили обновить 1с до 8.3.14.1694. С лицензиями пришлось немного повозиться.
29.04.2019 45750 Sander80 31
Зачем в 1С нужно периодически пересчитывать итоги по регистрам? Промо
Мы часто слышим рекомендацию о том, что пересчет итогов нужно проводить регулярно и эта операция проводит к улучшению производительности, но что скрывается за этой процедурой и какие именно проблемы решаются?
10.03.2013 247749 Aleksey.Bochkov 141
Практика перехода на Linux и Postgres в небольшой компании (10 пользователей)
Почему я решил поставить давнему клиенту Linux + Postgres вместо Windows + MS SQL? Что меня останавливало раньше?
22.04.2019 33641 starik-2005 180
Переход на 64-х разрядный сервер 1С
Переход с 32-х разрядной версии сервера 1С на 64-х разрядную с сохранением данных журналов регистрации информационных баз, используемых в 32-х разрядной версии.
05.04.2019 29120 ids79 20
Cannot insert duplicate key. Кто виноват и что делать
Ошибка «CANNOT INSERT DUPLICATE KEY» в базах 1С и связанная с ней «магия».
25.02.2019 26939 YPermitin 32
Создание пользователя СУБД MS SQL Промо
Создание пользователя MS SQL для развертывания базы 1С.
15.02.2017 47282 hayroff 9
Скорость работы 1С: Предприятие с разными СУБД: MS SQL и с PostgreSQL
Рассмотрим несколько вариантов работы 1С: Предприятие с различными СУБД.
20.02.2019 31076 valentinko 174
Восстановление файловой базы с помощью tools 1cd
Небольшая заметка, как удалось вылечить битую файловую базу 1С, с помощью утилиты tools 1cd.
19.02.2019 19395 rzabolotin 68
Debian 9.7 + PostgreSQL для 1С. Как завести с пол-оборота
Предлагаю взять на заметку информацию по установке и настройке в формате typical, typical, done.
02.02.2019 30037 valentinko 15
Все, что надо знать о технологической платформе 1С:Предприятие: компоненты, архитектуры, операционные системы, лицензии Промо
Все о платформе и лицензировании для начинающих и не только. (благодаря Сообществу учтены новейшие изменения лицензионной политики 1С!)
19.12.2015 80990 barelpro 51
1С и Яндекс.Облако Compute Cloud. Вдоль и поперек
Бороться и искать. Найти и перепрятать. Достаточно популярная поговорка во времена Союза. Вот и сейчас, те у кого сервер 1С в локальной сети мечтают вынести его в облако, а те у кого в облаке прикупить свой в локальную сеть. Тестирование Яндекс.Облако Compute Cloud для 1С Предприятие оставило у меня приятное впечатление. Возможно кто-то повторит его и внесет больше ясности в настройки виртуальных серверов, использованию API и так далее. Пока же пользуйтесь чем я послал. Интересующихся прошу под кат…
20.01.2019 19422 capitan 29
Малоизвестная хитрость определения модуля и номера строки при возникновении исключения (без запуска отладки и конфигуратора). Несколько очень удобных, но малоиспользуемых возможностей работы в конфигураторе
В статье описана возможность получить место возникновения исключения при работе пользователей без участия конфигуратора. Подробно описаны еще некоторые очень полезные приемы при работе в отладке.
17.01.2019 32137 PoZiTiFFF 54
Восстановление базы 1С, ошибка источника потока
Очередной кирпичик в основу решения проблемы восстановления работоспособности базы после динамического обновления.
09.01.2019 22190 idle 25
1С и Windows Script Host (WSH) и Windows Management Instrumentation (WMI). ОТ ТЕОРИИ К ПРАКТИКЕ. Часть I Промо
Описание возможностей Windows Script Host и Windows Management Instrumentation. Подборка «скриптовых» функций и процедур.
12.12.2012 81379 StepByStep 69
Сервер 1С:Предприятие на Ubuntu 16.04 и PostgreSQL 9.6, для тех, кто хочет узнать его вкус. Рецепт от Капитана
Если кратко описать мое отношение к Postgres: Использовал до того, как это стало мейнстримом. Конкретнее: Собирал на нем сервера для компаний среднего размера (до 50 активных пользователей 1С). На настоящий момент их набирается уже больше, чем пальцев рук пары человек (нормальных, а не фрезеровщиков). Следуя этой статье вы сможете себе собрать такой же и начать спокойную легальную жизнь, максимально легко сделать первый шаг в мир Linux и Postgres. А я побороться за 1. Лучший бизнес-кейс (лучший опыт автоматизации предприятия на базе PostgreSQL). Если, конечно, статья придется вам по вкусу.
25.12.2018 45915 capitan 150
Проверка COM-соединения
Универсальная внешняя обработка (СДРПроверкаCOMСоединения) для проверки COM-соединения с базами 1С и прочими COM-объектами. Платформа 8.3, управляемые формы. Версия 011 от 27.02.2020
23.12.2018 13714 117 ROL32 8
Заметки про лицензии 1С
Решил собрать шпаргалку по лицензиями 1С о разных нюансах, с которыми успел столкнуться.
15.12.2018 24535 MrWonder 24
Не работают регламентные задания? Промо
Работают не всегда стабильно. Что делать, как обеспечить стабильную работу пользователей? Качественную и устойчивую работу ИС? Делать контроль выполнения регламентных (фоновых) заданий. Ниже подробные комментарии с фрагментами кода.
27.09.2014 35826 ksnik 14
Установка клиента 1С:Предприятие 8.3 на Debian / Ubuntu
В последние годы интерес к альтернативным ОС, прежде всего Linux, возрастает, причем не только со стороны пользователей, но и со стороны разработчиков. Фирма 1С достаточно давно развивает свою платформу для использования в среде Linux, а теперь к ней стали подтягиваться производители торгового оборудования, выпуская драйвера и для этой ОС. Поэтому использование Linux в качестве платформы для рабочего места выглядит все более привлекательно и сегодня мы обобщим свой опыт и расскажем об установке клиентской части 1С:Предприятие в среде современных выпусков Debian / Ubuntu.
15.10.2018 52981 oldcopy 77
Когда 1С падает в дамп
Мой опыт устранения проблемы, при которой вылетала платформа 1С.
11.10.2018 64609 987ww765 48
Мониторинг активности пользователя
Работает ли пользователь с программой? Сколько времени пользователь работает в программе? Что пользователь делает в программе? — эти вопросы стандартно решаются или просмотром журнала регистрации, или с помощью внешних программ. В данной статье будет предложен способ, как следить за активностью пользователей, используя небольшую доработку конфигурации. Бонусом системы мониторинга является автоматическое завершение сеансов пользователей, не работающих с программой длительное время.
11.10.2018 20536 postovalov 26
Часто встречающиеся ошибки 1С и общие способы их решения Промо
Статья рассчитана в первую очередь на тех, кто недостаточно много работал с 1С и не успел набить шишек при встрече с часто встречающимися ошибками. Обычно можно определить для себя несколько действий благодаря которым можно определить решится ли проблема за несколько минут или же потребует дополнительного анализа. В первое время сталкиваясь с простыми ошибками тратил уйму времени на то, чтобы с ними разобраться. Конечно, интернет сильно помогает в таких вопросах, но не всегда есть возможность им воспользоваться. Поэтому надеюсь, что эта статья поможет кому-нибудь сэкономить время.
03.06.2014 280558 suggestive 52
[Шпаргалка] Несколько версий сервера 1С на одном сервере (компьютер)
Публикация-шпаргалка. Если у вас возникала необходимость в размещение нескольких серверов 1С разных версий на одном сервере (компьютере).
14.05.2018 31573 rpgshnik 27
Несколько версий сервера 1С на одном компьютере
Как установить несколько экземляров сервера 1С на один компьютер. Как установить несколько служб агента 1С на один сервер? Как запустить сервера разных платформ на одном компьютере.
18.04.2018 110699 spezc 97
Запуск Apache 2.4 с модулем 1С внутри Docker контейнера
Про Apache и про Linux слышали, наверное, все. А вот про Docker пока нет, но он сильно набирает популярность последнее время и не зря. Поделюсь своим опытом и дам пошаговую инструкцию настройки веб-сервера Apache с модулем 1С внутри Docker контейнера на Linux хосте. При этом сам сервер 1С может находиться совсем на другой машине и на другой операционной системе. Это не важно, главное чтобы Apache смог достучаться до сервера 1С по TCP. В статье дам подробное пояснение по каждой используемой команде со ссылками на документацию по Docker, чтобы не создавалось ощущение непонятной магии. Также прилагаю git репозиторий с описанием всей конфигурации, можете попробовать развернуть у себя буквально за 10 минут.
04.04.2018 32442 petr.myazin 38
Технология обновления нетиповых конфигураций 1С:Предприятия 8 (редакция 12.04.2012) Промо
Данная статья основана на многолетнем опыте по развитию и поддержке учетных решений на платформе 1С:Предприятия. В статье описаны некоторые довольно часто встречающиеся ситуации, вызывающие сложности при обновлении нетиповых конфигураций 1С:Предприятия 8.
Источник