Не работает домен почты

Содержание
  1. Типичные ошибки при подключении доменной почты
  2. Как подготовиться к рассылке?
  3. Сообщения от SMTP — что это?
  4. Разбор SMTP-ошибок и советы по исправлению
  5. Ошибка 421
  6. Код 451 — проблемы с обработкой
  7. Нехватка места на сервере
  8. Адресат недоступен, ошибка 550
  9. Проблемы с получением писем
  10. Проблемы с настройкой домена
  11. Подтверждение домена и проблема со статусом
  12. Почта перестала функционировать после передачи управления
  13. Как еще проверить функциональность почтового сервера?
  14. Возможные проблемы при работе с почтой REG.RU
  15. Не отправляется почта на ящики @mail.ru
  16. Письма не приходят только на почтовый ящик на домене
  17. Не отправляется вся почта через phpmail
  18. Не уходит почта через sendmail
  19. Почта — диагностика и устранение ошибок
  20. 451 domain.ru prohibited. Disk quota exceeded
  21. 451 Please try another server
  22. 452 message sending quota exceeded, try later
  23. 476 connections from your host are denied
  24. 550 Your message was identified as SPAM
  25. 550 mailbox@domain.ru prohibited. We do not relay
  26. 591 mailbox@domain.ru You must authenticate first
  27. 550 Sender domain does not match hosting account
  28. 550 Incorrect header syntax in From field

Типичные ошибки при подключении доменной почты

Для отправления рассылок или корпоративных писем обычный почтовый ящик не подойдет. Нужно учесть настройки вроде DKIM-подписок и MX-записей, чтобы наладить массовую рассылку и быть уверенным, что клиент или заказчик точно получит сообщение. Еще нужно пройти проверку спам-фильтров, которые могут заблокировать самые обычные письма, если они не соответствуют требованиям сервиса. Поэтому бизнесу легче создать корпоративный ящик, где большая часть настроек уже выполнена. Это можно сделать в сервисе Почта для домена от Mail.ru для бизнеса. Служба безопасности защитит ваши данные. Все параметры настроены для отправления рассылок и коммерческих сообщений. Но иногда при подключении доменного ящика могут появиться ошибки. Рассмотрим основные проблемы и расскажем, как их исправить.

Как подготовиться к рассылке?

Даже правильные настройки почтовой службы не гарантируют идеальную доставляемость писем. Особенно в первые время после подключения доменной почты. Часто письма не доходят из-за неисправностей со стороны получателя — проблемы с его сервером или ваш адрес оказался в спам-листе.

Отправку лучше начать со своего личного ящика — тестовая рассылка придет с корпоративной почты. Можно посмотреть получение письма в разных сервисах, проверить, как работает система ответов на сообщения и их принятие. В дальнейшем следите, как доставляются письма. Можно не заметить проблем с получением и продолжить рассылки. А почтовый сервис увидит, что вы не исправляете ошибки, и будет блокировать все исходящие.

Проблемы также возникают из-за ключевых параметров (DKIM- и SPF-подписки), которые мешают правильно выполнить массовую рассылку. Платформа «Mail.ru для бизнеса» помогает настроить их, а также выделяет IP, чтобы не попасть под спам-фильтры.

Сообщения от SMTP — что это?

Почтовые сервисы используют единый протокол для отправки и доставления писем — SMTP. Он помогает серверам общаться друг с другом и передавать данные о письмах. В случае возникновения неисправности протокол сообщает отправителю ее код. Например, «SMTP error» означает, что произошла критическая ошибка, а код класса «3xx» — что для отправки потребуются дополнительные действия. Во втором случае проблема, скорее всего, решится, но чуть позже. Отправителю нужно только проверить настройки.

Самые опасные и сложные ошибки — класса «4хх» и «5хх». Расскажем на примерах.

Разбор SMTP-ошибок и советы по исправлению

Ошибка 421

Это значит, что сервер недоступен. Возможно, параметры протокола SMTP заданы неверно или блокируется трафик. Необходимо посмотреть настройки:

  • Проверить SMTP в почтовом сервисе.
  • Создать новые правила для брандмауэра, если он блокирует IP.
  • Смените номер SMTP-порта (лучше на 465), если не проходит отправка через 25.
  • Свяжитесь с провайдером и попросите убрать ваш сервер из черного списка VPN.
Читайте также:  Пассат б5 не работает стеклоподъемник водительской двери

Код 451 — проблемы с обработкой

Протокол не будет отправлять письма, если превышен их лимит. Проверьте разрешенное количество сообщений в доменной почте. На сервере также стоит задать новый лимит — не на общее число сообщений, а на количество писем по одному адресу. Также стоит проверить MX-записи — они определяют сервер получателя. Подтвердите нужные разрешения и поправьте логи.

Нехватка места на сервере

Для отправки сообщений расходуется место для хранения. Когда оно заканчивается, SMTP присылает ошибку 452. Увеличьте объем серверного пространства или очистите его от ненужных файлов.

Адресат недоступен, ошибка 550

Проблемы со стороны получателя рассылки. Возможно, допущена ошибка в указании email-адреса или сервер получателя не работает. Сообщите об этом адресату, но проверьте и свои настройки. Возможно, на вашем ПК работает вирусная программа, которая массово рассылает письма с вашего ящика. Или провайдер установил лимит на отправление. Проверьте ПК на вирусы и свяжитесь с провайдером.

Проблемы с получением писем

Код 571 — продолжение ошибки 550. Спам-фильтры или антивирус мог заблокировать IP отправителя. Или он не получил разрешение на отправку писем через сервер-посредник, с которым работает сервер получателя. Справиться с этим может администратор сети и этого сервера.

Проблемы с настройкой домена

Подтверждение домена и проблема со статусом

Иногда после выполнения всех действий для подтверждения домена могут возникнуть ошибки. Все сделано верно, но статус не меняется, и домен не подключается. Нужно проверить способ подтверждения — верно ли указаны все настройки. Смотрим код страницы, куда был добавлен метатег, или проверяем, чтобы страница открывалась (подтверждение через HTML). Для проверки способа DNS потребуется несколько дней, однако сторонние сервисы помогут получить нужную информацию быстрее (например, Digwebinterface).

Почта перестала функционировать после передачи управления

Домен делегирует управление на подключенный DNS-сервер. Если почта не работает, необходимо убедиться в корректности MХ-записей.

Как еще проверить функциональность почтового сервера?

Тестовый вариант с отправлением писем на личные ящики важен, но не всегда может определить проблему. Список ошибок при подключении доменной почты довольно большой. Часть из них можно решить самостоятельно, а с некоторыми справятся только эксперты. Но если что-то работает не так, нужно определиться, в чем заключается проблема.

Источник

Возможные проблемы при работе с почтой REG.RU

При отправке почты с сайта могут наблюдаться следующие проблемы:

  • не отправляется почта на ящики @mail.ru;
  • письма не приходят только на почтовый ящик на домене;
  • не отправляется вся почта через phpmail;
  • не уходит почта через sendmail.

Ниже приведено решение каждой из проблем.

Не отправляется почта на ящики @mail.ru

Система mail.ru не принимает сообщения, отправленные через phpmail, если в почтовых заголовках числится ящик, принадлежащий mail.ru (это ящики @mail.ru @bk.ru @list.ru @inbox.ru).

Найдите строку вида:

В данной строке вместо «e-mail@mail.ru» укажите почтовый ящик, не относящийся к доменам mail.ru, inbox.ru, list.ru, bk.ru.
Желательно указать почтовый ящик на вашем домене, например, «webmaster@domain.ru», где domain.ru — ваш домен.

Если рекомендации не помогли, вам необходимо проверить заголовки генерируемого сообщения. Возможно, почтовый ящик (@mail.ru @bk.ru @list.ru @inbox.ru) прописан в поле «From», для этого необходимо проверить скрипт отправки сообщений.
Также рекомендуем обратиться к разработчику вашего сайта.

Письма не приходят только на почтовый ящик на домене

Проблема может наблюдаться когда на домене настроена сторонняя почта (Yandex, GoogleApps..), а в панели управления все еще активирована локальная почта.
В этом случае проблему решит отключение локальной маршрутизации почты. Делается это в панели управления хостингом:

Читайте также:  Как понять что сломалась помпа ваз 2115

Перейдите в раздел «Почтовые домены», выделите строку с названием вашего домена и нажмите Удалить:

В разделе «Электронная почта» выберите Маршрутизация электронной почты:

В выпадающем списке выберите необходимый домен и в блоке «Маршрутизация электронной почты» отметьте пункт Удаленный почтовый обменник:

На вкладке «Почта» перейдите в раздел Настройки почты и кликните по имени необходимого домена:

В открывшемся окне снимите галочку с «Активировать почтовую службу на этом домене» и нажмите Применить:

Готово. Отключение локальной маршрутизации почты решит проблему.

Не отправляется вся почта через phpmail

Проверьте, возможно ваш тарифный план «Host-Lite». На данном тарифе нет поддержки PHP, следовательно отправка сообщений с сайта посредством phpmail работать не будет. Узнать тарифный план можно на странице со списком услуг. Чтобы у вас появилась возможность отправки почты при помощи php, просто повысьте тарифный план: Как повысить тарифный план хостинга.

В других случаях, вероятнее всего, для вашей услуги хостинга заблокирована отправка сообщений через phpmail. Пожалуйста, выполните рекомендации следующего раздела справки: Отправка почты заблокирована

Не уходит почта через sendmail

Чаще всего проблема связана с тем, что в настройках sendmail указывается стандартный (25) порт, для которого заблокированы исходящие соединения на всех серверах виртуального хостинга REG.RU.

Для решения проблемы необходимо указать 587 порт в настройках sendmail, при этом используйте TLS-шифрование.

Источник

Почта — диагностика и устранение ошибок

451 domain.ru prohibited. Disk quota exceeded

Сообщение означает, что дисковое пространство, выделенное для домена получателя, исчерпано.

Необходимо повторить отправку через некоторое время. Как правило, почтовый сервер предпринимает повторную попытку автоматически.

Для того чтобы возобновить прием почты, вы можете:

  • перераспределить дисковое пространство в разделе Ресурсы панели управления хостингом,
  • освободить почтовые ящики вашего домена от ненужных сообщений,
  • перейти на тарифный план с большим дисковым пространством (с последующей корректировкой квот).

Увеличить квоту отдельного ящика можно в разделе панели управления Почта → Ваш домен → Ваш ящик.

451 Please try another server

Сообщение означает, что требуется повторить попытку подключения к другому принимающему серверу RU-CENTER. Если в результате нескольких попыток отправка сообщений заканчивается неудачно, необходимо скорректировать настройки почтового сервера отправителя:

  1. Отсутствие ответа от сервера mx02.nicmail.ru и ответ сервера mx03.nicmail.ru с кодом 4XX не должен восприниматься как фатальная ошибка, и попытки отправки должны продолжаться на серверы, указанные в других MX-записях.
  2. Отправляющий почтовый сервер, который подключается к серверам RU-CENTER, должен иметь корректно настроенные DNS-записи. Должна существовать PTR-запись для IP-адреса почтового сервера в обратной зоне. Значение PTR-записи в обратной зоне должно совпадать с А-записью в прямой зоне (т.е. с именем сервера). Например, сервер исходящей почты relay05.nicmail.ru имеет IP-адрес 194.85.88.236:

nslookup relay05.nicmail.ru
Non-authoritative answer:
Name: relay05.nicmail.ru
Address: 194.85.88.236

Для этого IP-адреса существует PTR-запись в обратной зоне со значением relay05.nicmail.ru, т.е. совпадающая с именем сервера.

nslookup 194.85.88.236
Name: relay05.nicmail.ru
Address: 194.85.88.236

Запись в обратной зоне не должна содержать характерных для динамических IP-адресов домашних интернет-провайдеров слов:

broadband, pptp, dynamic, pool, ppp, peer, dhcp, cable, node, client, dialup, static, wanadoo, dsl, public, user, vpn .

  • Ожидание ответов от сервера RU-CENTER (timeout) должно составлять не менее 5 минут в соответствии с RFC 5321:
    • ожидание на стадии подключения (до получения приглашения с кодом 220): не менее 5 минут;
    • ожидание после «MAIL FROM»: не менее 5 минут;
    • ожидание после «RCPT TO»: не менее 5 минут.
  • 452 message sending quota exceeded, try later

    Сообщение означает, что для почтового ящика достигнут лимит на отправку сообщений (50 писем в 15 минут). Возможность отправки писем будет восстановлена автоматически в течение 10 минут.

    Читайте также:  Не работает кнопка выключения звука айфон

    476 connections from your host are denied

    Сообщение означает, что подключение с вашего IP-адреса к почтовому серверу хостинга временно заблокировано. Это происходит в результате множественных ошибок при работе с почтовым сервером:

    • многократные попытки авторизации с неверными логином и паролем,
    • отправка писем на несуществующие адреса,
    • многократные попытки отправки писем при достижении лимитов, указанных на странице Ограничения и особенности почтовой системы.

    Блокировка снимается автоматически через 15 минут. Для устранения проблемы рекомендуем проверить корректность настроек почтовых клиентов. Если проблема сохранится, сообщите о ней в службу технической поддержки, написав на адрес support@nic.ru и указав в письме

    • номер вашего договора,
    • почтовый ящик , при попытке отправки с которого наблюдается проблема,
    • ваш внешний IP-адрес. Узнать его вы можете на сайтах http://myip.ru и http://2ip.ru.

    550 Your message was identified as SPAM

    Сообщение означает, что входящее письмо было идентифицировано как спам на основе анализа его содержимого.

    Попробуйте изменить формулировку письма и повторить отправку. Если проблема сохранится, обратитесь, пожалуйста, к получателю с помощью других средств связи с просьбой добавить ваш домен в белый список.

    Если у вас нет контактных данных администратора домена получателя, воспользуйтесь сервисом Whois.

    Вы можете добавить домен отправителя в белый список, тогда почта с данного домена не будет проверяться спам-фильтром. Чтобы добавить домен example.net в белый список, необходимо:

    • авторизоваться в панели управления, используя номер своего договора и пароль;
    • перейти в раздел Почта;
    • нажать на название почтового домена;
    • перейти в раздел Спам-фильтр → Белый список;
    • добавить маску вида *@example.net в блоке Новая маска почтового адреса и нажать кнопку Создать.

    550 mailbox@domain.ru prohibited. We do not relay

    Сообщение означает, что адрес mailbox@domain.ru не существует в почтовой системе хостинга RU-CENTER. Проверьте правильность написания адреса и повторите отправку.

    591 mailbox@domain.ru You must authenticate first

    Сообщение означает, что в почтовом клиенте не настроена авторизация на сервере исходящей почты ( SMTP ) mail.nic.ru по имени ящика и паролю (аналогично серверу входящей почты).
    Рекомендуем проверить корректность настроек почтового клиента. Например, если вы используете Outlook, убедитесь, что в настройках учетной записи для сервера исходящей почты стоит галочка напротив параметра SMTP-серверу требуется проверка подлинности и Аналогично серверу для входящей почты.

    550 Sender domain does not match hosting account

    Сообщение означает, что доменная часть адреса отправителя в заголовке «FROM» или в поле «MAIL FROM» конверта письма пустая или содержит домен, не добавленный на вашу услугу хостинга в качестве имени почтового домена или его синонима.

    Рекомендуется проверить настройки почтового клиента или иного ПО, отправляющего почту, и указать адрес отправителя в домене, добавленном на ваш хостинг.

    550 Incorrect header syntax in From field

    Сообщение означает, что в письме поле «From» с адресом отправителя содержит информацию, которая не соответствует требованиям rfc5321 и rfc5322.

    В частности, если в поле From в дополнение к адресу электронной почты указывается имя пользователя, оно должно быть заключено в кавычки:
    From: «User Name»

    Рекомендуем проверить настройки почтового клиента или иного ПО, отправляющего почту, проверить текст, указанный в качестве имени отправителя, заключить его в кавычки. В некоторых почтовых клиентах использование кавычек и спецсимволов внутри имени пользователя, например, «Иван Иванов, ООО «Ромашка»» может приводить к ошибке, в этом случае кавычки или спецсимволы рекомендуется удалить, а также рассмотреть возможность обновления почтового клиента.

    Источник

    Оцените статью