Не работает или не открывается phpmyadmin

Содержание
  1. phpmyadmin не работает после того, как я его установил
  2. не обнаружена
  3. phpmyadmin не работает после того, как я его установил
  4. 9 ответов
  5. Не открывается phpmyadmin. Вообще не открывается, просто белое окно
  6. Сообщения 9
  7. 1 Тема от liudok 2011-11-23 20:10:07
  8. Тема: Не открывается phpmyadmin. Вообще не открывается, просто белое окно
  9. 2 Ответ от Hanut 2011-11-23 20:20:50
  10. Re: Не открывается phpmyadmin. Вообще не открывается, просто белое окно
  11. 3 Ответ от liudok 2011-11-23 21:43:22
  12. Re: Не открывается phpmyadmin. Вообще не открывается, просто белое окно
  13. 4 Ответ от Hanut 2011-11-23 21:51:59
  14. Re: Не открывается phpmyadmin. Вообще не открывается, просто белое окно
  15. 5 Ответ от liudok 2011-11-23 22:16:29
  16. Re: Не открывается phpmyadmin. Вообще не открывается, просто белое окно
  17. 6 Ответ от Hanut 2011-11-23 22:29:24
  18. Re: Не открывается phpmyadmin. Вообще не открывается, просто белое окно
  19. 7 Ответ от liudok 2011-11-23 22:47:25
  20. Re: Не открывается phpmyadmin. Вообще не открывается, просто белое окно
  21. 8 Ответ от liudok 2011-11-23 22:51:07
  22. Re: Не открывается phpmyadmin. Вообще не открывается, просто белое окно
  23. 9 Ответ от Hanut 2011-11-23 23:04:39
  24. Re: Не открывается phpmyadmin. Вообще не открывается, просто белое окно
  25. Сообщения 9

phpmyadmin не работает после того, как я его установил

Я использую Ubuntu-11.04 .

Я следовал за этими шагами на этом сайте:

Пока что мои apache2, php и mysql работают нормально, кроме phpmyadmin . Всякий раз, когда я запускаю это:

Я получаю эту ошибку в своем браузере:

не обнаружена

Запрошенный URL / phpmyadmin / не найден на этом сервере.

Сервер Apache / 2.2.17 (Ubuntu) на локальном хосте, порт 80

Пожалуйста, прочтите этот раздел в Ubuntu Wiki. Вам нужно будет настроить ваш apache2.conf, чтобы phpMyAdmin работал.

Затем добавьте следующую строку в конец файла.

Затем перезапустите Apache

Пробовал разными способами.

Наконец, это, это из документации по Ubuntu , работает для меня:

Ubuntu 16.04

После установки и настройки имени пользователя и пароля в mysql и phpmyadmin выполните следующую команду

Работал на меня .

Edit1 Если вам просто нужны apache, phPmyAdmin и MySql только для среды веб-приложений, тогда я предлагаю для экзамена, который установит все три для вас, и тогда вы готовы к работе. Вот ссылка

Не паникуйте! Просто запустите следующий код с правами root в терминале

Я столкнулся с той же проблемой, я исправил ее, запустив sudo dpkg-reconfigure phpmyadmin

дать новое имя пользователя и пароль

Вам нужно найти, где phpmyadmin находится, например locate phpmyadmin , некоторые из них вернут местоположение, например /usr/share/phpmyadmin .

Тогда вы можете символическую ссылку так: sudo ln -s /usr/share/phpmyadmin /var/www

Запуск Ubuntu 14.04 и выше /var/www больше не работает /var/www/html . например, sudo ln -s /usr/share/phpmyadmin /var/www/html

Проверено и работает. Запуск, который должен решить это для любого, кто хочет 1 лайнер.

Я перепробовал все вышеперечисленные методы, и они не сработали для меня. Наконец этот сработал.

Откройте терминал и переключитесь на супер пользователя с помощью команды: sudo su

После установки phpmyadmin, используя инструкции, приведенные в ссылке , откройте /etc/apache2/conf-available .

Читайте также:  Не работает маслонасос бензопилы

Там вы найдете файл с именем phpmyadmin.conf . Скопируйте это в /etc/apache2/conf-enabled . Или просто используйте команду

Перезапустите apache2 ( sudo service apache2 restart ), а затем откройте ссылку localhost / phpmyadmin в браузере.

Источник

phpmyadmin не работает после того, как я его установил

Я использую ubuntu-11.04.

Я выполнил следующие шаги на этом сайте:

Установка Apache2 с поддержкой PHP5 и MySQL на Ubuntu | HowtoForge

До сих пор мои apache2, php и mysql отлично работают, кроме phpmyadmin . Всякий раз, когда я запускаю это:

Я получаю эту ошибку в своем браузере:

Не найдено Запрошенный URL / phpmyadmin / не найден на этом сервере. Apache / 2.2.17 (Ubuntu) Сервер на локальном хосте Порт 80

9 ответов

Пробовал различные способы.

Наконец, это из документации ubuntu работало для меня:

После установки и настройки пользователя и пароля в mysql и phpmyadmin выполните следующую команду

Работали для меня .

Ubuntu 16.04 Если вам просто нужны apache, phPmyAdmin и MySql только для среды веб-приложений, то я предлагаю для примера установить все три для вас, а затем вы готовы к работе. Здесь ссылка

Установщики и загрузки XAMPP | Друзья Apache

Не паникуйте! Просто запустите следующий код с правами root в терминале

Я столкнулся с такой же проблемой, я исправил ее, запустив sudo dpkg-reconfigure phpmyadmin

, чтобы указать новое имя пользователя и пароль

Вы должны найти, где phpmyadmin находится, например. locate phpmyadmin, некоторые из них вернут местоположение, например /usr/share/phpmyadmin.

Затем вы можете символически ссылаться на него следующим образом: sudo ln -s /usr/share/phpmyadmin /var/www

Запуск Ubuntu 14.04 и выше, /var/www больше не работает /var/www/html. например, sudo ln -s /usr/share/phpmyadmin /var/www/html

Ссылка: где разместить мой локальный сайт, начиная с версии apache2 версии 2.4.7?

Проверено и работает. Выполнение этого должно решить его для всех, кто хочет 1 лайнер.

Я пробовал все вышеперечисленные методы, и они не работали для меня. Наконец, это сработало.

Откройте терминал и переключитесь на суперпользователя с помощью команды: sudo su

После установки phpmyadmin с помощью инструкций, приведенных в ссылке, откройте /etc/apache2/conf-available.

Вы найдете файл с именем phpmyadmin.conf. Скопируйте его в /etc/apache2/conf-enabled. Или просто используйте команду

Перезапустите apache2 (sudo service apache2 restart), а затем откройте ссылку в браузере.

Источник

Не открывается phpmyadmin. Вообще не открывается, просто белое окно

Форум PHP-MyAdmin.RU → Работа с phpMyAdmin → Не открывается phpmyadmin. Вообще не открывается, просто белое окно

Чтобы отправить ответ, вы должны войти или зарегистрироваться

Сообщения 9

1 Тема от liudok 2011-11-23 20:10:07

  • liudok
  • Редкий гость
  • Неактивен
  • Зарегистрирован: 2011-11-23
  • Сообщений: 9

Тема: Не открывается phpmyadmin. Вообще не открывается, просто белое окно

Вчера было все нормально (сразу говорю, я в этом новичок еще). а сегодня загружаю комп, загружаю Denwer. прописываю http://localhost/tools/phpmyadmin/. раньше была ошибка: Проверте существует ли такая страница. а теперь вообще ничего, просто белый лист. ЧТО ДЕЛАТЬ.

2 Ответ от Hanut 2011-11-23 20:20:50

  • Hanut
  • Модератор
  • Неактивен
  • Откуда: Рига, Латвия
  • Зарегистрирован: 2006-07-02
  • Сообщений: 9,698
Читайте также:  Wolfenstein the new colossus не работает звук

Re: Не открывается phpmyadmin. Вообще не открывается, просто белое окно

Попробуйте посмотреть журналы ошибок (error.log).

3 Ответ от liudok 2011-11-23 21:43:22

  • liudok
  • Редкий гость
  • Неактивен
  • Зарегистрирован: 2011-11-23
  • Сообщений: 9

Re: Не открывается phpmyadmin. Вообще не открывается, просто белое окно

Попробуйте посмотреть журналы ошибок (error.log).

ошибка 80, 443 и 8648

4 Ответ от Hanut 2011-11-23 21:51:59

  • Hanut
  • Модератор
  • Неактивен
  • Откуда: Рига, Латвия
  • Зарегистрирован: 2006-07-02
  • Сообщений: 9,698

Re: Не открывается phpmyadmin. Вообще не открывается, просто белое окно

Это мне ни о чем не говорит. Покажите текст ошибок.

5 Ответ от liudok 2011-11-23 22:16:29

  • liudok
  • Редкий гость
  • Неактивен
  • Зарегистрирован: 2011-11-23
  • Сообщений: 9

Re: Не открывается phpmyadmin. Вообще не открывается, просто белое окно

Это мне ни о чем не говорит. Покажите текст ошибок.

[Wed Nov 23 21:52:59 2011] [notice] Child 4176: Child process is running
[Wed Nov 23 21:52:59 2011] [notice] Child 4176: Acquired the start mutex.
[Wed Nov 23 21:52:59 2011] [notice] Child 4176: Starting 25 worker threads.
[Wed Nov 23 21:52:59 2011] [notice] Child 4176: Listening on port 443.
[Wed Nov 23 21:52:59 2011] [notice] Child 4176: Listening on port 8648.
[Wed Nov 23 21:52:59 2011] [notice] Child 4176: Listening on port 443.
[Wed Nov 23 21:52:59 2011] [notice] Child 4176: Listening on port 80.

6 Ответ от Hanut 2011-11-23 22:29:24

  • Hanut
  • Модератор
  • Неактивен
  • Откуда: Рига, Латвия
  • Зарегистрирован: 2006-07-02
  • Сообщений: 9,698

Re: Не открывается phpmyadmin. Вообще не открывается, просто белое окно

Это не ошибки. Судя по тому что я вижу, Apache работает нормально. Посмотрите ошибки localhost.

7 Ответ от liudok 2011-11-23 22:47:25

  • liudok
  • Редкий гость
  • Неактивен
  • Зарегистрирован: 2011-11-23
  • Сообщений: 9

Re: Не открывается phpmyadmin. Вообще не открывается, просто белое окно

Это не ошибки. Судя по тому что я вижу, Apache работает нормально. Посмотрите ошибки localhost.

02sample/images/storiesext_plugin.png File: tinybrowser.php Line: 108
2009-05-23 13:59:17 (CEST) 2 Warning filesize() [function.filesize]: stat failed for C:/xampp/htdocs/eclipse/k2102sample/images/storiesext_plugin.png File: tinybrowser.php Line: 109
2009-05-23 13:59:17 (CEST) 2 Warning getimagesize(C:/xampp/htdocs/eclipse/k2102sample/images/storiesext_plugin.png) [function.getimagesize]: failed to open stream: No such file or directory File: tinybrowser.php Line: 112
2009-05-23 13:59:17 (CEST) 2 Warning filemtime() [function.filemtime]: stat failed for C:/xampp/htdocs/eclipse/k2102sample/images/storiesjoomla-dev_cycle.png File: tinybrowser.php Line: 108
2009-05-23 13:59:17 (CEST) 2 Warning filesize() [function.filesize]: stat failed for C:/xampp/htdocs/eclipse/k2102sample/images/storiesjoomla-dev_cycle.png File: tinybrowser.php Line: 109
2009-05-23 13:59:17 (CEST) 2 Warning getimagesize(C:/xampp/htdocs/eclipse/k2102sample/images/storiesjoomla-dev_cycle.png) [function.getimagesize]: failed to open stream: No such file or directory File: tinybrowser.php Line: 112
2009-05-23 13:59:17 (CEST) 2 Warning filemtime() [function.filemtime]: stat failed for C:/xampp/htdocs/eclipse/k2102sample/images/storieskey.jpg File: tinybrowser.php Line: 108
2009-05-23 13:59:17 (CEST) 2 Warning filesize() [function.filesize]: stat failed for C:/xampp/htdocs/eclipse/k2102sample/images/storieskey.jpg File: tinybrowser.php Line: 109
2009-05-23 13:59:17 (CEST) 2 Warning getimagesize(C:/xampp/htdocs/eclipse/k2102sample/images/storieskey.jpg) [function.getimagesize]: failed to open stream: No such file or directory File: tinybrowser.php Line: 112
2009-05-23 13:59:17 (CEST) 2 Warning filemtime() [function.filemtime]: stat failed for C:/xampp/htdocs/eclipse/k2102sample/images/storiespastarchives.jpg File: tinybrowser.php Line: 108
2009-05-23 13:59:17 (CEST) 2 Warning filesize() [function.filesize]: stat failed for C:/xampp/htdocs/eclipse/k2102sample/images/storiespastarchives.jpg File: tinybrowser.php Line: 109
2009-05-23 13:59:17 (CEST) 2 Warning getimagesize(C:/xampp/htdocs/eclipse/k2102sample/images/storiespastarchives.jpg) [function.getimagesize]: failed to open stream: No such file or directory File: tinybrowser.php Line: 112
2009-05-23 13:59:17 (CEST) 2 Warning filemtime() [function.filemtime]: stat failed for C:/xampp/htdocs/eclipse/k2102sample/images/storiespowered_by.png File: tinybrowser.php Line: 108
2009-05-23 13:59:17 (CEST) 2 Warning filesize() [function.filesize]: stat failed for C:/xampp/htdocs/eclipse/k2102sample/images/storiespowered_by.png File: tinybrowser.php Line: 109
2009-05-23 13:59:17 (CEST) 2 Warning getimagesize(C:/xampp/htdocs/eclipse/k2102sample/images/storiespowered_by.png) [function.getimagesize]: failed to open stream: No such file or directory File: tinybrowser.php Line: 112
2009-05-23 13:59:17 (CEST) 2 Warning filemtime() [function.filemtime]: stat failed for C:/xampp/htdocs/eclipse/k2102sample/images/storiestaking_notes.jpg File: tinybrowser.php Line: 108
2009-05-23 13:59:17 (CEST) 2 Warning filesize() [function.filesize]: stat failed for C:/xampp/htdocs/eclipse/k2102sample/images/storiestaking_notes.jpg File: tinybrowser.php Line: 109
2009-05-23 13:59:17 (CEST) 2 Warning getimagesize(C:/xampp/htdocs/eclipse/k2102sample/images/storiestaking_notes.jpg) [function.getimagesize]: failed to open stream: No such file or directory File: tinybrowser.php Line: 112
2009-05-23 13:59:17 (CEST) 2 Warning filemtime() [function.filemtime]: stat failed for C:/xampp/htdocs/eclipse/k2102sample/images/storiesweb_links.jpg File: tinybrowser.php Line: 108
2009-05-23 13:59:17 (CEST) 2 Warning filesize() [function.filesize]: stat failed for C:/xampp/htdocs/eclipse/k2102sample/images/storiesweb_links.jpg File: tinybrowser.php Line: 109
2009-05-23 13:59:17 (CEST) 2 Warning getimagesize(C:/xampp/htdocs/eclipse/k2102sample/images/storiesweb_links.jpg) [function.getimagesize]: failed to open stream: No such file or directory File: tinybrowser.php Line: 112
2009-05-24 11:48:07 (CEST) 2 Warning imagejpeg() [function.imagejpeg]: Unable to open ‘C:/xampp/htdocs/eclipse/k2102sample/images/stories/sig/_thumbs/_027_pics.jpg’ for writing: No such file or directory File: fns_tinybrowser.php Line: 113
2009-05-24 11:48:08 (CEST) 2 Warning imagejpeg() [function.imagejpeg]: Unable to open ‘C:/xampp/htdocs/eclipse/k2102sample/images/stories/sig/_thumbs/_034_pics.jpg’ for writing: No such file or directory File: fns_tinybrowser.php Line: 113
2009-05-24 11:48:08 (CEST) 2 Warning imagejpeg() [function.imagejpeg]: Unable to open ‘C:/xampp/htdocs/eclipse/k2102sample/images/stories/sig/_thumbs/_044_pics.jpg’ for writing: No such file or directory File: fns_tinybrowser.php Line: 113

Читайте также:  Почему не работает ritmix

8 Ответ от liudok 2011-11-23 22:51:07

  • liudok
  • Редкий гость
  • Неактивен
  • Зарегистрирован: 2011-11-23
  • Сообщений: 9

Re: Не открывается phpmyadmin. Вообще не открывается, просто белое окно

До этого все нормально работало. А сейчас, захожу на localhost, все, что-то пытается грузить, но ничего не грузит.
Пробовала и с включеным интернетом и с выключеным.
Пинговала 127.0.0.1, все нормально,
Сервер включается без ошибок,
пробовала вбивать Прокси, вбил 127.0.0.1, порт 80, но всеравно без результата.

9 Ответ от Hanut 2011-11-23 23:04:39

  • Hanut
  • Модератор
  • Неактивен
  • Откуда: Рига, Латвия
  • Зарегистрирован: 2006-07-02
  • Сообщений: 9,698

Re: Не открывается phpmyadmin. Вообще не открывается, просто белое окно

Ошибки за 2009 год, к тому же xampp, как я понял, не помогут выяснить причину проблем.

Могу только предположить, что есть конфликт в работе Apache или MySQL. Для начала проверьте, чтобы был запущен только Денвер, остальные веб-сервера были отключены. Проверьте, чтобы был выключен Skype. Прокси никакие вбивать не надо.

Больше пока посоветовать нечего. Если поведение веб-сервера хоть как-то изменится, то можно будет подумать о причине.

Сообщения 9

Чтобы отправить ответ, вы должны войти или зарегистрироваться

Форум PHP-MyAdmin.RU → Работа с phpMyAdmin → Не открывается phpmyadmin. Вообще не открывается, просто белое окно

Форум работает на PunBB , при поддержке Informer Technologies, Inc

Currently installed 7 official extensions . Copyright © 2003–2009 PunBB.

Источник

Оцените статью