- Эксплуатация » Поломался Орион Про, как ПРОЩЕ починить или переустановить?
- Эксплуатация » Орион 1.20, МЦС, не удалось подключиться к серверу
- 9 ответов
- forum-bolid.ru
- Менеджер центрального сервера , проблемы с Параметрами БД
- forum-bolid.ru
- Проблема с Windows Server 2016 и Орион Про
- forum-bolid.ru
- Центральный сервер периодически виснет
Эксплуатация » Поломался Орион Про, как ПРОЩЕ починить или переустановить?
Microsoft Server 2003 Std
Орион Про 1.12 без SP
Всё ставилось с дистрибутива Орион Про, ничего постороннего
На сервере установлены: Сервер, Оболочка с Ядром опроса, Управление сервером. Всё остальное не устанавливалось, сервер только для сервера.
Соединения с двумя пультами через два COM-порта.
UProg с этого сервера успешно общается с приборами, то есть, COM-порты рабочие.
Сегодня была авария по питанию, которую не заметили из-за ИБП. После смерти ИБП отвалились мониторы. Подали электричество, запустили, оболочка на сервере (не на мониторах) запускается с ошибкой соединения. Лог такой
29.07.2019 12:54:46 | Hint: Соединение с сервером
29.07.2019 12:54:59 | Error: Ошибка 240. Невыполнение запроса: транслируемые события
В ядре опроса СОМ-порты перестали присутствовать.
Orion.ini нормальный (у меня сохранён эталонный для сравнения)
Сейчас система работает под пультами и БКИ, есть время подумать.
Как с меньшими потерями запустить сервер?
Могу развернуть системный диск из февральского образа + субботний бэкап базы. Проблема — потеряется доверие в домене, придётся выводить из домена и затаскивать обратно. Вроде бы несложно и я знаю, как это сделать.
Можно переустановить сервер на работающей машине. Не представляю себе это, просто никогда не делал. Сдуру переустановлю всё.
А может быть можно при переустановки отметить галочкой только ядро опроса и всё?
Посоветуйте.
Источник
Эксплуатация » Орион 1.20, МЦС, не удалось подключиться к серверу
Установлена Орион ПРО 1.20. ЦСО запущен.
Когда первый раз заходил в Мнеджер Центрального Сервера, ошибка — не удалось подключиться к серверу.
В файле orion.ini прописал локальный сервер (127.0.0.1), порт 2001 — заработало. Всё увидело.
Спустя 2 дня снова ошибка — не удалось подключится к серверу.
Что можно сделать в данной ситуации?
3 года 7 месяцев назад
– Налетов Константин 3 года 7 месяцев назад
9 ответов
Не изменилось ничего.
Просто пишет — не удалось соединиться с сервером.
ЦСО запущен 100%. В автозагрузке висит. Запускаю МЦС при открытом ЦСО — выдаёт ошибку.
Запускалось. Чего ей щас не хватает — непонятно. Пробовал в orion.ini писать имя компа, его локальный ip-адрес. Всё равно ошибка.
3 года 7 месяцев назад
– Комаров Александр Федорович 3 года 7 месяцев назад
– Налетов Константин 3 года 7 месяцев назад
Совершенно недавно поднималась тема про антивирус KAV https://partners.bolid.ru/forum/forum_3486.html, который закрывает порты, может и у Вас такая же ситуация.
3 года 7 месяцев назад
Антивирус не установлен. Разве что встроенный windows defender. Но ведь работало.
3 года 7 месяцев назад
А как узнать, какие каталоги правильные? Всё запускается из одной директории. Версия 1.20 (выпуск 1, постройка 803).
3 года 7 месяцев назад
Если у вас каталог всего один — он с вероятностью 99% правильный, если вы руками не заменяли модули.
У каждой программы есть версия (которую в том числе можно посмотреть в свойствах файла на вкладке «подробно») и они на ЦСО и менеджере сервера должны быть 1.20 или выше.
Откройте ЦСО на вкладке «О программе». Посмотрите текущий порт. (по умолчанию 2001).
Выполните в командной строке команду
Запустите менеджер сервера. Дождитесь ошибки, что не удалось подключиться и нажмите ок.
В менеджере сервера выберите пункт «Файл\Сервер. «. В открывшемся окне укажите текущий адрес компьютера (или 127.0.0.1 для локального) и порт совпадающий с тем, который указан в ЦСО. Нажмите ок.
Если нет записи что порт LISTENING или всё равно возникает ошибка — надо проверять настройки антивирусов и фаерволов.
Если совсем ничего не получается — обращайтесь в техподдержку. С вами ещё раз проверят все настройки и если не найдут ошибок в настройках — вышлют специальные модули для диагностики проблемы.
– Комаров Александр Федорович 3 года 7 месяцев назад
Источник
forum-bolid.ru
Менеджер центрального сервера , проблемы с Параметрами БД
Здравствуйте, есть Орион Про 1.20.1 настроен, работает.
НО есть 2 проблемы.
1) При запуске утилиты, как приложено в картинке, нет параметров БД , информации по базе . НО при этом сам орион работает, монитор, сервер и все все все. А вот в Менеджере ничего сделать нельзя ибо во вкладке БД все пункты серые, не активные.
Лечится данная ерись методом перебора способа подключения базы (127.0.0.1, имя сервера при поиске из списка, ай пи адресс) Настроено по айпи адресу. Раза с 20-30 помогает, и соединение появляется и все ок. Проблема возникает через раз, а если перезагрузки компьютера небыло больше недели то 100 %.
КАК решить данную проблему?
2) Где искать или может кто поможет пошагово написав инструкцию по Резервному копированию БД при помощи Винды и планировщика задач.(у самого нихрена не получается. Болидовцы говорят что мля нажми 2 кнопки и все гуд. НО нихрена не работает, Задача не создается автоматически).
Картинку для наглядности и то что получается.(качество режет форум)
И по 2 вопросу, я написал что хотел, трудности с пониманием и знанием функционала, тогда наверное не стоит писать ненужные посты, а если хотите поговорить за жизнь то пишите в личку, пообщаемся.
Можно попробовать в реестре поискать ветку BOLID, и там в подветках ручками поправить, тоже прокатывает.
У меня как-то тоже была проблема с именем базы, ручками поправил в реестре и прокатило.
Ну это так, если другие варианты не получатся. Атак же.
Pahill , у Вас используется плата расширения на 10 com портов?
Посмотрите в программном модуле Администратор Базы Данных (АБД) настройки com портов- какой там задан тип ПИ ?
Возможно поможет тема (последнее сообщение):
Загрузка CPU сервера опроса.
У ТС проблема была в типе преобразователя интерфейсов. Разница между ними кстати описана в инструкции, но про рекомендации для С2000-Ethernet ни гу-гу.
«. Тип преобразователя интерфейсов, используемого для конвертирования RS-485 интерфейса.
Источник
forum-bolid.ru
Проблема с Windows Server 2016 и Орион Про
Здравствуйте!
На Windows 7 (EN) работает всё отлично, ставил сам.
Сейчас осуществляем переезд на другую железку с Windows Server 2016. Система англоязычная, поэтому сначала установил SQLEXPRESS2012 с активированной учеткой SA и паролем 1-6, импортировал нашу базу, установил Орион Про, изменил в реестре данные для нашей базы.
Запускаю shell, запускаю cso (OCS) и больше ничего не запустить. При запуске Server Manager — ошибка «Can’t connect to server». Адрес 127.0.0.1 и порт 2001. Пробовал локальный адрес машины указывать — бестолку.
Пробовал разные версии Ориона — 1.20/1.20.1/1.12 и русские и английские.. Ставил с нуля sqlexpress 2008/2012..
Чувство, что сервер (CSO) находится в своей песочнице и его не видят остальные компоненты программы. Прошу помочь, уже третий день сна не знаю
У вас сервер менеджер не может подключиться к ЦСО.
До SQL дело даже близко не доходит.
Открываем ЦСО на первую вкладку и смотрим внизу порт.
Идём в фаервол и убеждаемся что порт не заблокирован. Идём в антивирус и убеждаемся что порт не заблокирован. Идём в командную строку netstat /a от админа и убеждаемся что порт открыт. Если не открыт — идём в настройки совместимости и запускаем ЦСО от имени администратора. Если порт всё ещё не открыт а ЦСО «работает» — на этом моменте мы уже обращаемся в техподдержку.
Дальше идём в каталог с Орион ПРО в файл orion.ini.
В разделе SrvLog проверяем SrvAddr — адрес машины. Можно 127.0.0.1 если всё на одной машине и lopback активен (проходит пинг на 127.0.0.1). SrvPort — должен совпадать с тем, который выводит ЦСО.
После того как всё проверили — запускаем сервер менеджер. И если оно опять не коннектится — обращаемся в техподдержку.
При обращении в техподдержку быть готовы назвать: Точную версию Орион ПРО (можно посмотреть в файле version_orion.ini). Версию ОС (включая разрядность). Версию SQL.
Не доходит дело до SQL.
Давайте ещё пару моментов проверим. Посмотрите в свойствах файлов ЦСО и Сервер менеджера в дополнительных что они одного выпуска. Если случайно попались ЦСО и сервер менеджер из разных выпусков (до 1.20 и после), то они не смогут соединиться.
Дальше вы говорите что руками переносили в реестр настройки. Стоит их убрать — полностью снести ветку. Возможно происходит какая то внутренняя ошибка при чтении.
Ну и в личку номер обращения в техподдержку.
Стандартный чеклист на этом заканчивается. Дальше только логи (в идеале тимвьювер или аналоги). Но это всё только через техподдержку.
Так может потому и пишут, что сервер не запущен ))
Таааакс. Так с SQL сервером-то ЦСО связывается, а не менеджер сервера. Откуда он может знать, сервер менеджер, что SQL сервер работает (или не работает), если он не может связаться с ЦСО?
Добавлено спустя 36 секунд:
А так да, вижу, SQL сервер запущен.
Получил следующий ответ от поддержки. Увы, на пятом шаге всё та же ошибка.. Переустанавливаю систему)
Спойлер Для настройки параметров SQL сервера, после установки АРМ Орион ПРО в ручном режиме на ПК с уже установленным SQL сервером необходимо:
1.
с помощью Среда SQL Server Management Studio необходимо проверить подключение к SQL серверу, при этом необходимо выбрать авторизацию SQL ввести учетную запись «sa» и пароль «123456».
Если при этом подключение не будет выполнено, то в SQL необходимо настроить данную учетную запись.
Так же стоит обратить внимание, на то что если в меню пуск в группе SQL Сервера отсутствует Среда SQL Server Management Studio, то её необходимо поставить и проверить.
2.
Далее если вход выполняется корректно, необходимо отключится от SQL сервера или перезапустить Management Studio. Из окна авторизации необходимо скопировать имя сервера (оно потом понадобится при настройке параметров сервера).
3.
При закрытом центральном сервере Орион ПРО необходимо зайти в редактор реестра по команде regedit путь
HKEY_LOCAL_MACHINE\SOFTWARE\Bolid\ORION\CSO\ для 32х
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Bolid\ORION\CSO\ для 64х
и удалить папку DBPARAMS и если есть DBPARAMS12.
4.
Запустить центральный сервер Орион ПРО из контекстного меню «от имени администратора» (актуально для win7 и новее, что бы каждый раз не использовать данное меню можно зайти в свойства ярлыка выбрать вкладку совместимость и задать параметр «всегда выполнять от имени администратора»).
5.
Запустить «управление сервером» из меню пуск так же по правой кнопке — «от имени администратора», после запуска программы нужно ввести пароль 73173100, при этом в строке статуса должно быть указано «соединение установлено».
Если же при запуке выдается сообщение «нет соединения с сервером», то необходимо убедится, что в систем трее запущено CSO (центральный сервер), далее в меню файл — сервер — указать ip адрес текущего ПК, так же можно указать локальный адрес 127.0.0.1. После чего меню файл — переподключится и ввести пароль «73173100», результатом должно быть подключение к серверу и статус «соединение установлено».
6.
После запуска Менеджера центрального сервера, необходимо выбрать вкладку «параметры БД»
в параметрах указать
Database Access: ADO
Drivers: MSSQL
DATABASE NAME: не указываем
SERVER NAME: указывается имя сервера, скопированного из авторизации SQL Server Management Studio.
USER NAME: sa
CommandTimeout: 0
PASSWORD: 123456
7.
Далее
если была старая база SQL — указываем её имя в DATABASE NAME,
если база перенесена с другого ПК то в меню БД выбираем Восстановление (для восстановления из файла *.bak) или присоединение базы данных если скопированы файлы *.LDF и *.MDF
если не было базы, то в меню БД выбираем — «создать новую. «, далее следуя шагам мастера необходимо указать новое уникальное имя базы в поле DATABASE NAME.
Для присоедененных БД (или если база уже была на ПК) необходимо выполнить в меню БД — модернизация/слияние БД, в мастере отметить «модернизация» и следовать шагам. После кеширования в появившихся параметрах необходимо указать новое имя БД.
8.
После создания или присоединения БД, можно запустить оболочку Орион ПРО, в которой выбрать АБД, пароль либо 1, либо пароль от вашей старой БД.
9.
В АБД на первой вкладке нужно добавить ПК, указав его реальный ip в поле ip-адрес, а в поле имя указать hostname, после чего нажать сохранить.
10.
Далее необходимо отредактировать созданный ПК, в поле настройки выбрать «. » и отметить какие компоненты можно запускать на данном ПК, после чего сохранить параметры.
11.
Далее необходимо в меню сервис выбрать — обновление базы данных, при этом в оболочке параметр «анализ окружения» должен увеличится до 100%, и с некоторой задержкой запуститься Оперативная задача.
На этом настройка параметров сервера завершена.
Источник
forum-bolid.ru
Центральный сервер периодически виснет
Физический сервер — HP ProLiant DL145 Generation 2
ОС — Windows Server 2008 R2 Standart Service Pack 1 64bit
СУБД — MS SQL Server 2005 32bit
Версия программы — Центральный сервер Орион 1.11.2.46
На этой же машине подключены приборы по COM-порту. Там же работает Оболочка системы и Оперативная задача. В системе есть ещё 3 клиентские машины, каждая со своими ролями:
— Персональная карточка (стоит на раб. месте охранника у турникетов)
— Оперативная задача (раб. место начальника смены охраны)
— АБД (бюро пропусков).
Периодически (иногда несколько раз в день . ) что-то происходит с Центральным сервером (по всей видимости). Выглядит это так — на раб. местах Оперативная задача появляется сообщение о потере соединения с центральным сервером, на раб. месте персональная карточка перестают обновляться фото проходящих через турникет сотрудников.
Простым перезапуском на сервере Оболочки и Сервера БД Орион не лечится. Убийство процессов Оболочки и Центрального сервера в Диспетчере задач также не помогает. Приходится перезагружать ОС, запускать там Сервер БД Орион, Оболочку системы и Оперативную задачу (чтобы собирать данные с турникетов и приборов). Сегодня такое случалось уже 18 раз .
Ещё CoreOrion.exe не помешает. И надеюсь у вас в сообщение, а не в правилах антивируса опечатка — CSO.exe
Что выводится в лог оболочки при разрыве связи?
Локально (на ПК с ЦСО) тоже теряется связь с центральным сервером?
В доверенной зоне антивируса добавил CoreOrion.exe, исправил опечатку вместо sco.exe сделал cso.exe
Вот последние записи в файле EventLog.log
========== 21.04.2014 14:30:00 ========== omonitor.exe 1.11.2.1896()
21.04.2014 14:30:00 | Error: Соединение с сервером: Прерванный вызов функции
21.04.2014 14:30:00 | Error: Соединение с сервером: Прерванный вызов функции
21.04.2014 14:30:00 | Error: Соединение с сервером: Соединение закрыто по таймауту
21.04.2014 14:30:00 | Warning: Разрыв связи
21.04.2014 14:30:27 | Error: Соединение с сервером: Прерванный вызов функции
21.04.2014 14:30:27 | Error: Соединение с сервером: Прерванный вызов функции
21.04.2014 14:30:27 | Error: Соединение с сервером: Соединение закрыто по таймауту
21.04.2014 14:30:27 | Warning: Разрыв связи
21.04.2014 14:30:58 | Error: Соединение с сервером: Прерванный вызов функции
21.04.2014 14:30:58 | Error: Соединение с сервером: Прерванный вызов функции
21.04.2014 14:30:58 | Error: Соединение с сервером: Соединение закрыто по таймауту
21.04.2014 14:30:58 | Warning: Разрыв связи
========== 21.04.2014 14:37:53 ========== omonitor.exe 1.11.2.1896()
21.04.2014 14:37:53 | Hint: Соединение с сервером
21.04.2014 14:38:35 | Hint: TabAdd
21.04.2014 14:38:35 | Hint: Периметр 1
21.04.2014 14:38:35 | Hint: Периметр 2
21.04.2014 14:38:35 | Hint: Периметр 3
21.04.2014 14:38:35 | Hint: Периметр 4
21.04.2014 14:38:35 | Hint: Периметр 5
21.04.2014 14:38:35 | Hint: Периметр 6
21.04.2014 14:38:35 | Hint: Периметр 7
21.04.2014 14:38:35 | Hint: Периметр 8
21.04.2014 15:06:27 | Hint: TabAdd
21.04.2014 15:06:27 | Hint: Периметр 1
21.04.2014 15:06:27 | Hint: Периметр 2
21.04.2014 15:06:27 | Hint: Периметр 3
21.04.2014 15:06:27 | Hint: Периметр 4
21.04.2014 15:06:27 | Hint: Периметр 5
21.04.2014 15:06:27 | Hint: Периметр 6
21.04.2014 15:06:27 | Hint: Периметр 7
21.04.2014 15:06:27 | Hint: Периметр 8
21.04.2014 15:09:17 | Hint: TabAdd
21.04.2014 15:09:17 | Hint: Периметр 1
21.04.2014 15:09:17 | Hint: Периметр 2
21.04.2014 15:09:17 | Hint: Периметр 3
21.04.2014 15:09:17 | Hint: Периметр 4
21.04.2014 15:09:17 | Hint: Периметр 5
21.04.2014 15:09:17 | Hint: Периметр 6
21.04.2014 15:09:17 | Hint: Периметр 7
21.04.2014 15:09:17 | Hint: Периметр 8
А вот последние записи в файле logErrorFromShell.log
========== 21.04.2014 14:26:39 ========== Shell.exe 1.11.2.996()
21.04.2014 14:26:39 | Hint: Соединение с сервером
21.04.2014 14:28:39 | Error: Соединение с сервером: Прерванный вызов функции
21.04.2014 14:28:39 | Error: Соединение с сервером: Прерванный вызов функции
21.04.2014 14:28:39 | Error: Соединение с сервером: Соединение закрыто по таймауту
21.04.2014 14:28:39 | Warning: Разрыв связи
21.04.2014 14:29:20 | Error: Соединение с сервером: Прерванный вызов функции
21.04.2014 14:29:20 | Error: Соединение с сервером: Прерванный вызов функции
21.04.2014 14:29:20 | Error: Соединение с сервером: Соединение закрыто по таймауту
21.04.2014 14:29:20 | Warning: Разрыв связи
21.04.2014 14:30:01 | Error: Соединение с сервером: Прерванный вызов функции
21.04.2014 14:30:01 | Error: Соединение с сервером: Прерванный вызов функции
21.04.2014 14:30:01 | Error: Соединение с сервером: Соединение закрыто по таймауту
21.04.2014 14:30:01 | Warning: Разрыв связи
21.04.2014 14:30:41 | Error: Соединение с сервером: Прерванный вызов функции
21.04.2014 14:30:41 | Error: Соединение с сервером: Прерванный вызов функции
21.04.2014 14:30:41 | Error: Соединение с сервером: Соединение закрыто по таймауту
21.04.2014 14:30:41 | Warning: Разрыв связи
21.04.2014 14:31:22 | Error: Соединение с сервером: Прерванный вызов функции
21.04.2014 14:31:22 | Error: Соединение с сервером: Прерванный вызов функции
21.04.2014 14:31:22 | Error: Соединение с сервером: Соединение закрыто по таймауту
21.04.2014 14:31:22 | Warning: Разрыв связи
========== 21.04.2014 14:33:00 ========== Shell.exe 1.11.2.996()
21.04.2014 14:33:00 | Error: Соединение с сервером: Соединение закрыто по таймауту
21.04.2014 14:33:00 | Error: Соединение с сервером: Прерванный вызов функции
21.04.2014 14:33:00 | Error: Соединение с сервером: Прерванный вызов функции
21.04.2014 14:33:00 | Warning: Разрыв связи
========== 21.04.2014 14:37:36 ========== Shell.exe 1.11.2.996()
21.04.2014 14:37:36 | Hint: Соединение с сервером
Оба лога с компьютера-сервера, на клиентских станциях логи пока не смотрел
Источник