Не работает mysql workbench

Не работает Mysql Workbench

Доброго времени суток. Случилась следующая проблема — Mysql Workbench перестал работать. Сама программа запускается, но при попытке подключится к серверу выдаёт следующую ошибку:

При этом из консоли всё подключается и нормально работает. Google ничего внятного не выдаёт.

Система OpenSuse 13.1, Workbench 6.1 установлен из репа server:/database.

Может кто сталкивался и в курсе как исправить?

Язабан за неиспользование гугла

google://Can’t get ‘MysqlSqlFacade’ module

почитай на досуге

Ну и где там решение? Я кажется русским языком написал: «Google ничего внятного не выдаёт». Или мне надо было расписать простыню текста, что конкретно я перепробовал перед тем как задал вопрос?

Капец, как дёргают такие как ты. Если все будут отсылать в Гугл, вместо того что бы отвечать на вопросы, то откуда у Гугла будут браться ответы, что бы можно было-бы их нагуглить? Не хочешь помочь, или не можешь — пройди мимо.

мне гугл выдал кучу результатов с такой же проблемой как у тебя. И беглый просмотр сообщил, что следует собирать из исходных кодов с нужной версией gcc

там инструкция о том, как задавать вопросы. у тебя в шапке темы нет не то что информации о том, как устанавливал программу — даже простейшей информации о дистрибутиве и его версии

не хотел бы — не писал бы сюда.

не можешь нормально писать на форум — не пиши, проходи мимо. Или пиши в платную тех.поддержку. А тут тебе форум, где люди друг другу помогают бесплатно, т.е. «за просто так». Так что соизволь свое ЧСВ засунуть куда поглубже и предоставить нужную информацию.

Удачи. И да, ссылку прочитай — в будущем поможет.

Ты вообще моё первое сообщение до конца дочитал? Нормально читал или по диагонали? Вот это вот, из топка, что по твоему — «Система OpenSuse 13.1, Workbench 6.1 установлен из репа server:/database»?

Судя по твоему сообщению, это у тебя проблемы с ЧСВ. И если для тебя привычно засовывать везде куда не лень, то не думай, что и другие ведут себя так-же.

Если твоё первое сообщение можно назвать помощью, то я уж не знаю. Прям вершина информативности. И да, целых 51 ссылка от гугла, причём целых две на форум Генту, на одну и ту же ветку, а остальные, либо на какие-то левые сайты, либо вообще не по теме — это конечно куча результатов. Прям зачитаться можно.

Если ты считаешь, что самый умный, так ты так и скажи сразу об этом, люди и не будут тогда тебе перечить.

Ты бы хоть посмотрел, о какой версии Workbench’a там пишут. И какая у меня. В стандартных репах OpenSuse есть gcc 4.8, там же предлагают собирать с версией 4.4. Тем более я пробовал качать сырцы, но увы, по спискам зависимостей, не удалось найти всех пакетов. В итоге решил повременить со сборкой нужной версии gcc, поиском нужных, по зависимостям, пакетов, и спросить на форуме — а вдруг у кто-либо, кто пользуется OpenSuse 13.1 уже была такая проблема? Может местные гуру знают более простое решение, чем перелопатить пол системы из-за одной софтины. А тут, как назло, парнокопытное, живущее в лесу, мимо проходило, и не удержалось, что бы своё ЧСВ продемонстрировать.

Ты вообще моё первое сообщение до конца дочитал?

странно, вроде прочитал, но не заметил.
похоже, гребаный интернет с навязчивой привычкой «чтения по диагонали» до ручки скоро меня доведет

Попробуй собери из исходных кодов, предварительно обновив gcc до последней версии.

Блин, ты судя по всему и последнее сообщение не до конца дочитал.

Так и писал бы в ОП-посте, что ты уже читал/предпринимал, чтобы решить проблему. Ну не паяльником же из тебя выпытывать, мм?

К сожалению, знаю, что большие сообщения в топике очень мало кто дочитывает до конца. А что бы описать всё что я уже пробовал пришлось бы настрочить страницу текста. Тут вон, не у всех пять строк получается прочитать

Гм, ну «краткое содержание предыдущих серий» всё же стоит приводить. Простыни от тебя никто не просил, интересны были вехи на твоём пути поиска решения проблемы.

Для пополнения добавлю, что только что (2014.09.11 18:00 UTC) пересобрал Workbench из исходников, что лежали в репе server:/database, с помощью gcc 4.8.1. Результат — те же грабли. Сейчас буду качать исходники с сайта и пробовать собирать из них.

Источник

Устраняем типичные ошибки в MySQL

MySQL — система управления базами данных (СУБД) с открытым исходным кодом от компании Oracle. Она была разработана и оптимизирована специально для работы веб-приложений. MySQL является неотъемлемой частью таких веб-сервисов, как Facebook, Twitter, Wikipedia, YouTube и многих других.

Эта статья расскажет, как определять, с чем связаны частые ошибки на сервере MySQL, и устранять их.

Не удаётся подключиться к локальному серверу

Одной из распространённых ошибок подключения клиента к серверу является «ERROR 2002 (HY000): Can’t connect to local MySQL server through socket ‘/var/run/mysqld/mysqld.sock’ (2)».

Читайте также:  Как настроить звук микрофона андроид

Эта ошибка означает, что на хосте не запущен сервер MySQL ( mysqld ) или вы указали неправильное имя файла сокета Unix или порт TCP/IP при попытке подключения.

Убедитесь, что сервер работает. Проверьте процесс с именем mysqld на хосте сервера, используя команды ps или grep, как показано ниже.

Если эти команды не показывают выходных данных, то сервер БД не работает. Поэтому клиент не может подключиться к нему. Чтобы запустить сервер, выполните команду systemctl.

Чтобы проверить состояние службы MySQL, используйте следующую команду:

Если в результате выполнения команды произошла ошибка службы MySQL, вы можете попробовать перезапустить службу и ещё раз проверить её состояние.

Если сервер работает (как показано) и вы по-прежнему видите эту ошибку, вам следует проверить, не заблокирован ли порт TCP/IP брандмауэром или любой другой службой блокировки портов.

Tproger , Удалённо , От 80 000 до 180 000 ₽

Для поиска порта, который прослушивается сервером, используйте команду netstat .

Не удаётся подключиться к серверу MySQL

Ещё одна похожая и часто встречающаяся ошибка подключения — «(2003) Can’t connect to MySQL server on ‘server’ (10061)». Это означает, что в сетевом соединении было отказано.

Следует проверить, работает ли в системе сервер MySQL (смотрите выше) и на тот ли порт вы подключаетесь (как найти порт, можно посмотреть выше).

Похожие частые ошибки, с которыми вы можете столкнуться при попытке подключиться к серверу MySQL:

Ошибки запрета доступа в MySQL

В MySQL учётная запись (УЗ) определяется именем пользователя и клиентским хостом, с которого пользователь может подключиться. УЗ может также иметь данные для аутентификации (например, пароль).

Причин для запрета доступа может быть много. Одна из них связана с учётными записями MySQL, которые сервер разрешает использовать клиентским программам при подключении. Это означает, что имя пользователя, указанное в соединении, может не иметь прав доступа к базе данных.

В MySQL есть возможность создавать учётные записи, позволяющие пользователям клиентских программ подключаться к серверу и получать доступ к данным. Поэтому при ошибке доступа проверьте разрешение УЗ на подключение к серверу через клиентскую программу.

Увидеть разрешённые привилегии учётной записи можно, выполнив в консоли команду SHOW GRANTS
Входим в консоль (пример для Unix, для Windows консоль можно найти в стартовом меню):

В консоли вводим команду:

Дать привилегии конкретному пользователю в БД по IP-адресу можно, используя следующие команды:

Ошибки запрещённого доступа могут также возникнуть из-за проблем с подключением к MySQL (см. выше).

Потеря соединения с сервером MySQL

С этой ошибкой можно столкнуться по одной из следующих причин:

  • плохое сетевое соединение;
  • истекло время ожидания соединения;
  • размер BLOB больше, чем max_allowed_packet .

В первом случае убедитесь, что у вас стабильное сетевое подключение (особенно, если подключаетесь удалённо).

Если проблема с тайм-аутом соединения (особенно при первоначальном соединении MySQL с сервером), увеличьте значение параметра connect_timeout .

В случае с размером BLOB нужно установить более высокое значение для max_allowed_packet в файле конфигурации /etc/my.cnf в разделах [mysqld] или [client] как показано ниже.

Если файл конфигурации недоступен, это значение можно установить с помощью следующей команды.

Слишком много подключений

Эта ошибка означает, что все доступные соединения используются клиентскими программами. Количество соединений (по умолчанию 151) контролируется системной переменной max_connections . Устранить проблему можно, увеличив значение переменной в файле конфигурации /etc/my.cnf .

Недостаточно памяти

Если такая ошибка возникла, это может означать, что в MySQL недостаточно памяти для хранения всего результата запроса.

Сначала нужно убедиться, что запрос правильный. Если это так, то нужно выполнить одно из следующих действий:

  • если клиент MySQL используется напрямую, запустите его с ключом —quick switch , чтобы отключить кешированные результаты;
  • если вы используете драйвер MyODBC, пользовательский интерфейс (UI) имеет расширенную вкладку с опциями. Отметьте галочкой «Do not cache result» (не кешировать результат).

Также может помочь MySQL Tuner. Это полезный скрипт, который подключается к работающему серверу MySQL и даёт рекомендации по настройке для более высокой производительности.

MySQL продолжает «падать»

Если такая проблема возникает, необходимо выяснить, заключается она в сервере или в клиенте. Обратите внимание, что многие сбои сервера вызваны повреждёнными файлами данных или индексными файлами.

Вы можете проверить состояние сервера, чтобы определить, как долго он работал.

Чтобы узнать время безотказной работы сервера, запустите команду mysqladmin .

Кроме того, можно остановить сервер, сделать отладку MySQL и снова запустить службу. Для отображения статистики процессов MySQL во время выполнения других процессов откройте окно командной строки и введите следующее:

Заключение

Самое важное при диагностике — понять, что именно вызвало ошибку. Следующие шаги помогут вам в этом:

  • Первый и самый важный шаг — просмотреть журналы MySQL, которые хранятся в каталоге /var/log/mysql/ . Вы можете использовать утилиты командной строки вроде tail для чтения файлов журнала.
  • Если служба MySQL не запускается, проверьте её состояние с помощью systemctl . Или используйте команду journalctl (с флагом -xe ) в systemd.
  • Вы также можете проверить файл системного журнала (например, /var/log/messages ) на предмет обнаружения ошибок.
  • Попробуйте использовать такие инструменты, как Mytop, glances, top, ps или htop, чтобы проверить, какая программа использует весь ресурс процессора или блокирует машину. Они также помогут определить нехватку памяти, дискового пространства, файловых дескрипторов или какого-либо другого важного ресурса.
  • Если проблема в каком-либо процессе, можно попытаться его принудительно остановить, а затем запустить (при необходимости).
  • Если вы уверены, что проблемы именно на стороне сервера, можете выполнить команды: mysqladmin -u root ping или mysqladmin -u root processlist , чтобы получить от него ответ.
  • Если при подключении проблема не связана с сервером, проверьте, нормально ли работает клиент. Попробуйте получить какие-либо его выходные данные для устранения неполадок.

Хинт для программистов: если зарегистрируетесь на соревнования Huawei Cup, то бесплатно получите доступ к онлайн-школе для участников. Можно прокачаться по разным навыкам и выиграть призы в самом соревновании.

Перейти к регистрации

Источник

Читайте также:  Капает кран фильтра аквафор как починить

SQL WorckBench зависает и не подключается к базе даных

Суть проблемы: я уже 3 раз переустанавливаю по всем возможным руководствам базу даных MySQL и у меня тупо все зависает на моменте когда необходимо подключится к базе даных. Просто у меня пишет что мы подключаемся долго ждет и нечего не происходит. Если нажмем отмена то высвитит ошибку подключения, очень срочно нужна помощь. Зарание спасибо.

1 ответ 1

Вопрос решился сам по себе, возможно у кого-то будет таже ошибка как и у меня, поэтому отвечу сам что-бы помочь кому-то, просто вместо того что-бы заходить на созданый по умолчанию конект, нажмите тот серый плюсик и создайте свой, там просто вверху напишите имя введите пароль который вы в момент инсталяции для пользователя root поставили и просто зайдите уже через новый и все отлично работает ).

Всё ещё ищете ответ? Посмотрите другие вопросы с метками mysql или задайте свой вопрос.

Похожие

Подписаться на ленту

Для подписки на ленту скопируйте и вставьте эту ссылку в вашу программу для чтения RSS.

дизайн сайта / логотип © 2021 Stack Exchange Inc; материалы пользователей предоставляются на условиях лицензии cc by-sa. rev 2021.10.18.40487

Нажимая «Принять все файлы cookie» вы соглашаетесь, что Stack Exchange может хранить файлы cookie на вашем устройстве и раскрывать информацию в соответствии с нашей Политикой в отношении файлов cookie.

Источник

Не удается подключиться к серверу базы данных (mysql workbench)

Не могли бы вы помочь мне решить эту проблему?

Когда я пытаюсь щелкнуть «базу данных запросов» в меню базы данных в Workbench Mysql. это дает мне ошибку:

ОТВЕТЫ

Ответ 1

Вероятно, проблема связана с тем, что аутентификация сокета включена для пользователя root по умолчанию, когда пароль не задан, во время обновления до ubuntu 16.04.

Решение состоит в том, чтобы вернуться к аутентификации собственного пароля. Вы можете сделать это, войдя в MySQL, используя проверку сокетов, выполнив:

После входа в систему:

который вернется к исходной (старой по умолчанию) аутентификации пароля.

Теперь используйте пароль в качестве пароля, когда это требуется MySQL.

Ответ 2

Попробуйте открыть services.msc из окна поиска в меню «Пуск» и попробуйте вручную запустить службу MySQL.

Ответ 3

Похоже, есть много причин этой ошибки.

Моя причина/решение

В моем случае причина была в том, что мой сервер был настроен на прием соединений только от localhost. Я исправил это, выполнив следующую статью: Как включить удаленный доступ к серверу баз данных MySQL?. В моем файле my.cnf не было строки skip-networking , поэтому я просто изменил строку

Это позволяет устанавливать соединения с любого IP, а не только с 127.0.0.1.

Затем я создал пользователя MySql, который мог подключиться с моего клиентского компьютера, выполнив следующие команды терминала:

где 1.2.3.4 — это IP-адрес клиента, с которого вы пытаетесь подключиться. Если у вас действительно есть проблемы, вы можете использовать ‘%’ вместо ‘1.2.3.4’ , чтобы позволить пользователю подключаться с любого IP.

Другие причины

Ответ 4

Вы пытались определить, является ли это проблемой с Workbench или общей проблемой соединения? Попробуйте следующее:

  • Откройте терминал
  • Тип mysql -u root -p -h 127.0.0.1 -P 3306
  • Если вы можете подключиться успешно, вы увидите приглашение mysql после ввода пароля (введите quit и Enter there to exit).

Сообщите, как это сработало.

Ответ 5

У меня была похожая проблема в Mac OS, и я смог ее исправить следующим образом:

Из терминала запустите:

Затем меня попросили ввести пароль. Я просто нажал Enter, так как пароль не был установлен.

Я получил сообщение следующим образом:

Добро пожаловать на монитор MySQL. Команды заканчиваются на; или \g. Ваш идентификатор соединения MySQL — 181. Версия сервера: 8.0.11 Homebrew.

Если вам удалось войти в mysql>, выполните следующую команду:

Вы должны получить сообщение, подобное этому:

Запрос в порядке, затронуто 0 строк (0,19 с)

Теперь ваш пароль — » пароль «, а имя пользователя — » root «.

Ответ 6

Мне пришлось запустить Workbench в качестве администратора. По-видимому, у него не было необходимых разрешений для подключения к процессу сервера базы данных localhost.

Щелкните правой кнопкой мыши ярлык Workbench и выберите Run as Administrator . В окне свойств ярлыка вы можете нажать «Дополнительно» и поставить галочку рядом с надписью «Запуск от имени администратора», чтобы всегда запускать Workbench с правами администратора.

Ответ 7

Я некоторое время боролся с этой проблемой и делал несколько переустановок MySQL, прежде чем обнаруживать это.

Я знаю, что сервер MySQL работал нормально, потому что я мог получить доступ ко всей моей БД с помощью командной строки.

Надеюсь, это сработает для вас.

В MySQL Workbench (5.2.47 CE)

нажмите Экземпляры сервера Mange (нижний правый угол)

нажмите Соединение

в поле Соединение выберите:

Локальный экземпляр ($ ServerName) — [email protected]: 3306 ‘

нажмите Изменить выбранные.

под Параметры, Имя хоста измените localhost или 127.0.0.1 на имя NetBIOS

нажмите Проверить соединение

Если это сработает для вас, отлично. Если имя хоста не изменилось, то оно было.

Ответ 8

Ошибка возникает из-за того, что сервер mysql не запускается на вашем компьютере. Вы должны запустить его вручную. Выполните следующие действия:

Загрузите и установите сервер Wamp в соответствии со своей битовой версией (32 бит или 64 бит) на вашем компьютере (http://wampserver-64bit.en.softonic.com/). позволяет загружать сервер Wamp на 64-разрядный.

Как только вы его установили, вы можете дважды щелкнуть и запустить его.. (вы можете увидеть значок в правой руке панели задач. Возможно, он скрыт. Вы можете щелкнуть стрелку, которая показывает вам скрыть запуск приложений). Нажмите на значок и перейдите в Mysql

Читайте также:  Как настроить время гранд чероки

Затем перейдите в Сервис, и там вы можете найти Начать/возобновлять службы.

И теперь это делается. Откройте рабочий стол mysql и увидите. Он будет работать.

Ответ 9

Запустите команду ALTER USER. Обязательно смените пароль на надежный пароль по вашему выбору.

sudo mysql # Войдите в MySQL

Запустите приведенную ниже команду

Теперь вы можете получить к нему доступ, используя новый пароль.

Ответ 10

Чтобы быть в курсе последних версий и более поздних посетителей:

В настоящее время я работаю над win7 64bit с различными инструментами, включая python 2.7.4, как необходимое условие для google android.

Когда я обновил с WB 6.0.8-win32 до верхних версий, чтобы иметь 64-битную производительность, у меня были некоторые проблемы, например, на 6.3.5-winx64. У меня была ошибка в представлении деталей таблиц (неупорядоченное представление), что привело к понижению до 6.2.5-winx64.

В качестве пользователя GUI легкие функции пересылки вперед/назад и относительные элементы сервера db работали хорошо, но когда мы пытаемся Database>Connect to Database , у нас будет Not connected и будет ошибка python, если мы попытаемся выполнить запрос, однако DB серверная служба абсолютно запущена и работает хорошо, и эта проблема не с сервера, а с рабочего места. Чтобы решить эту проблему, мы должны использовать Query>Reconnect to Server , чтобы явно выбрать соединение с БД, а затем почти все выглядит хорошо (это может быть связано с моими множественными соединениями db, и я не смог найти какое-то решение для определения подключения по умолчанию в рабочем столе).

В качестве примечания: потому что я использую последнюю версию Xampp (даже в зависимостях от linux:)), в последнее время Xampp использует mariadb 10 вместо mysql 5.x приводит к тому, что версия файла mysql равна 10, может вызвать некоторые проблемы, такие как переадресация разработка процедур, которые могут быть решены с помощью mysql_upgrade.exe , но при попытке проверить соединение db wb сообщит о неправильной версии, однако это не критично и работает хорошо.

Заключение: Таким образом, иногда проблемы с подключением db в workbench могут быть связаны с самим собой, а не с сервером (если у вас нет других проблем с подключением к db).

Ответ 11

Причина была в том, что я пытался использовать новейший MySQL Workbench 8.x для подключения к MySQL Server 5.1 (оба работают на Windows Server 2012).

Когда я удалил MySQL Workbench 8.x и установил MySQL Workbench 6.3.10, он успешно подключился к базе данных localhost

Ответ 12

Я тоже долгое время боролся с этой проблемой.

Я также набрал (очевидно) некоторый хороший SO Q/A.

Похоже, что сообщение, упомянутое в вопросе «user948950», может исходить из широкого круга причин: слишком большой файл журнала, неправильные значения файла mysql.ini, пробелы в пути к файлу, проблема безопасности /acl, старые записи в реестр и т.д.

Итак, после попытки за 3 часа исправить это. Я отказался и решил сделать старую старую переустановку.

Гэри Уильямс писал (а): Привет, ребята,

У меня была точно такая же проблема, и вот как я ее работаю для меня, начиная с нерабочей установки.

Остановите службу Windows для любой существующей установки mysql.

Как и при большинстве удалений, старые файлы остаются позади. Если ваш каталог это C:\mysql\etc, то удалите файлы innob и т.д., но оставьте сами каталоги, а также любые существующие базы данных в «данных». Если ваш каталог — C:\Program Files\etc, удалите все mysql каталоги.

Теперь стоит запустить regedit, чтобы удалить старые записи реестра, а также удалить. Если нет, удалите их.

Хорошо использовать новый .msi-установщик (только для основных файлов), однако.

Не используйте свой путь установки по умолчанию! Некоторые гении устанавливают путь с пробелами в нем! Выберите пользовательскую установку и выберите разумный путь, т.е. C:\mysql (примечание от Adrien: C:\mysqldata для. данных)

Не следует изменять параметры безопасности. Снимите флажок в соответствующем поле, и установка завершится без установки root пароль.

Думаю, я все вспомнил.

Я столкнулся с проблемами, когда просто копировал/вставлял базы данных, которые у меня были в предыдущем каталоге данных, в новый. Поэтому работа, которую я нашел, заключалась в том, чтобы экспортировать каждую базу данных (я знаю. много веселья), а затем повторно импортировать их по одному.

FYI: я использовал следующую команду для импорта C:/ /My SQL Server x.x/bin/mysql -u root -p \ .sql» , например C:/mysql/MySQL Server 5.6/bin/mysql -u root -p mySupaCoolDb

Ответ 13

Я был в подобных ситуациях до и в прошлый раз, когда обнаружил, что это проблема с выпуском Windows (не уверен). На этот раз я открыл Workbench MySQL и не нашел подключения к моей локальной базе данных. Я не вижу свои таблицы, но вчера я мог подключиться к базе данных.

Я обнаружил, что моя причина в том, что после того, как мой компьютер снова сработает и снова проснется, служба mysql не работает. Мое решение: перезапустите службу с именем «mysql» и перезапустите верстак. Перезапуск службы занимает некоторое время, но он работает.

Ответ 14

Моя проблема заключалась в том, что сервер MySQL фактически не был установлен. Я запустил MySQL Installer, но он не установил сервер MySQL.

Я перезапущу установщика, нажмите «Добавить», а затем добавил сервер MySQL в список. Теперь он отлично работает.

Ответ 15

В моем случае я только что установил MySQL Workbench, но после удаления MySQL Workbench и установки установщика MySQL он одинаков как для 32-разрядных, так и для 64-разрядных, после чего он работает как чудо. Надеюсь, это может быть полезно.

Источник

Оцените статью