Не работает настройка базы

forum-bolid.ru

Менеджер центрального сервера , проблемы с Параметрами БД

Здравствуйте, есть Орион Про 1.20.1 настроен, работает.
НО есть 2 проблемы.
1) При запуске утилиты, как приложено в картинке, нет параметров БД , информации по базе . НО при этом сам орион работает, монитор, сервер и все все все. А вот в Менеджере ничего сделать нельзя ибо во вкладке БД все пункты серые, не активные.
Лечится данная ерись методом перебора способа подключения базы (127.0.0.1, имя сервера при поиске из списка, ай пи адресс) Настроено по айпи адресу. Раза с 20-30 помогает, и соединение появляется и все ок. Проблема возникает через раз, а если перезагрузки компьютера небыло больше недели то 100 %.
КАК решить данную проблему?
2) Где искать или может кто поможет пошагово написав инструкцию по Резервному копированию БД при помощи Винды и планировщика задач.(у самого нихрена не получается. Болидовцы говорят что мля нажми 2 кнопки и все гуд. НО нихрена не работает, Задача не создается автоматически).

Картинку для наглядности и то что получается.(качество режет форум)
И по 2 вопросу, я написал что хотел, трудности с пониманием и знанием функционала, тогда наверное не стоит писать ненужные посты, а если хотите поговорить за жизнь то пишите в личку, пообщаемся.

Можно попробовать в реестре поискать ветку BOLID, и там в подветках ручками поправить, тоже прокатывает.
У меня как-то тоже была проблема с именем базы, ручками поправил в реестре и прокатило.

Ну это так, если другие варианты не получатся. Атак же.

Pahill , у Вас используется плата расширения на 10 com портов?

Посмотрите в программном модуле Администратор Базы Данных (АБД) настройки com портов- какой там задан тип ПИ ?

Возможно поможет тема (последнее сообщение):
Загрузка CPU сервера опроса.

У ТС проблема была в типе преобразователя интерфейсов. Разница между ними кстати описана в инструкции, но про рекомендации для С2000-Ethernet ни гу-гу.

«. Тип преобразователя интерфейсов, используемого для конвертирования RS-485 интерфейса.

Источник

Ошибки и решение проблем с Базой Данных

На что влияет ошибка Базы Данных и почему появляется?

В базе данных TRASSIR хранит события и связанную с ними информацию. События — это всё что происходит в TRASSIR помимо записи видео. Вход пользователя на сервер, появление движения на канале, распознание номера AutoTrassir, чек или инцидент POS, распознание лица — это события. Примеры информации, связанной с событиями — внутренний список номеров AutoTrassir или база лиц.

Читайте также:  Настроить phpmyadmin для ubuntu

При ошибке базы данных TRASSIR не может записать новые события и узнать что-нибудь про старые. Вы не сможете посмотреть инциденты за прошлый день в экспертном режиме POS или проверить, какие номера машин въехали на территорию на прошлой неделе. Хотя новые события могут появляться в интерфейсе TRASSIR, они не попадут в базу данных и будут утеряны.

База данных запускается и работает отдельной службой независимо от работы TRASSIR. В Настройки сервера → База Данных на регистраторе вводятся настройки подключения TRASSIR к базе данных. Поэтому есть три основных причины возникновения ошибки базы данных:

    • Неверные настройки подключения.
    • Не работает служба базы данных.
    • База данных сломана.

В качестве базы данных TRASSIR использует СУБД PostgeSQL.

Особенности Базы Данных на разных платформах

TRASSIR OS

По умолчанию база данных хранится на одном из жёстких дисков с архивом. После установки диска TRASSIR OS самостоятельно создаст базу данных, настроит и запустит службу PostgreSQL.
Ошибка базы данных на регистраторе «из коробки» до установки жёстких дисков — это нормально. Установите жёсткий диск и она пропадёт.


Пароль вводить не требуется.

Windows

PostgreSQL устанавливается пользователем самостоятельно: автоматически во время установки ПО TRASSIR или отдельной установкой. Во втором случае может потребоваться дополнительная настройка — настройка ОС, настройка запуска PostgreSQL или создание отдельной базы данных для использования в TRASSIR. Рекомендуется использовать установщики, скачанные из подраздела «Вспомогательные утилиты» на странице с последними версиями ПО нашего сайта.

Как правило, база данных находится на той же машине, что и сервер TRASSIR
Чтобы проверить, запущена ли у вас служба PostgreSQL:

  • Нажмите WIN+S, в появившемся окне введите «Службы» и нажмите Enter.
  • В списке служб убедитесь, что служба PostgreSQL существует и выполняется.

    Чтобы запустить остановленную службу, нажмите на неё правой кнопкой и выберите Запустить
    Если служба не запускается автоматически, то откройте её двойным щелчком и выберите Автоматический тип запуска.

Известные ошибки и пути их решения

fe_sendauth: no password supplied

PgConnection disconnected

Причина: Неверно указан Адрес или Порт.


Пароль вводить не требуется.

Иероглифы-postgres или другие понятные буквы-Иероглифы


Пароль вводить не требуется.

Не удалось подключиться к серверу. В соединении отказано. Он действительно работает по адресу.


Пароль вводить не требуется.

relation . already exists

Причина: После обновления, замены лицензии или при некоторых сбоях TRASSIR не с первого раза внёс данные в базу.

  • Нужно проверить, носит ли ошибка только информационный характер. TRASSIR мог успешно внести данные со второго раза и сейчас работает нормально. Переподключитесь к базе данных, чтобы обновить информацию об ошибках:
    1. Запомните или запишите текущий Порт.
    2. Смените Порт на любой другой. Например, с 5432 на 5433.
    3. Подождите 10 секунд, пока ошибка не сменится на ошибку о подключении.
    4. Смените Порт обратно на изначальный.
    5. Подождите 10 секунд, пока ошибка не сменится на статус «Соединение установлено».
  • Если вместо статуса «Соединение установлено» снова появляется ошибка «relation . already exists», нужно создать новую базу данных.
Читайте также:  Как настроить firewall centos

Unknown error

Failed to start connection, unable to obtain connection socket

cannot drop table pos_events/pos_incidents.

Причина: Сломана база данных

  • Если вы готовы предоставить удалённый доступ к регистратору, техническая поддержка может попробовать починить текущую базу данных. Данные из повреждённых частей базы не удастся сохранить. Например, при ошибке на скриншоте события POS будут удалены, но события о распознанных лицах могут остаться.
  • В остальных случаях требуется создать новую базу данных

Случайно поменяли настройки подключения к базе данных, как можно вернуть обратно?

  • Если регистратор на TRASSIR OS хранит базу данных на архивных дисках — настройте подключение к базе данных по умолчанию


Пароль вводить не требуется.

В остальных случаях можно восстановить настройки из ранее созданного бэкапа

Так как настройки восстанавливаются все без исключения, вы можете потерять, например, подключения к камерам, созданные после бэкапа. Поэтому перед восстановлением бэкапа рекомендуется вручную сохранить текущие настройки: в Настройки сервера нажмите Сохранить бэкап конфигурации → В файл.

Из файла: В Настройки сервера нажмите Восстановить бэкап конфигурации → Из файла.

Из облака: Если сервер был добавлен в облако, то бэкап его настроек может автоматически сохраняться в облаке. Для восстановления из облачного бэкапа в Настройки сервера нажмите кнопку Восстановить бэкап конфигурации → Облако и выберите наиболее подходящий вам по дате бэкап.

Если был утерян пароль для базы данных, работающей на Windows, можно временно настроить вход без пароля.
С помощью инструкции из нашего руководства найдите файл настройки pg_hba.conf и сделайте его резервную копию. В файле замените md5 на trust. Сохраните файл, найдите службу PostgreSQL в списке служб, нажмите на неё правой кнопкой и выберите Перезапустить. После перезапуска к базе данных можно будет подключиться без пароля. Этот способ рекомендуется только для сохранения данных из базы с последующей переустановкой PostgreSQL.

При повреждении файла pg_hba.conf служба PostgreSQL не запустится. Если после редактирования файла у вас не запускается служба — восстановите файл из резервной копии и попробуйте ещё раз.

Пересоздание базы данных

В некоторых случаях возможно сохранить данные из повреждённой базы и загрузить их в новую базу.

TRASSIR OS: Воспользуйтесь скриптами из статьи Backup PSSQL.

Читайте также:  Как настроить металлоискатель минелаб эксплорер

Большинство способов необратимо удаляет текущую базу данных вместе со всеми записанными в ней событиями.

TRASSIR OS

Если регистратор хранит базу данных на архивных дисках, нужно только удалить старую базу данных. TRASSIR самостоятельно создаст новую базу данных. Для удаления воспользуйтесь одним из способов:

Используйте скрипт удаления базы данных на диске регистратора Remove BD on Trassir OS

Удалите базу данных вручную

  1. На регистраторе откройте Настройки сервера → База Данных.
  2. Смените Порт с 5432 на 5431.
  3. На регистраторе перейдите в Настройки сервера → Архив.
  4. Уберите галочку Включить с диска, название которого начинается со звёздочки. Звёздочка означает, что диск используется для хранения базы данных.
  5. На регистраторе перейдите в Настройки сервера → Скриншоты.

  6. В выпадающем списке в верхней части экрана выберите имя вашего диска.
  7. Выберите папку TrassirDB, нажмите на неё правой кнопкой мыши и выберите Удалить.

Убедитесь, что вы выбрали нужную папку и только её. В соседних папках находится архив.

Если в регистратор установлены два и более дисков — можно создать новую базу данных на другом диске:

Сломанная база данных не пропадёт с предыдущего диска. Если в будущем ПО TRASSIR начнёт использовать этот диск для хранения базы данных, ошибка снова появится.

Если служба PostgreSQL работает, известны логин и пароль для подключения и проблема только в самой базе данных, то достаточно создать другую базу данных в уже работающей службе и настроить работу TRASSIR с новой базой данных.

  1. Запустите программу pgAdmin. Найдите её в Главном меню Windows или нажмите Win+S, введите «PgAdmin» и нажмите Enter.
  2. Дважды щелкните в списке серверов по серверу на (localhost:5432)
  3. В появившемся окне введите пароль пользователя postgres. Это автоматически созданный пользователь базы данных с максимальными правами.
  4. Нажмите правой кнопкой на пункт меню «Базы данных» и выберите Новая база данных.
  5. В появившемся окне введите только Имя новой базы данных и нажмите ОК. Никакие другие настройки вводить не надо.
  6. На сервере TRASSIR зайдите в Настройки сервера → База Данных и введите новое Имя базы даннных.
  • Переустановка службы PostgreSQL:
    1. Удалите текущую установку стандартными средствами Windows. Например, нажмите Win+S, начните вводить «Программ» и выберите в результатах поиска «Программы и компоненты» или «Установка и удаление программ». В открывшемся окне выберите в списке программ PostgreSQL и нажмите кнопку Удалить.
    2. Удалите оставшиеся файлы PostgreSQL с дисков. По умолчанию нужно удалить папки «C:\Program Files\PostgreSQL» и «C:\Program Files (x86)\PostgreSQL» со всем содержимым.
    3. Скачайте установщик PostgreSQL из подраздела «Вспомогательные утилиты» на странице с последними версиями ПО нашего сайта.
    4. Установите PostgreSQL по инструкции из нашего руководства пользователя. По необходимости проведите настройку ОС Windows.
    5. Создайте новую базу данных и настройте TRASSIR для работы с новой базой.
  • Источник

    Оцените статью