Не работает owa exchange 2007

OWA или ECP перестают работать после установки обновления безопасности

Симптомы

После установки обновления безопасности на сервере, который работает Microsoft Exchange Server, либо Outlook в Интернете (OWA) или Exchange Панели управления (ECP), либо оба приложения перестанут работать на сервере.

OWA отображает следующее сообщение об ошибке:

Что-то пошло не так Ваш запрос не удалось завершить. КОД состояния HTTP: 500

ECP отображает следующее сообщение об ошибке:

Ошибка сервера в приложении «/ecp». Не удалось загрузить файл или сборку «Microsoft. Exchange. Common, Version=15.0.0.0 . Culture=neutral, PublicKeyToken=31bf3856ad364e54′ или одна из зависимостей. Не удается найти указанный файл.

Причина

Эти ошибки возникают, если обновление безопасности было установлено вручную на сервере с включенной поддержкой управления учетной записью пользователей, но без использования повышенных разрешений.

Решение

Используйте повышенные разрешения, чтобы переустановить обновление безопасности на сервере.

  1. Нажмите кнопку Пуск, затем введите cmd.
  2. Щелкните в результатах поиска Командную строку правой кнопкой мыши и выберите Запуск от имени администратора.
  3. Если открывается окно Контроль учетных записей, выберите вариант открытия окна командной строки с повышенными привилегиями и нажмите кнопку Продолжить.
    Если окно контроля учетных записей (UAC) не появляется, перейдите к следующему шагу.
  4. Введите полный путь к файлу .msp для этого обновления безопасности, а затем нажмите клавишу Ввод.
  5. После установки обновления перезапустите сервер.

Проверьте, можно ли теперь получить доступ к OWA и ECP на сервере без получения сообщения об ошибке.

Если сообщение об ошибке ECP продолжает отображаться, сделайте следующее:

Запустите IIS Manager на сервере.

Перейдите Exchange веб-сайт > ECP Virtual directory.

Выберите параметры > приложения BinsearchFolder.

Проверьте пути к указанным Exchange каталогам. Вы можете увидеть пути каталога, похожие на следующие:

%ExchangeInstallDir%bin;
%ExchangeInstallDir%bin\CmdletExtensionAgents;
%ExchangeInstallDir%ClientAccess\Owa\bin

Замените пути следующими путями:

C:\Program Files\Microsoft\Exchange Server\V15\bin;
C:\Program Files\Microsoft\Exchange Server\V15\bin\CmdletExtensionAgents;
C:\Program Files\Microsoft\Exchange Server\V15\ClientAccess\Owa\bin

Примечание Пути должны указать, где Exchange Server установлен. В следующих примерах предполагается, что программа установлена на диске C и что версия Microsoft Exchange Server 2013. Если он установлен на другом диске на сервере или используется другая версия, например Microsoft Exchange Server 2010 г., используйте подходящие для установки сведения о пути и версии.

Перейдите к папке, которая включает Exchange Server скрипты. По умолчанию скрипты находятся в следующем пути для Exchange Server 2013 г.:

Примечание В Exchange Server 2010 г. скрипты будут в V14 папке.

Запустите Exchange в качестве администратора и запустите следующие скрипты: .\UpdateCas.ps1 и .\UpdateConfigFiles.ps1 .

Выход Exchange командной оболочки и откройте окно Командная подсказка в качестве администратора.

Перезапустите сервер и убедитесь, что сообщение об ошибке больше не будет получаться при доступе к ECP.

Источник

Не работает owa exchange 2007

Профиль | Отправить PM | Цитировать

Изображения

owa.JPG
(79.3 Kb, 21 просмотров)
» width=»100%» style=»BORDER-RIGHT: #719bd9 1px solid; BORDER-LEFT: #719bd9 1px solid; BORDER-BOTTOM: #719bd9 1px solid» cellpadding=»6″ cellspacing=»0″ border=»0″>

Сообщения: 26
Благодарности: 0

Вложения

owa.txt
(76.9 Kb, 21 просмотров)
какого типа нужно для него создать ящик? »

——-
MVP: Exchange Server 2009 — 2018
Microsoft Regional Director 2015 — 2017

» width=»100%» style=»BORDER-RIGHT: #719bd9 1px solid; BORDER-LEFT: #719bd9 1px solid; BORDER-BOTTOM: #719bd9 1px solid» cellpadding=»6″ cellspacing=»0″ border=»0″>

Сообщения: 26
Благодарности: 0

вот когда создаю пользователя почты допусти 1@dom.xx, там есть поле внешняя почта там указываю адрес тоттже 1@dom.xx когда начинаю отправлять почту этому пользователю то потом от сервака приходит письмо что он неможет отправить писмо данному пользователю, хотя зам этот юзер может отправлять пиьма но не получать, как то странно? »

——-
MVP: Exchange Server 2009 — 2018
Microsoft Regional Director 2015 — 2017

» width=»100%» style=»BORDER-RIGHT: #719bd9 1px solid; BORDER-LEFT: #719bd9 1px solid; BORDER-BOTTOM: #719bd9 1px solid» cellpadding=»6″ cellspacing=»0″ border=»0″>

Сообщения: 2125
Благодарности: 499

——-
MVP: Exchange Server 2009 — 2018
Microsoft Regional Director 2015 — 2017

Источник

Устранение неполадок набора данных о работоспособности OWA

Применяется к: Exchange Server 2013 г.

Набор Outlook Web App (OWA) отслеживает общее состояние Outlook Web App службы.

Если вы получаете оповещение о том, что Outlook Web App является нездоровым, это указывает на проблему, которая может помешать пользователям получить доступ к своим почтовым ящикам с помощью Outlook Web App.

Объяснение

Служба Outlook Web App отслеживается с помощью следующих зондов и мониторов.

Outlook Web App

Распространенные проблемы

Этот зонд может не работать по нескольким причинам. Ниже приведено несколько распространенных причин.

Пул Outlook Web App приложений, который находится на отслеживаемом сервере клиентского доступа (CAS), не отвечает, а пул приложений, который находится на сервере почтовых ящиков, не отвечает.

Cas испытывает проблемы с сетью, и он не может подключиться к серверу почтовых ящиков или контроллеру домена.

Введены неправильные данные учетной записи наблюдения.

База данных пользователя не установлена, или хранилище информации недоступно для этого почтового ящика.

Банк данных не отвечает.

Контроллеры доменов не отвечают.

Действия пользователя

Служба может восстановить работу после отображения оповещения. Поэтому если вы получите оповещение о неработоспособном состоянии настроек работоспособности, сначала убедитесь в наличии данной проблемы. Если проблема не устранена, выполните соответствующие действия по восстановлению, указанные в приведенных ниже разделах.

Проверка наличия проблемы

Определите имена настроек работоспособности и сервера, указанные в оповещении.

В сообщении приводятся подробные сведения о точной причине возникновения оповещения. В большинстве случаев в сообщении приводится достаточно сведений по устранению неполадок для определения основной причины проблемы. Если в сообщении приводятся непонятные сведения:

Откройте Exchange командную команду, а затем запустите следующую команду, чтобы получить сведения о наборе здоровья, сгенерированном оповещением:

Outlook Web App набор сведений о server1.contoso.com, запустите следующую команду:

Просмотрите выходные данные команды, чтобы определить монитор, сообщивший об ошибке. Значение AlertValue для монитора, выдаваемой оповещением, Unhealthy составляет .

Перезапранить связанный зонд для монитора, который в нездоровом состоянии. Обратитесь к таблице в разделе Explanation, чтобы найти связанный зонд. Для этого выполните следующую команду.

Например, чтобы создать зонд Exchange ActiveSync мониторинга на server1.contoso.com, запустите следующую команду:

В выходных данных команды просмотрите значение параметра Результат зонда. Если этот параметр имеет значение Succeeded, ошибка была временной и в настоящее время устранена. В противном случае обратитесь к действиям по восстановлению, приведенным в следующих разделах.

Действия по восстановлению монитора OwaCtpMonitor

Уведомление по электронной почте, отправляемое настройками работоспособности, содержит следующие сведения.

Имя сервера, отправившего оповещение.

Полная трассировка исключения, связанного с последней ошибкой, включая диагностические данные и конкретные сведения о заголовке HTTP.

Примечание. Для устранения неполадок можно использовать сведения в полном следе исключения. Исключение, создаваемое зондом, содержит поле «Причина сбоя» с описанием причины сбоя. Например, исключение содержит следующие сведения.

MissingKeyword: ожидаемое ключевое слово не было найдено в ответе сервера. В этом случае исключение содержит ожидаемые ключевые слова.

NameResolution: разрешение DNS не удается разрешить заданное имя сервера.

NetworkConnection. Зонд получает сбой сетевого подключения при попытках подключения к пулу приложений OWA в CAFE.

UnexpectedHttpResponseCode: Response had an unexpected HTTP code. Например, сервер вернул код HTTP 503.

RequestTimeout. Серверу потребовалось слишком много времени, чтобы ответить на запрос клиента.

ScenarioTimeout. Зонд успешно завершил работу, но для этого потребовалось более одной минуты. Обычно это указывает на перегрузку системы.

OwaErrorPage: Outlook Web App страницу ошибки. Обычно в сообщении об исключении приводится имя ошибки, которая привела к сбою.

OwaMailboxErrorPage: Outlook Web App страницу ошибки, содержаную ошибку, связанную с магазином почтовых ящиков. Это обычно указывает на неработоспособность хранилища почтовых ящиков или отключение почтовых ящиков.

Трассировка исключения содержит важное поле FailingComponent. Зонд пытается определить причину сбоя, как, например, в следующем примере.

Почтовый ящик: зонд может достигать Outlook Web App, но не может подключиться к магазину почтовых ящиков. В этом случае возник сбой зонда, или задержка доступа к почтовому ящику привела к сбою зонда и созданию ошибки ScenarioTimeout. При таких сбоях следует проверить работоспособность серверов почтовых ящиков.

Active Directory. Зонд может достичь Outlook Web App, но не может подключиться к Active Directory. В этом случае сбой зонда или задержки вызовов Active Directory могли привести к задержке времени зонда. При таких сбоях необходимо проверить состояние контроллеров домена, а также проверить сетевые подключения между серверами ЦС и почтовых ящиков и контроллерами доменов.

Owa. Как правило, это означает, что ошибка произошла в Outlook Web App уровне. При таких сбоях необходимо проверить состояние Outlook Web App на серверах ЦС и почтовых ящиков, а также проверить сетевые подключения.

Исключение также содержит сведения о последнем HTTP-запросе и ответе, полученным до сбоя зонда. Текст сообщения об эскалации содержит путь к журналам зонда. Эти сведения можно использовать для определения полного веб-запроса HTTP и ответов, отправленных при сбое зонда. Этот файл содержит данные только для неисправных зондов, поскольку в журнал записываются исключительно неудачные попытки. Эти сведения можно использовать для получения более подробной информации о сбое при тестировании.

Насколько опустилась метрика доступности (x%).

Полный путь к папке, которая содержит полные трассировки HTTP-запроса для зонда. По умолчанию эти сведения находятся в папке \ \ \ OWA \ ClientAccessProbe для мониторинга журналов.

Время и дата возникновения оповещения.

Для устранения данной проблемы выполните действия, указанные ниже.

Создайте тестовую учетную запись пользователя, а затем войдите из нее на сервер клиентского доступа. Например, войдите в систему с помощью https:// /owa.

Если не удается войти в систему, выполните проверку, используя другой сервер клиентского доступа, чтобы убедиться, что проблема возникает на определенном сервере клиентского доступа, а не на сервере почтовых ящиков.

Проверьте сетевое подключение между серверами клиентского доступа и почтовых ящиков. С помощью служебной программы ping.exe убедитесь, что отвечает каждый сервер.

Проверьте наличие оповещений, которые связаны с настройками работоспособности OWA.Protocol и могут указывать на проблему с определенным сервером почтовых ящиков. Подробнее см. в разделе Troubleshooting OWA.Protocol Health Set.

Запустите диспетчер IIS и подключите к серверу, который сообщает о проблеме, чтобы убедиться, что пул приложений MSExchangeOwaAppPool запущен в CAS.

В диспетчере IIS убедитесь, что запущен веб-сайт по умолчанию.

Найдите неисправные зонды в базе данных почтовых ящиков и убедитесь, что она активна на сервере почтовых ящиков, а также что хранилище почтовых ящиков работоспособно. Чтобы получить сведения о GUID неисправной базы данных, откройте сведения о полной трассировке исключения. Каждый сбой должен содержать запись, похожую на следующий пример.

Запуск зонда Owa с target: https://localhost/owa/ , имя пользователя: HealthMailboxdf8b87828ab0427cb91e985bbdfcec62@yourdomain.com

Скопируйте GUID HealthMailbox, а затем выполните в командной консоли следующую команду.

Например, выполните следующую команду:

В возвращаемом объекте можно найти имя базы данных пользователя, а также определить, где находится активная база данных в настоящее время.

Если между сайтами настроено перенаправление, можно наблюдать за сбоями зондов и созданием ошибки MissingKeyword. Это происходит в связи с тем, что по умолчанию зонды сервера клиентского доступа запускаются в учетных записях для любого расположения, а также с тем, что зонд не пытается выполнить проверку сервера клиентского доступа на другом сайте при использовании перенаправления. Чтобы устранить эту проблему, убедитесь, что серверы на каждом сайте содержатся в MonitoringGroups. Серверы клиентского доступа в заданной группе мониторинга выполняют проверку только совместно с серверами почтовых ящиков в той же группе.

Чтобы определить группы мониторинга для своих серверов, выполните следующую команду.

Чтобы изменить группу мониторинга на сервере, используйте параметр MonitoringGroup вместе с командлетом Set-ExchangeServer. Например, введите следующее:

В диспетчере IIS щелкните пулы приложений, а затем утилизировать пул приложений MSExchangeOWAAppPool, выполив следующую команду из командной Exchange:

Повторное повторение связанного зонда, как показано на шаге 2c в разделе Проверка проблемы.

Если проблема не устранена, перезапустите службы IIS с помощью служебной программы IISReset или следующей команды.

Повторное повторение связанного зонда, как показано на шаге 2c в разделе Проверка проблемы.

Если проблема не устранена, перезапустите сервер.

После перезапуска сервера повторно запустите связанный зонд, как показано в шаге 2c раздела Verifying the issue still exists.

Если зонд все еще не работает, вам понадобится помощь для устранения данной проблемы. Для решения этой проблемы обратитесь к специалисту службы технической поддержки Майкрософт. Чтобы связаться с специалистом службы поддержки Майкрософт, посетите службу поддержки бизнеса и выберите серверы > Exchange Server. Так как обращение непосредственно в службу технической поддержки Майкрософт в вашей организации может регламентироваться, сначала ознакомьтесь с инструкциями организации.

Источник

Зонд Настройки работоспособности Зависимости Связанные мониторы
Читайте также:  Что можно починить своими руками
Оцените статью