Не работает перемещаемый профиль
Вопрос
Здравствувйте, прошу помощи / консультации в решении перемещаемых профилей на windows 7 (AD — 2012 R2)
— Есть сервера 2012 R2 (AD), 2012 R2 (FS), есть 30 компьютеров 20 на win10 и 10 на win7.
— На 2012 R2 (FS) была создана папка для профилей, согласно правам доступа из сайта майкрософт: https://msdn.microsoft.com/ru-ru/lib. (v=ws.11).aspx
— На 2012 R2 (AD) для каждой учетной записи был прописан путь к папке профиля: \\server\profiles$\%username%
— Все компьютеры на win10, благополучно создали свои папки профилей (%username%.V6)
— Все компьютеры на win7 категорически отказываются создавать папки профилей.
1521 — Windows не удалось найти серверную копию перемещаемого профиля, выполняется попытка входа с использованием локального профиля. Изменения этого профиля не будут копироваться на сервер при выходе из системы. Возможная причина — сетевые проблемы или недостаточные права безопасности.
ПОДРОБНО — Отказано в доступе.
Я уже более 2-х недель страдаю, не знаю в чём может быть проблема? Ведь если для 10-ки доступ есть, то почему его может небыть для 7-ки? ведь условия одинаковые!
Источник
Не работает перемещаемый профиль
Этот форум закрыт. Спасибо за участие!
Лучший отвечающий
Вопрос
возникла вот такая плавающая проблема.
На всех рабочих станциях (Windows7) стала переодически возникать такая ошибка.
Windows не удалось найти серверную копию перемещаемого профиля, выполняется попытка входа с использованием локального профиля. Изменения этого профиля не будут копироваться на сервер при выходе из системы. Возможная причина — сетевые проблемы или недостаточные права безопасности.
ПОДРОБНО — Отказано в доступе.
При этом до какого-то момента, доступ был постоянно, после неопределенного момента в прошлом, профиль перестал находиться. При чем изредка, то есть доступ, то нет доступа.
Профили лежат на DFS’ной папке Windows 2008, разрешения на папку стандартные, и тот факт, что через какое-то время профиль все таки загружается, говорит о том, что разрешения здесь ни при чем.
Просто даже ума не приложу в какую сторону копать.
В основном проблема проявляется после первого запуска компьютера, если выйти из временного профиля и войти заново, то профиль подгружается нормально.
Ответы
Алексей, я нашел багу. Спасибо за подсказку с переносом профиля на другой сервак.
Ну очень уж не хотелось переставлять хранилище и я пошел по пути DFS.
У DFS кроме пути пространства имен (NameSpace Path), где храняться сами данные, есть еще DFS root. И вот их было 2, один бытый, то есть просто пустой.
При загрузке он пытался зайти на пустой DFS корень — получал отлуп, возможно из-за ограничений по времени. Потом после выхода и входа из пользователя уже заходил на живой корень (но опять же не всегда) — и процесс шел нормальным путем.
Нашел еще так же в другом пространстве имен привязку к корню DFS на этом же серваке (тоже битому). Но там было проще, во-первых там было три корня и два живых. Во-вторых там не было ограничения по времени, ну не зашел на диск, подождал пару минут, и нормально зашел. Видимо, он через определенное время, сам смотрит в другой корень.
P.S. а патч требует перезагрузки, 29 числа были веселые выходные. по перезагрузке многих серваков. Иначе не хотел менять часовой пояс.
Все ответы
1) В тестовых целях включите политику Computer Configuration -> Policies -> Administrative Templates-> System -> User Profiles -> Do not check for user ownership of roaming profiles folders и проверьте, устранится ли проблема.
2) Что фиксируется на сервере в момент возникновения данной ошибки?
Мнения, высказанные здесь, являются отражением моих личных взглядов, а не позиции корпорации Microsoft. Вся информация предоставляется «как есть» без каких-либо гарантий
1) Не помогло. Да и права вроде стандартные, как просит майкрософт, так и выставлено. Пользователь владелец и полный доступ, правда еще администраторы добавлены на полный доступ (но раньше так работало). На расшареную папку тоже все рекомендуемые права.
2) В том то и дело, что ничего не пишет, точнее среди ошибок нет ничего, что можно было бы связать по времени с этим событием. То есть событие происходить всегда (ну почти) при загрузке машины, а на сервере пара ошибок за день. Очень похоже, что просто не успевает подгрузиться профиль, но «медленного подключения» — нет. Да и если выйти и войти в систему, то профиль всегда подгружается нормально. При чем сколько бы раз я это не делал, всегда нормально, а если перезагрузить и войти то почти всегда со временным профилем (95%).
Если перенести прфиль на другую шару (тоже DFS, но на других серверах) со станадртными профильными правами, то там такой ошибки не возникает. То есть видимо проблема с текущим сервером, на котором хранятся профили.
1. Забэкапте все проифили.
2. Войдите под всеми пользователями, и добейтесь чтобы вход был нормальный.
3. Удалите все профили.
4. Выйдите из системы всеми пользователями (в этот момент должны создаться профили с ПРАВИЛЬНЫМИ правами доступа).
Есть и другой вариант:
1. Тот же что и выше.
2. Удалите все профили.
3. Зайдите под всеми пользователями (в этот момент опять же создадуться новые профили).
4. Выйдите из системы всеми пльзователями.
5. Восстановите необходимые элементы профилей из бэкапа.
P.S. Есть еще вариант, что система не может дождаться полной загрузки профиля, например у кого-нибудь лежит фильм (а не ссылка) на рабочем столе.
попробую конечно для начала на одном профиле оба варианта, но если я создаю новый профиль (то есть делаю тоже самое с пункта 3), не помогает.
P.S. Пробовал включать все политики, относящиеся к ожиданию загрузки профиля, — не помогает. Да и профиль весит 2 мегабайта, это перемещаемый обязательный профиль, включена политика перенаправления папок пользователя. Есть просто перемещаемы профили мегабайт по 10-20, у них папки пользователя так же перенаправлены (там хранится мегабайт 500). Поведение абсолютно идентично. Да и на гигабитном канале проверял. Все таки, у меня стойкое ощущение, что на сервере, что-то плохо, но не знаю как проверить.
\\server\Profile — сетевой размещение профилей
\\server\Home — сетевое размещение домашних каталогов
Под удалением профиля подразумевается не только удаление содержимого папки профиля пользователя, но и удаление самой папки профиля, т.е. удалять нужно будет \\server\Profile\User1. При удалении этой папки User1 удаляются и пермишины на нее, при первом входе пользователя User1 его профиль (папка \\server\Profile\User1) будет создана заново с установкой пермишинов по умолчанию (полный доступ для пользователя User1 и запрет для всех остальных, причем пермишины \\server\Profile к папке \\server\Profile\User1 добавлены не будут). Соответсвенно если при первом входе пользователя создается профиль, то при повторном входе он ДОЛЖЕН получить свой сетевой профиль. Исключение составляет вариант если профиль не успел ФИЗИЧЕСКИ сбросится на винт (возможна блокировка какими либо процессами типа антивирусов). Но если это происходит значит проблема не профилях, а в чем-то другом, и тут нужен более глубокий анализ.
Я не зря указал \\server\Home если используете еще и домашние каталоги, то часть профиля лежит там, ее тоже желательно чистить, но аккуратно, там могут лежать данные пользователя (точные указания не могу дать не помню что нужно удалять, а проверить негде, но папку Windows там точно можно удалить).
Кстати, можете еще попробовать вообще удалить папку профилей(\\server\Profile), и заново её создать.
И ОБЯЗАТЕЛЬНО прочекайте диск на котором лежат профиля пользователей.
Источник
Не работает перемещаемый профиль
Этот форум закрыт. Спасибо за участие!
Лучший отвечающий
Вопрос
На сервере Win Storage Server 2008 Std 6.0.6002 SP2 Build 6002 ProLiant SE1220 x64 расшарена папка для перемещаемых профилей.
На некоторых профилях при перемещении пользователя на другой компьютер не подгружаются с сервера некоторые файлы из перемещаемого профиля. Если зайти под временным профилем этого пользователя и копировать файлы из папки его перемещаемого профиля с сервера на локальную машину — на каком-то файле происходит затык с копированием. Если потом копировать файл, вызвавший проблему отдельно — он копируется без проблем.
Безопасность на все файлы стоит одинаковая. У пользователя права полные.
Если перенести шару на сервер 2003 — все профиля грузятся без ошибок.
Ответы
Все ответы
Тип события: Ошибка
Источник события: Userenv
Категория события: Отсутствует
Код события: 1509
Дата: 06.08.2010
Время: 9:22:32
Пользователь: .
Компьютер: .
Описание:
Не удалось скопировать файл . Возможные причины — неполадки в сети или недостаточные права доступа. Если проблема не устраняется, обратитесь к сетевому администратору.
Подробно: Не удается найти указанный файл.
Тип события: Ошибка
Источник события: Userenv
Категория события: Отсутствует
Код события: 1515
Дата: 06.08.2010
Время: 9:22:32
Пользователь: .
Компьютер: .
Описание:
Windows сохранила архивную копию профиля этого пользователя. Windows будет автоматически пытаться использовать эту копию профиля при следующем входе в систему этого пользователя.
Тип события: Ошибка
Источник события: Userenv
Категория события: Отсутствует
Код события: 1511
Дата: 06.08.2010
Время: 9:22:43
Пользователь: NT AUTHORITY\SYSTEM
Компьютер: .
Описание:
Не удалось найти ваш локальный профиль, вход в систему выполнен с временным профилем. Любые изменения профиля будут потеряны при выходе.
По блокировке файлов ничего не нашел.
Есть ошибки не связанные напрямую с проблемой:
Log Name: System
Source: VDS Dynamic Provider
Date: 10.08.2010 11:17:20
Event ID: 10
Task Category: None
Level: Error
Keywords: Classic
User: N/A
Computer: .
Description:
The provider failed while storing notifications from the driver. The Virtual Disk Service should be restarted. hr=80042505
Event Xml:
Log Name: System
Source: Microsoft-Windows-DistributedCOM
Date: 08.08.2010 21:29:24
Event ID: 10010
Task Category: None
Level: Error
Keywords: Classic
User: N/A
Computer: .
Description:
The server <7d1933cb-86f6-4a98-8628-01be94c9a575>did not register with DCOM within the required timeout.
Event Xml:
Log Name: Application
Source: Automated Storage Manager (Server)
Date: 10.08.2010 15:31:23
Event ID: 0
Task Category: None
Level: Warning
Keywords: Classic
User: N/A
Computer: .
Description:
Could not connect via COM to VDS Service. Restarting VDS service
Event Xml:
0
3
0
0x80000000000000
60913
Application
.
Could not connect via COM to VDS Service. Restarting VDS service
Log Name: Application
Source: Automated Storage Manager (Server)
Date: 10.08.2010 15:32:08
Event ID: 0
Task Category: None
Level: Error
Keywords: Classic
User: N/A
Computer: .
Description:
Alert: Share not found at given path
Event Xml:
0
2
0
0x80000000000000
60921
Application
.
Alert: Share not found at given path
Источник