- Почему не стартует служба Apache? Решение проблемы
- Apache не запускается из панели управления XAMPP в Windows 10
- Apache не запускается из панели управления XAMPP
- 1] Clear World Wide Web Services
- 2] Изменить порт Apache TCP/IP по умолчанию
- 3] Остановите издательский сервис World Wide Web
- Windows не удалось запустить Apache2 на локальном компьютере-проблема
- 19 ответов
Почему не стартует служба Apache? Решение проблемы
Как то раз запускал службу веб-сервера Apache, а он отказался стартовать. Начал разбираться в чём же проблема. Дело было на рабочем компьютере под ОС Microsoft Windows. Полез в журналы операционной системы: Компьютер -> Свойства -> Управление (Управление компьютером) -> Служебные программы -> Просмотр событий -> Журналы Windows -> Приложение. Здесь нашёл множество сообщений касательно Apache. Привожу список сообщений об ошибках найденных в журналах касательно Apache:
- The Apache service named reported the following error: AH00558: httpd.exe: Could not reliably determine the server’s fully qualified domain name, using xxxx::yyyy:zzzz:www:nnnn. Set the ‘ServerName’ directive globally to suppress this message.
- The Apache service named reported the following error: AH00015: Unable to open logs.
- The Apache service named reported the following error: AH00451: no listening sockets available, shutting down.
- The Apache service named reported the following error: (OS 10048) Обычно разрешается только одно использование адреса сокета (протокол/сетевой адрес/порт). : AH00072: make_sock: could not bind to address 0.0.0.0:80.
Таким образом становится понятно, что Apache не может слушать 80-ый сетевой порт т.к. он уже кем-то занят, поэтому и не хочет стартовать. Т.е. надо либо настроить Apache таким образом, что бы он слушал какой-нибудь другой порт (свободный), либо же освободить 80-ый порт закрыв приложение, которое его использует или перенастроив это приложение на использование другого порта. Указать веб-серверу Apache прослушиваемый порт можно в конфигурационном файле httpd.conf директивой Listen .
Посмотрим кем занят 80-ый порт. В командой строке (она же cmd) вбиваю netstat -ab или так для более полной информации netstat -abno . И узнаю, что 80-ый сетевой порт слушает запущенный Skype. Да, я в курсе, это старая тема про которую все давно знают, что Skype по-умолчанию занимает 80-ый порт. В общем? отключил в Скайпе (Skype) прослушивание 80-ого порта и проблема была решена. Если у вас другое приложение занимает этот порт, то соответственно отключайте или перенастраивайте его.
Источник
Apache не запускается из панели управления XAMPP в Windows 10
После установки панели управления XAMPP в Windows 10 многие пользователи сообщали об ошибке при запуске Apache . Эта проблема обычно возникает, когда такой процесс, как World Wide Publishing Service, продолжает работать на 80-м порту вашего устройства. Из-за этого операционная система Windows 10 не позволяет серверу Apache работать, и это вызывает ошибку.
Фактически, порт 80 на компьютере также был портом TCP / IP по умолчанию, который модуль Apache использует на XAMPP. А поскольку два разных приложения не могут использовать один и тот же сетевой порт, вам необходимо остановить его перед запуском сервера Apache XAMPP. Если вы также столкнулись с этой проблемой на своем устройстве, есть несколько простых способов, которые я упомянул в этом руководстве. Итак, начнем.
Apache не запускается из панели управления XAMPP
Очистка службы публикации в World Wide Web была бы лучшим подходом, чтобы снова запустить Apache. Однако вы также можете получить его, изменив номер порта TCP / IP или остановив службу, если это необходимо. Итак, чтобы исправить запуск Apache на панели управления XAMPP, выполните следующие возможные действия:
- Clear World Wide Web Services
- Изменить порт Apache TCP/IP по умолчанию
- Остановите World Wide Web Publishing Service
Давайте посмотрим на них подробно.
1] Clear World Wide Web Services
Чтобы решить начальную проблему службы Apache, вам необходимо очистить всемирную паутину от вашего устройства. Но прежде чем начать, убедитесь, что у вас нет приложений, использующих этот сервис.
Если все в порядке, откройте панель управления в вашей системе Windows.
После того, как он откроется, выберите для просмотра панели управления параметр «Большие значки» или «Маленькие значки», чтобы можно было видеть все элементы панели управления.
Из доступных элементов выберите Программы и компоненты.
В левой боковой панели есть ссылка «Включение или отключение функций Windows», нажмите на нее.
В диалоговом окне «Функции Windows» разверните Информационные службы Интернета.
Теперь снимите флажок «World Wide Web Services» и нажмите кнопку «ОК», чтобы сохранить изменения.
Выполнив вышеуказанные действия, перезагрузите устройство. После этого откройте панель управления XAMPP и нажмите кнопку «Пуск» в Apache. Теперь он должен работать в порту 80 на вашем компьютере.
2] Изменить порт Apache TCP/IP по умолчанию
Если по какой-либо причине вышеуказанный обходной путь не работает для вас, вам необходимо настроить Apache для выполнения на другом порту TCP/IP. Итак, следуйте этим советам:
Откройте панель управления XAMPP на вашем устройстве Windows.
Нажмите на кнопку Config модуля Apache.
Выберите пункт Apache (httpd.conf) в списке всплывающего меню.
На следующей странице блокнота вам нужно найти Listen 80.
Чтобы упростить поиск, нажмите сочетание клавиш Ctrl + F. Во всплывающем меню введите то, что вы хотите найти. Марк Wrap вокруг флажка, оставить дело Match бесконтрольно, а затем нажмите на Find Next кнопку.
Как только вы найдете соответствующую строку, измените номер порта на любой произвольный номер по вашему выбору.
Например, вы можете попробовать порт 121. Тогда соответствующий результат для номера порта TCP/IP будет что-то вроде — Listen 121.
Нажмите сочетание клавиш Ctrl + S, чтобы сохранить изменения в блокноте.
Примечание. Обратите внимание, что при использовании этой конфигурации вам всегда нужно добавить номер порта TCP/IP в URL, который вы хотите подключить к своему сайту. Например, чтобы получить доступ к серверу Apache в вашем браузере, вам нужно будет ввести: localhost:121/dashboard , а не localhost/dashboard .
После правильного выполнения вышеуказанных шагов, проблема запуска Apache в XAMPP будет исправлена.
3] Остановите издательский сервис World Wide Web
В качестве альтернативы вам необходимо остановить службу публикации в Интернете и изменить ее параметры, чтобы она могла быть запущена только вручную. Итак, начнем:
Чтобы остановить службу публикации в Интернете, сначала необходимо открыть диспетчер служб Windows на компьютере с Windows 10.
На экране «Службы» найдите параметр «Служба публикации в Интернете» в столбце «Имя».
Как только вы найдете, дважды щелкните по нему, чтобы открыть окно свойств.
В окне свойств по умолчанию открывается вкладка Общие.
На вкладке General найдите тип запуска и переключите его на Manual. Это позволит вам запустить службу вручную, когда это потребуется.
Продвигаясь вперед, остановите статус работающей службы и нажмите Apply > кнопку OK.
Теперь откройте панель управления XAMPP и нажмите кнопку «Пуск», чтобы запустить сервер Apache.
Вот и все. Я надеюсь, что это руководство поможет вам исправить проблему запуска службы Apache на панели управления XAMPP.
Источник
Windows не удалось запустить Apache2 на локальном компьютере-проблема
во время установки Apache2 я получил следующее сообщение в окно cmd:
установка Apache2.2 обслуживание Apache2.2 обслуживание успешно установленный. Тестирование файле httpd.conf.
ошибки здесь должны быть исправлены перед запуском службы. файл httpd.exe: не может надежно определить сервер полное доменное имя , используя 192.168.1.3 для Имя_сервера (OS 10048)только одно использование каждый сокет адрес (протокол / сеть адрес / порт) обычно разрешен. : make_sock: не удалось привязать к адресу 0.0.0.0:80 нет доступных сокетов для прослушивания, выключение невозможно открыть журналы обратите внимание на ошибки или сообщения выше, и нажмите кнопку, чтобы выход. 24.
и после установки все выглядело нормально, но это не так. Если я пытаюсь запустить службу, я получил следующее сообщение:
Windows не удалось запустить Apache2 на локальный компьютер. For more информация, просмотрите журнал системных событий. Если это не с micorsoft услуг, свяжитесь с поставщик услуг и обратитесь к сервис-код ошибки 1.
версия Apach2-это 2.2.9
У кого-нибудь есть такая же проблема или может помочь мне.
19 ответов
есть какая-то другая программа прослушивает порт 80, Обычные подозреваемые
- Skype (прослушивает порт 80)
- NOD32 (добавьте Apache в список исключений IMON, чтобы разрешить Apache связываться)
- некоторые другие антивирусы (такие же, как и выше)
способ исправить это либо завершение работы программы, которая использует порт 80 или настроить его на использование другого порта или настроить Apache для прослушивания другого порта с помощью Listen директива в httpd.conf. В случае антивируса настройте антивирус, чтобы разрешить Apache связываться с выбранным вами портом.
способ диагностировать, какое приложение, если таковое имеется, привязано к порту 80, запускает netstat с этими параметрами, ищите: 80 рядом с локальным IP-адресом (второй столбец) и найдите PID (последний столбец). Затем в диспетчере задач вы можете найти, какой процесс имеет PID, который вы получили на предыдущем шаге. (Возможно, Вам потребуется добавить столбец PID в задачу менеджер)
C:\Users\vinko > netstat-ao-p tcp
Я надеюсь, что это помогает другим с этой ошибкой.
запустите httpd.exe из командной строки чтобы получить точное описание проблемы.
У меня было такое же сообщение об ошибке,и оказалось, что это путь настроенного ServerRoot. Даже после запуска setup_xampp.бат файл httpd.конф выбрал неверный путь.
моя ошибка.журнал был пуст, и запуск службы не дает информативного сообщения об ошибке.
лучший способ решить проблему-изменить номер порта в Apache2\conf\httpd.conf . Измените номер порта как fallows. Listen 8888 и Имя_сервера имя_машины: 8888 .Перезапустите сервер Apache после изменения номера порта.
У меня была та же проблема. Я проверил netstat, другие запущенные процессы, брандмауэр и изменил httpd.конф, остановил антивирус, но все мои усилия были напрасны. 🙁
Итак, наконец, решение состояло в том, чтобы остановить IIS. И это сработало 🙂
Я думаю, IIS и apache не могут работать вместе. Если кто-нибудь знает о работе, дайте нам знать.
запустите httpd.exe из командной строки, как упоминал Тим. Путь к PostgreSQL изменился, больше ничего не работало на порту 80, и я ничего не видел в .
Я клонирую свой загрузочный диск / раздел после установки базы, поэтому мне не нужно тратить три дня на установку и ретвакинг всего. Оказывается, я переустановил свой стек WAPP и использовал очень конкретные имена/версии для PostgreSQL. Windows не вернет определенное сообщение об ошибке, если вы не запустите команда из командной строки.
следуйте этому шагу, он будет работать нормально. Перейти к панель управления—>программы и компоненты—>меню включить функции Windows ВКЛ и выкл—> посмотреть IIS проверен или нет Если проверено, пожалуйста, unckeck IIS и перезагрузить компьютер.После этого откройте службы see Web Deployement Agent статус Службы если он запущен, пожалуйста, остановитесь.А также смотрите WampAppache и WampSqlID если его не начала начать вручную. это сработает для меня.
Привет, я также встречаю эту проблему сегодня. И ошибка журнала в средстве просмотра событий выглядит следующим образом Названная служба Apache сообщила о следующей ошибке:
1.PHP-обертки-цги.невозможно получить доступ к exe: (720005)доступ запрещен.
2.монитор службы apache: запрошенная операция завершилась неудачно
это фактическая проблема доступа.Так что решение, как течет, помогает мне изменение php-cgi.exe в свойствах безопасности
не inheit от родительского разрешения.
пожалуйста, добавьте пользователя everyone
Если appache и IIS оба работают одновременно, то есть возможность повесить службу apache.
когда я остановил все веб-сайты IIS один раз, а затем перезапустил службу apache, и она работает для меня. Джай.
проблема с операционной системой Windows Vista Home Premium: самый простой способ решить эту проблему-изменить номер порта в Apache2\conf\httpd.conf.
измените номер порта в следующих строках. ‘Listen’ от 80 до 8888 и’ ServerName ‘ machinename (например:localhost) от 80 до 8888. Сохранить затем закрыть. Откройте монитор службы Apache и перезапустите службу или перейдите в Управление компьютером > службы и найдите Apache 2.2 и запустите или перезапустите.
удалите apache с панели управления и удалите папку apache из программных файлов и перезагрузите компьютер, затем снова установите apache. Это решит проблему; если не сделать следующее: Установите IIS если не установлен, запустите IIS и остановите его . Использование служб запустите службу apache. наслаждайтесь apache.
У меня была эта проблема дважды. Первая проблема была исправлена с помощью отмеченного ответа на этой странице (Спасибо за это). Однако второй раз оказался немного сложнее.
Я нашел это в моем httpd-vhosts.conf-файл, который я допустил ошибку при назначении корня документа доменному имени. Исправление этого решило мою проблему. Стоит проверить (или даже вернуться к пустой копии) ваш httpd-vhosts.conf файл для любых ошибок и опечаток.
Если вы используете ОС windows и считаете, что skype не является подозреваемым, то вы можете проверить диспетчер задач и проверить «показать процессы от всех пользователей» и убедитесь, что нет записи для httpd.исполняемый. В противном случае завершите процесс. Это решает мою проблему.
Да, мне пришлось изменить порт: 80 на: 90, поскольку порт: 80 был занят каким-то другим системным ресурсом.
вы можете увидеть журналы в папке Apache2.2 \ logs
всегда дважды проверьте файл httpd.conf, чтобы узнать, правильно ли корень документа указывает на существующую папку
DocumentRoot указывает на папку, которая должна существовать на диске.
У меня была та же проблема. когда я перезапустил свой wamp, он становится желтым цветом, но не зеленым. В службах я останавливаю все службы sql server. после этого он работает на меня..
- два думает, что должен быть осторожен. 1 ) порт должен быть разным 2) остановите те сервисы которые могут быть на порту 80
Спасибо за помощь, ребята. Я нашел другого преступника. Недавно SimplifyMedia добавил опцию обмена фотографиями. По-видимому, он также использует порт 80 и предотвратил запуск Apache. Надеюсь, это кому-то поможет.
У меня тоже такая же проблема. Решение состоит в том, чтобы добавить или удалить программы, затем нажмите Включить или выключить функции windows. Выключите IIS. То есть отключите «информационные службы интернета» и «съемное веб-ядро информационной службы Интернета». Я выбрал оставшиеся функции. Компьютер попросит перезагрузить систему. Перезагрузите компьютер ur и установите http-сервер apache. Я понял. Сервер успешно работает.
для меня это было результатом установки корня документа (в httpd.conf ) в каталог, который не существовал (я только что очистил htdocs от предыдущего проекта).
Windows 10-учетная запись администратора
Мне нужно было переключить учетную запись на учетную запись типа администратора в службах windows
не удается добавить настройки прав пользователей.
Источник