- Устранение ошибок, которые возникают при Windows компьютеров на основе Windows домена
- Где найти файл Netsetup.log
- Сетевые сообщения об ошибках и разрешениях
- Ошибка 1
- Решение
- Ошибка 2
- Решение
- Ошибка 3
- Решение
- Ошибка 4
- Решение
- Ошибка 5
- Решение
- Ошибка 6
- Решение
- Ошибка 7
- Решение
- Ошибка 8
- Решение
- Ошибка 9
- Решение
- Ошибка 10
- Решение
- Сообщения об ошибках проверки подлинности и разрешения
- Ошибка 1
- Решение
- Ошибка 2
- Решение
- Ошибка 3
- Решение
- Ошибка 4
- Решение
- Ошибка 5
- Решение
- Ошибка 6
- Решение
- Ошибка 7
- Решение
- Ошибка 8
- Решение
- Решение проблем с DNS в Windows 7
- Предисловие
- Суть проблемы
- Решение проблемы
- Слетает тип сети с доменной на частную на Windows Server
- Цели статьи
- Введение
- Изменение типа сети на доменную
- Причины изменения типа сети
- Заключение
Устранение ошибок, которые возникают при Windows компьютеров на основе Windows домена
В этой статье описано несколько распространенных сообщений об ошибках, которые могут возникать при подступах к клиентских компьютерах, Windows в домен. В этой статье также содержится предложение по устранению неполадок для этих ошибок.
Применяется к: Windows Server 2016, Windows Server 2012 R2
Исходный номер КБ: 4341920
Где найти файл Netsetup.log
Windows в файле %windir% отламывание \ \ Netsetup.log.
Сетевые сообщения об ошибках и разрешениях
Ошибка 1
Попытка разрешить DNS-имя dc в присоединяемом домене не удалась. Убедитесь, что этот клиент настроен для достижения DNS-сервера, который может разрешать имена DNS в целевом домене.
Решение
При вводе доменного имени убедитесь, что введите имя системы доменных имен (DNS), а не имя Network Basic Input/Output System (NetBIOS). Например, если имя DNS целевого домена , убедитесь, что вы вводите вместо доменного имени contoso.com contoso.com NetBIOS «contoso».
Кроме того, убедитесь, что компьютер может достичь DNS-сервера, на котором размещена зона DNS целевого домена, или разрешить DNS-имена в этом домене. Убедитесь, что правильный DNS-сервер настроен на этом клиенте как предпочтительный DNS и что клиент имеет подключение к этому серверу. Чтобы убедиться в этом, можно выполнить одну из следующих команд:
Ошибка 2
Попытка устранить имя DNS контроллера домена в присоединяемом домене не удалась. Убедитесь, что этот клиент настроен для достижения DNS-сервера, который может разрешать имена DNS в целевом домене.
Решение
При введите доменное имя, убедитесь, что вы введите имя DNS, а не имя NetBIOS.
Кроме того, убедитесь, что компьютер может достичь DNS-сервера, на котором размещена зона DNS целевого домена, или разрешить DNS-имена в этом домене. Убедитесь, что правильный DNS-сервер настроен на этом клиенте как предпочтительный DNS и что клиент имеет подключение к этому серверу. Чтобы убедиться в этом, можно выполнить одну из следующих команд:
Ошибка 3
Была предпринята попытка операции при несущестовом сетевом подключении.
Решение
При введите доменное имя, убедитесь, что вы введите имя DNS, а не имя NetBIOS. Кроме того, перезапустите компьютер, прежде чем пытаться присоединиться к компьютеру в домен.
Ошибка 4
Не допускается несколько подключений к серверу или общему ресурсу одного пользователя с несколькими именами пользователей. Отключите все предыдущие подключения к серверу или общему ресурсу и попробуйте еще раз.
Решение
Перезапустите компьютер, который вы пытаетесь присоединиться к домену, чтобы убедиться в том, что на серверах домена нет никаких затаивных подключений.
При введите доменное имя, убедитесь, что вы введите имя DNS, а не имя NetBIOS.
Ошибка 5
Решение
Убедитесь, что компьютер может достичь DNS-сервера, на котором размещена зона DNS целевого домена, или разрешить DNS-имена в этом домене. Убедитесь, что правильный DNS-сервер был настроен на этом клиенте как предпочтительный DNS и что клиент имеет подключение к этому серверу. Чтобы убедиться в этом, можно выполнить одну из следующих команд:
При введите доменное имя, убедитесь, что вы введите имя DNS, а не имя NetBIOS.
Кроме того, можно обновить драйвер сетевого адаптер.
Ошибка 6
В настоящее время на этом удаленном компьютере не может быть подключено больше подключений, так как подключений уже столько, сколько может принять компьютер.
Решение
Перед присоединением компьютера к домену убедитесь, что вы счистили все подключений к любым дискам.
Перезапустите компьютер, который вы пытаетесь присоединиться к домену, чтобы убедиться в том, что на серверах домена нет никаких затаивных подключений.
При введите доменное имя, убедитесь, что вы введите имя DNS, а не имя NetBIOS.
Ошибка может быть переходной. Повторите попытку позже. Если проблема сохраняется, проверьте состояние постоянного тока, к который подключается клиент (активные подключения, подключение к сети и так далее). При сохраняемой проблеме может потребоваться перезапустить dc.
Ошибка 7
Формат указанного имени сети недействителен.
Решение
Убедитесь, что компьютер может достичь DNS-сервера, на котором размещена зона DNS целевого домена, или разрешить DNS-имена в этом домене. Убедитесь, что правильный DNS-сервер был настроен на этом клиенте как предпочтительный DNS и что клиент имеет подключение к этому серверу. Чтобы убедиться в этом, можно выполнить одну из следующих команд:
При введите доменное имя, убедитесь, что вы введите имя DNS, а не имя NetBIOS. Убедитесь, что для сетевого адаптера клиентского компьютера установлены самые последние драйверы. Проверка подключения между подключенным клиентом и целевой dc над требуемой портами и протоколами. Отключите функцию разгрузки труб TCP и разгрузку IP.
Ошибка 8
Служба каталогов исчерпала пул относительных идентификаторов.
Решение
Убедитесь, что контроллер постоянного тока, в котором размещен мастер операций по относительному ID (RID), является сетевым и функциональным. Дополнительные сведения см. в документе Event ID 16650:в сервере Windows идентификатор учетной записи не удалось инициализировать.
Вы можете использовать netdom query fsmo команду, чтобы определить, какая роль dc имеет главную роль RID.
Убедитесь, что Active Directory реплицируется между всеми DCs. Для обнаружения ошибок можно использовать следующую команду:
Ошибка 9
Вызов удаленной процедуры не удался и не выполняется.
Решение
Убедитесь, что для сетевого адаптера клиентского компьютера установлены самые последние драйверы. Проверка подключения между подключенным клиентом и целевой dc над требуемой портами и протоколами. Отключите функцию разгрузки труб TCP и разгрузку IP.
Эта проблема также может быть вызвана одним из следующих условий:
- Сетевое устройство (маршрутизатор, брандмауэр или VPN-устройство) блокирует подключение к портам и протоколам, используемым протоколом MSRPC.
- Сетевое устройство (маршрутизатор, брандмауэр или VPN-устройство) отклоняет сетевые пакеты между клиентом, который присоединяется, и dc.
Ошибка 10
Изменение имени DNS основного домена этого компьютера на «» не удалось. Имя останется «.». Указанный сервер не может выполнять операцию.
Решение
Эта ошибка возникает при использовании пользовательского интерфейса присоединиться к домену Windows 7 или Windows Server 2008 R2 в домен Active Directory, указав целевой домен DNS. Чтобы устранить эту ошибку, см. в 2018583 Windows 7 или Windows 2008 R2 домена Server 2008отображает ошибку «Изменение имени DNS основного домена этого компьютера на «» не удалось. » .
Сообщения об ошибках проверки подлинности и разрешения
Ошибка 1
Вы превысили максимальное количество учетных записей компьютера, которые можно создать в этом домене.
Решение
Убедитесь, что у вас есть разрешения на добавление компьютеров в домен и что квота, определяемая администратором домена, не превышается.
Чтобы присоединить компьютер к домену, учетной записи пользователя необходимо предоставить разрешение на создание объектов компьютера в Active Directory.
По умолчанию пользователь, не управляющий, может присоединиться к домену Active Directory не более 10 компьютеров.
Ошибка 2
Ошибка logon. Имя целевой учетной записи неверно.
Решение
Убедитесь, что контроллеры домена (DCs) зарегистрированы с помощью правильных IP-адресов на DNS-сервере и правильно ли зарегистрированы их имена главных служб (SPNs) в учетных записях Active Directory.
Ошибка 3
Ошибка logon: пользователю не был предоставлен запрашиваемого типа логотипа на этом компьютере.
Решение
Убедитесь, что у вас есть разрешения на добавление компьютеров в домен. Чтобы присоединиться к компьютеру в домене, учетной записи пользователя необходимо предоставить разрешение на создание объекта компьютера в Active Directory.
Кроме того, убедитесь, что указанной учетной записи пользователя разрешено войти на локальном компьютере клиента. Для этого настройте журнал Разрешить локальное настройку в групповой политике в соответствии с конфигурацией компьютера > Windows Параметры > безопасности Параметры > локальных политик > назначения прав пользователей.
Ошибка 4
Ошибка logon: неизвестное имя пользователя или плохой пароль.
Решение
Убедитесь, что вы используете правильное имя пользователя и сочетание паролей существующей учетной записи пользователя Active Directory, когда вам будут предложены учетные данные для добавления компьютера в домен.
Ошибка 5
Сопоставление между именами учетных записей и ИД безопасности не было сделано.
Решение
Эта ошибка, скорее всего, является переходной ошибкой, которая регистрируется при вступивании домена в поиске целевого домена, чтобы определить, была ли уже создана учетная запись компьютера с учетной записью, которая соответствует этому, или же операция при подсоединение должна динамически создать учетную запись компьютера в целевом домене.
Ошибка 6
Недостаточное хранилище доступно для выполнения этой операции.
Решение
Эта ошибка может возникнуть, когда размер маркера Kerberos превышает максимальный размер по умолчанию. В этой ситуации необходимо увеличить размер маркера Kerberos компьютера, который вы пытаетесь присоединиться к домену. Дополнительные сведения см. в следующих статьях Базы знаний:
935744 сообщение об ошибке «Недостаточное хранилище для выполнения этой операции» при использовании контроллера домена для пользования компьютером в домене
327825 проверки подлинности Kerberos, когда пользователь принадлежит к многим группам
Ошибка 7
Учетная запись не разрешена для входа с этой станции.
Решение
Эта проблема связана с несоответствием параметров подписи SMB между клиентского компьютера и dc, который в настоящее время связаться для операции пользования доменом присоединиться. Просмотрите следующую документацию для дальнейшего изучения текущих и рекомендуемых значений в вашей среде:
281648 ошибки: учетная запись не разрешена для входа с этой станции 823659 проблемы с клиентом, службой и программой могут возникнуть при изменении параметров безопасности и назначений прав пользователей
Ошибка 8
Учетная запись, указанная для этой службы, отличается от учетной записи, указанной для других служб, работающих в том же процессе.
Решение
Убедитесь, что в dc, через который вы пытаетесь присоединиться к домену, запущена Windows time.
Источник
Решение проблем с DNS в Windows 7
Предисловие
В нашей компании для удобства конфигурации и работы мы используем центральный сервер, на котором находятся все рабочие версии проектов. У каждого разработчика имеется своя папка, которую он подключает как сетевой диск. В папке лежат его проекты. Все директории из неё автоматически добавляются как поддомены. До недавнего времени для того, чтобы попасть по HTTP на рабочую версию сайта — нужно было вводить примерно следующее:
Но, со временем, надоело набирать длинные URL и было решено настроить всё таким образом, чтобы можно было использовать:
Для этого на сервере были проведены небольшие настройки, а на клиентских машинах нужно было включить автоматическое добавление DNS-суффикса или добавить в список суффиксов company.com, что и было проделано. После этого всё заработало и всё стали счастливы. Все, кроме тех, у кого стояла Windows 7.
Суть проблемы
В Windows Vista и выше имеется одна неприятная штука. Если в имени домена встречается точка, то суффикс почему-то не добавляется. То есть:
ping user – работает и ведет на user.company.com
ping project.user – не работает
Говорят, что это баг. Microsoft даже объявила, что исправила его в Vista SP2, если не ошибаюсь, но, как видим — он есть.
Решение проблемы
1. Пуск -> Выполнить -> gpedit.msc
2. Конфигурация компьютера -> Административные шаблоны -> Сеть -> DNS-клиент
3. Включить следующие параметры:
— Разрешить добавление DNS-суффиксов к запросам несоответствующих составных имен
— Primary DNS Suffix Devolution Level.
После проделывания сих шаманских действий всё магическим образом заработало. Надеюсь заметка будет кому-то полезна.
Источник
Слетает тип сети с доменной на частную на Windows Server
Продолжительное время пытаюсь разобраться с одной проблемой в доменной сети. На разных Windows Server после перезагрузки периодически тип сети с доменной (domain) меняется на частную (private). Происходит этот как на контроллерах домена, так и на рядовых серверах. Поделюсь своими рецептами борьбы с этой проблемой.
Цели статьи
- Описать проблему, с которой столкнулся, по смене категории сети на сетевом интерфейсе после перезагрузки windows сервера.
- Показать методы, которые применял для решения проблемы.
- Получить помощь или совет по текущей проблеме.
Введение
Сразу проясню технические моменты.
- Все события происходят на серверах версии Windows Server 2012 R2.
- Используются бесплатные гипервизоры Windows Hyper-V Server 2012 R2 и Windows Hyper-V Server 2016.
- Все серверы включены в домен. Часть серверов сами являются контроллерами доменов.
Теперь по симптомам. Периодически после плановой установки обновлений и перезагрузки в свойствах сетевого подключения меняется тип сети. Она перестает быть доменной и становится приватной.
Так же несколько раз была ситуация, когда сетевое подключение получало новое имя. Как видно на примере, сетевой интерфейс имеет имя Сеть 3. То есть это уже третий раз, когда он поменял имя. Оба эти события не всегда случаются одновременно. Имя сети может и не поменяться, но поменяется ее тип. При этом вирутальные машины никуда не переезжают, их настройки не меняются. Мне совершенно не понятно, почему может измениться сетевой интерфейс.
Пару раз была ситуация, когда сервер вообще был недоступен по сети после перезагрузки. При подключении к консоли я видел запрос на выбор типа сети. После того, как я указывал тип сети, сервер становился досупен. При этом его сетевые настройки не слетали, везде прописана статика. Конкретно эта ошибка гарантирована не воспроисзводилась, я особо не занимался расследованием. А вот со сменой типа сети сталкиваюсь регулярно, поэтому накопилась статистика.
Изменение типа сети на доменную
Простого способа указать, что данное соединение доменное в windows server нет. Я нашел как минимум 2 рабочих способа, которые гарантированно позволяют вернуть соединению статус Domain Network.
- Способ номер один. Заходим в свойства сетевого подключения и отключаем ipv6. Сеть сразу же становится доменной.
- Способ номер два. Перезапускаем службу Служба сведений о подключенных сетях (Network Location Awareness Service).
Идея полностью отключать ipv6 мне не нравится, потому что неоднократнго видел информацию о том, что она каким-то образом нужна для корректной работы сервера и Microsoft не рекомендует ее отключать.
При втором способе, если сделать для службы тип запуска Автоматически (отложенный запуск), то после перезагрзки сервера статус сети всегда будет доменный. Это вроде как решает проблему, хотя мне кажется, что это больше костыль, чем решение.
В целом, мне не понятно, в чем конкретно проблема и почему она стала проявляться в какой-то определенный момент, причем на разных серверах. Иногда помогает просто перезагрузка, иногда нет. Когда я последний раз исследовал ошибку, она на 100% повторялась на двух серверах с ролью контроллера домена, dhcp и dns сервера. Помогало либо отключение ipv6, либо перезапуск службы. В логах при этом ничего подходящего под указанную проблему не находил.
Причины изменения типа сети
Теоретически, Windows определяет тип сети как доменный, если с соответствующего адаптера достижим контроллер домена, с которого были получены групповые политики. На контроллере домена этот сервер — он сам, все сетевые адаптеры на нём должны определяться как принадлежащие доменной сети. Почему у меня на контроллерах домена сеть оказывалась не доменной, ума не приложу.
Есть мысли, что это из-за настроек ipv6. Изначально там указано получать адрес автоматически. И Windows какой-то адрес получала. Даже не знаю откуда.
Пытался разобраться в теме ipv6, но скажу честно, сходу в нее не вник. Там все как-то не просто и надо погружаться, изучать. Пытался указывать ipv6 адрес вручную, статический. Думал, это может помочь. Почему-то после перезагрузки, настройки слетали обратно на получение адреса автоматически.
Отдельно пробовал настройку Предпочтение протокола IPv4 протоколу IPv6, как описано в руководстве на сайте microsoft. Это не помогло. На проблемном сервере гарантированно получал частную сеть вместо доменной.
Заключение
По факту каких-то проблем из-за данной настройки я не получал. Отличий в настройке фаервола в зависимости от типа сети у меня нет, так что видимых проблем не было. На текущий момент там, где последний раз словил эту ошибку, настроил отложенный запуск службы сведений о подключенных сетях (Network Location Awareness Service). Ошибка больше не воспроизводится. Буду наблюдать дальше.
Если вы сталкивались с подобными ошибками, либо есть советы, что еще попробовать, буду рад комментариям по этой теме.
Источник