Не работает сетевое окружение служба не запущена

Решаем проблему с ошибкой «Сеть отсутствует или не запущена» в Windows 7

Устранение ошибки «Сеть отсутствует или не запущена»

Данная ошибка возникает при неполадках в работе такого компонента, как «Клиент для сетей Microsoft». Далее, по цепочке, происходит сбой в работе очень важной службы с названием «Рабочая станция» и зависимых от нее сервисов. Причины могут быть разные – от простого «каприза» системы до вирусной атаки. Есть еще один неочевидный фактор – отсутствие необходимого пакета обновления.

Способ 1: Конфигурация и перезапуск службы

Речь пойдет о сервисе «Рабочая станция» и сетевом протоколе SMB первой версии. Некоторые узлы сети отказываются работать с устаревшим протоколом, поэтому необходимо сконфигурировать службу таким образом, что бы она работала с SMB версии 2.0.

    Запускаем «Командную строку» от имени администратора.

Подробнее: Вызов «Командной строки» в Windows 7
«Говорим» службе, чтобы она переключилась на протокол второй версии командой

sc config lanmanworkstation depend= bowser/mrxsmb20/nsi

После ввода нажимаем клавишу ENTER.


Далее отключаем SMB 1.0 следующей строкой:

sc config mrxsmb10 start= demand


Перезапускаем службу «Рабочая станция», выполнив по очереди две команды:

net stop lanmanworkstation
net start lanmanworkstation

  • Перезагружаемся.
  • Если во время выполнения указанных выше действий возникают ошибки, следует попытаться переустановить соответствующий системный компонент.

    Способ 2: Переустановка компонента

    «Клиент для сетей Microsoft» позволяет взаимодействовать с сетевыми ресурсами и является одной из важнейших служб. При его сбое неизбежно возникнут проблемы, в том числе и сегодняшняя ошибка. Здесь поможет переустановка компонента.

      Открываем «Панель управления» и переходим к апплету «Центр управления сетями и общим доступом».


    Идем по ссылке «Изменение параметров адаптера».


    Нажимаем ПКМ на то устройство, через которое осуществляется подключение, и открываем его свойства.


    Выделяем в списке «Клиент для сетей Microsoft» и удаляем его.


    Windows запросит подтверждение. Нажимаем «Да».


    Перезагружаем ПК.


    Далее снова заходим в свойства адаптера и нажимаем кнопку «Установить».


    В списке выбираем позицию «Клиент» и жмем «Добавить».


    Выбираем пункт (если вы вручную не устанавливали компоненты, то он будет единственным) «Client for Microsoft Networks» и нажимаем ОК.

  • Готово, компонент переустановлен. Для верности перезагружаем машину.
  • Способ 3: Установка обновления

    Если приведенные выше инструкции не работают, возможно, на вашем компьютере отсутствует обновление KB958644. Оно представляет собой «заплатку» для предотвращения проникновения в систему некоторых вредоносных программ.

      Идем на страницу загрузки пакета на официальном сайте Майкрософт в соответствии с разрядностью системы.


    Получаем файл с названием «Windows6.1-KB958644-х86.msu» или «Windows6.1-KB958644-х64.msu».

    Запускаем его обычным способом (двойным кликом) и ждем окончания установки, после чего перезагружаем машину и пробуем повторить действия по настройке службы и переустановке сетевого компонента.

    Читайте также:  Не работает slick slider при подключении

    Способ 4: Восстановление системы

    Суть данного способа заключается в том, чтобы вспомнить, когда или после каких ваших действий начались проблемы, и восстановить систему с помощью доступных инструментов.

    Способ 5: Проверка на заражение вирусами

    Виной тому, что при работе возникают ошибки, могут быть вредоносные программы. Особенно опасны те, что взаимодействуют с сетью. Они способны перехватывать важные данные или просто «ломать» конфигурацию, изменяя настройки или повреждая файлы. При возникновении неполадок необходимо незамедлительно произвести сканирование и удаление «вредителей». «Лечение» можно проводить и самостоятельно, но лучше обратиться за бесплатной помощью на специальные сайты.

    Как видите, решения задачи по устранению причин ошибки «Сеть отсутствует или не запущена» в целом довольно несложные. Правда, если речь идет о вирусной атаке, ситуация может оказаться весьма серьезной. Удаление вредоносных программ не приведет к желаемому результату, если ими уже были внесены значительные изменения в системные файлы. В таком случае, скорее всего, поможет только переустановка Windows.

    Помимо этой статьи, на сайте еще 12336 инструкций.
    Добавьте сайт Lumpics.ru в закладки (CTRL+D) и мы точно еще пригодимся вам.

    Отблагодарите автора, поделитесь статьей в социальных сетях.

    Источник

    Проблемы с сетевым окружением Windows 2003/XP или злобный вирус kido

    Статья написана для того чтобы потомки не наступали на грабли на которые наступил я.
    Если на вашем сервере/локальном компьютере перестало открываться сетевое окружение с ошибкой «Ни одна из служб доступа к сети не может обработать сетевой путь» добро пожаловать

    Симптомы:

    В общем в один прекрасный день мне позвонил пользователь и сказал что не может по самбе законектиться на основной сервер (естественно он сказал не так, но суть передана) Я попробовал со своего компьютера набрать \\server (имя изменено для удобства понимания) и получил ошибку. хотя сервер прекрасно пинговался и все нужные порты были открыты. После перезагрузки сервера (а это как известно полный ахтунг посреди рабочего дня) сервер проработал около часа и ошибка повторилась. На самом сервере при попытке пойти по сети на любой компьютер \\user получали ошибку «Ни одна из служб доступа к сети не может обработать сетевой путь»

    Анамнез

    Как было сказано ранее порт 445 был открыт. Ошибка «Ни одна из служб» подтолкнуло на мысль что проблема в службах 🙂
    Итак лезем в службы и на вскидку видим следующее: службы сервер, рабочая станция, обозреватель компьютеров упали. Запускаем — работает, минут через 10-15 снова падает. В логах приложений видим ошибку
    «Ошибка приложения svchost.exe, версия 5.2.3790.3959, модуль kernel32.dll, версия 5.2.3790.3959, адрес 0x0006beb8.»
    Сразу после которой падают службы

    Дифференциальный диагноз 1

    Приходим к однозначному выводу что причиной всему некоторый вирус kido, который атакует компы сети по 445 порту, приводя к ошибке buffer-overflow. Решение — запуск kk.exe на всех компьютерах сети. kk.exe — програмка для лечения вируса kido от касперских. Сам антивирус касперского не переношу на дух, хотя проверку провел — сам касперский угроз не обнаружил, а kk.exe — нашел и по всей видимости полечил.

    Читайте также:  Если жена не работает как можно получить декретные

    Лечение

    Пройдя по всем компьютерам сети и запустив kk обнаружили и почистили много этой вирусни. Кроме того дабы обезопасить только что зараженные компьютеры запустили kk в режиме мониторинга «kk -m» и добавили в автозагрузку. После всех этих манипуляций вздохнули свободно, хотели отдохнуть, но не тут то было. Сервисы стали падать не так часто. Но от этого легче не стало! Кстати временное решение проблемы — зайти в свойства одного из сервисов и установить «перезапускать сервер» во всех полях закладки восстановления. Сервисы хоть и падают, но почти сразу восстанавливаются.

    Дифференциальный диагноз 2

    Итак стал думать почему сервисы падают пачками. И что объединяет эти сервисы. ответ оказался прост — один из svchost.exe запускал все эти сервисы. Вот полный список:
    • Обозреватель компьютеров (!)
    • Службы криптографии
    • Диспетчер логических дисков
    • Служба событий COM+
    • Справка и поддержка
    • Сервер (!)
    • Рабочая станция (!)
    • Сетевые подключения (!)
    • Служба сетевого расположения
    • Планировщик заданий (!)
    • Вторичный вход в систему
    • Уведомление о системных событиях
    • Определение оборудования оболочки
    • Клиент отслеживания изменившихся связей
    • Инструментарий управления windows
    • Автоматическое обновление
    • Беспроводная настройка

    В общем мысль пошла далее. Раз вирусов на сервере больше нет, значит вирус все еще есть на каких либо компьютерах сети. И он продолжает атаковать сервер. Но почему сервер от этого падает? Значит есть какаято дыра. А если есть дыра — значит должна быть заплатка. С горем пополам нашел такую заплатку для WinXP — KB958644
    А уж имея название заплатки для Win2003 нашел заплатку без проблем.

    Лечение часть 2

    поставил заплатки на сервер и все компьютеры сети. вместо ошибки
    «Ошибка приложения svchost.exe, версия 5.2.3790.3959, модуль kernel32.dll, версия 5.2.3790.3959, адрес 0x0006beb8.»
    стало появляться предупреждение
    «Отчет об ошибке постановки в очередь: ошибка приложения svchost.exe, версия 5.2.3790.3959, модуль kernel32.dll, версия 5.2.3790.3959, адрес 0x0006beb8.»

    В принципе проблема решена, можно выписывать. Но (!) Раз атаки продолжаются значит вирус еще где то действует. Вот об этом хотелось бы спросить хабрасообщество — как выявить зараженный в сети компьютер?
    Логично предположить что нужно слушать 445 порт — кто лезет, тому и по рогам. Но ведь на сервере пошарено много всего, люди лезутредактируютсоздаютсохранаютсмотрют… Как нормальный траф 445 порта отделить от вредоносного?
    В комментариях жду советов, и надеюсь что в будущем моя статья поможет кому либо побыстрее разобраться с этой проблемой.

    ЗЫЖ автоматическое обновление стояло, 2003 был обновлен — почему то эта заплатка не качается со всеми вместе.

    Источник

    Не работает сетевое окружение служба не запущена

    Этот форум закрыт. Спасибо за участие!

    Спрашивающий

    Вопрос

    На ноуте Aser Aspire 3680 установлена Win xp profа sp2 русская версия.

    Не стартует служба «Сетевые подключения» выдается ошибка 126 «Не найден указанный модуль»

    При этом регистрируется Event id

    Тип события: Ошибка
    Источник события: Service Control Manager
    Категория события: Отсутствует
    Код события: 7023
    Дата: 03.05.2007
    Время: 14:30:36
    Пользователь: Н/Д
    Компьютер: QWE
    Описание:
    Служба «Сетевые подключения» завершена из-за ошибки
    Не найден указанный модуль.
    Тоже со службами «Беспроводная настройка» и «Центр обеспечения безапасности».

    Читайте также:  Как настроить триколор ручной поиск 2 часа

    По поиску удалось найти похожее http://support.microsoft.com/kb/329441/ru, советуют переставить sp1 .

    Все ответы

    Попробуйте перерегистрировать библиотеки, выполняя в командной строке:

    regsvr32 netshell.dll
    regsvr32 netcfgx.dll
    regsvr32 netman.dll

    Следите за сообщениями об успешной регистрации. Затем перезагрузите компьютер.

    Вот тут обсуждается случай точь-в-точь как ваш.

    Как я понял помогло следующее:

    net start netman

    Да мне не повезло

    C:\Documents and Settings\Администратор>net start netman
    Служба «Сетевые подключения» запускается.
    Не удалось запустить службу «Сетевые подключения».

    Системная ошибка 126.

    Не найден указанный модуль.

    У меня все видать еще запущеней.

    Выполните рекомендации статьи

    (там их много ). Судя по другим обсуждениям, проблема довольно неприятная. Мне не удалось найти среди предложений надежное решение.

    Давайте попробую пальцем в небо

    netsh winsock reset

    netsh int ip reset c:\resetlog.txt

    Перезагружаемся, смотрим помогло ли

    Выполнил оба действия.Никаких изменений.

    reset SYSTEM\CurrentControlSet\Services\Dhcp\Parameters\Options\15\RegLocation
    old REG_MULTI_SZ =
    SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\?\DhcpDomain
    SYSTEM\CurrentControlSet\Services\TcpIp\Parameters\DhcpDomain

    added SYSTEM\CurrentControlSet\Services\Netbt\Parameters\Interfaces\Tcpip_<7b2c1f77-b308-4cb9-a082-3b50af1f995b>\NetbiosOptions
    added SYSTEM\CurrentControlSet\Services\Netbt\Parameters\Interfaces\Tcpip_\NetbiosOptions
    deleted SYSTEM\CurrentControlSet\Services\Netbt\Parameters\EnableLmhosts
    added SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<03562a6b-6a20-4186-a996-9c0a8c2c43e3>\AddressType
    added SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<03562a6b-6a20-4186-a996-9c0a8c2c43e3>\DisableDynamicUpdate
    reset SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<03562a6b-6a20-4186-a996-9c0a8c2c43e3>\RawIpAllowedProtocols
    old REG_MULTI_SZ =
    0

    Накатывал 2 sp и систему обновлял.

    Что то мне подсказывает что надо переставлять систему и усе

    Проверьте, присутствует ли библиотека sens.dll в /system32/

    Мне помогло её копирование с другой xp машины. По каким-то причинам, эта библиотека у меня пропала.

    reset SYSTEM\CurrentControlSet\Services\Dhcp\Parameters\Options\15\RegLocation
    old REG_MULTI_SZ =
    SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\?\DhcpDomain
    SYSTEM\CurrentControlSet\Services\TcpIp\Parameters\DhcpDomain

    added SYSTEM\CurrentControlSet\Services\Netbt\Parameters\Interfaces\Tcpip_<23133c35-a922-427c-a77f-12fa7c3cadaf>\NetbiosOptions
    reset SYSTEM\CurrentControlSet\Services\Netbt\Parameters\Interfaces\Tcpip_<608fdb5a-8529-4017-bf44-b3b2ed90da85>\NameServerList
    old REG_MULTI_SZ =

    added SYSTEM\CurrentControlSet\Services\Netbt\Parameters\Interfaces\Tcpip_<608fdb5a-8529-4017-bf44-b3b2ed90da85>\NetbiosOptions
    reset SYSTEM\CurrentControlSet\Services\Netbt\Parameters\Interfaces\Tcpip_\NameServerList
    old REG_MULTI_SZ =

    added SYSTEM\CurrentControlSet\Services\Netbt\Parameters\Interfaces\Tcpip_\NetbiosOptions
    added SYSTEM\CurrentControlSet\Services\Netbt\Parameters\Interfaces\Tcpip_\NetbiosOptions
    deleted SYSTEM\CurrentControlSet\Services\Netbt\Parameters\EnableLmhosts
    added SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<4b7c6c6e-ff44-4d00-a122-ebaac9601708>\AddressType
    added SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<4b7c6c6e-ff44-4d00-a122-ebaac9601708>\DisableDynamicUpdate
    reset SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<4b7c6c6e-ff44-4d00-a122-ebaac9601708>\RawIpAllowedProtocols
    old REG_MULTI_SZ =
    0

    reset SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<4b7c6c6e-ff44-4d00-a122-ebaac9601708>\TcpAllowedPorts
    old REG_MULTI_SZ =
    0

    reset SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<4b7c6c6e-ff44-4d00-a122-ebaac9601708>\UdpAllowedPorts
    old REG_MULTI_SZ =
    0

    deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<608fdb5a-8529-4017-bf44-b3b2ed90da85>\NameServer
    added SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<7fc156a1-ee5d-4391-8792-1564acf63f2c>\DisableDynamicUpdate
    deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<7fc156a1-ee5d-4391-8792-1564acf63f2c>\IpAutoconfigurationAddress
    deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<7fc156a1-ee5d-4391-8792-1564acf63f2c>\IpAutoconfigurationMask
    deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<7fc156a1-ee5d-4391-8792-1564acf63f2c>\IpAutoconfigurationSeed
    reset SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<7fc156a1-ee5d-4391-8792-1564acf63f2c>\RawIpAllowedProtocols
    old REG_MULTI_SZ =
    0

    reset SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<7fc156a1-ee5d-4391-8792-1564acf63f2c>\TcpAllowedPorts
    old REG_MULTI_SZ =
    0

    reset SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<7fc156a1-ee5d-4391-8792-1564acf63f2c>\UdpAllowedPorts
    old REG_MULTI_SZ =
    0

    reset SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\\DefaultGateway
    old REG_MULTI_SZ =
    192.168.97.132

    reset SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\\DefaultGatewayMetric
    old REG_MULTI_SZ =
    0

    added SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\\DisableDynamicUpdate
    reset SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\\EnableDhcp
    old REG_DWORD = 0

    reset SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\\IpAddress
    old REG_MULTI_SZ =
    192.168.4.224

    deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\\IpAutoconfigurationAddress
    deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\\IpAutoconfigurationMask
    deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\\IpAutoconfigurationSeed
    reset SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\\NameServer
    old REG_SZ = 192.168.97.132

    reset SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\\RawIpAllowedProtocols
    old REG_MULTI_SZ =
    0

    reset SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\\SubnetMask
    old REG_MULTI_SZ =
    255.255.255.0

    reset SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\\TcpAllowedPorts
    old REG_MULTI_SZ =
    0

    reset SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\\UdpAllowedPorts
    old REG_MULTI_SZ =
    0

    deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\\NameServer
    added SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\\AddressType
    added SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\\DisableDynamicUpdate
    reset SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\\RawIpAllowedProtocols
    old REG_MULTI_SZ =
    0

    reset SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\\TcpAllowedPorts
    old REG_MULTI_SZ =
    0

    reset SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\\UdpAllowedPorts
    old REG_MULTI_SZ =
    0

    deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\DefaultTtl
    deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\DontAddDefaultGatewayDefault
    deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\EnableIcmpRedirect
    deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\EnablePmtuBhDetect
    deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\EnablePmtuDiscovery
    deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\EnableSecurityFilters
    deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\GlobalMaxTcpWindowSize
    deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\SackOpts
    deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\SearchList
    deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Tcp1323Opts
    deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\TcpWindowSize
    deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\UseDomainNameDevolution
    reset Linkage\UpperBind for ROOT\MS_NDISWANIP\0000. bad value was:
    REG_MULTI_SZ =
    PSched

    reset Linkage\UpperBind for PCI\VEN_8086&DEV_4222&SUBSYS_10018086&REV_02\4&76610A1&0&00E5. bad value was:
    REG_MULTI_SZ =
    PSched

    reset Linkage\UpperBind for PCI\VEN_11AB&DEV_4363&SUBSYS_17051043&REV_13\4&41FE850&0&00E0. bad value was:
    REG_MULTI_SZ =
    PSched

    Источник

    Оцените статью