Не работает solidworks flexnet server
В таблице ниже приведены коды наиболее распространенных ошибок FlexNet, о которых может сообщать Autodesk Network License Manager. Коды ошибок, как правило, имеют вид «Ошибка [1.5.###]», где ### соответствует коду ошибки, указанному в таблице.
| Код ошибки | Описание |
| 21 | Сбой lc_flexinit из-за отсутствия прав на запуск службы FlexNet Publisher. Проблема устраняется настройкой автоматического запуска службы. |
| 20 | Служба FlexNet Publisher не установлена. |
| 13 | Расчетный путь к нужному файлу слишком длинный для операционной системы Mac OS X. |
| 12 | Недопустимый идентификатор пакета в операционной системе Mac OS X. |
| 11 | Платформа, указанная идентификатором пакета, не загружена. |
| 10 | Ошибка при создании пути из URL-адреса. |
| 9 | Ошибка при создании URL-адреса. |
| 8 | Строка пути задана не в формате UTF-8. |
| 7 | Вызов lc_flexinit запрещен после вызова lc_flexinit_cleanup. |
| 6 | Приложение для активации не обработано с помощью программы подготовки. |
| 5 | Не удалось выделить ресурсы. |
| 4 | Сбой инициализации. |
| 3 | Неподдерживаемая версия операционной системы. |
| 2 | Не удалось загрузить библиотеку активации. |
| 1 | Не удалось найти библиотеку активации. |
| -1 | Не удалось найти файл лицензии. |
| -2 | Недопустимый синтаксис файла лицензии. |
| -3 | Отсутствует система серверов лицензий для данного объекта. |
| -4 | Достигнуто максимальное число лицензированных пользователей. |
| -5 | Нет такого объекта. |
| -6 | В файле лицензии не указан номер порта TCP/IP, и служба лицензирования FlexNet Service не существует (только до версии 6). |
| -7 | Отсутствует соединение сокета со службой диспетчера серверов лицензий. |
| -8 | Недопустимый (несогласованный) ключ или подпись лицензии. Ключ/подпись лицензии и данные объекта не совпадают. Обычно это происходит, если файл лицензии был изменен. |
| -9 | Недопустимый хост. Идентификатор хоста данной системы не совпадает с идентификатором хоста, указанным в файле лицензии. |
| -10 | Срок действия объекта истек. |
| -11 | Недопустимый формат даты в файле лицензии. |
| -12 | Из системы серверов лицензий возвращены недопустимые данные. |
| -13 | Строки SERVER отсутствуют в файле лицензий. |
| -14 | Не удается найти имя хоста SERVER в сетевой базе данных. Поиск имени хоста в строке SERVER в файле лицензий завершился неудачей. Это часто происходит при наличии недопустимых NIS, DNS или файла хостов. Решение: вместо имени хоста используйте IP-адрес (например, 123.456.789.123). |
| -15 | Не удается подключиться к системе серверов лицензий. Сервер (lmadmin или lmgrd) еще не запущен, либо используется неверный порт и хост, либо порт TCP/IP или имя хоста в файле лицензии были изменены. В Windows XP с пакетом обновления 2 существует ограничение на количество попыток TCP/IP-соединения в секунду, которое могло быть превышено. Об изменении ограничения можно узнать в документации производителя. |
| -16 | Не удалось прочитать данные из системы серверов лицензий. |
| -17 | Не удалось записать данные в систему серверов лицензий. |
| -18 | Система серверов лицензий не поддерживает данный объект. |
| -19 | Ошибка при выборе вызова системы. |
| -20 | Система серверов лицензий занята (нет большинства). |
| -21 | Файл лицензии не поддерживает данную версию. |
| -22 | В системе серверов лицензий обнаружен сбой при возврате объекта. |
| -23 | Система серверов лицензий временно занята (подключается новый сервер). |
| -24 | Пользователи добавлены в очередь для данного объекта. |
| -25 | Система серверов лицензий не поддерживает данную версию объекта. |
| -26 | Запрашивается больше лицензий, чем поддерживает данный объект. |
| -29 | Не удалось найти устройство Ethernet. |
| -30 | Не удалось прочитать файл лицензии. |
| -31 | Дата запуска объекта запланирована на будущее. |
| -32 | Нет такого атрибута. |
| -33 | Неправильная синхронизация шифрования с управляющей программой поставщика. |
| -34 | Слишком большая разница между часами клиента и системы серверов лицензий. |
| -35 | В очереди на данный объект. |
| -36 | База данных объекта повреждена в управляющей программе поставщика. |
| -37 | Несоответствие повторного выбора для данного объекта. Не поддерживается управляющей программой поставщика версии 8.0 или более поздней. |
| -38 | Пользователь/хост находятся в списке ИСКЛЮЧЕНИЙ для объекта. |
| -39 | Пользователь/хост не входят в список ВКЛЮЧЕНИЯ для объекта. |
| -40 | Не удается выделить динамическую память. |
| -41 | Объект не выдавался. |
| -42 | Недопустимый параметр. |
| -47 | Проверка настройки часов недоступна в управляющей программе поставщика. |
| -52 | Управляющая программа поставщика не откликнулась в течение времени ожидания. |
| -53 | Запрос о выдаче отклонен фильтром выдачи, определенным поставщиком. |
| -54 | В файле лицензии отсутствует строка FEATURESET. |
| -55 | Недопустимая строка FEATURESET в файле лицензии. |
| -56 | Невозможно вычислить данные FEATURESET из файла лицензии. |
| -57 | Не удалось вызвать сокет. |
| -59 | Ошибка контрольной суммы сообщения. |
| -60 | Ошибка контрольной суммы сообщения от системы серверов лицензий. |
| -61 | Не удается прочитать файл лицензии из системы серверов лицензий. |
| -62 | Сетевое программное обеспечение (TCP/IP) недоступно. |
| -63 | Вы не являетесь администратором лицензий. |
| -64 | Команда lmremove запрошена до истечения минимального интервала. |
| -67 | Нет лицензий, доступных для заимствования. |
| -68 | Поддержка ЗАИМСТВОВАНИЯ лицензий не включена. |
| -69 | FLOAT_OK не может работать автономно в системе серверов лицензий. |
| -71 | Недопустимая переменная среды часового пояса (TZ). |
| -73 | Локальный фильтр выдачи отклонил запрос. |
| -74 | Попытка чтения после конца пути к файлу лицензий. |
| -75 | Ошибка вызова SYS$SETIMR (VMS). Сообщает об ошибке вследствие сбоя операционной системы. |
| -76 | Внутренняя ошибка лицензирования FlexNet. Сообщите об ошибке в компанию Flexera Software. |
| -77 | Неверный номер версии, должно быть число с плавающей точкой и без букв. |
| -82 | Недопустимая строка PACKAGE в файле лицензий. |
| -83 | Версия FlexNet Licensing у клиента более новая, чем у сервера. |
| -84 | Не указаны пользователи лицензии USER_BASED; см. журнал серверов лицензий. |
| -85 | Система серверов лицензий не поддерживает этот запрос. |
| -87 | Выдача превышает максимальное значение, указанное в файле параметров. |
| -88 | Системные часы переведены назад. |
| -89 | Платформа не авторизована лицензией. |
| -90 | Неизвестный формат файла лицензии или орфографическая ошибка в файле лицензии. Файл сформирован для более поздней версии FlexNet Licensing, которая не поддерживается данной программой. |
| -91 | Источники шифрования не являются уникальными. |
| -92 | Объект удален при выполнении команды lmreread, или использован недопустимый идентификатор хоста в строке SERVER. |
| -93 | Данный объект доступен в другом пуле лицензий. Данная ошибка является предупреждением. Сервер поместил одну или несколько строк INCREMENT в один и тот же пул; запрос сделан к строке INCREMENT, которая помещена в пул. |
| -94 | Попытка создать лицензию с несовместимыми атрибутами. |
| -95 | Ошибка сетевого подключения к THIS_HOST. Измените значение this_host в строке SERVER файла лицензии на фактическое имя хоста. |
| -96 | Сервер лицензий отключен или не отвечает. Попросите системного администратора включить сервер или проверьте, связываетесь ли вы с нужным сервером. |
| -97 | Требуемая управляющая программа поставщика отключена. 1. Проверьте файл журнала lmadmin или lmgrd. 2. Попробуйте запустить команду lmreread. |
| -98 | Невозможно преобразовать строку FEATURE в десятичный формат. |
| -99 | Номер лицензии с десятичным форматом введен неправильно. |
| -100 | Невозможно удалить заимствованную лицензию. |
| -101 | Все лицензии зарезервированы для других пользователей. Системный администратор зарезервировал все лицензии для других пользователей. Резервирование настраивается в файле параметров. Чтобы изменения в файле параметров вступили в силу, необходимо перезагрузить сервер. |
| -102 | Ошибка заимствования FLEXid. |
| -103 | Удаленный клиент сервера терминалов запрещен. |
| -104 | Невозможно заимствовать на этот срок. |
| -105 | Объект уже возвращен на сервер лицензий. |
| -106 | Система серверов лицензий не подключена к сети. Управляющая программа поставщика не в состоянии обработать больше пользователей. Подробные сведения см. в журнале отладки. |
| -110 | Не удается прочитать аппаратный ключ: проверьте аппаратный ключ или драйвер. Аппаратный ключ не присоединен, либо не установлен драйвер для данного типа аппаратного ключа. |
| -112 | Отсутствует драйвер аппаратного ключа. Чтобы прочитать идентификатор хоста FLEXid, необходимо установить подходящий драйвер. Драйверы доступны у разработчика ПО. |
| -114 | Требуется ключевое слово SIGN=, отсутствующее в сертификате лицензии. Необходимо получить версию SIGN= данной лицензии у поставщика. |
| -115 | Ошибка в пакете «Открытый ключ». |
| -116 | TRL не поддерживается для данной платформы. |
| -117 | Ошибка ЗАИМСТВОВАНИЯ. |
| -118 | Период ЗАИМСТВОВАНИЯ истек. |
| -119 | На сервере лицензий необходимо запустить команды lmdown и lmreread. |
| -120 | Не удается применить команду lmdown к серверу при заимствовании лицензии. |
| -121 | Для FLOAT_OK требуется ровно один идентификатор хоста FLEXid. |
| -122 | Не удалось удалить локальную информацию о заимствовании. |
| -123 | Преждевременный возврат заимствованных лицензий не поддерживается. Для получения подробной информации свяжитесь с разработчиком. |
| -124 | Ошибка возврата заимствованной лицензии. |
| -125 | Необходимо указать компонент PACKAGE. |
| -126 | Составной идентификатор хоста не инициализирован. |
| -127 | Элемент, необходимый для составного идентификатора хоста, отсутствует или является недопустимым. |
| -128 | Ошибка: заимствованная лицензия не соответствует ни одной лицензии сервера. |
| -135 | Ошибка при включении журнала событий. |
| -136 | Журнал событий отключен. |
| -137 | Ошибка записи в журнал событий. |
| -139 | Время ожидания связи истекло. |
| -140 | Недопустимая команда сообщения. |
| -141 | Ошибка записи в сокет. Сокет закрыт одноранговым узлом. |
| -142 | Ошибка: невозможно создать лицензию для версии, привязанную к одному составному идентификатору хоста. |
| -143 | Подписи для отдельных версий не поддерживаются для несчетных лицензий. |
| -144 | Шаблон лицензий содержит лишние спецификаторы подписей. |
| -145 | Недопустимая подпись V71_LK. |
| -146 | Недопустимая подпись V71_SIGN. |
| -147 | Недопустимая подпись V80_LK. |
| -148 | Недопустимая подпись V80_SIGN. |
| -149 | Недопустимая подпись V81_LK. |
| -150 | Недопустимая подпись V81_SIGN. |
| -151 | Недопустимая подпись V81_SIGN2. |
| -152 | Недопустимая подпись V84_LK. |
| -153 | Недопустимая подпись V84_SIGN. |
| -154 | Недопустимая подпись V84_SIGN2. |
| -155 | Необходим ключ лицензии, но его нет в сертификате лицензии. Приложению требуется наличие ключа лицензии в сертификате лицензии. Необходимо получить версию ключа лицензии для данного сертификата от разработчика. |
| -156 | С помощью ключевого слова AUTH= указана недопустимая подпись. |
| -157 | Доверенное хранилище взломано; требуется восстановление. Инструкции по восстановлению можно получить у разработчика. |
| -158 | Сбой при открытии доверенного хранилища. Подробные сведения можно узнать у разработчика. |
| -159 | Недопустимая запись операции. Подробные сведения можно узнать у разработчика. |
| -160 | Получен недопустимый запрос об активации. Подробные сведения можно узнать у разработчика. |
| -161 | В доверенном хранилище отсутствует операция, соответствующая запросу. Подробные сведения можно узнать у разработчика. |
| -162 | Получен недопустимый ответ об активации. Подробные сведения можно узнать у разработчика. |
| -163 | Не удалось вернуть указанную активацию. Подробные сведения можно узнать у разработчика. |
| -164 | Количество возвратов превысит максимум для данной операции. Подробные сведения можно узнать у разработчика. |
| -165 | Не осталось доступных восстановлений. Для авторизации дополнительных восстановлений обратитесь к разработчику. |
| -166 | Указанная операция запрещена. Подробные сведения можно узнать у разработчика. |
| -167 | Запрошенная активация отклонена, так как настройки в файле параметров не разрешают пользователю или хосту активировать данное право. |
| -168 | Файл параметров содержит настройки прав, в которые не включен этот пользователь или хост. |
| -169 | Ошибка активации. Подробные сведения можно узнать у разработчика. |
| -170 | Недопустимый формат даты в доверенном хранилище. Причиной может быть перевод системных часов на более раннюю дату. Убедитесь, что системные часы настроены на текущую дату и время. |
| -171 | Ошибка шифрования сообщения. Внутренняя ошибка. Отправьте отчет в компанию Flexera Software Inc. |
| -172 | Ошибка расшифровки сообщения. Внутренняя ошибка. Отправьте отчет в компанию Flexera Software Inc. |
| -173 | Недопустимый параметр фильтра. Внутренняя ошибка. Отправьте отчет в компанию Flexera Software Inc. |
| -174 | Конфликт объекта SUPERSEDE. Подробные сведения можно узнать у разработчика. |
| -175 | Недопустимый синтаксис SUPERSEDE_SIGN. Подробные сведения можно узнать у разработчика. |
| -176 | SUPERSEDE_SIGN не содержит имени объекта и подписи лицензии. Подробные сведения можно узнать у разработчика. |
| -177 | ONE_TS_OK не поддерживается данной платформой Windows. |
| -178 | Внутренняя ошибка. Отправьте отчет в компанию Flexera Software Inc. |
| -179 | Разрешена только одна выдача данного объекта удаленному клиенту сервера терминалов. |
| -180 | Внутренняя ошибка. Отправьте отчет в компанию Flexera Software Inc. |
| -181 | Внутренняя ошибка. Отправьте отчет в компанию Flexera Software Inc. |
| -182 | Внутренняя ошибка. Отправьте отчет в компанию Flexera Software Inc. |
| -183 | В составном определении идентификатора хоста не может быть несколько идентификаторов хоста Ethernet. Подробные сведения можно узнать у разработчика. |
| -184 |