Не работают ftp сервера

Содержание
  1. Помощь
  2. Вход в личный кабинет
  3. Регистрация клиента
  4. Сообщить об ошибке
  5. Решение наиболее частых проблем с FTP
  6. Невозможно подключиться к серверу по FTP
  7. ОС CentOS
  8. ОС Debian/Ubuntu
  9. Невозможно просмотреть .htaccess по FTP
  10. Невозможно подключиться пользователем root по FTP
  11. Ошибки при работе с FTP
  12. Медленная работа FTP
  13. Неправильная загрузка файлов
  14. Ошибка: Bad IP connecting
  15. Ошибка: 530 Login incorrect
  16. Превышено количество FTP-пользователей
  17. FTP. Решение проблем
  18. Проверка режима FTP
  19. Ошибка Unable to connect to remote host: Connection refused
  20. Ошибка 530 Login incorrect
  21. FTP — частые проблемы
  22. Содержание
  23. По ftp не видно файлов .htaccess
  24. Не могу зайти пользователем root
  25. Не могу подключиться по FTP
  26. Debian
  27. Установлен ли FTP-сервер
  28. Запущен ли FTP-сервер (открыт ли 21 порт)?
  29. Запрет для пользователя
  30. Security или Firewall
  31. CentOS
  32. Установлен ли FTP-сервер?
  33. Запущен ли FTP-сервер? (открыт ли 21 порт)
  34. Запрет для пользователя.
  35. Security или Firewall
  36. Ubuntu
  37. Установлен ли FTP-сервер?
  38. Запущен ли FTP-сервер? (открыт ли 21 порт)
  39. Запрет для пользователя.
  40. Security или Firewall
  41. Что делать если не удается подключиться к ftp серверу?

Помощь

Вход в личный кабинет

Регистрация клиента

Сообщить об ошибке

  1. Помощь
  2. Загрузить свой сайт
  3. Решение наиболее частых проблем с FTP

Решение наиболее частых проблем с FTP

Невозможно подключиться к серверу по FTP

Проверьте, установлен ли FTP-сервер на удаленном сервере.

ОС CentOS

В примере ответ сервера означает, что сервер FTP установлен. В случае, если сервер не установлен, ответ будет либо пустым, либо содержать сообщение о том, что FTP не установлен. В этом случае выполните установку FTP-сервера командой

ОС Debian/Ubuntu

В примере ответ сервера означает, что сервер FTP установлен. В случае, если сервер не установлен, ответ будет либо пустым либо содержать сообщение о том, что FTP не установлен. В этом случае выполните установку FTP-сервера командой

Проверьте, запущен ли сервис FTP на удаленном сервере. Выполните команду

В результате выполнится проверка, открыт ли 21 порт на удаленном сервере и есть ли соединение через этот порт. Если команда telnet не работает, то установите утилиту

Проверить работоспособность 21 порта на удаленном сервере можно командой

Результат выполнения команды “21. *LISTEN” говорит о том, что 21 порт открыт и прослушивается.

Для альтернативной проверки работоспособности ftp выполните команду

Если команда netstat не работает, то установите утилиту командой

Если в результате выполнения вышеперечисленных команд, вы убедились, что 21 порт закрыт, выполните команду, запускающую ftp сервис

Проверьте разрешения пользователя на подключение по FTP.

Перечень пользователей, которым запрещен доступ по FTP, находится в файле /etc/ftpusers. Убедитесь, что в нем отсутствует имя пользователя, который не может подключиться к серверу. Для ОС CentOS 6 выполните команды

Проверьте, не блокирует ли фаервол IP-адрес, с которого выполняется подключение к серверу. Выполните команду

Просмотрите ответ команды и убедитесь, что 21 порт не заблокирован фаерволом.

Невозможно просмотреть .htaccess по FTP

В UNIX-подобных операционных системах все файлы, которые начинаются с точки, являются скрытыми. При подключении по FTP укажите, что нужно показать скрытые файлы. Мы рекомендуем использовать FTP-клиент Filezilla, который находится в открытом доступе на сайте http://filezilla.ru/.

Альтернативным вариантом является отображение скрытых файлов для любых подключений. Эта настройка выполняется на FTP-сервере. Например, для proftpd в конфигурационный файл /usr/local/etc/proftpd.conf добавьте строку

Если вы используете ISPmanager, то данная настройка выполнена по умолчанию.

Невозможно подключиться пользователем root по FTP

По протоколу FTP доступ суперпользователю root закрыт в целях безопасности. Используйте протокол SFTP либо подключайтесь другим пользователем.

Источник

Ошибки при работе с FTP

При работе с протоколом FTP могут возникать сложности. Основные проблемы и методы их решения описаны в статье.

Читайте также:  Шевроле круз не работает приборка

Медленная работа FTP

  • При подключении используйте пассивный режим передачи файлов. Если вы используете FTP-клиент FileZilla, в меню «Менеджер сайтов» на вкладке «Настройки передачи» выберите режим передачи: Пассивный.
  • Отключите TLS-соединение, если оно включено. Для этого выберите тип шифрования Использовать обычный FTP.

Неправильная загрузка файлов

Как правило, FTP-клиенты самостоятельно определяют режим работы по типу файла. Но иногда происходят ошибки и файлы загружаются неправильно. Чаще всего это происходит при загрузке зашифрованных бинарных файлов с расширением .php. В таком случае выберите необходимый режим загрузки файлов:

для передачи текстовых файлов, html-документов, php-скриптов, css-таблиц и т. п. — текстовый (ASCII);

для передачи картинок, исполняемых файлов, зашифрованных скриптов и т. п. — двоичный (бинарный, binary или bin).

В FileZilla режим загрузки файлов можно выбрать в меню «Передача» на вкладке Режим передачи.

Ошибка: Bad IP connecting

Эта ошибка говорит о том, что IP-адрес, с которого было инициировано соединение, изменился. Это значит, что ваш интернет-провайдер предоставляет динамический IP, который изменился в ходе разрыва сессии. Перезагрузите роутер или переустановите интернет-соединение на компьютере и попробуйте подключиться заново.

Ошибка: 530 Login incorrect

Эта ошибка означает, что логин или пароль доступа к FTP введены неверно. Проверьте, верно ли вы указываете логин и пароль при подключении.

Посмотреть логин и пароль основного FTP-аккаунта можно на странице услуги в Личном кабинете.

Если вы меняли пароль от основного или дополнительного аккаунта FTP, восстановите или смените его по инструкции.

Превышено количество FTP-пользователей

Данная ошибка означает, что вы уже создали максимальное количество FTP-аккаунтов на вашем тарифе.

Увидеть текущий лимит FTP-аккаунтов вы можете в панели управления: раздел Главное, вкладка Ограничения:

Чтобы добавить новый FTP-аккаунт, удалите один из уже существующих или повысьте тарифный план.

В разделе FTP-пользователи два раза кликните по пользователю и нажмите Удалить:

Источник

FTP. Решение проблем

Иногда случаются проблемы с подключением по FTP. Для того, чтобы оперативно решить такую задачу, необходимо выполнить диагностические меры, описанные ниже.

Проверка режима FTP

Первым делом стоит проверить, какой режим FTP используется. Рекомендуется использовать Пассивный, к примеру в клиенте Filezilla это настраивается во вкладке Редактирование -> Настройки -> FTP

Если изначально режим используется пассивный, то стоит проверить, не блокирует ли соединение локальный брендмауер (фаервол) или антивирус. Для этого банально отключаем поочередно брендмауер и антивирус и подключаемся еще раз. Если проблема осталась актуальной, то проведём диагностику подключения.

Для начала, проверим подключение к серверу через утилиту telnet, в качестве имени сервера указываем название, которое можно посмотреть в личном кабинете в разделе FTP (в нашем случае — это matrix.beget.com).

Если все в порядке, то должно будет появиться приглашение сервера, что-то вроде этого:

Ошибка Unable to connect to remote host: Connection refused

Означает, что FTP-клиент не может соединиться с сервером. Обычно ошибка выглядит примерно так:

Как правило, здесь имеют место быть три причины:

  • блокировка ftp-подключения брандмауэром (файерволом) или антивирусом Вашего компьютера;
  • блокировка вашего внешнего ip-адреса на нашем сервере;
  • проблемы на стороне промежуточных узлов (между нашим сервером и вашим компьютером).

Чтобы попробовать определить на каком узле происходит обрыв, нужно сделать трассировку маршрута командой traceroute:

В Mac OS X команда будет выглядеть так:

Должно появиться примерно следующее:

Также стоит пропинговать хост утилитой ping:

Должно появиться примерно следующее:

Возможно проблема связана с тем, что Ваш внешний IP-адрес заблокирован на сервере, для проверки идем на сайт http://myip.ru/, он отобразит Ваш внешний IP-адрес. Его нужно сообщить технической поддержке, чтобы специалисты проверили, не заблокирован ли указанный IP-адрес на сервере, к которому идет подключение. Лучше всего обратиться, написав тикет из Личного кабинета (раздел «Связь» или «Помощь и поддержка»). В тикете необходимо предоставить вывод команд ping, tracert (traceroute) и внешний IP-адрес, который Вы узнали на сайте http://myip.ru/. Не лишним будет указать также данные, с которыми Вы пытаетесь подключиться, так как зачастую ошибка в подключении кроется в неверно вводимых данных: логин, пароль, имя сервера.

Ошибка 530 Login incorrect

Очень распространённая ошибка «Login incorrect«. В журнале FTP-клиентов она выглядит примерно так:

Читайте также:  Форд фокус не работает печка стеклоподъемники

Означает эта ошибка то, что передаваемые логин, пароль или сервер ошибочные. В этом случае перепроверьте правильность введённых данных и исправьте ошибку.

Удачной работы! Если возникнут вопросы — напишите нам, пожалуйста, тикет из Панели управления аккаунта, раздел «Помощь и поддержка».

Источник

FTP — частые проблемы

Статья давно не обновлялась, поэтому информация могла устареть.

Содержание

По ftp не видно файлов .htaccess

В *nix системах все файлы начинающиеся с точки считаются скрытыми. Обычно в настройках ftp клиента есть галочка «показывать скрытые файлы». Для вашего же удобства используйте FTP клиент: Filezilla, который доступен для бесплатного скачивания на официальном сайте: http://filezilla.ru/ Так же возможно сделать чтобы ftp сервер их всегда отображал. Для proftpd надо прописать в файл (для FreeBSD) /usr/local/etc/proftpd.conf строку

В шаблонах с ISPmanager данная опция, как правило, прописана по-умолчанию

Не могу зайти пользователем root

Так как протокол ftp не предполагает шифрования то во время передачи сравнительно легко украсть пароль. Из соображений безопастности доступ пользователем root по ftp отключен. Это стандартная настройка. Если вам всё же необходимо иметь доступ к серверу через ftp протокол, то используйте протокол SFTP.

Не могу подключиться по FTP

Debian

Установлен ли FTP-сервер

Удостоверьтесь, что сервер установлен и сервис запущен, в Debian вы можете использовать команду dpkg:

Или запустить следующую команду:

В любом случае, если ftp пакет установлен, будет возвращен ответ сервера, если ftp не установлен, команда покажет вам это, или не будет ответа вообще, в таком случае FTP сервер необходимо установить:

Запущен ли FTP-сервер (открыт ли 21 порт)?

Подключитесь к серверу, используя ssh, и попробуйте команду telnet (посмотреть открыт ли 21 порт):

Следующим шагом запускаем команду netstat -tulpn, смотрим запущен ли 21 порт:

Или попробуйте следующую команду:

Если порт не открыт, запустите ftp-сервис/сервер. Используйте следующую команду:

Запрет для пользователя

Если у пользователя не получается использовать ваш ftp сервер, удостоверьтесь, что он имеет разрешение. Файл /etc/ftpusers — список пользователей, которым запрещен доступ по ftp, убедитесь, что пользователь не в этом файле.

Security или Firewall

Убедитесь, что firewall/tcpd не блокирует подключение к вашему ftp серверу. Запустите следующую команду:

Если в ответе вы увидите, что 21 порт заблокирован firewall, вам нужно использовать iptables rules для порта 21. Так же убедитесь, что файл /etc/hosts.deny не блокирует подключение к 21 порту для вашего хоста.

CentOS

Установлен ли FTP-сервер?

Удостоверьтесь, что сервер установлен и сервис запущен, в CentOS вы можете использовать команду rpm:

В любом случае, если ftp пакет установлен, будет возвращен ответ сервера, если ftp не установлен, команда покажет вам это, или не будет ответа вообще, в таком случае FTP сервер необходимо установить:

Запущен ли FTP-сервер? (открыт ли 21 порт)

Подключитесь к серверу, используя ssh, и попробуйте команду telnet (посмотреть открыт ли 21 порт:

Читайте также:  Где взять справку что не работаешь пенсионеру

Следующим шагом запускаем команду netstat -tulpn, посмотреть запущен ли 21 порт:

Или попробуйте следующую команду:

Если порт не открыт, запустите ftp-сервис/сервер. Используйте следующую команду: Centos 6

Запрет для пользователя.

Если у пользователя не получается использовать ваш ftp сервер, удостоверьтесь, что он имеет разрешение. Файл /etc/ftpusers — список пользователей, которым запрещен доступ по ftp, убедитесь, что пользователь не в этом файле.

Security или Firewall

Убедитесь, что firewall/tcpd не блокирует подключение к вашему ftp серверу. Запустите следующую команду:

Если в ответе вы увидите, что 21 порт заблокирован firewall, вам нужно использовать правила iptables для порта 21. Так же убедитесь, что файл /etc/hosts.deny не блокирует подключение к 21 порту для вашего хоста.

Ubuntu

Установлен ли FTP-сервер?

Удостоверьтесь, что сервер установлен, в Ubuntu вы можете использовать команду dpkg:

В любом случае, если ftp-пакет установлен, будет возвращен ответ сервера, если ftp не установлен, команда покажет вам это, или не будет ответа вообще, в таком случае FTP-сервер необходимо установить:

Запущен ли FTP-сервер? (открыт ли 21 порт)

Подключитесь к серверу, используя ssh, и попробуйте команду telnet (посмотреть открыт ли 21 порт):

Следующим шагом запускаем команду netstat -tulpn, посмотреть запущен ли 21 порт:

Или попробуйте следующую команду:

Если порт не открыт, запустите FTP-сервис/сервер. Используйте следующую команду:

Запрет для пользователя.

Если у пользователя не получается использовать ваш FTP-сервер, удостоверьтесь, что он имеет разрешение. Файл /etc/ftpusers — список пользователей, которым запрещен доступ по FTP, убедитесь, что пользователь не в этом файле.

Security или Firewall

Убедитесь, что firewall/tcpd не блокирует подключение к вашему ftp-серверу. Запустите следующую команду:

Источник

Что делать если не удается подключиться к ftp серверу?

Помощь в написании контрольных, курсовых и дипломных работ здесь.

Не удается подключиться к серверу mysql
логин и пароль точно верные, через phpmyadmin нормально с ними захожу. через mysql_connect .

Не удается подключиться к прокси-серверу
Не удается подключиться к прокси-серверу во всех браузерах, снятие галочек в свойствах браузера не.

Не удается подключиться к серверу ldap
Доброго дня. Изучаю ldap, перешёл к «практике») Накатил на VB убунту, там собственно поселил.

понятно — web-версия обычного ftp-клиента.

Ну и? На этом сайте у тебя все работает (т.е. положительный конект), а из других источников не пускает?
Что пишет? Какие ошибки? Лог ftp-сервера покажи

Добавлено через 7 минут

а про безопасность не забыл? ты же на этом сайте вводишь все данные для «кулхацкеров» Где гарантия, что твои учетные данные не снифятся и не «утекут» на сторону?
Это как сайт для проверки надежности Вашего пароля от админки роутера
Я бы не пользовался такими.

Добавлено через 1 час 31 минуту

Не выводит никаких ошибок и потом появляется окно не удалось установить соединение

Добавлено через 7 минут
Странная штука не могу подключиться к ftp://ftp.microsoft.com хотя по идее это открытый сервер

Не удается подключиться к прокси-серверу
Запускаю хром,яндекс,ие и при загрузке страниц выдает сообщение: Не удается подключиться к.

Не удается подключиться к SQL серверу
Доброго времени суток . У меня следующая проблема. Устанавливаю Microsoft SQL Server Express.

Не удается подключиться по ftp и залить файл
В программе я авторизуюсь и закачиваю файл с локалки на удаленный ftp, программа компилится, но у.

не удается подключиться к серверу через ilo Remote Control
Добрый день, народ имеется блэйд сервер hp. Не могу нормально зайти в управление на этот сервер.

Источник

Оцените статью