- get — PHP $ _GET перестал работать
- Решение
- сайт не работает с get параметром
- Рекомендуемые сообщения
- Для публикации сообщений создайте учётную запись или авторизуйтесь
- Создать учетную запись
- Войти
- Похожий контент
- Последние посетители 0 пользователей онлайн
- Не передается GET параметр
- Решение
- Ошибка Я. Вебмастера: найдены страницы дубли с GET-параметрами — что делать
- Что такое get-параметры на сайте
- Как избавиться от ошибки — Найдены страницы дубли с GET-параметрами
- Как использовать Clean-param
- Как использовать Disallow
- Ошибка Я. Вебмастера: найдены страницы дубли с GET-параметрами — что делать
- Что такое get-параметры на сайте
- Как избавиться от ошибки — Найдены страницы дубли с GET-параметрами
- Как использовать Clean-param
- Как использовать Disallow
get — PHP $ _GET перестал работать
Поэтому я использовал $ _GET для доступа к статьям, передавая идентификатор статьи через URL и читая этот идентификатор на следующей странице, чтобы можно было извлечь все значения, относящиеся к статье.
Код прохода выглядит следующим образом
Пока есть статьи, получайте изображения, делайте ссылки на изображения, а затем, когда изображение щелкнет, добавьте «id = #» в конец URL.
И, как и ожидалось, когда ссылка нажата, я получаю это.
Пока все выглядит нормально, и все же используя этот код, чтобы затем получить идентификатор и поместить его в переменную
Всегда заканчивается возвращаемой ошибкой, он не может увидеть значение, даже если он был успешно добавлен к URL, и я не могу сказать, почему.
Стоит отметить, что этот точный код работал на живом веб-сайте до сегодняшнего дня, я не внес изменений в код (за исключением перемещения заголовка в файл включения, заголовка, который не влияет на этот фрагмент кода), и, похоже, не быть причиной того, что это прекратилось.
В целях безопасности я даже вернулся к коду, который был старше недели (ПУТЬ до того, как возникла ошибка), и это не исправило ошибку.
РЕДАКТИРОВАТЬ: в ответ на ответы, я протестировал скрипт с var_dump ($ _ GET), который возвращает «Пусто».
error_reporting (E_ALL);
ini_set (‘display_errors’, 1);
Это предложение, однако, не дает никакой обратной связи (которую я могу найти) вообще, вероятно, означая, что никаких ошибок со сценарием не найдено?
РЕДАКТИРОВАНИЕ 3: Поскольку никаких ошибок не было найдено, я создал два довольно простых файла, чтобы проверить, работают ли геттеры и сеттеры.
Это приводит к такому выводу
И просто чтобы убедиться, что он на самом деле работает, я попробовал другое значение
Конечно, это означает, что это не мой проект, который «сломан», но в худшем случае только один или два файла, упомянутых выше? (вероятно, просто article.php)?
РЕДАКТИРОВАТЬ 4: даже дальнейшее тестирование (изменение начальной ссылки с article.php? ….» на testget.php? ….» показывает, что индекс определенно все еще работает, как и ожидалось, вывод сгенерированных идентификаторов через var_dump
Таким образом, проблема заключается только в странице article.php.
EDIT5: VAR_DUMP ($ _ GET); на «Article.php» теперь получает идентификатор из URL, но тест GET не работает, поэтому он все еще не работает (хотя я чувствую, что прогресс достигнут, наконец)
РЕДАКТИРОВАТЬ 6: Мне удалось заставить передачу id работать отлично на localhost, и все же после загрузки новой рабочей копии в godaddy, она все еще не работает. Значение $ _GET передается, как проверено var_dump, но метод get не работает (по иронии судьбы), потому что он не может найти значение get … что абсолютно бессмысленно.
Решение
Слишком много скобок; попробуй это:
Кроме того, если вы точно знаете, что обращаетесь к переменной id через GET, нет причин пытаться выполнить POST, поэтому избавьтесь от этого лишнего кода.
Вы упомянули что-то о файлах включения? Поместите этот код в начало скрипта, и он может дать вам некоторые ошибки, которые вам нужно увидеть, чтобы вы знали, в чем проблема:
Если есть какие-либо ошибки, связанные с PHP на стороне сервера, это выведет их для вас и сообщит, что происходит.
РЕДАКТИРОВАТЬ:
На данный момент я должен представить, что ваша служба хостинга обновила свои серверы или внесла некоторые изменения, чтобы вы не могли получить доступ к переменным запроса $ _GET, не используя что-то более безопасное. Это все может быть расширенной функцией безопасности. Попробуй это:
Источник
сайт не работает с get параметром
Рекомендуемые сообщения
Для публикации сообщений создайте учётную запись или авторизуйтесь
Вы должны быть пользователем, чтобы оставить комментарий
Создать учетную запись
Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!
Войти
Уже есть аккаунт? Войти в систему.
Похожий контент
Есть задача смена дизайна на работающим OpenCart магазине.
Чтобы не резать на живую сайт был перенесен на рабочую машину.
В config.php и admin/config.php поправил пути на локальные, базу экспортировал. Все завелось.
Но! При переходе по меню на ссылки типа http://127.0.0.1/my_site/index.php?route=news/news браузер выдает ERR_TOO_MANY_REDIRECTS.
Причем админка работает без проблем, несмотря на наличие ссылок вида http://127.0.0.1/my_site/admin/index.php?route=catalog/category&token=00016ae2d2d35d388be36ae7b0bec664/
В .htaccess прописал
RewriteBase /my_site/
RewriteRule ^([^?]*) /my_site/index.php?_route_=$1 [L,QSA]
Ситуация не изменилась.
Господа, помогите кто чем может!
OC: Windows 7
OpenCart: 1.5.4.1
В качестве сервера xampp.
Последние посетители 0 пользователей онлайн
Ни одного зарегистрированного пользователя не просматривает данную страницу
Источник
Не передается GET параметр
Добрый день. По какой причине может не передаваться get параметр серверу?
Вывел массив get с помощью var_dump(), но увы, параметров там нет.
Помощь в написании контрольных, курсовых и дипломных работ здесь.
Не передается параметр
Здравствуйте, помогите разобраться почему не передается параметр: 8
Выводит page=1, либо ту цифру, которую передаю в параметре, значит сервер получил строку полностью.
Нужны ли какие разрешения со стороны сервера для получения get- параметров? Возможно ли то, что я что то недописал в htaccess?
Добавлено через 1 час 16 минут
Может быть было у кого такое?
Решение
кавычки точно такие же использовали?
Вывод ошибок включён?
Если в корневой папке есть файл .htaccess, удалите его (можно переместить в другую директорию).
Запустите сервер (если на локалке работаете).
В адресную строку вбейте site.ru/index.php?param=ok
В индексном файле вставьте echo $_GET[‘param’];
Всё копируйте отсюда (естественно site.ru замените на свой)
Мой htaccess. Если его убрать, то выходит 500 ошибка сервера.
Добавлено через 10 минут
Если я сам ввожу в адресную строку строку эти данные, а именно ?page=3
Добавлено через 2 минуты
Что то не распознается как я понимаю, но не могу понять что
Добавлено через 1 час 4 минуты
На свежую голову нашел в чем была беда
Изменил строчку в htaccess и все заработало.
Не передается параметр из Textbox
Ошибка в коде, все компилируется но параметр из Textbox 2 не передается почему-то,поэтому после.
Не передается параметр в функцию
Доброго дня уважаемые коллеги. Столкнулся с проблемой и никак не могу решить. Помогите пожалуйста.
Есть проект с формами. после формы описан класс Class boolExpr с определяемым методом Public.
Мне нужно получить сид текущего юзверя по принцупу передачи строки в функцию. Короче додумался до.
Источник
Ошибка Я. Вебмастера: найдены страницы дубли с GET-параметрами — что делать
Дубли страниц могут приводить к потери позиций в поисковой выдаче и снижать скорость индексации. Стоит понимать, что у поискового робота есть определенный лимит запросов к домену в день. Поэтому существует вероятность того, что он потратит все лимиты на сканирование мусорных страниц и не доберется до страниц с уникальным контентом.
О наличии проблемы с дублированным контентом свидетельствует сообщение в панели Вебмастера: «Найдены страницы дубли с GET параметрами». В своем сообщении Яндекс информирует вебмастера о том, что на некоторых страницах сайта размещен одинаковый контент, различающийся только гет-параметрами.
Что такое get-параметры на сайте
Как избавиться от ошибки — Найдены страницы дубли с GET-параметрами
Если в поиске есть дублированные страницы из-за гет-параметров, Яндекс предлагает воспользоваться правилом Clean-param в robots.txt (правило действительно только для Яндекс, Google его не воспринимает).
В результате использования Clean-param поисковый робот Яндекса объединяет сигналы с дублированных страниц на основной. После того, как краулер узнает обо всех произошедших изменениях, страницы с не имеющими значение гет-параметрами исчезнут из поисковой выдачи.
Как использовать Clean-param
Для понимания того, как используется Clean-param, стоит привести простой пример. Существуют дубли страницы со следующими гет-параметрами:
Чтобы в результатах поиска учитывалась только основная страница http://mysite.ru/cat/auto/nissan/, нужно задать правило Clean-param в файле robots.txt:
User-agent: Yandex
Clean-param: sort&order /cat/auto/nissan/
sort&order – это динамические параметры, не требующие учета;
/cat/auto/nissan/ — это префикс использования директивы, обозначающий, что не следует учитывать указанные параметры для страниц, которые начинаются с /cat/auto/nissan/.
Как использовать Disallow
Избавиться от страниц-дублей с GET-параметрами можно, используя директиву Disallow. Для примера возьмем те же страницы-дубли:
Чтобы в результатах поиска учитывалась только основная страница http://mysite.ru/cat/auto/nissan/, нужно задать правило в файле robots.txt:
User-agent: *
Disallow: *?sort=
Disallow: *&order=
*?sort= , *&order= – это динамические параметры. Страницы, содержащие такие параметры индексироваться не будут.
Также можно закрыть от индексации ВСЕ Get-параметры одним правилом?
User-agent: *
Disallow: *?
Будьте осторожны! Используйте директиву Disallow очень внимательно, чтобы случайно не закрыть от индексации нужные страницы (например, не используйте правило, если карточки товара или категории в обязательном порядке содержат get-параметр в url).
Источник
Ошибка Я. Вебмастера: найдены страницы дубли с GET-параметрами — что делать
Дубли страниц могут приводить к потери позиций в поисковой выдаче и снижать скорость индексации. Стоит понимать, что у поискового робота есть определенный лимит запросов к домену в день. Поэтому существует вероятность того, что он потратит все лимиты на сканирование мусорных страниц и не доберется до страниц с уникальным контентом.
О наличии проблемы с дублированным контентом свидетельствует сообщение в панели Вебмастера: «Найдены страницы дубли с GET параметрами». В своем сообщении Яндекс информирует вебмастера о том, что на некоторых страницах сайта размещен одинаковый контент, различающийся только гет-параметрами.
Что такое get-параметры на сайте
Как избавиться от ошибки — Найдены страницы дубли с GET-параметрами
Если в поиске есть дублированные страницы из-за гет-параметров, Яндекс предлагает воспользоваться правилом Clean-param в robots.txt (правило действительно только для Яндекс, Google его не воспринимает).
В результате использования Clean-param поисковый робот Яндекса объединяет сигналы с дублированных страниц на основной. После того, как краулер узнает обо всех произошедших изменениях, страницы с не имеющими значение гет-параметрами исчезнут из поисковой выдачи.
Как использовать Clean-param
Для понимания того, как используется Clean-param, стоит привести простой пример. Существуют дубли страницы со следующими гет-параметрами:
Чтобы в результатах поиска учитывалась только основная страница http://mysite.ru/cat/auto/nissan/, нужно задать правило Clean-param в файле robots.txt:
User-agent: Yandex
Clean-param: sort&order /cat/auto/nissan/
sort&order – это динамические параметры, не требующие учета;
/cat/auto/nissan/ — это префикс использования директивы, обозначающий, что не следует учитывать указанные параметры для страниц, которые начинаются с /cat/auto/nissan/.
Как использовать Disallow
Избавиться от страниц-дублей с GET-параметрами можно, используя директиву Disallow. Для примера возьмем те же страницы-дубли:
Чтобы в результатах поиска учитывалась только основная страница http://mysite.ru/cat/auto/nissan/, нужно задать правило в файле robots.txt:
User-agent: *
Disallow: *?sort=
Disallow: *&order=
*?sort= , *&order= – это динамические параметры. Страницы, содержащие такие параметры индексироваться не будут.
Также можно закрыть от индексации ВСЕ Get-параметры одним правилом?
User-agent: *
Disallow: *?
Будьте осторожны! Используйте директиву Disallow очень внимательно, чтобы случайно не закрыть от индексации нужные страницы (например, не используйте правило, если карточки товара или категории в обязательном порядке содержат get-параметр в url).
Источник