Не работают все страницы кроме главной

Ошибка 404 на внутренних страницах при переносе сайта

Если главная страница сайта отображается, а внутренние выдают ошибку 404 или 500, проблема заключается в отсутствии файла .htaccess или его неправильном содержании.

Внутренние страницы перестают открываться на CMS (WordPress, Joomla, DLE), поскольку в этих системах файл .htaccess имеет большое значение и часто видоизменяется. Проблема появляется при переносе сайта с одного виртуального хостинга на другой.

Оглавление статьи:

Причины и решение ошибки 404/500

Файл .htaccess должен содержать записи, необходимые для работы CMS. При переносе сайта на новый хостинг, особенно через браузерные версии панелей хостеров, данный файл может не попасть в архив из-за настроек безопасности. Как следствие, на новом хостинге файла не будет, и правильно развернутая из бекапа и настроенная CMS работать не будет — кроме главной страницы. Наиболее часто проблема наблюдается на сайтах, где вместо стандартного отображения URL подключено ЧПУ.

Внутренние страницы перестают открываться, если:

  1. Файл .htaccess отсутствует. Проблема актуальна при переносе сайта с одного хостинга на другой.
  2. Файл пустой. Содержимое файла может быть удалено по ошибке, в результате заражения сайта вирусами или по иной причине.
  3. Содержимое файла изменено или повреждено. Если внутренние страницы сайта перестали работать после каких-либо действий с .htaccess, следует проверить файл на наличие всех директив, необходимых для работы CMS.

Отличительной особенностью ошибки с файлом .htaccess является измененный дизайн страницы 404/500. Страницы ошибки 404 будут отдаваться сервером и отличаться от оформления 404 у сайта (с шаблоном и дизайном, элементами навигации). Актуально, по крайней мере, для WordPress.

Для исправления ошибок нужно создать .htaccess с нужным содержимым. Содержание файла будет меняться в зависимости от CMS. Помимо указанного кода, в файле может содержаться любая информация и директивы, необходимые для функционирования сайта.

Файл .htaccess для WordPress

Каждая система управления контентом требует определенных директив для полноценного и корректного функционирования. Документ .htaccess должен располагаться в корне сайта и иметь, как минимум, указанное ниже содержание (для WordPress).

# BEGIN WordPress

RewriteEngine On
RewriteBase /
RewriteCond % !-f
RewriteCond % !-d
RewriteRule . /index.php [L]

# END WordPress

Содержимое файлов для других популярных CMS можно без проблем найти в сети — там текста в разы больше, и в статью информация попросту бы не влезла. У WordPress содержимое файла не менялось годами, а потому ошибка одинаково хорошо решается на всех версиях движка.

Хостинг на Windows и панель ISPmanager

Любые операции с файлом .htaccess актуальны только для хостингов, расположенных на Linux-серверах. Сервера от Windows попросту не имеют такого файла — вместо него аналогичные функции выполняются в документе web.config. Уточнять содержимое данного файла следует в поддержке соответствующей CMS.

Помимо этого, проблема с ошибкой 404 на внутренних страницах актуальна для Linux-серверов с панелями ISPmanager. В этом случае требуется отключить автоподдомены, если они включены, и проверить наличие проблемы. Ошибки 404 и 500 могут исчезнуть и без замены .htaccess (либо с файлом изначально все нормально, если он присутствует в корне и правильно заполнен).

Источник

Не открывает странички, кроме главной

Здравствуйте! Почему-то сайт не открывает все странички кроме главной..Пишет на них Not Found

The requested URL /название страницы тут.html was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
Apache/2.2.19 (Unix) mod_ssl/2.2.19 OpenSSL/0.9.8e-fips-rhel5 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 mod_wsgi/3.3 Python/2.6.5 Phusion_Passenger/3.0.9 Server at retrans55.ru Port 80

Ничего не делала, не удаляла страницы..в чем может быть причина? Как решить данную проблему?

Помощь в написании контрольных, курсовых и дипломных работ здесь.

вирус заблокировал работу браузеров или открывает странички в html коде
пользуюсь в основном гуглохромом,скачал недавно файл какой-то, нажал открыть и комп перезагрузился.

Не открывает браузеры кроме ИЕ
ошибка вылазиет в любом браузере, на вирусы комп проверял 4 мя антивирусами , удалил много вирусов.

Браузер при клике открывает странички с рекламой, вулканом и именем «redirekt»
Здравствуйте, помогите плиз в борьбе с вирусом. Браузер почти при каждом клике открывает левые.

вылетело все кроме главной
Доброго времени суток. Есть форум сдл. Раньше все странички были в индексе (около 20000). но в.

в папке public_html/assets/cache/ есть такие странички вида docid_20.pageCache в php и если я блокнотом открываю какой-нибудь такой файл то там открываются мои потерянные странички. Я пробовала скопировать или переименовать в нужные допустим pechat.html, и вставить ее и в эту папку cahce, но всеравно нужная ссылка в данном примере pechat.html неоктрывает. Пробовала скопировать страницу в папку public_html-выдает чистый белый лист, и в assets пробовала скопировать — тоже не открывает-ошибку выдает. Пробовала сохранять pechat.php — тоже неоткрывает. Думала просто из этих страничек вида docid_20.pageCache что я писала выше покопировать инфу и переименовать в нужные ссылки и скопировать в public_html но почему-то выдает ошибку и все тут.

Читайте также:  Не работает скутер хонда дио причина

Добавлено через 4 минуты
все отображалось..но была и остается проблема с занятым дисковым пространством. я написала в техподдержку о том что немогу попасть в веб-почту шоб удалить спам захламлявший много места. написала можете ли вы мне почистить спам..в итоге после этого стали вылазить ошибки. Потом шоб это устранить эти ошибки зашла в файлы-резервные копии. Там где «Восстановить резервную копию домашнего каталога» в обзоре выбрала с компа копию которая хранилась на компе — нажала Загрузить. Потом окрылась страница, и в итоге на чистой странице появилось надпись слева вверху Восстановление файлов. И все. Но после этого все тоже самое..те же ошибки 404

Источник

Кроме главной все страницы 404 Есть решение

Добавил новый сайт kelme-shop.ru все сделал по инструкции, но почему то все страницы, кроме главной выдают 404 ошибку, в чем может быть дело?

18 ответов

Проверил не помогает ничего.

1. У вас не поддерживается хостингом mod_rewrite, но при этом в конфиге wa-config/config.php указано mod_rewrite => 1
В этом случае нужно поменять 1 на 0

2. У вас отсутствует или был изменён файл .htaccess, в этом случае его нужно восстановить.

Попробуйте отключить mod_rewrite в /wa-config/config.php. Помню смутно в чем именно дело было, но что-то именно c mod-rewrite и симптомы идентичные.

Спасибо за помощь, помогло это:

У вас не поддерживается хостингом mod_rewrite, но при этом в конфиге wa-config/config.php указано mod_rewrite => 1

В этом случае нужно поменять 1 на 0

А у вас именно хостинг или свой сервер?

Хостинг beget.ru, но я выше написал что помогло.

Это ж разве помогло? 🙂 Теперь везде index.php лезть будут. Хостингами давно не пользовался, не помню что там к чему, но вспомнилось что mod_rewrite с настройками по умолчанию как-то неадекватно себя вел при использовании alias в настройках апача и приводил к такому эффекту.

Уточнил, у меня mod_rewrite включен на хостинге по умолчанию!

А чтобы вылезало index.php не приемлемо, еще есть варианты?

При этом у меня то 2 сайта на этой же платформе работают нормально.

Рабочий каталог апача какой? А в каких каталогах остальные 2 сайта лежат? А в каком тот сайт на котором не работает? Ну схематично опишите, без конкретики можно.

Все сайты лежат в одном каталоге и управляются через 1 бэкенд. Один на основном домене, второй на поддомене.

Теперь в этот бэкенд добавил сайт в настройках сайта, а домен привязал к основной дериктории.

Содержимое файла .htaccess в корне установке выложите сюда.

Источник

PressDev

Все об IT

Свежие записи
Свежие комментарии
  • Дмитрий к записи Сохраняем и открываем DBF-файлы в Excel 2007 и 2010
  • Мирон к записи Уменьшаем или увеличиваем количество выводимых тегов WordPress
  • DuavidkeK к записи Что такое лиды в интернет-маркетинге?
  • Елена к записи Получаем бесплатно инвайт для социальной сети PostPR
  • Mixkino к записи Запрещаем доступ к сайтам с локального компьютера
  • Кроме главной страницы ничего больше не открывается на ресурсе

    Всем привет дорогие друзья. В данной статье я хотел бы с Вами поговорить о том, что делать, если на Вашем ресурсе открывается только главная страница. То есть, вроде бы сайт и работает, но не работает, так как главная страница открывается, как положена, а все внутренние, например статьи, не открывается, выдает 404 ошибку, а именно пишет Not Found The requested URL /sitemap/ was not found on this server.

    Я столкнулся с такой проблемой, долго думал, что я не так сделал, ведь сервер вещь такая, что он требует ухода и внимания, на хостинге все проще. Но, выявил для себя некоторые пункты, по которым можно определить, почему сервер показывает Вам такую ошибку и не открываются внутренние страницы ресурса.

    Все очень просто, такая ошибка в большинстве случаях появляется, если у Вас не правильно настроен файл htaccess. А неправильно он у Вас может быть настроен по простым причинам:

    В имени файла не указана точка (файл должен называться .htaccess)

    • Файл htaccess у Вас пустой, то есть, там не находится никакой информации, хотя она должна присутствовать даже по минимуму
    • Вы записали данный файл на свой сервер не под тем владельцем, для которого имеет доступ Ваш ресурс
    • У Вас не правильно выставлены права на данный файл

    Вот дорогие друзья, основные проблемы, которые могут привести к Вашему ресурсу. Я столкнулся с двумя, у моего файла не было в имени указана точка, а также я закачал его не под тем владельцем. Очень долго думал, даже связывался с техподдержкой хостинга, но если Вы сами что-то натворили, то даже служба поддержки Вам не поможет, так будьте внимательны и все у Вас получиться.

    Читайте также:  Как настроить голосовое управление роботом пылесосом xiaomi

    Источник

    WordPress дает мне 404 страницы, не найденные для всех страниц, кроме главной страницы

    внезапно я иду на свой сайт WordPress,и все страницы дают мне 404 страницы, которые не найдены. Я предполагаю, что проблема заключается в структуре permalink, которую я могу поклясться, что не трогал. Постоянная ссылка на «месяц и название.»

    Я исследовал подобные случаи этой проблемы в интернете, и многое из этого связано с ? Я пытался найти, но не могу. Может, его как-то удалили? Где он должен быть расположен.

    любой предложения будут полезны

    и, конечно, я вижу скрытые файлы.

    21 ответов

    .htaccess-это скрытый файл, поэтому вы должны установить все файлы, как видимые в вашем FTP.

    Я предлагаю вам вернуть структуру permalink по умолчанию ( ?p=ID), поэтому вы гарантируете это .проблема в htaccess.

    после этого вы можете просто установить структуру «месяц и имя» снова и посмотреть, работает ли она.

    PS: вы обновили до 3.1? Я видел некоторых людей с проблемами плагина в этом случае.

    исправление этой проблемы очень просто, если вы использовали постоянные ссылки, отличные от default например Day and name , Month and name , Numeric , Post name или Custom Structure , вам необходимо лишь

    войти в вашу админку: Settings > Permalinks что надо : http://yoursite.com/wp-admin/options-permalink.php

    выбрать Default настройка permalink, затем Сохранить изменения

    тут вы можете верните его снова в другой предыдущий выбор permalink или сохранить как default как Yo желание

    обратите внимание, что эта проблема может возникнуть при перемещении сайта из домена или местоположения в другой.

    в основном .файл htaccess должен существовать и httpd.conf должен быть правильным.

    в моем случае я изменил файл /etc/httpd/conf / httpd.Conf в разделе:

    и перезапустите веб-сервер.

    если поведение по умолчанию ( example.com/?p=42 ) работает, вы должны:

    • изменить предпочтительный стиль permalink: Admin: Settings > Paramalinks , и нажмите кнопку Сохранить. Иногда это устраняет проблему. Если нет:
    • убедитесь, что файл /path/to/wordpress/.htaccess был изменен и теперь включает в себя строку RewriteEngine On . Если это не так, это проблема с разрешениями WordPress.

    убедитесь, что модуль «переписать» загружен: создайте PHP-файл с

    в нем, открыть его в браузере и поиск mod_rewrite . Он должен быть в разделе «загруженные модули». Если это не так, включите его — посмотрите на свой Apache default подробности — в Ubuntu, вы делаете это с помощью a2enmod .

    убедитесь, что сервер Apache смотрит на . открыть httpd.conf — или это альтернатива Ubuntu, /etc/apache2/apache2.conf . В нем, вы должны иметь что-то вроде

    после внесения этих изменений, не забудьте перезапустите сервер apache. sudo service apache2 restart

    в админке Вордпресса сделать следующее:

    перейдите в настройки администратора

    нажмите на permalink и выберите post name в переключателе.

    прокрутите вниз и вы увидите .htaccess код здесь нравится.

  • скопируйте код и вставьте в .
  • легко исправить проблему, просто выполните следующие действия ,Если вы получаете доступ для входа в панель администратора, то просто

    Go to Settings » Permalinks, and simply click on Save Changes button .

    это обновит ваши настройки постоянных ссылок и правила перезаписи flush. В большинстве случаев это решение исправляет ошибку WordPress posts 404. Однако, если это не работает для вас, то вам, вероятно, нужно обновить свой .файл htaccess вручную.

    войдите на свой сервер с помощью FTP и измените .реврайт файл, который находится в том же месте, где находятся папки, такие как /wp-content/ и / wp-includes/ , просто поместите коды ниже в свой .реврайт

    надеюсь, что это решит проблему.

    эта ошибка вызывает из-за отключения перезаписи mod в Apache httpd.conf документ, просто раскомментировать его и наслаждаться seo дружественных permalinks

    если все это не сработает, ваш .htaccess является правильным, и permalinks трюк не работал, вы, возможно, не включили свой apache2 rewite mod.

    Я побежал это и моя проблема была решена:

    • проверьте, что каталог включен .htaccess для правильного
    • Проверьте поля «siteurl» и «home» являются правильными

    Если у вас есть FTP-доступ к вашей учетной записи:

    во-первых, войдите в свой wp-admin и перейдите в Настройки > Permalinks

    вы должны увидеть что-то внизу, что говорит:

    «Если ваш .файл htaccess был доступен для записи, мы могли бы сделать это автоматически, но это не так, таковы правила mod_rewrite вы должны иметь в своем .файл htaccess. Щелкните в поле и нажмите CTRL + a, чтобы выбрать все.»

    Если это правда, сделайте следующий:

    перейдите в настройки для вашего FTP-клиента и убедитесь, что отображаются скрытые файлы (зависит от вашего FTP — клиента) — если вы этого не сделаете, вы не сможете найти свой файл htaccess

    перейдите в папку, в которой находятся каталоги wp-admin, wp-content, wp-includes. Проверять. файл htaccess. Если он существует, перейдите к шагу 4

    Если он не существует, создайте новый пустой файл в своем FTP-программу под названием .реврайт

    измените CHMOD для вашего .htaccess файл в 666 (ваши предпочтения о том, как вы хотите это сделать)

    вернитесь на страницу Permalinks и отредактируйте нужную структуру ссылок. Проблема должна быть решена!

    обязательно измените chmod файла htaccess на 644 после того, как вы закончите.

    просто была та же проблема, и казалось, что это исправить мгновенно! Удачи!

    большую часть времени эта проблема исправлена, просто посетив Настройки — > Permalink страница в Администраторе WordPress и нажмите «Сохранить» (как уже указывалось в нескольких других ответах). Когда эта страница доступна, WordPress переписывает директивы в .htaccess файл, который волшебным образом устраняет проблему. Проблема часто возникает после перемещения сайта (Сайт ломается, потому что .htaccess остается позади или настройки должны быть обновлены).

    если WordPress не имеет правильные разрешения для записи .htaccess файл, уведомление появится в верхней части страницы и дальнейшие инструкции в нижней части, когда настройки будут сохранены. В этом случае вам нужно отредактировать .htaccess файл самостоятельно или, лучше, чтобы исправить разрешения на этот файл. Файл находится в корне установки WordPress. cd в каталоге sudo chmod 644 .htaccess . Вы также можете проверить, принадлежит ли файл к правильной группе, и изменить это с помощью chown . Спросите вашего хостинга провайдер если вы не знаете, как это сделать.

    если вы находитесь на общем хостинге, это, вероятно, все, что вы можете сделать. Если у вас все еще есть проблема, вы можете поговорить с поддержкой хостинг-провайдера. В противном случае убедитесь, что используется .htaccess файлы включена на сервере, как @георгеос уже предложил. Обратите внимание, что httpd.conf не всегда используется (Ubuntu указывает, что он устарел но официальные документы Apache по-прежнему говорят, что это часто основная конфигурация файл). /etc/httpd/conf/httpd.conf и /etc/apache2/apache2.conf кажется, наиболее распространенными местами для этого файла. Найдите блок для общей папки, обычно и убедитесь, что AllowOverride директива установлена в All . Если установлено значение None ваш .htaccess файл просто игнорируется сервером.

    Я установил mod_rewrite, чтобы исправить эту проблему. Ниже ссылка предоставляет руководство по установке:- http://www.iasptk.com/enable-apache-mod_rewrite-ubuntu-14-04-lts/

    у нас была такая же проблема и решил ее проверить на ошибки.журнал нашего виртуального хоста. Мы нашли следующее сообщение:

    AH00670: параметры FollowSymLinks и SymLinksIfOwnerMatch отключены, таким образом, директива RewriteRule также запрещена из-за ее сходства возможность обойти ограничения каталога : /СРВ/в WWW/htdocs в/РГ-интранет/

    решение было установить Options All и AllowOverride All в нашей конфигурации виртуального хоста.

    У меня такая же проблема, и поэтому я удаляю Apache и делаю это снова, и проблема была решена.

    возможно .htaccess запрещен в настройках веб-хоста. Настройка постоянные ссылки по умолчанию будет работать в этом случае.

    просто перейдите в раздел Настройки — >Permalink в приборной панели, а затем Сохранить Изменения кнопка в последнем.\

    Случай 1: — давайте подумаем, если перенести сайт с одного хостинга на другой хостинг, если видите такую проблему.

    решение: — просто перейдите к старой копии сервера .htaccess код файла, затем мимо в новом сервере .файл htaccess. 99% его работ.

    если ваша установка WordPress находится в подпапке (ex. https://www.example.com/subfolder) измените эту строку в своем WordPress .htaccess

    таким образом, вы говорите серверу искать WordPress index.php в папке WordPress (ex. https://www.example.com/subfolder), а не в общей папке (ex. https://www.example.com).

    Я просто изменил постоянную ссылку на «месяц и День» всех сообщений, перейдя к настройке>Постоянная ссылка.

    теперь все сообщения открыты и работают нормально.

    опять же, я переименовал все сообщения в его фактическую постоянную ссылку. Его снова работает нормально.

    этот метод сработал для меня: -)

    для пользователей nginx

    используйте следующее в файле conf для вашего сайта (обычно /etc/nginx/sites-available/example.com )

    Это руки от всех запросов permalink индексировать.php со строкой URI и предоставленными аргументами. Сделай systemctl reload nginx чтобы увидеть изменения, и ваши ссылки не на главной странице должны загружаться.

    У меня была эта проблема не так давно. Я сбросил свою постоянную ссылку по умолчанию или просто сохранил ее, обновил темы/ядро до (4.7.4)/плагинов, деактивировал все плагины, переключился на тему по умолчанию, оптимизировал базу данных .htaccess уже по умолчанию, проверены права доступа к файлам, mod_rewrite включен.

    пока ничего не работает, что работает сообщения, новая страница, страница /contact за исключением старых страниц.

    в основном, страницы / URL-адреса, которые не работают являются:

    Ultimate, я нашел эти файлы в корневой папке:

    /разведения.php и / обучение.в PHP

    я переименовал оба файла, и страницы выше работали.

    Источник

    Оцените статью