- Деректива Nginx — location с примерами
- Пытаюсь задать location в конфиге nginx, не работает
- Не видит страницу по location в nginx
- 1 ответ 1
- Всё ещё ищете ответ? Посмотрите другие вопросы с метками nginx или задайте свой вопрос.
- Связанные
- Похожие
- Подписаться на ленту
- Частые ошибки в настройках Nginx, из-за которых веб-сервер становится уязвимым
- Отсутствует корневой каталог
- Потерявшийся слеш
- Небезопасное использование переменных
- Использование $uri может привести к CRLF-инъекции
- Произвольные переменные
- Чтение необработанного ответа сервера
- merge_slashes отключены
- Попробуйте сами
- Вывод
- Почему не работает location (Переход с Apache в Nginx)?
Деректива Nginx — location с примерами
Директива location служит для установки конфигурации в зависимости от URI-запроса. Синтаксис location в общем виде следующий:
Перед тем, как перейти к более детальному изучению, нужно заметить, что location определяется в контексте server (или в location в случае вложенной директивы), и в одном настраиваемом виртуальном хосте могут использоваться разные конфигурации в зависимости от обрабатываемого сервером URI.
Префикс «@» («собака») определяет именованные расположения. Такие location’ы не используются для обработки обычных запросов. Вместо этого они используются для перенаправления запросов (пример №6). Они не могут быть вложенными и содержать в себе вложенные.
- = Строковые совпадения. Если найдено, проверка заканчивается. = значит полное совпадение шаблона и проверяемой строки, например = / — заход в секцию будет исключительно для корня, и даже файлы в корне уже сюда не подходят.
- ^
Приоритетное строковое значение. Хотя по-моему было бы правильнее назвать «приоритетным регулярным выражением», поскольку в отличии от = требуется совпадение только начала. ^
/ полностью отключит регулярные выражения для секции server, если нет более точного location без ^
* Регулярные выражения, в порядке определения в конфиге. При совпадении — выполняется этот регэксп, проверка заканчивается.
— с учётом регистра,
* — без.
Источник
Пытаюсь задать location в конфиге nginx, не работает
Вот мой конфиг.
server <
listen 80 default_server;
listen [::]:80 default_server ipv6only=on;
root /home/box/web;
index index.html index.htm;
# Make site accessible from http://localhost/
server_name test.com;
location /bazinga/ <
root /uploads;
>
Есть директория /home/box/web. Там хранятся файлы. Запросы из браузера типа test.com/uploads/cat2.jpeg работают, открываются картинка. Но тут я решил сделать некий location, чтобы если набрать test.com/bazinga/uploads/cat2.jpeg должен открыться файл по адресу test.com/uploads/cat2.jpeg. Директории bazinga не существует. Почему-то этого не происходит, ошибка 404. Что я написал не правильно?
Сервер перезапускаю, все делал по доку http://nginx.org/ru/docs/beginners_guide.html.
Помощь в написании контрольных, курсовых и дипломных работ здесь.
Как сделать переадресацию по условию в конфиге nginx?
У меня сменилась структура сайта и все ссылки надо переправлять на другой адрес с кодом 301 Moved.
location в nginx
Требуется url типа /context/static/media/
Как программно задать label.Location.Y?
есть Public Class Screen Private Sub Screen_Load(ByVal sender As System.Object, ByVal e As.
1. Celeron 1,6GH, 256 MB RAM Как работает на этом конфиге Windows XP. 2. Можно ли увеличить RAM.
Источник
Не видит страницу по location в nginx
На localpikabu.com:8080 все работает. Когда перехожу на localpikabu.com:8080/hi , выдает 404.
hi.html лежит в той же папке, что и index.html . Что не так?
1 ответ 1
чтобы ваша конструкция «заработала», надо:
- либо создать каталог hi в корне сайта и переместить туда файл hi.html .
либо добавить в location директиву alias примерно так:
либо воспользоваться директивой try_files примерно так:
Всё ещё ищете ответ? Посмотрите другие вопросы с метками nginx или задайте свой вопрос.
Связанные
Похожие
Подписаться на ленту
Для подписки на ленту скопируйте и вставьте эту ссылку в вашу программу для чтения RSS.
дизайн сайта / логотип © 2021 Stack Exchange Inc; материалы пользователей предоставляются на условиях лицензии cc by-sa. rev 2021.10.18.40487
Нажимая «Принять все файлы cookie» вы соглашаетесь, что Stack Exchange может хранить файлы cookie на вашем устройстве и раскрывать информацию в соответствии с нашей Политикой в отношении файлов cookie.
Источник
Частые ошибки в настройках Nginx, из-за которых веб-сервер становится уязвимым
Nginx — это веб-сервер, на котором работает треть всех сайтов в мире. Но если забыть или проигнорировать некоторые ошибки в настройках, можно стать отличной мишенью для злоумышленников. Detectify Crowdsource подготовил список наиболее часто встречающихся ошибок, делающих сайт уязвимым для атак.
Nginx — один из наиболее часто используемых веб-серверов в Интернете, поскольку он модульный, отзывчивый под нагрузкой и может масштабироваться на минимальном железе. Компания Detectify регулярно сканирует Nginx на предмет неправильных настроек и уязвимостей, из-за которых могут пострадать пользователи. Найденные уязвимости потом внедряются в качестве теста безопасности в сканер веб-приложений.
Мы проанализировали почти 50 000 уникальных файлов конфигурации Nginx, загруженных с GitHub с помощью Google BigQuery. С помощью собранных данных удалось выяснить, какие ошибки в конфигурациях встречаются чаще всего. Эта статья прольёт свет на следующие неправильные настройки Nginx:
Отсутствует корневой каталог
Небезопасное использование переменных
Чтение необработанного ответа сервера
Отсутствует корневой каталог
Root-директива указывает корневую папку для Nginx. В приведённом выше примере корневая папка /etc/nginx , что означает, что мы можем получить доступ к файлам в этой папке. В приведенной выше конфигурации нет места для / (location / <. >) , только для /hello.txt . Из-за этого root-директива будет установлена глобально, а это означает, что запросы к / перенаправят вас на локальный путь /etc/nginx .
Такой простой запрос, как GET /nginx.conf , откроет содержимое файла конфигурации Nginx, хранящегося в /etc/nginx/nginx.conf. Если корень установлен в /etc , запрос GET на /nginx/nginx.conf покажет файл конфигурации. В некоторых случаях можно получить доступ к другим файлам конфигурации, журналам доступа и даже зашифрованным учётным данным для базовой аутентификации HTTP.
Из почти 50 000 файлов конфигурации Nginx, которые мы проанализировали, наиболее распространёнными корневыми путями были следующие:
Потерявшийся слеш
При неправильной настройке off-by-slash можно перейти на один шаг вверх по пути из-за отсутствующей косой черты. Orange Tsai поделился информацией об этом в своём выступлении на Blackhat «Нарушение логики парсера!». Он показал, как отсутствие завершающей косой черты в location директиве в сочетании с alias директивой позволяет читать исходный код веб-приложения. Менее известно то, что это также работает с другими директивами, такими как proxy_pass . Давайте разберёмся, что происходит и почему это работает.
Если на Nginx запущена следующая конфигурация, доступная на сервере, можно предположить, что доступны только пути в http://apiserver/v1/ .
Когда запрашивается http://server/api/user , Nginx сначала нормализует URL. Затем он проверяет, соответствует ли префикс /api URL-адресу, что он и делает в данном случае. Затем префикс удаляется из URL-адреса, поэтому остаётся путь /user. Затем этот путь добавляется к URL-адресу proxy_pass , в результате чего получается конечный URL-адрес http://apiserver/v1//user .
Обратите внимание, что в URL-адресе есть двойная косая черта, поскольку директива местоположения не заканчивается косой чертой, а путь URL-адреса proxy_pass заканчивается косой чертой. Большинство веб-серверов нормализуют http://apiserver/v1//user до http://apiserver/v1/user , что означает, что даже с этой неправильной конфигурацией всё будет работать так, как ожидалось, и это может остаться незамеченным.
Эта неправильная конфигурация может быть использована путём запроса http://server/api../ , из-за чего Nginx запросит URL-адрес http://apiserver/v1/../ , который нормализован до http://apiserver/ . Уровень вреда от такой ошибки определяется тем, чего можно достичь, если использовать эту неправильную конфигурацию. Например, это может привести к тому, что статус сервера Apache будет отображаться с URL-адресом http://server/api../server-status , или он может сделать доступными пути, которые не должны быть общедоступными.
Одним из признаков того, что сервер Nginx имеет неправильную конфигурацию, является возврат сервером одинакового же ответа при удалении косой черты в URL-адресе. То есть, если http://server/api/user и http://server/apiuser возвращают один и тот же ответ, сервер может быть уязвимым. Он позволяет отправлять следующие запросы:
Небезопасное использование переменных
Некоторые фреймворки, скрипты и конфигурации Nginx небезопасно используют переменные, хранящиеся в Nginx. Это может привести к таким проблемам, как XSS, обход HttpOnly-защиты, раскрытие информации и в некоторых случаях даже RCE.
SCRIPT_NAME
С такой конфигурацией, как эта:
основная проблема будет заключаться в том, что Nginx отправит интерпретатору PHP любой URL-адрес, заканчивающийся на .php, даже если файл не существует на диске. Это распространённая ошибка во многих конфигурациях Nginx, и об этом говорится в документе «Ловушки и распространенные ошибки», созданном Nginx.
XSS возможен, если PHP-скрипт попытается определить базовый URL на основе SCRIPT_NAME ;
Использование $uri может привести к CRLF-инъекции
Другая неправильная конфигурация, связанная с переменными Nginx, заключается в использовании $uri или $document_uri вместо $request_uri .
$ur i и $document_uri содержат нормализованный URI, тогда как нормализация в Nginx включает URL-декодирование URI. В блоге Volema рассказывалось, что $uri обычно используется при создании перенаправлений в конфигурации Nginx, что приводит к внедрению CRLF.
Пример уязвимой конфигурации Nginx:
Символами новой строки для HTTP-запросов являются \r (возврат каретки) и \n (перевод строки). URL-кодирование символов новой строки приводит к следующему представлению символов %0d%0a . Когда эти символы включены в запрос типа http://localhost/%0d%0aDetectify:%20clrf на сервер с неправильной конфигурацией, сервер ответит новым заголовком с именем Detectify , поскольку переменная $uri содержит новые URL-декодированные строчные символы.
Произвольные переменные
В некоторых случаях данные, предоставленные пользователем, можно рассматривать как переменную Nginx. Непонятно, почему это происходит, но это встречается не так уж редко, а проверяется довольно-таки сложным путём, как видно из этого отчёта. Если мы поищем сообщение об ошибке, то увидим, что оно находится в модуле фильтра SSI, то есть это связано с SSI.
Одним из способов проверки является установка значения заголовка referer:
Мы просканировали эту неправильную конфигурацию и обнаружили несколько случаев, когда пользователь мог получить значение переменных Nginx. Количество обнаруженных уязвимых экземпляров уменьшилось, что может указывать на то, что уязвимость исправлена.
Чтение необработанного ответа сервера
С proxy_pass Nginx есть возможность перехватывать ошибки и заголовки HTTP, созданные бэкендом (серверной частью). Это очень полезно, если вы хотите скрыть внутренние сообщения об ошибках и заголовки, чтобы они обрабатывались Nginx. Nginx автоматически предоставит страницу пользовательской ошибки, если серверная часть ответит ей. А что происходит, когда Nginx не понимает, что это HTTP-ответ?
Если клиент отправляет недопустимый HTTP-запрос в Nginx, этот запрос будет перенаправлен на серверную часть как есть, и она ответит своим необработанным содержимым. Тогда Nginx не распознает недопустимый HTTP-ответ и просто отправит его клиенту. Представьте себе приложение uWSGI, подобное этому:
И со следующими директивами в Nginx:
proxy_intercept_errors будет обслуживать пользовательский ответ, если бэкенд имеет код ответа больше 300. В нашем приложении uWSGI выше мы отправим ошибку 500, которая будет перехвачена Nginx.
proxy_hide_header почти не требует пояснений; он скроет любой указанный HTTP-заголовок от клиента.
Если мы отправим обычный GET-запрос, Nginx вернёт:
Но если мы отправим неверный HTTP-запрос, например:
То получим такой ответ:
merge_slashes отключены
Для директивы merge_slashes по умолчанию установлено значение «on», что является механизмом сжатия двух или более слешей в один, поэтому /// станет / . Если Nginx используется в качестве обратного прокси и проксируемое приложение уязвимо для включения локального файла, использование дополнительных слешей в запросе может оставить место для его использования. Об этом подробно рассказывают Дэнни Робинсон и Ротем Бар.
Мы нашли 33 Nginx-файла, в которых для параметра merge_slashes установлено значение «off».
Попробуйте сами
Мы создали репозиторий GitHub, где вы можете использовать Docker для настройки своего собственного уязвимого тестового сервера Nginx с некоторыми ошибками конфигурации, обсуждаемыми в этой статье, и попробуйте найти их самостоятельно!
Вывод
Nginx — это очень мощная платформа веб-серверов, и легко понять, почему она широко используется. Но с помощью гибкой настройки вы даёте возможность совершать ошибки, которые могут повлиять на безопасность. Не позволяйте злоумышленнику взломать ваш сайт слишком легко, не проверяя эти распространённые ошибки конфигурации.
Вторая часть будет позднее.
Что ещё интересного есть в блоге Cloud4Y
Подписывайтесь на наш Telegram-канал, чтобы не пропустить очередную статью. Пишем не чаще двух раз в неделю и только по делу.
Источник
Почему не работает location (Переход с Apache в Nginx)?
Добрый вечер!
Сегодня впервые перевожу сайт на Nginx. Столкнулся с тем, что «location» не работает (я делаю что то нет). Борюсь с двумя правилами:
И не одно из них у меня не хочет работать. Сайт на https.
Подскажите, пожалуйста, что я делаю не так?
Спасибо.
- Вопрос задан более трёх лет назад
- 188 просмотров
И что значит «не работает» ? PHP не отрабатывает?
Slash-Zn, ну а кусок с обработкой php-файлов интерпретатором где?
Локейшен со статикой верный, только нужно корневой каталог указать.
Владимир Скибин, там три файла:
— blacklist-nginx.conf
— disabled.conf
— letsencrypt.conf
Надо их содержимое?
Не работает: например, кэширование «(jpg|jpeg|gif|png|ico|js|css|html)» — не кэшируется.
Правило: «try_files $uri /index.php?do=$uri;» — не срабатывает. Если URL без «index.php?do=», вылетает 404 ошибка.
ky0,
// ну а кусок с обработкой php-файлов интерпретатором где?
Не знаю. А что за кусок должен быть?
Источник