Не работает php в связке nginx + php5-fpm
Добрый вечер, даже не знаю что не работает, html работает, а при заходе на страницу php в хроме: Ошибка. Ссылка не работает. в логах php5-fpm все нормально, в nginx пусто в логах ошибок, php5-fpm слушает 9000 порт, было установлено: nginx/1.0.11 PHP 5.3.3-7+squeeze3 with Suhosin-Patch (cgi-fcgi) с подменой зависимостей на него поставил php5-fpm_5.3.3-1(плохо но может лучше, чем из репозиториев dotdeb и т.д.) все настроено. Даже не знаю куда копать, помогите пожалуйста.
user www-data;
worker_processes 1;
worker_rlimit_nofile 8192;
worker_priority -5;
pid /var/run/nginx.pid;
events <
worker_connections 768;
# multi_accept on;
>
sendfile on;
tcp_nopush on;
tcp_nodelay on;
keepalive_timeout 65;
types_hash_max_size 2048;
# server_tokens off;
server_names_hash_bucket_size 64;
# server_name_in_redirect off;
include /etc/nginx/mime.types;
default_type application/octet-stream;
access_log /var/log/nginx/access.log;
error_log /var/log/nginx/error.log;
gzip on;
gzip_disable «msie6»;
gzip_min_length 1100;
# gzip_vary on;
gzip_proxied any;
gzip_comp_level 9;
gzip_buffers 4 8k;
gzip_http_version 1.1;
gzip_types text/plain text/css application/json application/x-javascript text/xml application/xml application/xml+rss text/javascript;
map $scheme $server_https <
default off;
https on;
>
include /etc/nginx/conf.d/*.conf;
include /etc/nginx/sites-enabled/*;
>
server <
listen 80;
root /var/www;
index index.html index.htm;
server_name localhost;
location / <
# First attempt to serve request as file, then
# as directory, then fall back to index.html
try_files $uri $uri/ /index.html;
>
error_page 500 502 503 504 /50x.html;
location = /50x.html <
root /usr/share/nginx/www;
>
\.php$ <
# fastcgi_split_path_info ^(.+\.php)(/.+)$;
# # NOTE: You should have «cgi.fix_pathinfo = 0;» in php.ini
#
fastcgi_pass 127.0.0.1:9000;
fastcgi_index index.php;
include fastcgi_params;
fastcgi_param SCRIPT_FILENAME /var/www$fastcgi_script_name;
>
/sites-enabled/site.ru (изменил свой сайт на site.ru)
server <
listen 80;
server_name site.ru;
root /var/www/site.ru;
index index.php;
* ^.+.(js|css|png|jpg|jpeg|gif|ico)$ <
access_log off;
expires max;
>
location
.php$ <
# fastcgi_split_path_info ^(.+\.php)(.*)$
fastcgi_pass 127.0.0.1:9000;
fastcgi_index index.php;
fastcgi_param DOCUMENT_ROOT /site.ru;
fastcgi_param SCRIPT_FILENAME /site.ru$fastcgi_script_name;
fastcgi_param PATH_TRANSLATED /site.ru$fastcgi_script_name;
include fastcgi_params;
fastcgi_param QUERY_STRING $query_string;
fastcgi_param REQUEST_METHOD $request_method;
fastcgi_param CONTENT_TYPE $content_type;
fastcgi_param CONTENT_LENGTH $content_length;
fastcgi_intercept_errors on;
fastcgi_ignore_client_abort off;
fastcgi_connect_timeout 60;
fastcgi_send_timeout 180;
fastcgi_read_timeout 180;
fastcgi_buffer_size 128k;
fastcgi_buffers 4 256k;
fastcgi_busy_buffers_size 256k;
fastcgi_temp_file_write_size 256k;
>
location = /favicon.ico <
log_not_found off;
access_log off;
>
location = /robots.txt <
allow all;
log_not_found off;
access_log off;
>
## Disable viewing .htaccess & .htpassword
location
в настройках php5-fpm в файле /pool.d/ww(w).conf (добавил скобки, а то в ссылку преобразует) поменял только:
pm.max_children = 10
pm.start_servers = 1
pm.min_spare_servers = 1
pm.max_spare_servers = 10
и по дефолту было:
[www]
listen = 127.0.0.1:9000
user = www-data
group = www-data
Источник
Не запускаются PHP скрипты на NGINX
Приветствую всех форумчан, столкнулся с такой проблемой, на сервере Ubuntu 20.04 установлен NGINX+PHP7.4+MariaDB, NGINX работает испрапвно, html страничку при обращении к хосту выдаёт правильно, файл phpinfo.php при обращении не скачивается, а отображает информацию включая Server API: FPM/FastCGI — это говорит о том что PHP работает корректно, phpmyadmin тоже работает исправно, но вот проблема, пытаюсь залить хотябы скрипт форума phpbb и обращение к хосту выдаёт белую страницу, во всех папках присутствует файл .htaccess это я так понимаю атрибут APACHE, может какая то несовместимость? Как решить данную проблему и реально ли?
Кто знает, мой друг, кто знает? Кстати, что в журнале ошибок?
у тебя должен быть установлен php-fpm 7.4
в настройках nginx должен быть указан его сокет
Нет сокета -> нет коммуникации с fpm -> нет php -> нет phpinfo
А ОП нам говорит, что phpinfo есть.
ну пусть по мануалу пройдется и наличие процесса php-fpm проверит
Источник
PHP не работает Debian10 NGINX PHP-FPM php7.3
Взял впс для теста. Поставил NGINX PHP-FPM php7.3
html работает. Не могу добиться, чтобы заработал php.
nginx и php7.3-fpm сервисы активны
Очевидно, где-то ошибка в конфигах или в правах, но вот уже 4-й день не могу её найти )) Подскажите, в чём может быть косяк.
Очевидно, где-то ошибка в конфигах или в правах, но вот уже 4-й день не могу её найти
Вопрос — какие? fpm запущен. Ошибок нет. nginx пустой сегодня
Не могу добиться, чтобы заработал php.
Вообще раскрой эту тему: что в браузере запрашиваешь (какой ресурс у себя проверяешь), какой ответ видишь. Т.е. что значит у тебя «не работает».
Обращаюсь хоть по ip (понимаю, что это дефолтный конфиг), где вижу стандартную страницу nginx, в которую добавил, блок вывода в echo.
Хоть по url домена. Здесь мой index.php с echo. Есть и страничка c phpinfo(). Т.е. домен прикручен правильно, но php на страницах не срабатывает.
Есть предположение, что проблема с сокетами. Сервис работает, но порт не слушает. Не знаю как это посмотреть и как должно быть. master process вижу что под рутом запускается.
Источник
Почему не обрабатываются файлы .php в связке Nginx + PHP-FPM?
Подскажите пожалуйста, в чем может быть проблема.
Ubuntu Server 18.04
Установил Nginx 1.14 и PHP 7.2 FPM
Файлы .html нормально открываются а при обращении к .php просто пустая страница, ни ошибки ничего.
В логах пусто, только логи доступа.
php.ini стандартный
Поменял в нем только вот это
cgi.fix_pathinfo=0 (было 1)
Его я не трогал тоже, стандартный.
Конфиг www.conf тоже стандартный
В директории сайта все папки и файлы выставил владельца www-data, до этого был root
В чем может быть проблема, что я не доконфигурировал?
Естественно я каждый раз при изменении конфигов перезагружал и nginx и php-fpm
systemctl restart nginx && systemctl restart php7.2-fpm
- Вопрос задан более двух лет назад
- 710 просмотров
Попробуйте такой конф:
Вчера уже не получилось проверить, вот сейчас проверил.
Сейчас проверил и начал было уже писать Вам о новой ошибке.
С Вашим конфигом теперь при открытии любой страницы хоть .php хоть .html выскакивает 404 страница ошибки.
Потом еще раз глянул в конфиг и обнаружил что когда на тостер закидывал конфиг я домен подменил на site.ru, балбес блин )))
В общем я проверил и с Вашим конфигом теперь работает все!
За что огромное спасибо!
Отмечу решением.
У меня есть еще маленький вопрос, могу ли я создать пользователя и группу к примеру «yuri» и настроить php-fpm и nginx чтобы они работали и выполняли файлы сайты от этой группы и пользователя?
Ну соответственно я и сам сайт весь переведу на эту группу и пользователя CHOWN -R
А еще лучше если Вы мне подскажете как вообще для каждого сайта свой юзер и группа или так не делают по феншую и просто я загоняюсь? Как правильно делать? Или оставить родную группу www-data?
Я понял Вас, оставлю как есть группу и пользователя.
Источник
Не запускается связка nginx + php5-fpm
Установил nginx + php5-fpm. Конфиг nginx:
Такое впечатление, что все завелось, но код php все равно не выполняется. В логи пишется только это:
Что еще можно сделать, что попробовать? Очень нужен любой совет.
2 ответа 2
убедитесь, что php-fpm у вас действительно работает (приведён ориентировочный вывод команды):
убедитесь, что главный процесс php-fpm (master process) слушает тот самый unix-сокет, который вы указали в конфигурации ( -p 15 — это pid процесса из предыдущего листинга):
убедитесь, что в указанном вами файле — fastcgi_params (находится в конфигурационном каталоге nginx, скорее всего, это /etc/nginx ) — присутствует строка по поводу SCRIPT_FILENAME . если присутствует, то, возможно, значение параметра — $request_filename , а php-fpm ожидает, что там будет $document_root$fastcgi_script_name .
у меня (в debian gnu/linux), например, в качестве файла с параметрами fastcgi, указан не fastcgi_params , а fastcgi.conf , и вся разница между этими двумя файлами — лишь в наличии во втором этой самой строки
правда, не могу поручиться, что без неё работать не будет — не проверял.
Источник