Данная ошибка наиболее часто возникает по следующим причинам:
Домен не делегирован, то есть отсутствует привязка доменного имени к хостингу на котором размещен сайт ( см. статью Как направить домен на хостинг?)
Сайт недоступен из конкретной подсети. Для проверки можно использовать Webproxy. Введите имя вашего сайта в строке поиска и кликните GO. Если ваш сайт доступен, значит проблема находится на стороне вашего интернет-провайдера. Необходимо подождать обновления DNS-серверов провайдера. Обновление DNS-серверов может занимать от 24 часов до нескольких суток.
Сайт не открывается С или БЕЗ «www»
Сайт не открывается без «WWW» перед доменным именем
Скорее всего, при добавлении домена в панели управления хостингом вы добавили не сам домен, а его поддомен www.ваш_домен. Необходимо пересоздать домен в панели управления хостингом, добавив его без «www» вначале (см. статью Размещение сайта на хостинге).
Сайт не открывается с «WWW» перед доменным именем
Проверьте наличие синонима www.ваш_домен в панели управления хостингом. Создать синоним вы можете в панели управления в разделе Веб-сервер → Сайты. Найдите в таблице сайт, для которого создается синоним, и кликните на него. В открывшемся окне Управление сайтом нажмите Синонимы сайта и добавьте синоним www.ваш_домен.
Если домен делегирован не на DNS-серверы RU-CENTER или у вас подключена услуга DNS-хостинг — убедитесь в наличии CNAME-записи с «WWW».
На сайте белая страница
Белая страница может означать, что во время исполнения скрипта произошла ошибка. Попробуйте включить отображение ошибок (см. статью Диагностика и устранение неполадок в работе скриптов сайта).
Ошибка подключения к базе данных
В этом случае на сайте могут отображаться сообщения:
«DB error»
«Could not connect to MySQL»
«Error Establishing a Database Connection»
«Database connection error (2): Could not connect to MySQL»
«Невозможно подключиться к базе данных»
Проверьте реквизиты для подключения к базе данных. Узнать правильные реквизиты для подключения к базе данных можно через панель управления хостингом (см. статью Подключение к серверу MySQL ). Реквизиты для подключения к базе данных должны быть прописаны в конфигурационном файле вашего сайта (см. статью Конфигурационные файлы популярных CMS).
Ошибки 403, 404, 500
По спецификации протокола HTTP все ответы сервера, в нашем случае Apache , разделены на группы:
1xx: Информационные
2xx: Положительные — запрос обработан и документ отдан клиенту
3xx: Перенаправление — сообщается о перенаправлении пользовательского запроса на другой сервер, url и т.д.
4xx: Ошибки обработки запроса клиента — связаны с некорректно запрошенным url, отсутствием необходимой авторизации, отсутствием прав доступа и т.д.
5xx: Ошибки обработки запроса — связаны с ошибками работы пользовательских скриптов на сервере, нарушением связанности сети и пр.
Имя индексного файла сайта не соответствует описанным именам индексных файлов в конфигурации сервера, при этом запрещено отображение содержимого текущего каталога опцией Indexes.
Например, индексный файл имеет имя default.html, а в конфигурации сервера заданы следующие индексные файлы:
при этом в конфигурации сервера (или в файле .htaccess) на директорию установлен запрет отображения содержимого каталога:
Лучший способ — внести имя default.html в список индексных файлов, добавив в начало файла .htaccess строку: DirectoryIndex default.html
Отсутствие прав на исполнение у файла в cgi-директории.
Например, вы загрузили в директорию /home/[LOGIN]/Ваш_домен/cgi/ файл test.cgi, но при этом не установили права на исполнение (u+x). При обращении по адресу http://Ваш_домен/cgi.bin/test.cgi получаем ошибку 403.
С помощью клиентов ftp или ssh сменить права доступа на файл командой
Отсутствие запрашиваемого файла или сервер не может его найти.
1. Воспользуйтесь панелью управления хостингом для просмотра логов сервера.
2. Загрузите недостающие файлы или исправьте ссылки на сайте.
500 Internal Server Error
В файле. htaccess вы указали директивы, которые не могут быть обработаны веб-сервером.
Например, в файле указаны директивы из модуля mod_rewrite, а сам модуль не включен в конфигурацию сервера.
1. Воспользуйтесь панелью управления хостингом для просмотра логов сервера.
2. Включите необходимый модуль в разделе Управление веб-сервером панели управления хостингом.
Ошибка выполнения вашего скрипта.
Например, скрипт, написанный на perl , не может найти необходимый ему perl-модуль.
1. Воспользуйтесь панелью управления хостингом для просмотра логов сервера.
2. Установите недостающие модули или исправьте ошибки в скрипте.
Более подробную информацию по протоколу HTTP и кодам ответа веб-сервера можно посмотреть в RFC 2616.
В случае возникновения неполадок в работе сайта, в первую очередь, рекомендуем проверить содержимое лог-файлов вашего сайта на наличие ошибок.
Описание ошибок, которые могут возникать при выполнении PHP-скриптов доступно на странице Диагностика и устранение неполадок в работе скриптов сайта.
Сайт то работает, то нет
Нестабильная работа сайта может быть связана с превышением лимита оперативной памяти. Подробная инструкция по проверке и снижению потребления оперативной памяти приведена в статье Использование ресурсов хостинга.
Сайт в некорректной кодировке (кракозябры)
По умолчанию на хостинге используется кодировка UTF-8. Изменить кодировку можно в панели управления хостингом в разделе Сайты → ваш_домен → Настройки → Веб-сервер → параметр Кодировка сайта.
Источник
Почта — диагностика и устранение ошибок
451 domain.ru prohibited. Disk quota exceeded
Сообщение означает, что дисковое пространство, выделенное для домена получателя, исчерпано.
Необходимо повторить отправку через некоторое время. Как правило, почтовый сервер предпринимает повторную попытку автоматически.
Для того чтобы возобновить прием почты, вы можете:
перераспределить дисковое пространство в разделе Ресурсы панели управления хостингом,
освободить почтовые ящики вашего домена от ненужных сообщений,
перейти на тарифный план с большим дисковым пространством (с последующей корректировкой квот).
Увеличить квоту отдельного ящика можно в разделе панели управления Почта → Ваш домен → Ваш ящик.
451 Please try another server
Сообщение означает, что требуется повторить попытку подключения к другому принимающему серверу RU-CENTER. Если в результате нескольких попыток отправка сообщений заканчивается неудачно, необходимо скорректировать настройки почтового сервера отправителя:
Отсутствие ответа от сервера mx02.nicmail.ru и ответ сервера mx03.nicmail.ru с кодом 4XX не должен восприниматься как фатальная ошибка, и попытки отправки должны продолжаться на серверы, указанные в других MX-записях.
Отправляющий почтовый сервер, который подключается к серверам RU-CENTER, должен иметь корректно настроенные DNS-записи. Должна существовать PTR-запись для IP-адреса почтового сервера в обратной зоне. Значение PTR-записи в обратной зоне должно совпадать с А-записью в прямой зоне (т.е. с именем сервера). Например, сервер исходящей почты relay05.nicmail.ru имеет IP-адрес 194.85.88.236:
Ожидание ответов от сервера RU-CENTER (timeout) должно составлять не менее 5 минут в соответствии с RFC 5321:
ожидание на стадии подключения (до получения приглашения с кодом 220): не менее 5 минут;
ожидание после «MAIL FROM»: не менее 5 минут;
ожидание после «RCPT TO»: не менее 5 минут.
452 message sending quota exceeded, try later
Сообщение означает, что для почтового ящика достигнут лимит на отправку сообщений (50 писем в 15 минут). Возможность отправки писем будет восстановлена автоматически в течение 10 минут.
476 connections from your host are denied
Сообщение означает, что подключение с вашего IP-адреса к почтовому серверу хостинга временно заблокировано. Это происходит в результате множественных ошибок при работе с почтовым сервером:
многократные попытки авторизации с неверными логином и паролем,
отправка писем на несуществующие адреса,
многократные попытки отправки писем при достижении лимитов, указанных на странице Ограничения и особенности почтовой системы.
Блокировка снимается автоматически через 15 минут. Для устранения проблемы рекомендуем проверить корректность настроек почтовых клиентов. Если проблема сохранится, сообщите о ней в службу технической поддержки, написав на адрес support@nic.ru и указав в письме
номер вашего договора,
почтовый ящик , при попытке отправки с которого наблюдается проблема,
ваш внешний IP-адрес. Узнать его вы можете на сайтах http://myip.ru и http://2ip.ru.
550 Your message was identified as SPAM
Сообщение означает, что входящее письмо было идентифицировано как спам на основе анализа его содержимого.
Попробуйте изменить формулировку письма и повторить отправку. Если проблема сохранится, обратитесь, пожалуйста, к получателю с помощью других средств связи с просьбой добавить ваш домен в белый список.
Если у вас нет контактных данных администратора домена получателя, воспользуйтесь сервисом Whois.
Вы можете добавить домен отправителя в белый список, тогда почта с данного домена не будет проверяться спам-фильтром. Чтобы добавить домен example.net в белый список, необходимо:
авторизоваться в панели управления, используя номер своего договора и пароль;
перейти в раздел Почта;
нажать на название почтового домена;
перейти в раздел Спам-фильтр → Белый список;
добавить маску вида *@example.net в блоке Новая маска почтового адреса и нажать кнопку Создать.
550 mailbox@domain.ru prohibited. We do not relay
Сообщение означает, что адрес mailbox@domain.ru не существует в почтовой системе хостинга RU-CENTER. Проверьте правильность написания адреса и повторите отправку.
591 mailbox@domain.ru You must authenticate first
Сообщение означает, что в почтовом клиенте не настроена авторизация на сервере исходящей почты ( SMTP ) mail.nic.ru по имени ящика и паролю (аналогично серверу входящей почты). Рекомендуем проверить корректность настроек почтового клиента. Например, если вы используете Outlook, убедитесь, что в настройках учетной записи для сервера исходящей почты стоит галочка напротив параметра SMTP-серверу требуется проверка подлинности и Аналогично серверу для входящей почты.
550 Sender domain does not match hosting account
Сообщение означает, что доменная часть адреса отправителя в заголовке «FROM» или в поле «MAIL FROM» конверта письма пустая или содержит домен, не добавленный на вашу услугу хостинга в качестве имени почтового домена или его синонима.
Рекомендуется проверить настройки почтового клиента или иного ПО, отправляющего почту, и указать адрес отправителя в домене, добавленном на ваш хостинг.
550 Incorrect header syntax in From field
Сообщение означает, что в письме поле «From» с адресом отправителя содержит информацию, которая не соответствует требованиям rfc5321 и rfc5322.
В частности, если в поле From в дополнение к адресу электронной почты указывается имя пользователя, оно должно быть заключено в кавычки: From: «User Name»
Рекомендуем проверить настройки почтового клиента или иного ПО, отправляющего почту, проверить текст, указанный в качестве имени отправителя, заключить его в кавычки. В некоторых почтовых клиентах использование кавычек и спецсимволов внутри имени пользователя, например, «Иван Иванов, ООО «Ромашка»» может приводить к ошибке, в этом случае кавычки или спецсимволы рекомендуется удалить, а также рассмотреть возможность обновления почтового клиента.
Источник
Почему не открывается сайт?
Всем привет, создал домен на хостинге nic.ru. Дилегирование прошло успешно, но сайт сейчас не работает до сих пор. В чем может быть беда? Из-за чего сайт может еще не открываться? Была идея — что идет сейчас распространение по Интернету потому и не работает в 20 по мск еще проверю. Но надежда на это угасает.
Upd.: Всем спасибо — ответ был прост — надо было включить автоподдержку домена.
Вопрос задан более трёх лет назад
382 просмотра
Проверить домен в разных NS. nslookup мойсайт.ру 8.8.8.8 если ответит значит всё в порядке. пинганите адрес указанный в качестве A записи. ping x.x.x.x если ответит — пропишите у себя в hosts строку вида x.x.x.x мойсайт.ру и зайдите на сайт мойсайт.ру в браузере. на сайте должна быть какая-то страничка чтобы она открылась. При определённых условиях браузер может показать полностью пустую страницу или ошибку. Это может указывать на отсутствие в корне сайта необходимой страницы. Создайте index.html и откройте её в браузере http://мойсайт.ру/index.html Должна отобразиться именно страница либо будет ошибка.
Если 8.8.8.8 не вернёт адрес проверьте его в тех NS которые указаны в домене. Команда такая же только 8.8.8.8 замените на адрес DNS привязанного к домену. Если не вернёт корректный адрес, смотрите привязку домена к DNS.
Файл hosts отрабатывает до ресолва имён в DNS подсистеме. Тоесть имеет более высокий приоритет позволяет иметь доступ к сайту без реального существования имени в DNS подсистеме (разумеется web сервер должен отвечать на это имя)