- Проблемы на сайте после обновления версии WordPress
- Обновить до последней версии WordPress
- Сделать откат к старой версии WordPress
- Отключить автоматическое обновление WordPress.
- Посещаем форумы wordpress.org.
- Не работает сайт на WordPress, типичные ошибки
- Белый экран смерти
- Internal server error
- Ошибка установления подключения к базе данных
- Ошибка 404
- Режим обслуживания после обновления
- Н е получается войти в панель управления (консоль)
- П ереадресация на странице входа в панель управления (консоль)
- Б елый текст или отсутствующие иконки в редакторе
- Если ничего не помогает
Проблемы на сайте после обновления версии WordPress
Как устранить возникшие проблемы на сайте после обновления версии WordPress?
Обычно я не спешу с обновлением движка на своем сайте. Точно так же, как и не спешу обновлять плагины, если они успешно работают.
Понятно, что нужно дать некоторое время на обкатку новых версий.
За это время разработчики смогут исправить выявленные и незамеченные ими ранее ошибки. И тогда можно будет безбоязненно и безопасно пользоваться обновленными программами.
Но с некоторых пор появилось автоматическое обновление WordPress.
Обновление происходит не до самой последней версии, а до последней уже обкатанной. То есть той, которую разработчики считают уже достаточно надежной и проверенной.
Мой сайт благополучно прошел несколько таких автоматических обновлений. И это не повлияло на его успешную работу.
Но после автоматического обновления WordPress до версии 4.1.6 (23.07.2015) некоторые функции моего сайта нарушились.
Что делать, если после автоматического обновления (или ручного обновления) версии WordPress сайт перестал отрабатывать свои определенные функции?
Обновить до последней версии WordPress
1. Прежде всего, стоит обновить свой сайт и все установленные на нем плагины WordPress до последних существующих версий.
Вдруг там были какие-то ошибки, и разработчики уже успели их найти и исправить.
Сразу скажу, в моем случае этот вариант не сработал. После автоматического обновления WordPress 4.1.6 я обновила движок до последней существующей на тот момент версии 4.2.3, но это ситуацию не спасло.
Какие у меня возникли проблемы на сайте после обновления версии WordPress?
У меня перестали запускаться виджеты Твиттера (не из боковой колонки, а непосредственно со страницы сайта) и исчезли окна просмотра презентаций, расположенные прямо на страницах.
Все это автоматически запускалось с помощью специально добавленных на страницу скриптов Javascript (как выяснилось впоследствии).
Естественно, что я стала искать способ, как все это восстановить.
Сделать откат к старой версии WordPress
2. Следующим наиболее безопасным пунктом я посчитала откат к старой версии WordPress с помощью резервной копии сайта, созданной на хостинге.
Можно взять резервную копию, созданную за день до автоматического обновления (если таковая имеется) и восстановить свой сайт и его функции.
Если Вы давно ничего не меняли на сайте, то можно использовать и более ранние сохраненные резервные копии.
Как работать с различными хостингами и создавать там резервные копии можно посмотреть здесь (выбрать из таблицы).
Мой хостинг Sprinthost ежедневно автоматически создает резервные копии сайта. Браво!
Поэтому я для себя такую копию нашла.
Но было жаль потраченных усилий на обновление плагинов и удаление старых, которых я уже не использую. И откатывать назад я не стала.
А что делать, если такой резервной копии нет?
В таком случае откат к более ранней версии Вордпресс тоже возможен, но уже не столь безопасен и прост.
Нужно найти и скачать старую версию Вордпресс, а потом вручную заменить на хостинге некоторые файлы.
Согласитесь, что это уже немного сложнее. Не очень хочется таким заниматься. Только в случае крайней необходимости (так я решила для себя).
Отключить автоматическое обновление WordPress.
Анализируя работу с различными версиями Вордпресс, я нашла, что существуют специальные плагины, которые проверяют, допускает ли Ваш сайт автоматическое обновление Вордпресс и предоставляют возможность его запретить.
Настройки плагинов находятся в необычных местах. Поэтому я прилагаю скриншоты.
Запуск плагина тестирования возможности автоматического обновления Background Update Tester после установки.
Отключить автоматическое обновление Вордпресс с помощью плагина Update Control .
После установки и активации открыть: Консоль — Настройки – Общие.
И прокрутить в самый низ. Там появляется пункт запрета обновления.
Я установила плагины на тренировочном блоге.
Логика в этом случае такая:
откатить WordPress до более ранней версии;
убедиться, что сайт функционирует нормально;
установить плагин, запрещающий автоматическое обновление.
Ну а дальше: сделать резервную копию сайта и попытаться обновить WordPress до последней версии вручную через некоторое время. Может, проблема уже решена?
Если все в порядке, то можно оставить.
Если функции сайта нарушились, то его можно восстановить из резервной копии. Это, конечно, поможет.
Но я решила продолжить поиск решения проблемы, а не откладывать ее в долгий ящик.
Ведь таким образом можно накопить множество проблем, с которыми трудно будет потом разобраться.
Всегда лучше идти в ногу со временем.
Посещаем форумы wordpress.org.
3. Если это какая-то глобальная проблема, то, возможно, что она возникла не только у меня.
Задав, несколько вопросов в поисковиках, я ничего путного не нашла.
И решила посетить сайт wordpress.org .
Открыла в его горизонтальном меню раздел Support (Поддержка) и из выпадающего меню выбрала Форумы.
Там нужно зарегистрироваться и Вам пришлют на почту пароль для входа.
Форумы разделены на несколько тем. Меня заинтересовали две из них:
1 Проблемы и решения;
2.Обратная связь (с разработчиками Вордпресс).
Надо сказать, что попала я первоначально на англоязычный форум. Но, так как я использовала браузер Google Chrome, то он обеспечивал мне автоматический перевод.
Просматривая проблемы, которые возникли у владельцев сайтов в буржунете, я увидела, что многие сообщают о том, что у них не запускаются функции Javascript со страницы сайта WordPress после обновления версии WordPress.
А у меня ведь тоже виджеты Твиттера и показ презентаций на страницах организованы с помощью таких скриптов!
Ага! Значит проблема общая, а не только у меня.
Я стала искать, что советуют для исправления ситуации, и даже ввязалась в одно из обсуждений, написав фразу на русском языке. На что мне вежливо заметили, чтобы я открыла и описала свою проблему отдельно, а не вмешивалась в чужую.
А потом меня и вовсе отфутболили на русскоязычный форум. Оказывается, такие форумы существуют на разных языках и нужно выбирать свой (в моем случае ru.forums.wordpress.org ).
Я сделала соответствующие выводы и оставила свои вопросы о том, что у меня не запускается Javascript со страницы сайта на русскоязычном форуме.
Кстати, только сейчас заметила, что с ошибкой написала. Торопилась…
А потом перевела и написала то же самое на англоязычном.
На русскоязычном форуме мне посоветовали поочередно отключать плагины и искать, какой мешает.
А с англоязычного форума пришло письмо, что они помогут решить мою проблему всего за 49$, причем оплата, только после решения проблемы. Автор указал, что он является экспертом сайта fixrunner.com — «Ваша персональная группа поддержки WordPress».
Я подумала, что, может, для буржунета это и недорого, но для рунета – это явно дороговато. И отвечать не стала.
Отключать по очереди плагины на работающем сайте я тоже посчитала не целесообразным.
Я и так провела большую встряску. Все плагины обновила и все лишнее удалила. Поэтому я решила смоделировать аналогичную ситуацию на своем тренировочном блоге. И проверить эту идею там.
Обычно, при покупке хостинга предоставляют возможность завести не менее двух сайтов. Так что один из них можно сделать плацдармом для внедрения всякого рода новшеств, чтобы убедиться, что они не будут нарушать функционал блога. А потом уже переносить все эти новшества на основной работающий сайт.
Так вот. Установила я запасном блоге все те же самые плагины, что и на основном. Все обновила до последних версий. И получила возможность отключать плагины без ущерба для работающего блога.
Отключила так несколько, но ничего не изменилось…
Тогда я более внимательно вчиталась в анонсированные изменения последней новой версии WordPress. Ведь такая проблема, как выяснилось на форуме, возникла не только у меня.
В описании новой версии основной упор делался на усиление защиты WordPress.
Поэтому я сделала вывод, что для усиления защиты разработчики WordPress, возможно, сознательно отключили запуск Javascript со страницы блога.
Получается, что я начала эксплуатировать WordPress, когда автоматический запуск такого дополнительного скрипта можно было легко осуществить, разместив Javascript непосредственно в HTML коде страницы сайта.
Но в истории WordPress, оказывается, были и другие времена, когда сделать это было не так просто.
Необходимо было предварительно выполнить несколько шагов.
Были варианты размещения дополнительного скрипта в header.php (между открывающим и закрывающим тегами шапки сайта). Или сначала требовалось поместить свой скрипт в определенный файл, а потом еще и в очередь поставить.
Возможно, что придется к этому вернуться. Надо разбираться.
Понятно, что разработчики WordPress могли запретить запуск Javascript со страницы сайта из благих побуждений. Защиту хотели усилить.
И хотя пострадавшие (такие, как я) в этом случае и есть, но их, очевидно, не так уж и много. Большинство запуск таких функций непосредственно со страницы не используют.
Жаль только, что на форумах мне никто так и не подсказал, как в таком случае можно запускать такие скрипты на своем Вордпресс сайте.
Хотя, может, я недостаточно настойчиво искала ответ?
Узнайте, как мне удалось решить свои проблемы на сайте после обновления версии WordPress, разобраться с запуском Javascript со страницы и восстановить функционал блога.
Источник
Не работает сайт на WordPress, типичные ошибки
WordPress, наверное, самая распространенная CMS в мире, но зачастую, когда сайт перестает работать, сама CMS не предоставляет никакой информации об ошибках.
Наиболее распространённые ошибки и примеры их устранения.
Белый экран смерти
Белый экран смерти [WSOD], вместо сайта отображается белый экран.
Один из вариантов решения
Включите отображение ошибок, для чего добавьте в файл wp-config.php следующую строку:
После чего на сайте должен отображаться код ошибки, обычно в коде содержится имя неработающего плагина.
Один из вариантов решения
Деактивируйте все установленные плагины, а затем включайте по одному. Если консоль управления сайтом недоступна, откройте через FTP папку wp-content/plugins и переименуйте папку, например, в wp-content/plugins_ old.
Один из вариантов решения
Увеличьте количество памяти. Для чего откройте файл wp-config.php и добавьте следующую строку:
Значение может быть любым: 64, 128 и так далее, но помните, в любом случае вы не сможете использовать памяти больше, чем предоставляется тарифным планом хостинга.
Один из вариантов решения
Ошибка в активной теме, переключитесь на стандартную тему Twenty Seventeen; если админпанель сайта недоступна, то через FTP измените папку с темой Twenty Seventeen на название активной темы. Имя активной темы также придется на время поменять.
Internal server error
Внутренняя ошибка сервера, обычно возникает из-за неправильной работы скриптов.
Один из вариантов решения
Через FTP переименуйте файл . htaccess в . htaccess_ old. Перезагрузите страницу сайта и, если он заработал, сбросьте постоянные ссылки на панели управления WordPress через «Настройки» -> «Постоянные ссылки», чтобы создать новый файл .htaccess.
Ошибка установления подключения к базе данных
Один из вариантов решения
Откройте файл wp-config.php и убедитесь, что следующие данные базы данных верны: имя базы, имя пользователя, пароль и хост.
Ошибка 404
Ошибка, из-за которой пользователь не может получить доступ к одной или нескольким страниц на сайте, в то время как все остальные разделы работают нормально.
Один из вариантов решения
Перейдите в «Настройки» -> «Постоянные ссылки» на панели управления WordPress и просто нажмите кнопку «Сохранить изменения». Это обновит ваши настройки постоянных ссылок и очистит правила перезаписи. Если это не работает, вам необходимо обновить файл .htaccess вручную. Если вы не знакомы с редактированием файлов .htaccess, обратитесь к вашему хост-провайдеру и попросите его включить mod_rewrite.
Режим обслуживания после обновления
Ошибка, возникающая после обновления, с сообщением «Коротко недоступно для планового обслуживания. Вернитесь через минуту».
Как правило, причина в неудаленном файле . maintenance, удалите его из корневого раздела сайта через FTP или менеджер файлов.
Н е получается войти в панель управления (консоль)
Возможные причины
- Вы забыли пароль, и у вас нет доступа к электронной почте для восстановления. Откройте в phpMyAdmin базу вашего сайта, найдите таблицу wp_ uers, откройте ее, в поле » Password» выберите значение MD5 и установите новый.
- Возможно, входу мешает плагин, отключайте по очереди плагины, как это было описано выше.
- Ошибка скриптов: включите режим отладки, как это было описано выше.
- Сайт взломан. В этом случае можно попробовать удалить вредоносные скрипты самостоятельно либо обратится к специалистам.
П ереадресация на странице входа в панель управления (консоль)
При попытке зайти на страницы / wp- login, / wp- admin происходит редирект на главную страницу сайта.
Возможные причины
- Неправильные значения полей URL сайта и домашнего URL в таблице wp-config
- Ненастроенные постоянные ссылки
- Ошибки в .htaccess
Варианты решения
Очистите файлы cookie и кэш браузера и убедитесь, что в вашем браузере включен прием cookie.
Перезапустите браузер и попробуйте войти снова.
Деактивировать все плагины (см. предыдущие пункты).
Использовать тему по умолчанию (см. предыдущие пункты).
Удалите файл .htaccess из корневого каталога вашего сайта. (см. предыдущие пункты).
Добавьте в файл wp-config.php и добавьте эти строки (не забудьте заменить example.com собственным URL и добавить www. если вы используете этот префикс).
Б елый текст или отсутствующие иконки в редакторе
Возможные причины: проблема с объединенными файлами JavaScript, TinyMCE или плагином.
Очистить кеш браузера.
Заменить скрипты TinyMCE. Это можно сделать, заменив папку /wp-includes/js/tinymce/ новой копией.
Если ничего из вышеперечисленного не работает, откройте файл wp-config.php и добавьте следующую строку в самом верху после открывающего тега PHP.
Если ничего не помогает
Включите запись ошибок в лог сервера, как правило, подобные ошибки уже неоднократно встречались на множестве сайтов, погуглите, и в 99,9% случаев решение будет найдено.
Источник