Openmediavault не работает web интерфейс
Frequently Asked Questions
What is OMV? OMV is an abbreviation of openmediavault. Is openmediavault a fork of FreeNAS? No Does openmediavault have drivers for my hardware? All module drivers are provided by the Debian standard kernel of oldstable release 8.9 (aka Jessie). This distribution ships with kernel 3.16 by default. Optionally is possible to install the backport kernel 4.9. If hardware is supported under Debian Jessie then is supported under openmediavault. The Jessie backport kernel 4.9 is the default kernel used by Stretch (Debian 9.3) at the moment, so it provides support for newer hardware. Can I use a usb flash drive (stick) for installing the system? Yes, but the installation does not have any optimizations to reduce writes into the OS disk. The usb media will most likely start failing within a few weeks of usage. Most common symptom is basic command execution does not work, denied login, etc. More information here. What are the default credentials for the UI? Use the user вЂadmin’ and the password вЂopenmediavault’ for the first login. Can I give administrator privileges to non-privileged users to access the web control panel? Yes. By default non-privileged users can only access their account profile, they can change password and their email address if the administrator has allowed changes on their account. However the current web interface framework is designed for developers to create plugins where they can give limited or full access to non-privileged users. An example is the openvpn plugin by omv-extras.org. A non-privileged user can become a web interface administrator by adding them to the openmediavault-admin group. What is the file /etc/openmediavault/config.xml for? It is the database configuration store file for openmediavault. When a change is performed in the web interface, the config value is stored and/or retrieved by RPC to/from this file. Can I upgrade to Debian Testing/Unstable (Debian Testing/Sid) or use Ubuntu as a base distribution? Yes. But the end is most likely a broken web interface and possibly broken system. openmediavault releases are heavily tight to their Debian base distribution. IВґve lost the web interface password. How do I reset it? Simply connect via ssh into the server or login locally on the machine and type in: omv-firstaid. There is an option to reset the web interface password. Can I backup or restore an existing openmediavault configuration? There is no regular backup/restore procedure, but yes, in some way: keep the file /etc/openmediavault/config.xml for references purposes if the option is to go for a clean re-install. What is the default HTTP engine of openmediavault? NGINX. The last version of openmediavault with Apache was 0.5 Sardoukar. Can I use Apache as HTTP engine? Yes, but is not supported. Eventually every openmediavault package upgrade will activate NGINX again leaving the web interface broken. A parallel Apache instance next to Nginx is possible, just make sure the ports are different otherwise the openmediavault web interface will not work. How can use the default HTTP engine to hold my own web page? Do not modify openmediavault default NGINX files. Place the website configurations in /etc/nginx/sites-available and enable it with nginx_ensite . Read more information in the NGINX documentation. Why does the system rewrites a configuration file(s) that I have manually edited? OMV takes full control of some system services. This services include monit, ntp, samba, network, proftpd, nginx, php5-fpm, etc. Read here . How can I modify an internal value of some service openmediavault has control over? Read here for advanced configurations. How can I modify or add a network configuration with some custom options the web interface does not provide? Starting with openmediavault 5 systemd-networkd is used to configure the network. The interfaces file /etc/network/interfaces is controlled by openmediavault but not used anymore. To add network interfaces that are not configurable through the web interface or other options not present, use advanced settings . Alternatively write your own systemd-networkd configuration files. Why my disks mount paths have a long alphanumeric number?
The long number is called UUID, it is used by fstab to mount disks. This number is unique per filesystem (or at least unlikely possible that another filesystem comes with an identical one). This helps maintaining the mount points. The old linux way (sda1, sdb1, etc.) is not guaranteed that /dev/sda1 is the same disk on next reboot. If having trouble identifying them in terminal, create a pool with symlinks to each file system with easy to remember names.
This behaviour has been deprecated now in current openmediavault releases including stable (Jessie). The default creation of mount paths is documented here.
I don’t have a data disk, and I want to use my OS disk for storing data?
The default behaviour of openmediavault is to act as NAS server, that means OS files are separated from data disks.
However if the OS disk is partitioned the system will recognise the extra partitions besides rootfs if is formatted. You can mount it and use it for shared folders.
The current installer does not provide access to the partition manager, use a plain Debian iso then install openmediavault on top and accommodate the partitions, or resize the partition after installing using Gparted or SystemRescueCd.
Can I install openmediavault on top a running Debian system? Yes, but it is recommended that the current running OS not to have a desktop environment installed. What is the permissions/ownership of folders in openmediavault created by shared folders? The default is folders in 2775 mode, with root:users ownership. This means all users created in the web interface can read, write to folders created by the system in the data drives using the default. The setgid allows group inheritance, meaning new files/folders below will always have the group users (GID=100) membership. I need to delete a shared folder, why the delete button is greyed/disabled? Shared folder configurations can be used across different services. When removing a shared folder configuration is necessary to unlink it from every service is attached to, before the delete button becomes available. At the moment there is no internal database backend that can display information about which service is holding which shares. What is the omv-salt command for? omv-salt is a terminal console command that is used by the backend of openmediavault to pipe directives and values to service configuration files. The arguments that omv-salt accepts are related to the name of the service it configures. Type omv-salt in terminal, press TAB key, and the terminal will display all available arguments. I want to experiment with openmediavault or make changes to the code As a true open source system everything is possible. The recommendation is do not test with the production server to avoid breaking the web interface. The best thing to do is to use a Virtual Machine. On Sourceforge there are preconfigured openmediavault images with virtual disks ready to launch. Alternatively checkout the openmediavault GIT repository and use Vagrant to create a virtual machine. What is the omv-update and omv-release-upgrade for? Information about those commands are in the software section .
© Copyright 2018 and onwards by the authors Revision 6747f02b .
Источник
TroubleshootingВ¶
The web interface has missing fields and/or items showing that have been uninstalled.
Clear your browser cache.
The web interface keeps rejecting my admin/user password.
If the password is correct then this is most likely caused by the rootfs partition being full. This command can help track which folders are the biggest df -hx —max-depth=1 /
I have problem accessing the web interface with Firefox.
Try the solution mentioned in the Sencha ExtJS forum or the Mozilla bugtracker.
I only see a few items in the web interface interface like the user section of Access Rights Management.
You did not login as the admin user. This is the only user that can access everything.
I get an error every time I post in the forum especially if it is a long post and/or has links to external pages.
The error is deceiving. Please don’t keep trying to post. The spam filter has flagged your post and it will need to be approved. Please be patient.
I mounted the drive using the command line or GUI tool and I can’t pick that drive in the shared folder device dropdown.
Never mount a drive with anything other than the openmediavault web interface. This creates the necessary database entries to populate the device dropdown.
Samba is slow.
Read these threads
- read/write performance for SMB shares hosted on RPi4
- Tuning Samba for more speed (note: written for OMV 2.x)
- Tuning Samba for more speed 2 (note: written for OMV 2.x)
Samba share password is refused from Windows 10.
How to troubleshoot an error caused by an “Option” parameter passed to a plug-in
is now more vebose, then you will get a hint on STDOUT. If not, then you need to run journalctl -f in parallel to get the syslog output. Admittedly, not really novice friendly, but it’s really not possible to do it any other way. OMV always tries to be as error/debug friendly as possible; by default.
I am using JMicron drive enclosures and some of my drives are not appearing.
This is likely because JMicron controllers incorrectly report identical serial numbers and other data which confuses various systems. openmediavault provides an UDEV rules database which will fix that issue for several USB PATA/SATA bridge controllers. If your hardware still does not work, then please provide the information mentioned in that pull request and open a new tracker issue.
Alternatively you can manually “fix” this by adding a rule to /lib/udev/rules.d/60-persistent-storage.rules after the entry for “Fall back usb_id for USB devices”:
This will ensure that unique paths are created based on the serial number of the actual drives and not the enclosures.
© Copyright 2018 and onwards by the authors Revision 6747f02b .
Источник
Пропал web и smb доступ к openmediavault
Здравствуйте.
помогите восстановить работу системы. я в них новичок.
Установил openmediavault на старое железо. немного настроил под себя.
дело было так: шло копирование файлов по сети и я через web интерфейс решил добавить нового пользователя.
при добавлении вышла ошибка, нажал отмена и пропал доступ по сети.
перезагрузка не помогла.
нашел команду /etc/init.d/nginx status
● nginx.service — A high performance web server and a reverse proxy server
Loaded: loaded (/lib/systemd/system/nginx.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Sun 2019-01-27 00:09:42 +07; 50s ago
Docs: man:nginx(8)
Process: 2094 ExecStop=/sbin/start-stop-daemon —quiet —stop —retry QUIT/5 —pidfile /run/nginx.pid (code=exited, status=0/SUCCESS)
Process: 1160 ExecStart=/usr/sbin/nginx -g daemon on; master_process on; (code=exited, status=0/SUCCESS)
Process: 2194 ExecStartPre=/usr/sbin/nginx -t -q -g daemon on; master_process on; (code=exited, status=1/FAILURE)
Main PID: 1164 (code=exited, status=0/SUCCESS)
янв 27 00:09:42 shd systemd[1]: Starting A high performance web server and a reverse proxy server.
янв 27 00:09:42 shd nginx[2194]: nginx: [emerg] invalid number of arguments in «listen» directive in /etc/ngin…lt-pxe:2
янв 27 00:09:42 shd nginx[2194]: nginx: configuration file /etc/nginx/nginx.conf test failed
янв 27 00:09:42 shd systemd[1]: nginx.service: Control process exited, code=exited status=1
янв 27 00:09:42 shd systemd[1]: Failed to start A high performance web server and a reverse proxy server.
янв 27 00:09:42 shd systemd[1]: nginx.service: Unit entered failed state.
янв 27 00:09:42 shd systemd[1]: nginx.service: Failed with result ‘exit-code’.
Hint: Some lines were ellipsized, use -l to show in full.
понимаю что ошибка в файле openmediavault-pxe
привожу содержание
Помощь в написании контрольных, курсовых и дипломных работ здесь.
Пропал веб интерфейс Openmediavault
Имеется сервер с установленной Openmediavault, после пропажи света пропал веб интерфейс — выдает -.
Протокол SMB доступ
Всем привет, вообщем задача получить список файлов с расшаренного каталога на сервере, ничего по.
Всем привет. Имеется сервер на CentOS 7, он выполняет несколько функций. В частности.
Доступ из-за Mikrotik к SMB шаре
Доброго времени суток, Уважаемые Гуру! Имею небольшую сеточку с компами. На входе софтварный.
Источник
No access to Web Interface
Following an attempt to update by «Update Management» I do not have access to «Control Panel». Login with: admin and the password.
I always access through SSH
I still have access to my hard drives.
When I want to connect to the web interface to configure my OMV, I get this error message:
***********************
Erreur #0:
exception ‘OMV\Rpc\Exception’ with message ‘Failed to connect to socket: No such file or directory’ in /usr/share/php/openmediavault/rpc/rpc.inc:135
Stack trace:
#0 /var/www/openmediavault/rpc/session.inc(56): OMV\Rpc\Rpc::call(‘UserMgmt’, ‘authUser’, Array, Array, 2, true)
#1 [internal function]: OMVRpcServiceSession->login(Array, Array)
#2 /usr/share/php/openmediavault/rpc/serviceabstract.inc(124): call_user_func_array(Array, Array)
#3 /usr/share/php/openmediavault/rpc/rpc.inc(81): OMV\Rpc\ServiceAbstract->callMethod(‘login’, Array, Array)
#4 /usr/share/php/openmediavault/rpc/proxy/json.inc(95): OMV\Rpc\Rpc::call(‘Session’, ‘login’, Array, Array, 3)
#5 /var/www/openmediavault/rpc.php(45): OMV\Rpc\Proxy\Json->handle()
#6
How to get my access?
Thank you in advance.
OMV — 2.2.1 Raspberry pi 2
NAS Backup BD radio station.
Is this on an RPi2? Did you try logging in locally and executing omv-firstaid?
omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
omv-extras.org plugins source code and issue tracker — github
Please read this before posting a question.
Please don’t PM for support. Too many PMs!
The first thing to do in this case is to find out WHY the omv-engined daemon process is not running. To find out more you have to execute the following CLI command:
If there is a problem with a plugin or something else you will see an error message in the output.
Hello,
This is a configuration with Rpi2
I have SSH access without problems.
I do not know «omv-firstaid»
Thank you for your help
OMV — 2.2.1 Raspberry pi 2
NAS Backup BD radio station.
The answer, when I entered the indicated command:
# omv-engined -d -f
PHP Fatal error: Class ‘OMV\Rpc\ServiceAbstract’ not found in /usr/share/openme diavault/engined/rpc/flashmemory.inc on line 19
root@serveur-nas:
OMV — 2.2.1 Raspberry pi 2
NAS Backup BD radio station.
What is the output of: dpkg -l | grep openm
omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
omv-extras.org plugins source code and issue tracker — github
Please read this before posting a question.
Please don’t PM for support. Too many PMs!
Here is the result:
# dpkg -l | grep openm
ii openmediavault 3.0.13 all Open network attached storage solution
ii openmediavault-flashmemory 3.4.1 all folder2ram plugin for OpenMediaVault
ii openmediavault-keyring 0.4 all GnuPG archive keys of the OpenMediaVault archive
ii openmediavault-mpd 2.0 all OpenMediaVault MPD (Music Player Daemon) plugin
ii openmediavault-omvextrasorg 3.3.3 all OMV-Extras.org Package Repositories for OpenMediaVault
root@serveur-nas:
OMV — 2.2.1 Raspberry pi 2
NAS Backup BD radio station.
You need to update OMV itself if you want to use the latest flashmemory and omvextras plugins. This will also mean the mpd plugin will need to be removed.
omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
omv-extras.org plugins source code and issue tracker — github
Please read this before posting a question.
Please don’t PM for support. Too many PMs!
How to remove these plugins, I can do without.
I mainly need to regain access to the web interface
OMV — 2.2.1 Raspberry pi 2
NAS Backup BD radio station.
As root:
apt-get update
apt-get remove openmediavault-mpd
apt-get install openmediavault
omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
omv-extras.org plugins source code and issue tracker — github
Please read this before posting a question.
Please don’t PM for support. Too many PMs!
Phew .
Thank you I found the Web Interface .
A huge thank you to you .
OMV — 2.2.1 Raspberry pi 2
NAS Backup BD radio station.
I just have a message that will be displayed when I go to the «Service» FTP:
*******************************************************************************************
Failed to index key ‘enable’ of ‘enable.0’ Because It Has No children.
Erreur #0:
exception ‘RuntimeException’ with message ‘Failed to index key ‘enable’ of ‘enable.0′ because it has no children.’ in /usr/share/php/openmediavault/dictionary.inc:145
Stack trace:
#0 /usr/share/php/openmediavault/config/configobject.inc(193): OMV\Dictionary->set(‘enable.0’, true)
#1 /usr/share/php/openmediavault/config/configobject.inc(271): OMV\Config\ConfigObject->set(‘enable.0’, ‘1’, false)
#2 /usr/share/php/openmediavault/config/configobject.inc(233): OMV\Config\ConfigObject->setFlatAssoc(Array, false, false)
#3 /usr/share/php/openmediavault/config/database.inc(85): OMV\Config\ConfigObject->setAssoc(Array, false)
#4 /usr/share/openmediavault/engined/rpc/ftp.inc(115): OMV\Config\Database->get(‘conf.service.ft. ‘)
#5 [internal function]: OMVRpcServiceFtp->getShareList(Array, Array)
#6 /usr/share/php/openmediavault/rpc/serviceabstract.inc(124): call_user_func_array(Array, Array)
#7 /usr/share/php/openmediavault/rpc/rpc.inc(81): OMV\Rpc\ServiceAbstract->callMethod(‘getShareList’, Array, Array)
#8 /usr/sbin/omv-engined(524): OMV\Rpc\Rpc::call(‘FTP’, ‘getShareList’, Array, Array, 1)
#9
*******************************************************************************************
If I’m «OK» in the «FTP Service» without problem.
For safety I’ll redo an SD version 2.2.5. Stable
Again thank you for everything.
OMV — 2.2.1 Raspberry pi 2
NAS Backup BD radio station.
Edited once, last by JackyNiew ( Jun 27th 2016 ).
Participate now!
Don’t have an account yet? Register yourself now and be a part of our community!
Источник