АСИОУ — автоматизированная система информационного обеспечения управления образовательным процессом
EleKrivo
EleKrivo
Ошибка 504: «Не запускается АСИОУ по ярлычку, появляется белый экран с надписью 504 Gatewey Time-out nginx/1.0.11»
«Появляется белый экран с надписью 504 Gatewey»
Возникает (часто) в случае превышения времени на выполнение запроса к базе данных по нескольким причинам.
I. Если 504 ошибка выдается при попытке начального запуска АСИОУ 7 после установки инсталлятором, то необходимо проверить запуск Служб.
Необходимо сделать следующее:
Зайти в Пуск->Панель управления->Администрирование и проверить службы: MySQL,nginx,ASIOU7. Они должны быть запущены. При необходимости запустить их вручную.
II. При работающей системе в каком-то режиме возникает ошибка 504.
Сначала необходимо проверить работоспособность АСИОУ 7 – запустить АСИОУ напрямую (через командную строку) для того, чтобы удостовериться, что дело действительно во времени. Данный запуск нужно выполнять на том компьютере, где установлена система.
1) Войти в командную строку (она либо отражается в меню «Пуск», либо ее необходимо найти, для этого в поле «Найти программы и файлы» в меню «Пуск» набрать cmd и выбрать из открывшегося списка командную строку).
2) В командной строке выполнить следующие команды:
python manage.py runserver
После этого черный экран НЕ закрывать, просто СВЕРНУТЬ!
3) В браузере перейти по адресу 127.0.0.1:8000
4) Выполнить ту операцию, на которой появилась ошибка 504 при обычном запуске программы АСИОУ.
Если ошибка повторилась, то обратиться за консультацией по электронной почте asiou7@yandex.ru.
Если после этого программа нормально запустилась и выполнила действия в результате которых возникала ошибка, необходимо выполнить ряд настроек:
I. Настройка антивирусной программы
Действия при исправлении ошибки следующие: добавить страницу АСИОУ в доверенные адреса антивирусника.
Например, для Касперского:
1) Перейти: вкладка Настройки –> Антивирусная защита –> Веб-Антивирус –> кнопка Настройка –> вкладка Доверенные веб-адреса –> кнопка Добавить
2) Добавить адрес: 127.0.0.1/* (или localhost/* или ip адрес сервера /*)
3) Нажимать ОК, еще раз ОК и сохранить
II. Настройка программы nginx
Нужно отредактировать несколько файлов, которые расположены в папке C:
ginxconf. Открыть их можно с помощью программы WordPad.
1) Файл nginx.conf.
Добавить после строчки default_type application/octet-stream; четыре новые строки:
2) Файл fastcgi_params.
Исправить в последней строке – fastcgi_param REDIRECT_STATUS – трехзначное число на 500. Сохранить файл.
3) Файл fastcgi.conf.
Исправить в последней строке – fastcgi_param REDIRECT_STATUS – трехзначное число на 500. Сохранить файл.
4) Файл fastcgi_params_django.
Исправить в последней строке – fastcgi_param REDIRECT_STATUS – трехзначное число на 500. Сохранить файл.
5) Перезагрузить компьютер.
Результат этих действий высылать на asiou7@yandex.ru
Инструкция для диагностики 504
1. Запустить АСИОУ7 с ярлыка
2. Если выдается 504 ошибка, сделать копию экрана и сохранить с примечанием, что запуск с ярлыка.
3. Закрыть браузер.
4. Запустить АСИОУ 7 с помощью runserver по следующему алгоритму:
a. Войти в командную строку (она либо отражается в меню «Пуск», либо ее необходимо найти, для этого в поле «Найти программы и файлы» в меню «Пуск» набрать cmd и выбрать из открывшегося списка командную строку).
b. В командной строке выполнить следующие команды:
python manage.py runserver
c. После этого черный экран НЕ закрывать, просто СВЕРНУТЬ!
d. В браузере перейти по адресу 127.0.0.1:8000
5. Сделать копию экрана и сохранить с примечанием, что запуск с помощью runserver.
6. Перейти в командную строку, сделать копию экрана и сохранить в файле.
7. Выслать письмо на адрес asiou7@yandex.ru с указанием проблемы «Ошибка 504», прикрепить ВСЕ копии экранов (3 штуки) и два файла из папки www (она как правило располагается на диске С
EleKrivo
ОШИБКА: «Не могу найти службы ASIOU7 и nginx»
Необходимо сделать следующее:
1) Открыть командную строку (несколько способов открытия):
— пуск — программы — стандартные — командная строка
— пуск — все программы — стандартные — командная строка
— пуск — выполнить — cmd — нажать ОК или Enter
— win + R — cmd — нажать OK или Enter
2) В командной строке выполнить команду cd c:www
3) Выполнить команду as_srv.exe install
4) Выполнить команду cd c:
ginx
5) Выполнить команду ng_srv.exe install
6) Перезагрузить компьютер
7) Зайти в Панель управления — Администрирование – Службы и проверить, что службы ASIOU7 и nginx появились в списке.
EleKrivo
ОШИБКА:«Не могу найти отчеты, которые должны быть в системе».
Возникает в случае несоответствия файла options.ini типу данного учреждения.
Поэтому действия при исправлении ошибки следующие:
Скачать по ссылке нужный файл options.ini (тот, который именно для этого типа ОУ) и положить его в папку C:wwwasiou
Перезагрузить компьютер или перезапустить службу ASIOU7.
Ссылки на файл options.ini в соответствии с типом учреждений:
EleKrivo
ОШИБКА: «Не выбирается класс для перевода учащихся, не копируется учебный план»
Возникает в случае отсутствия значения в поле «Год обучения» при создания классов и учебных групп.
Поэтому действия при исправлении ошибки следующие:
1. Войти по очереди во все классы и учебные группы по кнопке [Изменить] (желтый карандаш).
2. В поле «Год обучения» выбрать из справочника соответствующую параллель.
EleKrivo
ОШИБКА: «Не могу найти классный час», «Нет классного часа в списке предметов»
При формировании справочников для данного учреждения необходимо выбрать «классный час» как предмет из стандартного справочника предметов ( а не набирать эти два слова вручную! ).
Затем в учебном плане всем классам добавить «классный час» как предмет и указать в качестве учителя ФИО классного руководителя.
EleKrivo
Ошибка при загрузке файла «expmark-Current.xml»: Нарушена связь в файле «expmark-Current.xml»! Не существует учащегося с ID:ХХХХ
Учащийся с указанным ID недавно выбыл. Но кто-то из учителей поставил ему в журнале «н» после приказа о выбытии. Необходимо найти эти «н», удалить их и повторить выгрузку. Фамилию ребенка можно найти в меню «Контингент» по номеру ID.
EleKrivo
ОШИБКА: «В справочниках нет объекта с типом None»
Появляется при попытке работать с группами.
Возможны следующие варианты:
1. Не определены виды групп. Определяются в пункте главного меню «ОУ», подпункт «Виды групп»
2. У видов групп не стоит флаг «формируется извне».
EleKrivo
ОШИБКА: «Попытка добавить любой объект (учащегося, предмет, учителя и т.п.) вызывает появление сообщения «Объект с таким ID уже есть»».
Возникает в том случае, если по какой-либо причине не была выполнена команда re_sequence для переназначения идентификаторов.
Для исправления ситуации в командной строке нужно выполнить следующие команды:
python manage.py re_sequence
EleKrivo
СИТУАЦИЯ: «Необходимо переустановить АСИОУ7 с помощью инсталлятора в случае аварийного прерывания процесса инсталляции»
Необходимо сделать следующее:
1) Зайти в Пуск->Панель управления->Администрирование и остановить там службы: MySQL,nginx,ASIOU7(если такие имеются и они работают). Для остановки службы встать на соответствующую строку и слева от списка будет ссылка Остановить службу.
2) Удалите с диска С папки www и Asiou_DB
3) Запустите инсталлятор
4) Если все успешно установится, то выполняйте обновление дальше согласно инструкции по обновлению или установки
Источник
Почему не работает асиоу
МОУ СОШ №56, г. Ярославль.
В нашей школе при работе с АСИОУ существует большая проблема: в то время, когда программой пользуется небольшое количество человек, АСИОУ работает нормально, но во время активной загруженности, практически не работает (списки классов не загружаются, отчёты не формируются, главная страница может совсем не открыться и т.д.). Мы обращались с этой проблемой в АСИОУ7: заменили в итоге ошибочные файлы и перенесли лишние уроки на лето прошлого года. Это результатов не дало. Специалист из ГЦРО переустановил нам АСИОУ на другой сервер, чтобы выяснить в чём проблема — в самой программе или в сервере. В итоге АСИОУ также не стала работать быстрее.
В АСИОУ7 нам сказали, что скорее всего проблема в том, что служба MySQL не оптимизирована под нашу систему. Где мы можем взять чёткую инструкцию по оптимизации работы MySQL под Windows?
Цитата: Где мы можем взять чёткую инструкцию по оптимизации работы MySQL под Windows?
А не припомните, где примерно вы видели инструкцию? Не можем найти.
Вот инструкция от Сергея (последнее замечание про монтирование файловой системы касается исключительно Линукса и мне смысл его не понятен):
# Размер буфера ключей, можно ставить до 25% от общего объема ОЗУ, распределяется между всеми потоками. Для 4Гб ОЗУ мы ставим 256М
# Кэширование открытых ранее таблиц, 512 значение для 4Гб ОЗУ, при увеличении можно
# так же увеличивать (при необходимости, зависит от размеров кол-ва БД и кол-ва таблиц)
# От этих параметров зависит будет временная таблица создана в памяти или будет записана на диск. При превышении указанного размера, будет записана на диск.
# Иногда при больших запросах создается временная таблица для подготовки и сортировки результата
# Буферы чтения, сортировки, значения для 4 Гб ОЗУ. При увеличении ОЗУ увеливать
# необходимо не пропорционально, например при 12 Гб ОЗУ, можно увеличить в 2 раза.
# Важный параметр, буфер для движка InnoDB, ставить надо максимально возможное значение, иp рекомендаций 50-80% доступного ОЗУ
Так же есть смысл монтировать раздел с БД с опцией noatime, при этом не будет записывать дата модификации файлов БД. Необходимо добавить данный параметр в fstab.
Продолжу тему про медленную работу АСИОУ.
Серверные мощности вполне себе хорошие: приложение крутиться на Xeon 2.4GHz 4Гб ОЗУ + MySQL на 8 cores Xeon 2.4GHz 8 Гб ОЗУ RAID0 из 2 SSD (запросы к СУБД отрабатывают быстро). Оба сервера находятся в пределах одной хост-машины, лаг сети — микросекунды.
Открываю вечером (когда я один пользователь) страницу с 30 сотрудниками и она генерится 3.5 секунды, что ооооочень долго для такого железа и софта. Картина повторяется стабильно. Данных пришло чуть менее 10Кб.
Дамп запросов к БД показал, что их было 1063. ТЫСЯЧА запросов для отображения 30 сотрудников! Не многовато ли?
Для анализа загрузки серверов увеличил число записей на странице и отобразил все (306 сотрудников). Страница генерилась уже 27 секунд (что вообще заоблачно) и весила 36 Кб. Дамп запросов показал, что на этот раз их было более 9200 (ничоси. ). Загрузка сервера приложений была около 50-60% (пол ядра), а сервера СУБД — 5-7%.
8 тысяч из них были к таблице asiou_p_params, точно не вариант с кэшированием значений?
Источник
Почему не работает асиоу
Ошибка 504: «Не запускается АСИОУ по ярлычку, появляется белый экран с надписью 504 Gatewey Time-out nginx/1.0.11»
«Появляется белый экран с надписью 504 Gatewey»
Возникает (часто) в случае превышения времени на выполнение запроса к базе данных по нескольким причинам.
I. Если 504 ошибка выдается при попытке начального запуска АСИОУ 7 после установки инсталлятором, то необходимо проверить запуск Служб.
Необходимо сделать следующее:
Зайти в Пуск->Панель управления->Администрирование и проверить службы: MySQL,nginx,ASIOU7. Они должны быть запущены. При необходимости запустить их вручную.
II. При работающей системе в каком-то режиме возникает ошибка 504.
Сначала необходимо проверить работоспособность АСИОУ 7 – запустить АСИОУ напрямую (через командную строку) для того, чтобы удостовериться, что дело действительно во времени. Данный запуск нужно выполнять на том компьютере, где установлена система.
1) Войти в командную строку (она либо отражается в меню «Пуск», либо ее необходимо найти, для этого в поле «Найти программы и файлы» в меню «Пуск» набрать cmd и выбрать из открывшегося списка командную строку).
2) В командной строке выполнить следующие команды:
python manage.py runserver
После этого черный экран НЕ закрывать, просто СВЕРНУТЬ!
3) В браузере перейти по адресу 127.0.0.1:8000
4) Выполнить ту операцию, на которой появилась ошибка 504 при обычном запуске программы АСИОУ.
Если ошибка повторилась, то обратиться за консультацией по электронной почте asiou7@yandex.ru.
Если после этого программа нормально запустилась и выполнила действия в результате которых возникала ошибка, необходимо выполнить ряд настроек:
I. Настройка антивирусной программы
Действия при исправлении ошибки следующие: добавить страницу АСИОУ в доверенные адреса антивирусника.
Например, для Касперского:
1) Перейти: вкладка Настройки –> Антивирусная защита –> Веб-Антивирус –> кнопка Настройка –> вкладка Доверенные веб-адреса –> кнопка Добавить
2) Добавить адрес: 127.0.0.1/* (или localhost/* или ip адрес сервера /*)
3) Нажимать ОК, еще раз ОК и сохранить
II. Настройка программы nginx
Нужно отредактировать несколько файлов, которые расположены в папке C:
ginxconf. Открыть их можно с помощью программы WordPad.
1) Файл nginx.conf.
Добавить после строчки default_type application/octet-stream; четыре новые строки:
2) Файл fastcgi_params.
Исправить в последней строке – fastcgi_param REDIRECT_STATUS – трехзначное число на 500. Сохранить файл.
3) Файл fastcgi.conf.
Исправить в последней строке – fastcgi_param REDIRECT_STATUS – трехзначное число на 500. Сохранить файл.
4) Файл fastcgi_params_django.
Исправить в последней строке – fastcgi_param REDIRECT_STATUS – трехзначное число на 500. Сохранить файл.
5) Перезагрузить компьютер.
Результат этих действий высылать на asiou7@yandex.ru
Инструкция для диагностики 504
1. Запустить АСИОУ7 с ярлыка
2. Если выдается 504 ошибка, сделать копию экрана и сохранить с примечанием, что запуск с ярлыка.
3. Закрыть браузер.
4. Запустить АСИОУ 7 с помощью runserver по следующему алгоритму:
a. Войти в командную строку (она либо отражается в меню «Пуск», либо ее необходимо найти, для этого в поле «Найти программы и файлы» в меню «Пуск» набрать cmd и выбрать из открывшегося списка командную строку).
b. В командной строке выполнить следующие команды:
python manage.py runserver
c. После этого черный экран НЕ закрывать, просто СВЕРНУТЬ!
d. В браузере перейти по адресу 127.0.0.1:8000
5. Сделать копию экрана и сохранить с примечанием, что запуск с помощью runserver.
6. Перейти в командную строку, сделать копию экрана и сохранить в файле.
7. Выслать письмо на адрес asiou7@yandex.ru с указанием проблемы «Ошибка 504», прикрепить ВСЕ копии экранов (3 штуки) и два файла из папки www (она как правило располагается на диске С
Источник