Почему не работает mamp не кликается

Ошибки PHP в новом MAMP

Я скачиваю абсолютно новую, последнюю версию MAMP 3.5.

Я захожу в phpInfo, и он говорит, что версия PHP 7.0.0 и файл конфигурации ( php.ini ) Путь это: /Applications/MAMP/bin/php/php7.0.0/conf ,

я иду в php.ini в этом пути и измените ошибки на: display_errors = On , Я проверяю это: error_reporting = E_ALL ,

Я останавливаю серверы и запускаю серверы. Я перезагружаю страницу в браузере. Я проверяю phpInfo и сейчас display_errors включен

Я не вижу ошибок.

Я перепробовал все и не вижу ошибок PHP. Что еще я могу сделать?

Решение

Предисловие вашего кода PHP с этим. Это приведет к отображению ошибок.

Также проверьте ваши файлы .ini в следующих местах:

Applications / MAMP / bin / php / (версия PHP) /conf/php.ini

Applications / MAMP / conf / php / (версия PHP) /conf/php.ini

Они оба должны быть установлены для:

РЕДАКТИРОВАТЬ: Я должен уточнить это, поскольку это может быть точка путаницы: вы должны перезагрузите сервер MAMP когда изменения будут завершены.

Другие решения

Я изменил свои файлы .ini, расположенные как Bangkoian, как указано выше. В MAMP PRO 3.5 Существует дополнительный или третий INI-файл, который необходимо изменить.

Доступ к этому файлу возможен только через MAMP Pro Меню Файл . Я не уверен, где это на самом деле находится в реальной файловой структуре.

Доступ к .ini по: Команда +4 или же
Файл> Изменить шаблон> PHP> Версия, которую вы используете

Найдите вокруг строки 271:

и изменить на E_ALL

под Отчет об ошибках Ищу display_errors и изменить:

и изменить на На

Вам в конечном итоге придется изменить эти строки в 3 разных места

Applications / MAMP / bin / php / (версия PHP) /conf/php.ini

Applications / MAMP / conf / php / (версия PHP) /conf/php.ini

и через сам MAMP Pro:
Команда +4 или же
Файл> Изменить шаблон> PHP> Версия, которую вы используете

После добавления третьего метода он заработал, как и ожидалось, я также использую PHP 7. Убедитесь, что Отладчик Активировать Xdebug это проверено под вкладкой PHP.

Источник

MAMP MySQL не запускается (Winows 10)

Из прочтения я вижу, что это очень распространенная проблема, и есть 2 рекомендуемых основных решения:

очистить временные файлы; а также проверьте, работает ли другой экземпляр MySQL.

Решение 1. Очистить файлы, которые я очистил ib_logfile0, ib_logfil1 и iddata1. Когда я перезапускаю MAMP, он воссоздает эти файлы, но сервер не запускается.

Решение 2. Закройте другие экземпляры MySWL. Я не могу найти способ проверить, работает ли MySQL еще где-нибудь. Читая вокруг (включая справочный сайт MAMP), я должен использовать диспетчер задач Windows, чтобы найти «MySQLd» и закрыть все запущенные экземпляры, однако Win10, похоже, удалил функцию поиска из диспетчера задач. Просмотр процессов не показал, хотя:

Читайте также:  Как отремонтировать кухню дома

Далее я видел людей, добавляющих «innodb_force_recovery = 1» в файл my.cnf. Я искал my.cnf, но не смог его найти. Вместо этого я попытался добавить строку в C:\MAMP\conf\mysql\my.ini, а также попытался добавить «innodb_force_recovery = 2». Ни один не работал.

Я попытался изменить номер порта, который использует MySQL, на 3307, который тоже не работал.

Наконец, я удалил и переустановил MAMP — не сработало.

Журнал ошибок MySQL гласит:

[Предупреждение] TIMESTAMP с неявным значением DEFAULT устарела. Пожалуйста, используйте опцию сервера —explicit_defaults_for_timestamp (см. Документацию для более подробной информации).

[Примечание] —secure-file-priv установлено в NULL. Операции, связанные с импортом и экспортом данных, отключены

[Примечание] C:\MAMP\bin\mysql\bin\mysqld.exe(mysqld 5.7.24-log), начиная с процесса 9044.

У кого-нибудь есть какие-либо идеи?

Я думаю, что было бы полезно, если есть способ проверить экземпляры MySQL, запущенные через командную строку, а затем, если они есть, как закрыть его из командной строки.

Любая помощь будет принята с благодарностью!

Источник

не могу заставить php работать в MAMP

Я пытаюсь изучить php, и Шаг первый — заставить php работать в некотором качестве. Я пытаюсь использовать MAMP, но у меня возникли некоторые проблемы.

в частности: если я создаю файл с приведенным ниже кодом и сохраняю его как индекс.html в каталоге «корень документа» MAMP, я получаю пустую страницу при указании моего браузера на http://localhost:8888/index.HTML-код.

альтернативно, если я помещу немного php в свой собственный файл (скажем, test.РНР) а затем мой браузер на этот файл, он просто отображает текст файла в браузере.

есть идеи, что я могу делать неправильно?

4 ответов

вы должны сохранить файл с PHP внутри него с a .расширение PHP. Поэтому вам нужно будет назвать его index.php вместо index.html . Простое решение.

У меня была аналогичная проблема.

создайте новый файл в TextWrangler или Komodo, или что угодно, и добавьте следующий код:

вы собираетесь сохранить файл как .откройте файл. htaccess (с точкой в передней; это имя файла). Сохраните его в / Applications/MAMP / htdocs. Это то же самое место, где вы сохраните файлы php и html. Этот.htaccess будет невидимым файлом; вы не увидите его в Finder, то вы можете, если вы компакт-диск к нему в терминале, или поиск ж / в Finder и выбор типа видимости файла в разделе вид.

теперь попробуйте перейти к localhost: 8888/ и вы должны увидеть все доступные файлы там. И с этим вновь созданным .htaccess файл, теперь вы можете встроить php в html-файл тоже.

в MAMP, отредактируйте файл:

/ приложения / MAMP/conf/apache / httpd.conf

, а затем найдите «#AddHandler type-map» (исключить кавычки). Ниже, добавьте,

приложение AddHandler / x-httpd-php .РНР. HTML-код

Читайте также:  Что делать когда сломался триколор

сохраните файл и остановите и повторно запустите MAMP. Синтаксический анализ Php будет происходить в файлах, заканчивающихся расширениями: .php и .формат html.

Итак, это просто сработало для меня:

поместите все свои файлы непосредственно в папку htdocs!

MAMP/htdocs / все ваши файлы, включая индекс.PHP и др.

Источник

Проблемы с MAMP

Столкнулся с проблемами, настраивая на Mac локальный сервер MAMP.

Первая проблема возникла, когда потребовалось организовать виртуальный хост, так чтобы можно было обращаться по адресу не localhost:8080/mysite , а mysite:8080 (у меня apache на MAMP настроен на порт 8080).

Ориентировался на эти инструкции: http://foundationphp.com/tutorials/vhosts_mamp.php (то же самое пишут и на других сайтах, например: http://sawmac.com/mamp/virtual/), однако, как выяснилось, попытка подключения файла httpd-vhosts.conf , в котором определяются виртуальные хосты, путем раскомментирования строки

в файле httpd.conf приводила к невозможности запуска Apache. Наиболее естественное предположение, а именно, что в подключаемом файле есть ошибка, оказалось под большим сомнением, т.к. раскомментирование данной строки приводило к невозможности запуска Apache даже если в подключаемом файле все строки были закомментированы. В чем тут дело, я так и не разобрался, вместо этого перенес предлагаемые по приведенным выше ссылкам описания из файла httpd-vhosts.conf непосредственно в файл httpd.conf, что и привело, в конце концов, положительному результату.

По ходу дела столкнулся с еще одной засадой, когда прописывал путь к папке виртуального хоста: я скопировал путь к папке, расположенной довольно глубоко в файловой системе, и найденной в Finder — в результате получил путь, несколько отличающийся от того, который был прописан чуть выше в том же httpd.conf — видимо, причина в жестких или символических, или каких-там-еще ссылках Unix-подобных систем…

Например, путь к каталогу localhost путем копирования пути получаю так:

а в httpd.conf путь к нему прописан так:

не знаю, почему это имеет значение, но это тоже заставило потерять уйму времени…

Вторая проблема: в сайте на Drupal, перенесенном с другого хостинга, отказались работать Clean URLs (чистые ссылки) — в моем сайте ссылки были с адресами вида mysite/node/8, теперь же ссылки все работать перестали (открывалась только первая страница), но соотвествующие страницы были доступны по адресам вида mysite/node/?q=node/8.

Чтобы это исправить оказалось достаточно поменять в одном месте AllowOverride None на AllowOverride All

# AllowOverride controls what directives may be placed in .htaccess files.
# It can be «All», «None», or any combination of the keywords:
# Options FileInfo AuthConfig Limit
#
AllowOverride None

в предыдущей строчке потребовалось поменять None на All

Источник

Сервер Apache не запускается в MAMP

сервер Apache не запускается, когда в MAMP. Вот журналы ошибок:

Я не думаю, что я сделал что-нибудь наше обычное, кроме создания новой папки в htdocs. Есть предложения?

8 ответов

мое решение: в /Applications/Mamp/Library / bin найдите файл envvars и переименуйте его в _envvars.

Читайте также:  Как настроить таймер для вебасто

теперь все работает.

измените имя файла envvars на _envvars в /Applications/MAMP/Library / bin , вот и все .

я столкнулся с этой же проблемой с тем же выходом журнала выше, но не нужно было переустановить MAMP, чтобы решить проблему в моем случае. Когда я столкнулся с этой ошибкой, это было связано с одним из хостов, которые я настроил. Перейдите на вкладку хосты и посмотрите, отображается ли какой-либо из ваших хостов красным цветом:

хост в красном требуется SSL сертификаты. В конфигурации у меня не было допустимых ссылок на требуемые сертификаты после того, как я изменил файловую структуру моего приложение. После исправления этой проблемы и применения изменений хост больше не выделялся красным цветом, и я смог запустить Apache через MAMP.

кроме того, вы можете убедиться, что проблема не связана с самим клиентом Apache, выполнив эту команду в терминале:

Если вы можете запустить Apache в терминале, вы исключили, что у вас есть ошибка с самим клиентом Apache MAMP.

просто переустановил MAMP и изменил порты. Не знаю, в чем была проблема, но теперь все исправлено.

вместо переустановки mamp я сделал следующее:

и он начал работать.

Если ваш существующий MAMP PRO внезапно больше не будет запускать Apache, то это может быть ошибка в настройках vhosts, которая не видна.

в apache_error часто нет указания.журнал — он просто приходит с сообщением.

в моем случае это был неверный путь в настройки виртуального хоста, таких как

конфигурация Vhost сохраняется в

/ Library / Application Support/appsolute/MAMP PRO / httpd.conf, чтобы вы могли проверить настройки там.

решение: MAMP 4-Dec 2017,macOS High Sierra

была эта проблема с MAMP Pro 3.4.1, поэтому я заплатил за новую лицензию, чтобы я мог перейти на версию 4.2.1, и проблема все еще возникла. Я пытался выше решение и, к сожалению, не повезло.

однако я снова запустил Apache по выбору все параметры для директивы каталога, как показано на рисунке ниже:

эта проблема возникла совершенно случайно, в один день все работает нормально, затем на следующий. Апач говорит нет. Я считаю, что проблема в том, что, как веб-браузеры используют кэш и отдельно также держат открытые процессы, я думаю, что иногда, когда MAMP или MAMP Pro не закрывается должным образом, он может испортить Apache, потому что он не остановлен правильно.

Я надеюсь, что этот ответ поможет любым людям, испытывающим эту проблему!

этот вопрос приходит ко мне сегодня … после попытки несколько решений, я нашел это диалоговое окно может появиться, если МАМП не находит сертификат, используемый securized на localhost. Поэтому будьте осторожны, чтобы держать их в месте, которое вы не будете перемещать или удалять.

Источник

Оцените статью