- Не работает Opencart на Openserver
- Рекомендуемые сообщения
- Для публикации сообщений создайте учётную запись или авторизуйтесь
- Создать учетную запись
- Войти
- Похожий контент
- Последние посетители 0 пользователей онлайн
- [Решено] После переноса на хостинг админка не работает
- Рекомендуемые сообщения
- Для публикации сообщений создайте учётную запись или авторизуйтесь
- Создать учетную запись
- Войти
- Похожий контент
- Последние посетители 0 пользователей онлайн
- OpenCart-Гид
- Содержание статьи
- Ошибки при установке модуля через менеджер расширений
- Internal Server Error (Ошибка 500)
- Ошибка «Неверный тип файла»
- Кракозябры при установке модуля
- Ошибки, содержащие слово ftp_. ()
- Call to undefined function zip_open()
- Fatal error: Class ‘DOMDocument’ not found
- copy(filename): failed to open stream
- mkdir(): No such file or directory in .
- Модификатору необходим уникальный id код!
- invalid argument supplied for foreach() in . /system/storage/modification/admin/controller/extension/installer on line 247
- Не отображается модуль
- Ошибка в списке модулей при нажатии кнопку «Установить»
- Site error: the ionCube PHP Loader needs to be installed
Не работает Opencart на Openserver
Автор Vladkh,
26 июля, 2018 в Курилка
Рекомендуемые сообщения
Для публикации сообщений создайте учётную запись или авторизуйтесь
Вы должны быть пользователем, чтобы оставить комментарий
Создать учетную запись
Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!
Войти
Уже есть аккаунт? Войти в систему.
Похожий контент
Приветствую форумчане. Такая проблема, пытаюсь выполнить ajax запрос, суть которого отправить некоторые данные с домена: a.com на b.com и соответственно получить ответ от b.com с целью дальнейшей его обработки в скрипте на a.com
Оба домена находятся на OpenServer на локальной машине, то есть у меня есть контроль над http://b.com/ и я могу прописать в php файле необходимые настройки.
Однако при попытке выполнить ajax запрос получаю ошибку:
jquery-3.6.0.min.js:2 Cross-Origin Read Blocking (CORB) blocked cross-origin response http://b.com/?callback=jQuery360001053556176974424_1630579545897&_=1630579545898 with MIME type application/json. See https://www.chromestatus.com/feature/5629709824032768 for more details.
Аналогичную ситуацию имею на хостинге уже на реальных доменах.
При этом данные c a.com на b.com в php скрипт все же попадают, однако, мне не удается добиться чтения ответа на домене a.com.
Что характерно в сети есть по меньшей мере один домен с которого таки удается получить данные таким способом.
Если вместо b.com подставить страницу:
https://jsonplaceholder.typicode.com/todos/1
то в этом случае получаю ответ:
Однако же добиться аналогичного эффекта на домене под собственным контролем я не могу.
Пробовал в js указывать crossDomain: true, на стороне php пробовал указывать различные заголовки по типу:
header(‘content-type: application/json’);
и тому подобное. пробовал даже скопировать из браузера заголовки которые отдает
сайт https://jsonplaceholder.typicode.com/todos/1 и подставить их в php файл через тот же header() однако ничего не выходит.
Подскажите куда копать? Вопрос вроде плевый, но сколько не пытаюсь ничего не получается.
Помогите решить проблему. После прохождения шага 1, создания и оплаты кампании, столкнулся с ошибкой на шаге 2: Error ID: 60e2d6f2321cf
Поддержка больше не осуществляется!
Модификатор Fix Analytics List v1.0 by Tramplin Studio исправляет баг связанный с некорректным отображением списка модулей в разделе расширений «Аналитика» (или «Статистика») в версиях OpenCart/ocStore 2.2 и 2.3.
В обновлении версии OC 2.2, в разделе аналитических расширений, для каждого отдельного магазина появились свои настройки. Это было очень полезным нововведением, но была допущена ошибка при формировании таблицы, которая была устранена лишь в версии OC 3.0.
Как проявляется ошибка?
Если у вас установлен только один аналитический модуль, скорее всего это простой базовый модуль «Google Analytics», то вы ничего не заметите. Однако если у вас установлен еще один модуль (например наш модуль «TS Yandex Metrika») или несколько, то доступны будут лишь магазины последнего в списке модуля. Магазины других модулей не отобразятся, их настройки будут не доступны. После установки модификатора Fix Analytics List вы сможете видеть все магазины, всех модулей.
Полезные советы:
Если вы серьезно относитесь к конверсии вашего интернет-магазина и вам важно знать все о действиях посетителей, тогда наш модуль «TS Yandex Metrika» может быть вам очень полезен! С этим модулем вы сможете передавать сервису Яндекс.Метрика не только такие простые данные как переходы по ссылкам и клики, но и подробную информацию о посетителях сайта, данные электронной коммерции, а также настраивать цели для отслеживания конверсий, не прибегая к вмешательству в код сайта и не обладая глубокими познаниями в веб-разработке.
————————————————————————————————
Смотреть DEMO админки (логин: demo, пароль: demo)
Инструкция по установке:
Перейдите в Панель администратора -> Модули -> Установка расширений; Загрузите архив с модулем для вашей версии OpenCart или ocStore; Обновите кеш модификаторов.
Файлы не перезаписываются!
Используется OCMod!
Данный модификатор является завершенным продуктом. Дальнейшее обновление модификатора маловероятно.
TS Fix Analytics List
Поддержка осуществляется в Пн-Пт с 18:00 до 20:00 по МСК!
Модификатор Fix Analytics List v1.0 by Tramplin Studio исправляет баг связанный с некорректным отображением списка модулей в разделе расширений «Аналитика» (или «Статистика») в версиях OpenCart/ocStore 2.2 и 2.3.
В обновлении версии OC 2.2, в разделе аналитических расширений, для каждого отдельного магазина появились свои настройки. Это было очень полезным нововведением, но была допущена ошибка при формировании таблицы, которая была устранена лишь в версии OC 3.0.
Как проявляется ошибка?
Если у вас установлен только один аналитический модуль, скорее всего это простой базовый модуль «Google Analytics», то вы ничего не заметите. Однако если у вас установлен еще один модуль (например наш модуль «TS Yandex Metrika») или несколько, то доступны будут лишь магазины последнего в списке модуля. Магазины других модулей не отобразятся, их настройки будут не доступны. После установки модификатора Fix Analytics List вы сможете видеть все магазины, всех модулей.
Полезные советы:
Если вы серьезно относитесь к конверсии вашего интернет-магазина и вам важно знать все о действиях посетителей, тогда наш модуль «TS Yandex Metrika» может быть вам очень полезен! С этим модулем вы сможете передавать сервису Яндекс.Метрика не только такие простые данные как переходы по ссылкам и клики, но и подробную информацию о посетителях сайта, данные электронной коммерции, а также настраивать цели для отслеживания конверсий, не прибегая к вмешательству в код сайта и не обладая глубокими познаниями в веб-разработке.
————————————————————————————————
Смотреть DEMO админки (логин: demo, пароль: demo)
Инструкция по установке:
Перейдите в Панель администратора -> Модули -> Установка расширений; Загрузите архив с модулем для вашей версии OpenCart или ocStore; Обновите кеш модификаторов.
Файлы не перезаписываются!
Используется OCMod!
Данный модификатор является завершенным продуктом. Дальнейшее обновление модификатора маловероятно.
Добавил TramplinStudio Добавлено 28.07.2019 Категория Прочее Системные требования Метод активации Без активации Ioncube Loader Нет OpenCart 2.3
2.2 ocStore 2.3 OpenCart.Pro, ocShop Обращение к серверу разработчика Нет Старая цена 0
Здравствуйте! После переноса сайта с хостинга на openserver перестала работать админка, при этом сам сайт работает нормально. Вылезает следующая ошибка:
Warning: require_once(E:/OpenServer/domains/site.test/catalog/system/startup.php): failed to open stream: No such file or directory in E:\OpenServer\domains\site.test\admin\index.php on line 17
Fatal error: require_once(): Failed opening required ‘E:/OpenServer/domains/site.test/catalog/system/startup.php’ (include_path=’.’) in E:\OpenServer\domains\site.test\admin\index.php on line 17
Насколько я понимаю система обращается к файлу в index.php на 17 строке под названием startup.php, где сам каталог system/startup.php’ (include_path=’.’) отсутствует. Как решить данный вопрос?
Последние посетители 0 пользователей онлайн
Ни одного зарегистрированного пользователя не просматривает данную страницу
Источник
[Решено] После переноса на хостинг админка не работает
Рекомендуемые сообщения
Для публикации сообщений создайте учётную запись или авторизуйтесь
Вы должны быть пользователем, чтобы оставить комментарий
Создать учетную запись
Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!
Войти
Уже есть аккаунт? Войти в систему.
Похожий контент
Добрый вечер уважаемые форумчане, вопрос такой: зашёл в админку, а тут появилось Важное уведомление о безопасности! И просит совершить ряд действий, а именно вынести директорию storage на уровень выше чем сам сайт и исправить конфигурационный файлы сайта config.php и admin/config.php и заменить строку на соответствующую с текущим путем к директории. Подскажите пожалуйста как перенести и как найти и исправить файлы?
Доброго времени суток!
Прошу помощи, делаю в первый раз.
Перенес Opencart 3 с OpenServer через Файлзиллу на хостинг.
config.php прописал, но с ошибками — не работает сайт. Не знаю что не так. Может вообще не туда залил (отмечено стрелкой). Базу данных вроде как правильно указал. Внизу скрины.
залил версию OcStore 15512 по ftp
создал базу MySQL
зашел по http на сервер для начала настройки. на шаге 2 (проверка исходного состояния) в п.3 проблема, пишет (см скрин):
Файл Состояние /usr/www/users/xxxxxx/xxxxxxx.xx/config.php Файл отсутствует /usr/www/users/xxxxxx/xxxxxxx.xx/admin/config.php Файл отсутствует
в инсталляции версии 15512, в папке Upload, такого файла нет в принципе, а есть файл нулевого размера config-dist.php в обеих папках. Соответственно, как есть в исходнике Upload все корректно залито в рутовую папку для этого домена. см скрин_1
подскажите, что делать? переименовать его в config.php?
При установке ocStore 1.5.5.1.2 на 2 шаге выдаёт сообщение:
В ручном режиме создал файлы «пустышки» с аналогичными именами и всё заработало.
У меня вопросы:
1) Подобное допустимо, или необходимо гдето чтото подправить изначально, чтобы установка прошла чисто без рчных созданий файлов ?
2) Для чего изначально созданы файлы: config-dist.php в корне сайта и папке admin если их размер не изменяется (0 байт) ?
Авансом спасибо за ответы.
Последние посетители 0 пользователей онлайн
Ни одного зарегистрированного пользователя не просматривает данную страницу
Источник
OpenCart-Гид
03.04.2018 14:30 (19501 просмотров)
Мы понимаем, что неподготовленному человеку довольно сложно устанавливать модули в OpenCart. Еще сложнее понять, по какой причине происходит ошибка при установке. И читать полотна текстов, а также разбираться в технических нюансах с незнакомыми терминами, когда у тебя работа остановилась, как-то не комильфо.
Мы хорошо знаем и любим свою работу. И делаем ее хорошо. И с радостью готовы помочь Вам пофиксить ошибку в Вашем интернет-магазине под управлением OpenCart.
Если Вы хотите решить вопрос как можно быстрее, поручите эту работу нам.
В то же время мы понимаем реальное положение дел: и не все магазины имеют коммерческий успех. Иногда владельцу приходится становиться еще и технарем. В таком случае, примите нашу помощь в виде подробной информации.
Содержание статьи
Ошибки при установке модуля через менеджер расширений
Internal Server Error (Ошибка 500)
Внимание! Описание данной ошибки читать обязательно всем!
Ошибка Internal Server Error — проявляется тогда, когда в настройках сервера выключен показ ошибок.
Чтобы убедиться, что у Вас отключен показ ошибок в настройках сервера, проверьте настройки с помощью функции phpinfo(). На рисунке показан скрин, как быть НЕ ДОЛЖНО на следующем снимке экрана.
Необходимо включить показ ошибок в настройках хостинга (сервера). Если не знаете как, обращайтесь в их службу поддержки.
Что будет в результате?
После включения ошибок Вы по факту не устраните проблему, но зато вместо абстрактной надписи Internal Server Error (что следует читать как «что-то не так с настройками сервера»), Вы увидите реальную причину сбоя. То есть, там будет описание ошибки на английском языке, с которой уже можно работать.
А если не помогло?
Кроме глобальных настроек показа ошибок на хостинге, в OpenCart также есть подобная настройка (см Система — Настройка магазина — Сервер — Пункт «Показывать ошибки»). Почем же я говорю об этом в последнюю очередь? Потому что частенько при глобальном запрете на показ ошибок данная функция OpenCart не срабатывает. Это, конечно, зависит от настроек конкретного хостинга, тем не менее, это весьма распространенное явление.
Внимание!
Проблемы, которые возникают исключительно при установке расширений (модулей) в OpenCart 3 (ocStore 3), вынесены на отдельную страницу — https://opencart-guide.com/administration/extensions/problemy-s-ustanovkoj-modulej-v-opencart-3.html.
Ошибка «Неверный тип файла»
На английском языке эта ошибка называется «Invalid file type!«. Появляется тогда, когда в качестве расширения загружается не тот файл, который нужно. Чаще всего такая ошибка случается при попытке установить модуль по старинке. То есть, на этапе установки пользователь распаковывает установочный архива some-name.ocmod.zip, загружает файлы модуля по FTP и затем пытается установить файл install.xml через менеджер расширений. Однако, чтобы модификатор соответствовал формату, необходимо переименовать файл install.xml на install.ocmod.xml
Есть еще один вариант возникновения такой ошибки.
При скачивании модуля иногда предлагается скачать под конкретную версию, а иногда — одним архивом. Когда для скачивание предоставляется только один архив, это означает, что, скорее всего, в нем находятся установочные архивы для отдельных версий + файлы readme.txt с описание установки.
В общем, пригодные установочный пакет должен иметь расширение *.ocmod.zip (для архивов) или *.ocmod.xml (для отдельных модификаторов).
Кракозябры при установке модуля
При установке модуля через менеджер расширений Вы увидели кракозябры, вместо описания ошибки. Выглядит это примерно вот так:
- Во-первых, там все-таки различаются ключевые слова. К примеру, ftp_login(), что уже намекает на то, в чем именно состоит ошибка.
- Во-вторых, чтобы прочитать это закодированное json-сообщение, можно декодировать его через json_decode().
- В-третьих, можно переключить язык админки на английский, и тогда описание ошибки будет на английском языке, что будет иметь читаемый вид.
Ошибки, содержащие слово ftp_. ()
ftp_login()
Такая ошибка значит, что php-скрипт не смог залогиниться по ФТП с теми данными, что Вы прописали в Система — Настройки — Настройки магазина — Вкладка «FTP».
ftp_chdir()
Warning: ftp_chdir(): Can\’t change directory to ftp.server. : failed: No such file or directory in . /admin/controller/extension/installer.php on line 298.
Зачастую ошибка связана с тем, что в настройках ФТП не правильно указан путь к корневой папке сайта, относительно той папки, которая является корневой для данного ФТП-пользователя. Причем к этим папкам нет прав доступа.
ftp_nlist() SyntaxError: JSON.parse: unexpected character at line 1 column 1 of the JSON data OK Warning: ftp_nlist(): listen() failed: Operation not permitted (1) in /. /public_html/admin/controller/extension/installer.php on line 327 Зачастую ошибка связана с тем, что в настройках ФТП вообще не указан путь к корневой папке сайта. Причем к этим папкам нет прав доступа.
Call to undefined function zip_open()
SyntaxError: JSON.parse: unexpected character at line 1 column 1 of the JSON data Fatal error: Call to undefined function zip_open() in /var/www/html/system/storage/modification/admin/controller/extension/installer.php on line 120
Такая ошибка появляет и в том случае, когда для загрузки модулей через менеджер расширений используется FTP, и в том, когда установлен модификатор localcopy.ocmod.xml . Ошибка состоит в том, что настройках сервера не включена функция для распаковки zip-архива. С такой ошибокй нужно обращаться в службу поддержки хостинга
Fatal error: Class ‘DOMDocument’ not found
copy(filename): failed to open stream
Warning: copy(/var/www/sites/opencart-2102.loc/admin//view/javascript/sortable/CONTRIBUTING.md): failed to open stream: Permission denied in /var/www/sites/opencart-2102.loc/system/storage/modification/admin/controller/extension/installer.php on line 284.
Ошибка связаны с ограничениями прав доступа и чаще всего может случаться на выделенных серверах.
mkdir(): No such file or directory in .
Warning: mkdir(): No such file or directory in .
Могут быть 2 причины:
- Не настроенные права доступа на папку /system/ — https://forum.opencart.com/viewtopic.php?t=155122
- Отсутствие папки /system/storage/upload/ (может быть «потеряна» при манипуляциях с сайтом (переход с версии 1.5.x на версию 2.x или подобное)
Модификатору необходим уникальный id код!
Ошибка случается при установке некорректного установочного модификатора (xml-файла). Есть вариант, когда разработчики действительно забывают внести секцию . Этот случай обсуждался вот здесь. Но, кроме этого, точно такая же ошибка выдавалась мне, когда тег присуствовал, а вот вот закрывающий тег случайно был удален. В этом случае, по идее xml-файл должен был быть перестать валидным, но вместо этого OpenCart ругался на уникальный id-код.
invalid argument supplied for foreach() in . /system/storage/modification/admin/controller/extension/installer on line 247
В редких случаях, когда на сайте установлен localcopy.ocmod.xml + еще какой-то модуль «лезет» в установку модулей, бывает новая ошибка invalid supliment argument supliment for foreach() in . /system/storage/modification/admin/controller/extension/installer.php on line 247 Честно говоря, сам я ее еще никогда не решал. И ко мне обращались с ней всего 2-3 раза и я сказал, что это ошибка точно не в моем модуле. Возможно (хотя это не факт), данная ошибка уже была пофиксина в русскоязычном сообществе:
Не отображается модуль
В момент установки все прошло гладко (без ошибок), но в списке модулей новый модуль не появился.
Такое происходит, если для установки модулей в системе включен ФТП. При этом неверно указан путь к корневой папке сайта.
Зачастую FTP-пользователь создается с правом доступа к корневой папке хостинга, а не конкретного сайта. В итоге файлы загружаются на уровень выше, чем находится папка с сайтом. Проверить, куда загрузились папки модуля, можно через ФТП-менеджер.
Панацеей от проблем с ошибками, начинающимися на ftp_. является модификатор localcopy.ocmod.xml. Установите его, и больше не «парьтесь» о правильных настройках ФТП.
Еще одна возможная причина, почему модуля нет в списке модулей — это нетипичная папка с языком админки. При загрузке расширений на OpenCartForum требуется только русский и английский языки. И если у Вас другой язык, то надо просто зайти в папку с языковыми файлами и скопировать файл модуля из папки русского языка в любой другой язык, который у Вас используется.
Ошибка в списке модулей при нажатии кнопку «Установить»
Site error: the ionCube PHP Loader needs to be installed
Полный текст ошибки: Site error: the ionCube PHP Loader needs to be installed. This is a widely used PHP extension for running ionCube protected PHP code, website security and malware blocking. Please visit get-loader.ioncube.com for install assistance. Также это может выглядеть следующим образом:
Не все модули выдают эту ошибку на этапе ативации в списке модулей. Иногда она вскрывается на этапе захода в настройки модуля или при обращении к какому-то отдельному функционалу.
Данная ошибка связана с тем, что на сервере (хостинге) не установлен IonCube Loader.Что делать? Необходимо включить IonCube Loader в настройках хостинга или установить этот модуль в случае с выделенным сервером. Если Вы не знаете, как это сделать, то обратитесь в поддержку хостинга.
Если в описании ошибки встречается фраза «corrupted file» — значит, при загрузке по FTP не была использована кодировка utf-8
Если даже при загрузке по FTP в режиме кодировки utf-8 (или модуль был установлен через Установка расширений), но ошибка все равно остается, тогда и только тогда это однозначно говорит о поврежденности файлов в модуле. Лишь в таком случае имеет смысл писать об этой ошибке автору модуля
Источник