Почему не работает удаленный компьютер

Содержание
  1. Решаем проблему с невозможностью подключения к удаленному ПК
  2. Невозможно подключиться к удаленному ПК
  3. Причина 1: Отключение удаленного управления
  4. Причина 2: Отсутствие пароля
  5. Причина 3: Спящий режим
  6. Причина 4: Антивирус
  7. Причина 5: Обновление безопасности
  8. Причина 6: Сторонние программы для шифрования
  9. Альтернативное решение: Программы для удаленного подключения
  10. Заключение
  11. «Не удается подключиться к удаленному компьютеру»: методы решения
  12. Избавляемся от ошибки «Не удается подключиться к удаленному компьютеру»
  13. Решение №1 Активирование опции сетевого обнаружения
  14. Решение №2 Открыть порт 3389 в Брандмауэре Windows
  15. Решение №3 Установка адресов DNS-серверов по умолчанию
  16. Устранение неполадок с отключенными ошибками удаленного рабочего стола
  17. Удаленный настольный сервер
  18. Удаленные подключения для администрирования
  19. Симптом 1. Ограниченные сеансы удаленного рабочего стола или подключения к сеансам удаленных служб рабочего стола
  20. Симптом 2. Конфликт назначения порта
  21. Симптом 3. Неправильно настроенные параметры проверки подлинности и шифрования
  22. Симптом 4. Развращение сертификата лицензии
  23. Разрешение для симптома 1
  24. Проверка включения удаленного рабочего стола
  25. Проверка ограничения числа подключений служб удаленного рабочего стола
  26. Проверка свойств служб удаленного рабочего стола RDP-TCP
  27. Проверка прав логотипа служб удаленного рабочего стола
  28. Добавление пользователей и групп в группу удаленных пользователей настольных компьютеров с помощью вкладки Remote
  29. Добавление пользователей и групп в группу удаленных пользователей настольных компьютеров с помощью привязки локальных пользователей и групп
  30. Разрешение для симптома 2
  31. Доступность прослушиватель сервера удаленного рабочего стола
  32. Определите, какое приложение использует тот же порт, что и RDP
  33. Изменение порта, назначенного RDP
  34. Перезапуск служб удаленного рабочего стола
  35. Убедитесь, что порт RDP изменился
  36. Убедитесь, что прослушиватель на сервере удаленного рабочего стола работает
  37. Разрешение для симптома 3
  38. Дополнительный шаг по устранению неполадок: включить журналы событий CAPI2
  39. Решение проблемы (невозможно полностью отключить подключение удаленного сервера рабочего стола), описанное в Symptom 3
  40. Разрешение для симптома 4
  41. Ссылки

Решаем проблему с невозможностью подключения к удаленному ПК

Невозможно подключиться к удаленному ПК

Проблема, о которой пойдет речь, возникает при попытке получить доступ к другому ПК или серверу с помощью встроенного в Windows RDP-клиента. Мы его знаем под именем «Подключение к удаленному рабочему столу».

Данная ошибка возникает по нескольким причинам. Далее мы подробнее поговорим о каждой и приведем способы решения.

Причина 1: Отключение удаленного управления

В некоторых случаях пользователи или системные администраторы выключают возможность удаленного подключения в настройках системы. Делается это в целях повышения безопасности. При этом изменяются некоторые параметры, отключаются службы и компоненты. Ниже приведена ссылка на статью, описывающую данную процедуру. Для того чтобы обеспечить удаленный доступ, необходимо включить все опции, которые мы в ней отключали.

Локальные групповые политики

На обоих компьютерах также необходимо проверить, не отключен ли компонент RDP в настройках локальных групповых политик. Данная оснастка присутствует только в профессиональных, максимальных и корпоративных редакциях ОС Windows, а также в серверных версиях.

    Для доступа к оснастке вызываем строку «Выполнить» комбинацией клавиш Windows+R и прописываем команду


В разделе «Конфигурация компьютера» открываем ветку с административными шаблонами, а затем «Компоненты Windows».


Далее по очереди раскрываем папки «Службы удаленных рабочих столов», «Узел сеансов удаленных рабочих столов» и кликаем по подпапке с настройками подключений.


В правой части окна дважды кликаем по пункту, разрешающему удаленное подключение с использованием служб удаленных рабочих столов.


Если параметр имеет значение «Не задано» или «Включить», то ничего не предпринимаем, в противном случае ставим переключатель в нужное положение и жмем «Применить».

  • Перезагружаем машину и пробуем получить удаленный доступ.
  • Причина 2: Отсутствие пароля

    Если на целевом компьютере, а точнее, на учетной записи того пользователя, по которым мы входим в удаленную систему, не установлена защита по паролю, то подключение выполнить не удастся. Для того чтобы исправить ситуацию, необходимо создать пароль.

    Причина 3: Спящий режим

    Спящий режим, включенный на удаленном ПК, может воспрепятствовать нормальному соединению. Решение здесь простое: необходимо отключить данный режим.

    Подробнее: Как отключить спящий режим на Windows 10, Windows 8, Windows 7

    Причина 4: Антивирус

    Еще одной причиной невозможности подключения может стать антивирусное программное обеспечение и входящий в его состав брандмауэр (файервол). Если такой софт установлен на целевом ПК, то его необходимо временно отключить.

    Причина 5: Обновление безопасности

    Данное обновление под номером KB2992611 призвано закрыть одну из уязвимостей Windows, связанную с шифрованием. Варианта исправления ситуации два:

    • Полное обновление системы.
    • Удаление этого апдейта.

    Причина 6: Сторонние программы для шифрования

    Некоторые программы, такие, как, например, КриптоПро, могут стать причиной возникновения ошибки удаленного подключения. Если вы пользуетесь подобным софтом, то его необходимо удалить с компьютера. Для этого лучше использовать Revo Uninstaller, так как кроме простого удаления нам еще придется почистить систему от оставшихся файлов и параметров реестра.

    Если без использования криптографического софта обойтись нельзя, то после удаления установите самую последнюю версию. Обычно такой подход помогает решить проблему.

    Альтернативное решение: Программы для удаленного подключения

    Если инструкции, приведенные выше, не помогли решить проблему, то обратите внимание на сторонние программы для удаленного управления компьютерами, например, TeamViewer. Его бесплатная версия обладает достаточным функционалом для полноценной работы.

    Заключение

    Причин, приводящих к невозможности выполнения подключения к удаленному рабочему столу с помощью RDP-клиента, великое множество. Мы привели способы устранения самых распространенных из них и, чаще всего, этого бывает достаточно. В случае повторного появления ошибки сэкономьте свое время и нервы, воспользовавшись сторонним клиентом, если такое возможно.

    Помимо этой статьи, на сайте еще 12339 инструкций.
    Добавьте сайт Lumpics.ru в закладки (CTRL+D) и мы точно еще пригодимся вам.

    Отблагодарите автора, поделитесь статьей в социальных сетях.

    Источник

    «Не удается подключиться к удаленному компьютеру»: методы решения

    В сегодняшней статье мы рассмотрим с вами ошибку «Не удается подключиться к удаленному компьютеру». Но прежде нам нужно кое в чем разобраться…

    Протокол удаленного рабочего стола — это встроенная утилита операционной системы Windows, которая позволяет пользователям получать доступ к компьютерам, подключенной к одной и той же или разным сетям без надобности в физическом контакте.

    Многие пользователи предпочитают использовать стороннее программное обеспечение для удаленного доступа к нужному им компьютеру, однако некоторые любят пользоваться системной утилитой, несмотря на то, что ее принято считать не самой надежной.

    Вернемся к нашей ошибке. Она появляется в тот момент, когда вы пытаетесь подключиться к нужному вам компьютеру, находящемуся в одной и той же сети, что и вы или же в другой сети. Сообщение ошибки гласит:

    Не удается подключиться к удаленному компьютеру.

    Повторите попытку подключения. Если проблема повторится, обратитесь к владельцу удаленного компьютера или администратору сети.

    Причины данной ошибки могут быть следующими:

    • некорректные настройки DNS;
    • деактивированная функция сетевого обнаружения;
    • необходимый порт заблокирован в брандмауэре Windows.

    Избавляемся от ошибки «Не удается подключиться к удаленному компьютеру»

    Решение №1 Активирование опции сетевого обнаружения

    Сетевое обнаружение — это особая опция Windows, которая определяет, может ли ваша система видеть/сканировать другие системы в сети или нет. Если вы хотите пользоваться функционалом удаленного рабочего стола, то вам просто-таки необходимо активировать эту опцию. Для этого сделайте следующее:

    1. нажмите Windows+S;
    2. пропишите в поисковую строку «Панель управления» и выберите найденный результат;
    3. откройте раздел «Сеть и Интернет»;
    4. перейдите в подраздел «Центр управления сетями и общим доступом»;
    5. кликните на строчку «Изменить дополнительные параметры общего доступа»;
    6. поставьте галочку возле опции «Включить сетевое обнаружение»;
    7. кликните на кнопку «Сохранить изменения» и закройте окошко.

    Проверяем наличие ошибки «Не удается подключиться к удаленному компьютеру».

    Решение №2 Открыть порт 3389 в Брандмауэре Windows

    Порт 3389 по умолчанию используется при удаленном доступе, так что у вас не получится установить подключение, если данный порт заблокирован в Брандмауэре Windows. Чтобы открыть порт 3389, сделайте следующее:

    1. нажмите Windows+R;
    2. пропишите в пустую строку значение «%windir%\system32\systempropertiesremote.exe» и нажмите Enter;
    3. поставьте галочку возле опции «Разрешить удаленные подключения к этому компьютеру» и нажмите «Применить/OK»;
    4. теперь нажмите Windows+S;
    5. пропишите «Панель управления» и выберите результат;
    6. откройте раздел «Система и безопасность»;
    7. перейдите в подраздел «Брандмауэр Защитника Windows»;
    8. кликните на строчку «Дополнительные параметры» в левой части окна;
    9. нажмите на «Правила для входящих подключений» и ищите правило «Удаленный помощник (сервер удаленного помощника TCP-входящий)»;
    10. убедитесь, что это правило активно;
    11. теперь поищите в списке правила «Удаленный рабочий стол — пользовательский режим (входящий трафик TCP)» и «Удаленный рабочий стол — пользовательский режим (входящий трафик UDP)»;
    12. убедитесь, что эти правила активны и их локальный порт выставлен на «3389»;
    13. внесите изменения, если в этом есть необходимость и закройте окошко.
    Читайте также:  Как настроить цифровые пакеты

    Попробуйте снова подключиться и проверьте, будет ли появляться ошибка «Не удается подключиться к удаленному компьютеру».

    Решение №3 Установка адресов DNS-серверов по умолчанию

    Не так давно задали особый адрес DNS-сервера для своей системы? Это нужно исправить, выставив значения для DNS по умолчанию. Для этого вам потребуется сделать следующее:

    1. нажмите комбинацию Windows+R;
    2. пропишите значение «ncpa.cpl» и нажмите Enter;
    3. нажмите ПКМ на свое сетевое подключение и выберите «Свойства»;
    4. дважды кликните ЛКМ на компонент «IP версии 4 (TCP/IPv4)»;
    5. поставьте галочку возле опции «Получить адрес DNS-сервера автоматически»;
    6. сохраните изменения и проверьте наличие проблемы при подключении.

    Мы надеемся, что данный материал мы полезен при решении ошибки «Не удается подключиться к удаленному компьютеру».

    Источник

    Устранение неполадок с отключенными ошибками удаленного рабочего стола

    В этой статье вы сможете понять наиболее распространенные параметры, используемые для создания сеанса удаленного рабочего стола в корпоративной среде, а также сведения об устранении неполадок при отключенных ошибках удаленного рабочего стола.

    Применяется к: Windows Server 2012 R2
    Исходный номер КБ: 2477176

    Эта статья предназначена для использования агентами поддержки и ИТ-специалистами.

    Удаленный настольный сервер

    Хост-сервер удаленного рабочего стола — это сервер, на котором Windows программ или полный рабочий Windows для клиентов remote Desktop Services. Пользователи могут подключаться к хост-серверу RD Session для запуска программ, сохранения файлов и использования сетевых ресурсов на этом сервере. Пользователи могут получить доступ к хост-серверу RD Session из корпоративной сети или из Интернета.

    Удаленный хост сеансов рабочего стола (RD Session Host) ранее был известен как служба ролей на сервере удаленного рабочего стола, а сервер удаленного рабочего стола (RD Session Host) ранее был известен как сервер удаленного рабочего стола.

    Удаленные подключения для администрирования

    Remote Desktop поддерживает два одновременно удаленных подключения к компьютеру. Для этих подключений не нужно иметь лицензии клиентских лицензий на доступ к удаленным настольным службам (RDS CALs).

    Чтобы разрешить более двух административных подключений или нескольких подключений пользователей, необходимо установить RD Session Host Role и иметь соответствующие ЦС RDS.

    Симптом 1. Ограниченные сеансы удаленного рабочего стола или подключения к сеансам удаленных служб рабочего стола

    При попытке подключения к удаленному рабочему столу (RDC) на удаленном компьютере или на удаленном настольном сервере (terminal Server), который работает Windows Server 2008 R2, вы получите одно из следующих сообщений об ошибке:

    Отключен удаленный рабочий стол.
    Этот компьютер не может подключаться к удаленному компьютеру.
    Попробуйте подключиться снова. Если проблема сохранится, обратитесь к владельцу удаленного компьютера или сетевому администратору.

    Кроме того, вы ограничены в количестве пользователей, которые могут подключаться одновременно к сеансу удаленного рабочего стола или сеансу удаленных служб рабочего стола. Ограниченное число подключений RDP может быть вызвано неправильной групповой политикой или свойствами RDP-TCP в конфигурации служб удаленного рабочего стола. По умолчанию подключение настроено, чтобы разрешить неограниченное количество сеансов для подключения к серверу.

    Симптом 2. Конфликт назначения порта

    Вы испытываете конфликт назначения порта. Эта проблема может указывать на то, что другое приложение на сервере удаленного рабочего стола использует тот же порт TCP, что и протокол удаленного рабочего стола (RDP). Порт по умолчанию, присвоенный RDP, — 3389.

    Симптом 3. Неправильно настроенные параметры проверки подлинности и шифрования

    После того как клиент удаленного настольного сервера теряет подключение к серверу удаленного рабочего стола, вы испытываете один из следующих симптомов:

    • Подключение невозможно сделать с помощью RDP.
    • Сеанс на сервере удаленного рабочего стола не переходит в отключенное состояние. Вместо этого он остается активным, даже если клиент физически отключен от сервера удаленного рабочего стола.

    Если клиент возвращается на тот же сервер удаленного рабочего стола, может быть установлен новый сеанс, а исходный сеанс может оставаться активным.

    Кроме того, вы получаете одно из следующих сообщений об ошибке:

    Сообщение об ошибке 1

    Из-за ошибки безопасности клиент не смог подключиться к серверу терминала. После входа в сеть попробуйте снова подключиться к серверу.

    Сообщение об ошибке 2

    Удаленный рабочий стол отключен. Из-за ошибки безопасности клиент не мог подключиться к удаленному компьютеру. Убедитесь, что вы вошли в сеть, а затем попробуйте подключиться снова.

    Симптом 4. Развращение сертификата лицензии

    Клиентам удаленных настольных служб неоднократно отказывали в доступе к серверу удаленного рабочего стола. Если вы используете клиента служб удаленного рабочего стола для входа на сервер удаленного рабочего стола, вы можете получить одно из следующих сообщений об ошибке.

    Сообщение об ошибке 1

    Из-за ошибки безопасности клиент не смог подключиться к серверу терминала. После входа в сеть попробуйте снова подключиться к серверу.

    Сообщение об ошибке 2

    Удаленный рабочий стол отключен. Из-за ошибки безопасности клиент не мог подключиться к удаленному компьютеру. Убедитесь, что вы вошли в сеть, а затем попробуйте подключиться снова.

    Сообщение об ошибке 3

    Из-за ошибки безопасности клиент не смог подключиться к серверу терминала. После входа в сеть попробуйте снова подключиться к серверу.
    Удаленный рабочий стол отключен. Из-за ошибки безопасности клиент не мог подключиться к удаленному компьютеру. Убедитесь, что вы вошли в сеть, а затем попробуйте подключиться снова.

    Кроме того, следующие ID-сообщения событий могут быть зарегистрированы в viewer событий на сервере удаленного рабочего стола.

    Сообщение события 1

    Сообщение события 2

    Сообщение события 3

    Сообщение события 4

    Сообщение события 5

    Разрешение для симптома 1

    Чтобы устранить эту проблему, при необходимости используйте следующие методы.

    Проверка включения удаленного рабочего стола

    Откройте элемент System в панели управления. Чтобы запустить средство System, нажмите кнопку Начните, нажмите панель управления, щелкните System и нажмите кнопку ОК.

    Под панелью управления главная щелкните удаленные параметры.

    Щелкните вкладку Remote.

    В удаленном рабочем столе выберите любой из доступных параметров в зависимости от требований к безопасности:

    Разрешить подключения с компьютеров с компьютеров с любой версией удаленного рабочего стола (менее безопасной)

    Разрешить подключение с компьютеров только с компьютеров с удаленным рабочим столом с проверкой подлинности на уровне сети (более безопасно)

    Если вы выберите не разрешайте подключение к этому компьютеру на вкладке Remote, никакие пользователи не смогут подключаться удаленно к этому компьютеру, даже если они являются членами группы пользователей удаленных настольных компьютеров.

    Проверка ограничения числа подключений служб удаленного рабочего стола

    Запустите оснастку групповой политики, а затем откройте локализованную политику безопасности или соответствующую групповую политику.

    Найдите следующую команду:

    Локализованная компьютерная политика > Конфигурация компьютера > Административные шаблоны > Windows компоненты > Удаленные службы настольных компьютеров > Удаленный хост сеансов рабочего стола > Подключение Ограничивает количество подключений

    Щелкните Разрешено.

    В разрешенной поле RD Maximum Connections введите максимальное количество подключений, которое необходимо разрешить, и нажмите кнопку ОК.

    Проверка свойств служб удаленного рабочего стола RDP-TCP

    Следуйте этим шагам в зависимости от версии операционной системы.

    Настройка с помощью конфигурации служб удаленного рабочего стола

    Настройка количества одновременных удаленных подключений, разрешенных для подключения:

    На хост-сервере сеанса RD откройте конфигурацию хост-сервера удаленного рабочего стола. Чтобы открыть конфигурацию хост-хозяйской сессии удаленного рабочего стола, нажмите кнопку Начните, указать на административные средства, указать на удаленные службы настольных компьютеров.

    В «Подключениях» щелкните правой кнопкой мыши имя подключения и нажмите кнопку Свойства.

    Читайте также:  Как настроить телевизор самсунг 9000

    На вкладке Сетевой адаптер нажмите кнопку Максимальное подключение, введите количество одновременных удаленных подключений, которые необходимо разрешить для подключения, а затем нажмите кнопку ОК.

    Если параметр Maximum подключений выбран и затемнеет, параметр Limit number of connections Group Policy включен и применен к серверу хост-сервера сеанса RD.

    Проверка прав логотипа служб удаленного рабочего стола

    Настройка группы удаленных пользователей настольных компьютеров.

    Группа пользователей удаленных настольных компьютеров на хост-сервере сеансов RD предоставляет пользователям и группам разрешение на удаленное подключение к хост-серверу сеансов RD. Вы можете добавить пользователей и группы в группу удаленных пользователей настольных компьютеров с помощью следующих средств:

    • Привязка локальных пользователей и групп
    • Вкладка Remote в диалоговом окне System Properties на хост-сервере сеанса RD
    • Активные пользователи каталогов и компьютеры, если хост-сервер сеанса RD установлен на контроллере домена

    Вы можете использовать следующую процедуру для добавления пользователей и групп в группу пользователей удаленных настольных компьютеров с помощью вкладки Remote в диалоговом окне System Properties на сервере хост-сервера сеансов RD.

    Членство в локальной группе администраторов или эквивалент на сервере хост-сервера сеанса RD, который вы планируете настроить, является минимальным, необходимым для завершения этой процедуры.

    Добавление пользователей и групп в группу удаленных пользователей настольных компьютеров с помощью вкладки Remote

    Запустите средство System. Для этого нажмите кнопку Начните, нажмите панель управления, нажмите значок System и нажмите кнопку ОК.

    Под панелью управления главная щелкните удаленные параметры.

    На вкладке Remote в диалоговом окне System Properties щелкните Выберите пользователей. Добавьте пользователей или группы, которые должны подключиться к серверу хост-сервера сеансов RD с помощью удаленного рабочего стола.

    При выборе параметра «Не разрешай подключения к этому компьютеру» на вкладке Remote пользователи не смогут подключиться удаленно к этому компьютеру, даже если они являются членами группы пользователей удаленных настольных компьютеров.

    Добавление пользователей и групп в группу удаленных пользователей настольных компьютеров с помощью привязки локальных пользователей и групп

    1. Нажмите кнопку Пуск, выберите пункт Администрирование и щелкните пункт Управление компьютером.
    2. В дереве консоли щелкните узел Локальные пользователи и группы.
    3. В области сведений дважды щелкните папку Группы.
    4. Дважды щелкните Удаленные пользователи настольных компьютеров и нажмите кнопку Добавить.
    5. В диалоговом окне Выбор пользователей щелкните Расположения, чтобы указать расположение поиска.
    6. Щелкните Типы объектов, чтобы указать типы объектов, которые необходимо искать.
    7. В поле Ввод имен объектов для выбора (примеров) введите имя, которое необходимо добавить.
    8. Нажмите кнопку Проверить имена.
    9. Когда имя расположено, нажмите кнопку ОК.
    • Вы не можете подключиться к компьютеру, который спит или спит, поэтому убедитесь, что параметры сна и спячки на удаленном компьютере настроены на Never. (Hibernation доступен не на всех компьютерах.) Сведения о внесении этих изменений см. в публикации Change, create or delete a power plan (scheme).
    • Для подключения к компьютеру с помощью Windows 7 Начальная, Windows 7 Домашняя базовая или Windows 7 Домашняя расширенная нельзя использовать удаленное подключение к Windows 7 Домашняя расширенная.
    • Члены локальной группы администраторов могут подключаться, даже если они не указаны.

    Разрешение для симптома 2

    В этот раздел, описание метода или задачи включены действия, содержащие указания по изменению параметров реестра. Однако неправильное изменение параметров реестра может привести к возникновению серьезных проблем. Поэтому следует в точности выполнять приведенные инструкции. Для дополнительной защиты создайте резервную копию реестра, прежде чем редактировать его. Так вы сможете восстановить реестр, если возникнет проблема. Дополнительные сведения о том, как создать и восстановить реестр, см. в этой информации, как создать и восстановить реестр в Windows.

    Чтобы устранить эту проблему, определите, какое приложение использует тот же порт, что и RDP. Если назначение порта для этого приложения невозможно изменить, измените порт, назначенный RDP, изменив реестр. После изменения реестра необходимо перезапустить службу удаленного рабочего стола. После перезапуска службы удаленных настольных служб необходимо убедиться, что порт RDP был изменен правильно.

    Доступность прослушиватель сервера удаленного рабочего стола

    Компонент прослушиватель работает на сервере удаленного рабочего стола и отвечает за прослушивание и принятие новых клиентских подключений к удаленному настольному протоколу (RDP), что позволяет пользователям создавать новые удаленные сеансы на сервере удаленного рабочего стола. Существует прослушиватель для каждого подключения удаленных настольных служб, которое существует на сервере удаленного рабочего стола. Подключения можно создавать и настраивать с помощью средства конфигурации служб удаленного рабочего стола.

    Для выполнения этих задач обратитесь к следующим разделам.

    Определите, какое приложение использует тот же порт, что и RDP

    Вы можете запустить средство netstat, чтобы определить, используется ли порт 3389 (или назначенный порт RDP) другим приложением на сервере удаленного рабочего стола:

    1. На сервере удаленного рабочего стола нажмите кнопку Начните, нажмите кнопку Выполнить, введите cmd, а затем нажмите кнопку ОК.
    2. В командной подсказке введите и netstat -a -o нажмите кнопку Ввод.
    3. Иском запись для порта TCP 3389 (или назначенного порта RDP) со статусом Listening. Это указывает на то, что другое приложение использует этот порт. Код PID (Идентификатор процесса) процесса или службы, использующий этот порт, отображается в столбце PID.

    Чтобы определить, какое приложение использует порт 3389 (или назначенный порт RDP), используйте средство командной строки для задач вместе с данными PID из средства netstat:

    1. На сервере удаленного рабочего стола нажмите кнопку Начните, нажмите кнопку Выполнить, введите cmd, а затем нажмите кнопку ОК.
    2. Введите tasklist /svc и нажмите кнопку Ввод.
    3. Найди запись для номера PID, связанного с портом (из вывода netstat). Службы или процессы, связанные с этим PID, отображаются справа.

    Изменение порта, назначенного RDP

    Необходимо определить, может ли это приложение использовать другой порт. Если вы не можете изменить порт приложения, необходимо изменить порт, который назначен RDP.

    Рекомендуется не изменять порт, который назначен RDP.

    Если необходимо изменить порт, назначенный RDP, необходимо изменить реестр. Для этого вы должны быть членом локальной группы администраторов или вам должны быть предоставлены соответствующие разрешения.

    Чтобы изменить порт, который назначен RDP, выполните следующие действия:

    На сервере удаленного рабочего стола откройте редактор реестра. Чтобы открыть редактор реестра, нажмите кнопку Пуск, выберите Выполнить. , введите regedit и нажмите кнопку ОК.

    Если появится диалоговое окно «Управление учетной записью пользователя», убедитесь, что отображаемая в нем акция является нужным, а затем нажмите кнопку Продолжить.

    Найдите и откройте следующий подраздел реестра:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Remote Desktop server\WinStations

    RDP-TCP — это имя подключения по умолчанию. Чтобы изменить порт для определенного подключения на сервере удаленного рабочего стола, выберите подключение под ключом WinStations:

    1. В области сведений дважды щелкните запись реестра PortNumber.
    2. Введите номер порта, который необходимо назначить RDP.
    3. Нажмите кнопку ОК, чтобы сохранить изменение, а затем закроем редактор реестра.

    Перезапуск служб удаленного рабочего стола

    Чтобы изменение назначения порта RDP вступает в силу, остановитесь и запустите службу удаленного рабочего стола. Для этого вы должны быть членом локальной группы администраторов или вам должны быть предоставлены соответствующие разрешения.

    Чтобы остановить и запустить службу удаленного рабочего стола, выполните следующие действия:

    На сервере удаленного рабочего стола откройте оснастку Services. Для этого нажмите кнопку Начните, указать административные средства, а затем щелкните Службы.

    Если появится диалоговое окно «Управление учетной записью пользователя», убедитесь, что отображаемая в нем акция является нужным, а затем нажмите кнопку Продолжить.

    В области Служб щелкните правой кнопкой мыши удаленные службы настольных компьютеров, а затем нажмите кнопку Перезапустить.

    Если вам предложено перезапустить другие службы, нажмите кнопку Да.

    Убедитесь, что столбец Status для службы удаленных служб настольных компьютеров отображает состояние Начало.

    Убедитесь, что порт RDP изменился

    Чтобы убедиться, что назначение порта RDP изменено, используйте средство netstat:

    На сервере удаленного рабочего стола нажмите кнопку Начните, нажмите кнопку Выполнить, введите cmd, а затем нажмите кнопку ОК.

    В командной подсказке netstat -a введите кнопку Ввод.

    Найми запись для номера порта, назначенного RDP. Порт должен отображаться в списке и иметь статус Listening.

    Читайте также:  Pce164p n03 ver006 не работает

    Удаленное подключение к рабочему столу и веб-клиент терминала сервера по умолчанию используют порт 3389 для подключения к серверу удаленного рабочего стола. Если вы измените порт RDP на сервере удаленного рабочего стола, вам придется изменить порт, используемый удаленным подключением к рабочему столу и веб-клиентом удаленного настольного сервера. Дополнительные сведения см. в веб-сайте Изменение порта прослушивания для удаленного рабочего стола на компьютере.

    Убедитесь, что прослушиватель на сервере удаленного рабочего стола работает

    Чтобы убедиться, что слушатель на сервере удаленного рабочего стола работает правильно, используйте любой из следующих методов.

    RDP-TCP — это имя подключения по умолчанию, а 3389 — порт RDP по умолчанию. Используйте имя подключения и номер порта, определенные конфигурации сервера удаленного рабочего стола.

    Чтобы установить удаленное подключение к серверу удаленного рабочего стола, используйте клиент RDP, например удаленное подключение к рабочему столу.

    Используйте средство qwinsta для просмотра состояния слушателя на сервере удаленного рабочего стола:

    1. На сервере удаленного рабочего стола нажмите кнопку Начните, нажмите кнопку Выполнить, введите cmd, а затем нажмите кнопку ОК.
    2. В командной подсказке введите qwinsta и нажмите кнопку Ввод.
    3. Состояние сеанса RDP-TCP должно быть Listen.

    Используйте средство netstat, чтобы просмотреть состояние слушателя на сервере удаленного рабочего стола:

    1. На сервере удаленного рабочего стола нажмите кнопку Начните, нажмите кнопку Выполнить, введите cmd, а затем нажмите кнопку ОК.
    2. В командной подсказке netstat -a введите кнопку Ввод.
    3. Запись для порта TCP 3389 должна быть «Прослушивание».

    Используйте средство telnet для подключения к порту RDP на сервере удаленного рабочего стола:

    1. С другого компьютера нажмите кнопку Начните, нажмите кнопку Выполнить, введите cmd, а затем нажмите кнопку ОК.
    2. В командной подсказке введите имя сервера удаленного рабочего telnet 3389 стола и нажмите кнопку Ввод.

    Если telnet успешно, вы получите экран telnet и курсор.

    Если telnet не успешно, вы получите следующее сообщение об ошибке:

    Подключение к имени сервера. Не удалось открыть подключение к хосту в порту 3389: Подключение не удалось

    Средства qwinsta, netstat и telnet также включены в Windows XP и Windows Server 2003. Вы также можете скачать и использовать другие средства устранения неполадок, такие как Portqry.

    Разрешение для симптома 3

    Чтобы устранить проблему, настройте проверку подлинности и шифрование.

    Чтобы настроить проверку подлинности и шифрование для подключения, выполните следующие действия:

    На хост-сервере сеанса RD откройте конфигурацию хост-сервера удаленного рабочего стола. Чтобы открыть конфигурацию хост-хозяйской сессии удаленного рабочего стола, нажмите кнопку Начните, указать на административные средства, указать на удаленные службы настольных компьютеров, а затем нажмите кнопку Удаленное конфигурация хозяйской сессии рабочего стола.

    В «Подключениях» щелкните правой кнопкой мыши имя подключения и нажмите кнопку Свойства.

    В диалоговом окне Свойства для подключения на вкладке General в уровне Безопасности выберите метод безопасности.

    На уровне шифрования щелкните нужный уровень. Вы можете выбрать low, Client Compatible, High или FIPS Compliant. См. шаг 4 выше для Windows Server 2003 для параметров уровня безопасности и шифрования.

    • Для выполнения данной процедуры необходимо входить в группу «Администраторы» на локальном компьютере или получить соответствующие полномочия путем делегирования. Если компьютер присоединен к домену, эту процедуру могут выполнять члены группы «Администраторы домена». По соображениям безопасности рекомендуется использовать команду «Запуск от имени».
    • Чтобы открыть конфигурацию служб удаленного рабочего стола, нажмите кнопку Начните, щелкните Панель управления, дважды щелкните административные средства, а затем дважды щелкните конфигурацию служб удаленного рабочего стола.
    • Любые параметры уровня шифрования, настроенные в групповой политике, переопределяют конфигурацию, заданную с помощью средства конфигурации служб удаленного рабочего стола. Кроме того, если включить системную криптографию: используйте алгоритмы, совместимые с FIPS, для шифрования, хаширования и подписания параметра групповой политики, этот параметр переопределит параметр Групповой политики шифрования клиентского подключения.
    • При изменении уровня шифрования новый уровень шифрования вступает в силу при следующем входе пользователя. Если требуется несколько уровней шифрования на одном сервере, установите несколько сетевых адаптеров и настройте каждый адаптер отдельно.
    • Чтобы убедиться, что сертификат имеет соответствующий закрытый ключ, в конфигурации служб удаленного рабочего стола щелкните правой кнопкой мыши подключение, для которого необходимо просмотреть сертификат, щелкните вкладку Общие, нажмите кнопку Изменить, щелкните сертификат, который необходимо просмотреть, а затем нажмите кнопку Просмотреть сертификат . В нижней части вкладки «Общие» должен отображаться закрытый ключ, соответствующий этому сертификату. Эти сведения также можно просмотреть с помощью оснастки Сертификаты.
    • Параметр FIPS, совместимый с FIPS (система криптографии: использование алгоритмов, совместимых с FIPS, для шифрования, хаширования и подписи в групповой политике или параметре fiPS Compliant в конфигурации серверов удаленного рабочего стола) шифрует и расшифровывает данные, отправленные от клиента на сервер и с сервера к клиенту, с помощью алгоритмов шифрования 140-1 Федерального стандарта обработки информации (FIPS) 140-1, с помощью криптографических модулей Майкрософт. Дополнительные сведения см. в технической справке Windows Server 2003.
    • Высокий параметр шифрует данные, отосланные от клиента на сервер и с сервера к клиенту с помощью сильного 128-битного шифрования.
    • Параметр Client Compatible шифрует данные, отосланные между клиентом и сервером, с максимальной силой ключа, поддерживаемой клиентом.
    • Параметр Low шифрует данные, отосланные от клиента на сервер с помощью 56-битного шифрования.

    Дополнительный шаг по устранению неполадок: включить журналы событий CAPI2

    Чтобы устранить эту проблему, вйдите в журналы событий CAPI2 на клиентских и серверных компьютерах. Эта команда показана на следующем скриншоте.

    Решение проблемы (невозможно полностью отключить подключение удаленного сервера рабочего стола), описанное в Symptom 3

    Чтобы решить эту проблему, выполните следующие действия:

    1. Нажмите кнопку Начните,нажмите кнопку Выполнить, введите gpedit.msc, а затем нажмите кнопку ОК.
    2. Расширение конфигурации компьютера, расширение административных шаблонов, расширение Windows компонентов, расширение служб удаленного рабочего стола, расширение удаленного рабочего стола, а затем нажмите кнопку Подключения.
    3. В правой области дважды щелкните Настройка интервала подключения с сохранением жизни.
    4. Выберите Включено и нажмите кнопку OK.
    5. Закрой редактор объектов групповой политики, нажмите кнопку ОК, а затем уйдите из Active Directory Users and Computers.

    Разрешение для симптома 4

    В этот раздел, описание метода или задачи включены действия, содержащие указания по изменению параметров реестра. Однако неправильное изменение параметров реестра может привести к возникновению серьезных проблем. Поэтому следует в точности выполнять приведенные инструкции. Для дополнительной защиты создайте резервную копию реестра, прежде чем редактировать его. Так вы сможете восстановить реестр, если возникнет проблема. Дополнительные сведения о том, как создать и восстановить реестр, см. в 322756 Как создать и восстановить реестр в Windows.

    Чтобы устранить эту проблему, повторите работу и удалите ключи реестра сертификатов X509, перезапустите компьютер, а затем активируете сервер лицензирования удаленных настольных служб. Для этого выполните указанные ниже действия.

    Выполните следующую процедуру на каждом из серверов удаленного рабочего стола.

    Убедитесь, что реестр серверов удаленного рабочего стола был успешно отла

    Откройте редактор реестра.

    Найдите и откройте следующий подраздел реестра:

    В меню реестра щелкните Файл реестра экспорта.

    Введите экспортируемого сертификата в поле имя файла, а затем нажмите кнопку *Сохранить.

    Если в будущем необходимо восстановить этот файл реестра, дважды щелкните файл Exported-parameters.reg, сохраненный на этом шаге.

    Щелкните правой кнопкой мыши каждое из следующих значений, щелкните Удалить, а затем нажмите кнопку Да, чтобы проверить удаление:

    • Сертификат
    • Сертификат X509
    • Удостоверение сертификата X509
    • Сертификат X5092

    Редактор exit Registry, а затем перезапустите сервер.

    Ссылки

    Дополнительные сведения о шлюзе удаленного рабочего стола см. в следующих статьях:

    Если эта статья не поможет вам устранить проблему или у вас появились симптомы, отличающиеся от описанных в этой статье, посетите службу поддержки Майкрософт для получения дополнительных сведений. Чтобы найти проблему, в поле «Поддержка поиска для справки» введите текст полученного сообщения об ошибке или введите описание проблемы.

    Источник

    Оцените статью