- Проблема связи с порталом ИТС
- Решение проблем интеграции с Порталом 1С:ИТС
- Содержание
- 1. Общие действия
- 2. Если у пользователя не работают услуги портала.
- Симптомы проблемы
- Решение
- 3. Расхождение данных портала и менеджера сервиса
- 4. Подписки перестали отправляться в портал
- 5. Устранение причин непринятия подписок порталом
- 5.1. Бизнес-ошибки
- Пример ошибки
- Решение
- Пример ошибки
- Решение
- Пример ошибки
- Решение
- 5.2. Технические ошибки
- Пример ошибки
- Решение
- Симптомы проблемы
- Решение
Проблема связи с порталом ИТС
Перенес сервер приложений 1с на новый сервер, и почему-то на нем не работает доступ к сервису ИТС. В частности, не могу указать регномер и пароль на новой базе, ругается что данные введены но невозможно проверить их правильность. Если зайти в «монитор портала 1с итс» в старой базе — там написано «Ошибка при подключении к интернет. Удаленный узел не прошел проверку.».
Проблема проявляется как на клиент-серверной, так и на файловой базе.
В интернете нагуглил:
—
Проверьте, что если в строке поиска в интернет эксплорере ввести https://webits.1c.ru/services/WebItsSimpleService?wsdl, то ссылка открывается.
Пользователь, от имени которого вы работаете, имеет доступ в интернет.
В случае, если это файловая база на машине клиента — проверять следует на ней.
Если это клиент-серверная база, то на сервере из- под пользователя, под которым запущен сервер 1С.
Проверять только браузером IE.
—
Доступ в интернет напрямую, не через прокси (яндекс пингуется нормально). Сайт 1с и вышеприведенный адрес webits нормально открываются интернет эксплорером, запущенном от имени usr1cv8 или в случае файловой базы — от имени текущего пользователя, без ошибок и предупреждений. Цепочка сертификатов корректная, ошибок нет.
В чем может быть проблема?
(1) За вторую ссылку спасибо.
По непонятной причине 1с для запроса списка отзыва сертификатов ломится через прокси, по видимому находя его через wpad, хотя имеется и прямой доступ к интернету с сервера, и не может авторизироваться на нем. Хотя в 1с и в пользовательской и в серверной настройке прокси сервера он отключен.
Тут, похоже, какой-то виндовый механизм задействуется, а не от 1с.
Настроил разрешение на прокси этому серверу без авторизации — всё заработало.
Источник
Решение проблем интеграции с Порталом 1С:ИТС
При интеграции с порталом и использовании услуг портала возможно возникновение проблем или ошибок, например:
У пользователя не работает услуга портала.
Подписки перестали отправляться в портал.
При возникновении ошибки с кодом ответа портала 500 в любой из перечисленных выше ситуаций следует обращаться на webits-info@1c.ru, прикрепив к письму описание ошибки.
Ниже описаны действия при возникновении других ошибок.
Содержание
1. Общие действия
Проверить актуальность расширения по интеграции с порталом ИТС для менеджера сервиса: команды меню Все функции — Управление расширениями конфигурации , расширение ИнтеграцияСПорталомИТС .
Если версия расширения не последняя — обновить расширение. Актуальная версия расширения доступна в составе продукта 1С:Предприятие. Облачная подсистема Фреш на сайте releases.1c.ru
Проверить основные настройки интеграции с порталом в менеджере сервиса: команды меню Интеграция — Учетные системы , учетная система Портал 1С:ИТС .
2. Если у пользователя не работают услуги портала.
При возникновении ошибок при работе с услугами портала, например не выполняется заполнение реквизитов контрагентов, необходимо выполнить следующие действия.
Нужно проверить, отправлены ли портал следующие данные:
| Вид данных | Проверка | |
|---|---|---|
| Данные абонента | ||
| Данные пользователей абонентов | Письмо или звонок в отдел разработки Портала 1С:ИТС | |
| 2 | Письмо или звонок в отдел разработки Портала 1С:ИТС | |
| 3 | Письмо или звонок в отдел разработки Портала 1С:ИТС | |
| 4 | Не удалось получить тикет аутентификации в Менеджере сервиса http://fresh:8888/int/sm/hs/tickets/ Код состояния: 500. Сообщение: Область данных: 38 253 Идентификатор пользователя: cd012524-30f1-11e8-80ce-8e51d7d8547d | Повторить отправку, если не удалось — письмо или звонок в отдел разработки Портала 1С:ИТС |
3. Расхождение данных портала и менеджера сервиса
Расхождение данных Портала 1С:ИТС и менеджера сервиса. Например: на портале на 10 подписок больше чем в менеджере сервиса.
Причина состоит в непосредственном удалении объектов. Если объект Подписка, Абонент, Пользователь абонента был создан ошибочно и сразу удалён из менеджера сервиса как объект без пометки удаления, то сообщение на портал не отправляется.
Чтобы объект также был удалён на портале, достаточно поставить пометку на удаление на соответствующий объект Подписки, Абонента или Пользователя абонента.
4. Подписки перестали отправляться в портал
Интеграция с порталом использует общую очередь сообщений. Если в менеджере сервиса «забита» очередь сообщений, то возможны 2 варианта решения:
- Дождаться освобождения очереди сообщений.
Отправить сообщения интеграции принудительно. Для этого нужно:
- Открыть элемент учетной системы 1С:Портал в списке Учетные системы (команды меню Интеграция — Учетные системы, учетная система Портал 1С:ИТС)
или переход по ссылке – e1cib/list/Справочник.УчетныеСистемы. - Выбрать команду меню формы Объекты к отправке.
- Нажать на кнопку «самолетик»
. - Все сообщения будут отправлены.
- Т.к. в портале процесс принятия сообщений разделен на 2 фазы: принятие к обработке и обработка, и между фазами возможен лаг 1-5 минут, процедуру отправки нужно будет при необходимости повторить через 5 минут.
- Если процедуру повторять 3 раза подряд, то сообщения заблокируются, но их можно разблокировать, нажатием на кнопку «замок»
.
5. Устранение причин непринятия подписок порталом
Для выяснения причин, почему подписка не была отправлена, нужно:
- Вывести карточку свойств подписки и выбрать команду меню Интеграция.
- Посмотреть описание состояния интеграции и лог отправки.
Открыть описание объекта к отправке, показанное в списке Данные к отправке:
По этим сведениям можно понять причину, после чего нужно эту причину устранить. Возможные причины делятся на 2 типа:
- Бизнес-ошибка в подписке
- Техническая ошибка на Портале 1С:ИТС
5.1. Бизнес-ошибки
Бизнес-ошибки нужно устранять силами партнера, указав ее причины.
На каждый запрос идет проверка по логину и паролю от конкретного экземпляра сервиса Фреш.
Также выполняются проверки заполнения полей. Описание проверок приведены в п.6 документа Rest API Портала 1С:ИТС Fresh-Integration
Ниже приведены примеры бизнес-ошибок.
Пример ошибки
Решение
У обслуживающей организации указан код партнера отличный от числа. Нужно чтобы у обслуживающей организации код партнера был числом.
Код партнера указывается в поле Идентификатор без последних цифр после «-«. Например, если Код партнера 000987-123, то указываем 000987, или 987 :
Пример ошибки
Решение
Тариф, на который оформляется подписка, не может быть оформлен на указанный срок. Возможные сроки оформления подписок на тариф обычно указываются на вкладке Описание формы свойств тарифа поставщика услуг.
Тарифы поставщиков услуг доступны с помощью команды меню Управление тарифами — Тарифы поставщиков услуг или по ссылке e1cib/list/Справочник.ТарифыПоставщиковУслуг.
Пример ошибки
Решение
Подписка была ранее получена порталом и изменена пользователем в срок, когда ее уже нельзя менять.
Партнер или оператор сервиса должен создать новую подписку. Эту подписку нужно вернуть в исходное состояние или пометить на удаление, если она не актуальна.
5.2. Технические ошибки
Технические ошибки нужно устранять самостоятельно, либо, если ошибка не устраняется, нужно связаться с отделом разработки портала 1С:ИТС.
Пример ошибки
Решение
В момент отправки сообщения в портал на портале 1С:ИТС производились технические работы и сообщение не смогло доставиться после 3-х попыток отправки.
Нужно в карточке свойств объекта (например, подписки) выбрать команду меню Интеграция и открыть сообщение, показанное в списке Данные к отправке:
В выведенной форме Объект к отправке нужно разблокировать сообщение, нажав на кнопку замка
Если в сообщении отображается пиктограмка «часы»
Такая проблема может быть массовой. В этом случае нужно проделать те же действия, но с большим числом сообщений. Для этого нужно открыть форму учетной системы Портал 1С:ИТС ( Интеграция — Учетные системы , учетная система Портал 1С:ИТС ) и выбрать в ней команду меню Объекты к отправке :
Здесь будут доступны те же кнопки
- Если в списке выделен один элемент, то операция будет выполнена для всех элементов списка.
- Если в списке выделено несколько элементов, то операция будет выполнена только для выделенных элементов.
Также в этом списке можно открывать отдельные объекты к отправке и выполнять их отправку из формы свойств объекта.
Симптомы проблемы
Сообщения отправляются в течение часа или более:
Решение
Ошибка проявляется на тестовых и боевых серверах.
- В инфраструктуре сервиса Портала 1С:ИТС идут какие-то нагрузочные тесты.
Возможно, отправляемое сообщение содержит некорректный код партнера.
Код партнера должен быть из существующих кодов партнера.
Нужно установить обслуживающей организации существующий код партнера, например 987 или 456.
Источник