После переименования сервера не работает сервер 1с

1С 8.3 : Ошибка соединения с сервером 1С:Предприятие Не запущен ни один рабочий процесс.

Бывает, однажды, ни с того и с чего программа 1С нам выдает: Ошибка соединения с сервером 1С:Предприятие Не запущен ни один рабочий процесс. Соединение с базой невозможно.

Несколько вариантов поиска ошибок и решений:

1. Глюк сервака — всякое бывает

Остановите в диспетчере задач процессы: ragent rphost rmngr и Запустите службу «Агент сервера 1С:Предприятие»

2. При внезапном отключения питания или аналогичных ситуациях — повредился файл srvribrg.lst

Нужно удалить все из папки srvinfo

Для Windows зайдите в каталог c:\program files\1c\1cv82\ srvinfo, если Linux — то файлы лежат в домашнем каталоге пользователя от имени которого запускается сервис: usr1cv8/home/.1cv8/1C/1cv8 .

Запустите службу «Агент сервера 1С:Предприятие».

Через Администрирование серверов 1С Предприятия по новой создать кластер 1С и добавить информационные базы

3. Переименовали сервер на котором служба агента 1С

После переименования сервера Windows Server 2008 с установленным 1С:Предприятие 8.2, перестала работать служба «Агент сервера 1С:Предприятие 8.2». Она запускается, работает несколько секунд и останавливается. Если подключаться к серверу 1С:Предприятие 8.2 через консоль серверов, то возникает ошибка:

Ошибка соединения с сервером 1С:Предприятие 8.2 server_addr=tcp://SERVER:1540 descr=Ошибка сетевого доступа к серверу (Windows Sockets — 10061(0x0000274D). Подключение не установлено, т.к. конечный компьютер отверг запрос на соединение.) line=590 file=.\Src\DataExchangeTcpClientItmpl.cpp

При подключении к базе на этом сервере имеем следующую ошибку:

Не запущен ни один рабочий процесс. Соединение с базой невозможно.

Данная проблема связана с тем, что настройки кластера серверов 1С:Предприятие хранятся в файлах в каталоге srvinfo (путь к нему указывает параметр -d в свойствах службы «Агент сервера 1С:Предприятие»). Поэтому после изменения имени компьютера надо выполнить дополнительно следующие действия:

Для Windows зайдите в каталог c:\program files\1c\1cv82\srvinfo, если Linux — то файлы лежат в домашнем каталоге пользователя от имени которого запускается сервис: usr1cv8/home/.1cv8/1C/1cv8 .

Читайте также:  Недостаточно памяти некоторые функции могут не работать xiaomi как убрать

Отредактируйте в любом текстовом редакторе два файла: srvinfo\srvribrg.lst и srvinfo\reg_1541\1CV8Reg.lst. Замените в этих файлах старое имя сервера на новое.

Запустите службу «Агент сервера 1С:Предприятие».

После выполнения указанных действий — Все будет

Источник

После переименования сервера не работает сервер 1с

PHP, Java, Delphi, 3D

Ошибка запуска 1С:Підприємство в Linux после переименования сервера

Переименовали сервер на котором служба агента «1С:Підприємство»

После переименования сервера Windows Server 2008 с установленным «1С:Підприємство», перестала работать служба «Агент сервера «1С:Підприємство»». Она запускается, работает несколько секунд и останавливается. Если подключаться к серверу «1С:Підприємство» 8.2 через консоль серверов, то возникает ошибка:

Ошибка соединения с сервером «1С:Підприємство» 8.2 server_addr=tcp://SERVER:1540 descr=Ошибка сетевого доступа к серверу (Windows Sockets — 10061(0x0000274D). Подключение не установлено, т.к. конечный компьютер отверг запрос на соединение.) line=590 file=.\Src\DataExchangeTcpClientItmpl.cpp

При подключении к базе на этом сервере имеем следующую ошибку:

Не запущен ни один рабочий процесс. Соединение с базой невозможно.

Данная проблема связана с тем, что настройки кластера серверов «1С:Підприємство» хранятся в файлах в каталоге srvinfo (путь к нему указывает параметр -d в свойствах службы «Агент сервера «1С:Підприємство»»). Поэтому после изменения имени компьютера надо выполнить дополнительно следующие действия:

Для Windows зайдите в каталог c:\program files\1c\1cv82\srvinfo, если Linux — то файлы лежат в домашнем каталоге пользователя от имени которого запускается сервис: usr1cv8/home/.1cv8/1C/1cv8 …

Отредактируйте в любом текстовом редакторе два файла: srvinfo\srvribrg.lst и srvinfo\reg_1541\1CV8Reg.lst. Замените в этих файлах старое имя сервера на новое.

Запустите службу «Агент сервера «1С:Підприємство»».

После этого, все будет запускаться нормально.

Источник

Ошибка соединения с сервером 1С Предприятия 8.3

Ошибка соединения с сервером 1С Предприятия 8.3 – Этот хост не известен.

Поймать такую ошибку можно после смены имени хоста вашего сервера или ПК (Вы сменили имя сервера или ПК на компьютере).

Гарантированно, после этого, Сервер 1С стартовать не будет, точнее, произойдет запуск и вскоре его остановка.

А если запустить утилиту «Администрирования серверов» собственно увидите ошибку как на скрине ниже.

Также вы поймаете такую ошибку, если попытаетесь сменить имя параметра центрального кластера утилитой администрирования серверов, оно в этом случаи будет отличаться от имени хоста и ошибка не заставит себя ждать.

Читайте также:  Как настроить беспроводной контроллер

Как решить проблему:

Здесь собственно есть несколько вариантов!

  1. Вернуть обратно имя хоста.
  2. Удалить полностью каталог «srvinfo» там, где установлен ваш Сервер 1С.
  3. Изменить имя хоста в настройках Сервера 1С.

Первый вариант предполагаю, отбросим сразу, так как есть причина, почему вы решили сменить имя хоста.

Второй уничтожит все подключения баз и настройки самого кластера также полетят «К чертям» ) Не вариант когда баз много, так как опять все подключения придется создавать, а если еще есть настройки на кластере, это однозначно не то что нам надо.

А вот третий вариант позволит нам, и все настройки уберечь и не потерять подключения баз.

Для этого, запускаем утилиту администрирования серверов 1С, и в свойствах кластера укажем новое имя. (Наш хост к примеру: «SERVER_OFFICE» ).

Затем открываем каталог «srvinfo» и откроем файл 1cv8wsrv.lst простым блокнотом.

Старое имя хоста «APACHE» сменим на «SERVER_OFFICE».

Если Вы хотите больше узнать о технической стороне 1С, тогда регистрируйтесь на первый бесплатный модуль курса: Администратор 1С >>>

Источник

Падение сервера 1С после переименования компьютера

Восстановление работы сервера 1С после изменения имени компьютера сервера

В работе сервера 1С (агента 1С) есть одна особенность — после того как вы его установили на ваш сервер, 1С-агент привязывается к имени компьютера. Поэтому, если после установки 1С-сервера вы решили привести имя компьютера к красивому виду, после перезагрузки компьютера вы будите неприятно удивлены — сервер 1С не работает ! В этом можно убедиться, заглянув в службы и увидев что служба «Агент сервера 1С:Предприятие 8.х» остановлена.

При попытке запуска службы она работает несколько секунд и останавливается. Если подключаться к серверу 1С:Предприятие 8.х через консоль серверов, то возникает ошибка: Ошибка соединения с сервером 1С:Предприятие 8.х server_addr=tcp://SERVER:1540 descr=Ошибка сетевого доступа к серверу (Windows Sockets — 10061(0x0000274D). Подключение не установлено, т.к. конечный компьютер отверг запрос на соединение.) line=590 file=.\Src\DataExchangeTcpClientItmpl.cpp При подключении к базе на этом сервере имеем следующую ошибку: «Не запущен ни один рабочий процесс. Соединение с базой невозможно».

Данная проблема связана с тем, что настройки кластера серверов 1С:Предприятие хранятся в файлах в каталоге srvinfo (путь к нему указывает параметр -d в свойствах службы «Агент сервера 1С:Предприятие»). Поэтому после изменения имени компьютера надо выполнить дополнительно следующие действия:

Читайте также:  Как настроить панель android

Источник

Ошибка соединения с сервером 1С:Предприятие Не запущен ни один рабочий процесс.

Бывает, однажды, ни с того и с чего программа 1С нам выдает: Ошибка соединения с сервером 1С:Предприятие Не запущен ни один рабочий процесс. Соединение с базой невозможно.

Несколько вариантов поиска ошибок и решений:

1. Глюк сервака — всякое бывает

Остановите в диспетчере задач процессы: ragent rphost rmngr и Запустите службу «Агент сервера 1С:Предприятие»

2. При внезапном отключения питания или аналогичных ситуациях — повредился файл srvribrg.lst

Нужно удалить все из папки srvinfo

Для Windows зайдите в каталог c:\program files\1c\1cv82\ srvinfo, если Linux — то файлы лежат в домашнем каталоге пользователя от имени которого запускается сервис: usr1cv8/home/.1cv8/1C/1cv8 .

Запустите службу «Агент сервера 1С:Предприятие».

Через Администрирование серверов 1С Предприятия по новой создать кластер 1С и добавить информационные базы

3. Переименовали сервер на котором служба агента 1С

После переименования сервера Windows Server 2008 с установленным 1С:Предприятие 8.2, перестала работать служба «Агент сервера 1С:Предприятие 8.2». Она запускается, работает несколько секунд и останавливается. Если подключаться к серверу 1С:Предприятие 8.2 через консоль серверов, то возникает ошибка:

Ошибка соединения с сервером 1С:Предприятие 8.2 server_addr=tcp://SERVER:1540 descr=Ошибка сетевого доступа к серверу (Windows Sockets — 10061(0x0000274D). Подключение не установлено, т.к. конечный компьютер отверг запрос на соединение.) line=590 file=.\Src\DataExchangeTcpClientItmpl.cpp

При подключении к базе на этом сервере имеем следующую ошибку:

Не запущен ни один рабочий процесс. Соединение с базой невозможно.

Данная проблема связана с тем, что настройки кластера серверов 1С:Предприятие хранятся в файлах в каталоге srvinfo (путь к нему указывает параметр -d в свойствах службы «Агент сервера 1С:Предприятие»). Поэтому после изменения имени компьютера надо выполнить дополнительно следующие действия:

Для Windows зайдите в каталог c:\program files\1c\1cv82\srvinfo, если Linux — то файлы лежат в домашнем каталоге пользователя от имени которого запускается сервис: usr1cv8/home/.1cv8/1C/1cv8 .

Отредактируйте в любом текстовом редакторе два файла: srvinfo\srvribrg.lst и srvinfo\reg_1541\1CV8Reg.lst. Замените в этих файлах старое имя сервера на новое.

Запустите службу «Агент сервера 1С:Предприятие».

После выполнения указанных действий — Все будет

Источник

Оцените статью