- Вопросы и ответы: ViPNet Деловая Почта
- Вопросы и ответы: ViPNet Деловая Почта
- Что необходимо для работы ViPNet Деловая почта без клиента?
- В версии программы 4.5.1 ViPNet Деловая почта не устанавливается отдельно от ViPNet Client
- Не добавляется вложение, если в его названии присутствуют спецсимволы других языков
- Возникает ошибка ViPNet Деловой почты при архивации писем
- Если при обработке входящего письма программой ViPNet Деловая почта произошла ошибка, в зависимости от типа ошибки входящее письмо будет автоматически помещено в одну из двух основных подпапок в папке «Аудит», а на экране появится соответствующее предупреждение
- Не удается выполнить аутентификацию с помощью сертификата
- После установки vipnet не работает outlook
- Вопрос
- Ответы
- Все ответы
Вопросы и ответы: ViPNet Деловая Почта
Вопросы и ответы: ViPNet Деловая Почта
Что необходимо для работы ViPNet Деловая почта без клиента?
Для работы ViPNet Деловая почта без клиента необходимо:
Прописать адрес координатора в настройках mftp, если не задан в ЦУС.
На координаторе в правилах открытого локального трафика разрешить прохождение tcp:5000-5002.
Обязательно наличие связи на уровне узлов с координатором.
В версии программы 4.5.1 ViPNet Деловая почта не устанавливается отдельно от ViPNet Client
Не добавляется вложение, если в его названии присутствуют спецсимволы других языков
Открыть в панели управления настройку «Язык и региональные стандарты».
Перейти на вкладку «Дополнительно»> «Изменить язык системы. ».
В качестве текущего языка системы из списка выбрать тот язык, спецсимволы которого присутствуют в имени файла, который необходимо передать в качестве вложения.
Возникает ошибка ViPNet Деловой почты при архивации писем
Если работал автопроцессинг без архивации писем, а потом в настройках деловой почты «Инструменты – Настройки – Архивация – Автоматическая архивация» включили автоматическую архивацию, поставили флажок «Размер хранилища меньше» или значение меньше текущего размера файла базы данных ms4.db, то при следующей архивации возникает ошибка «Обнаружена исключительная ситуация в модуле wmail.exe» и после нажатия «OK» в окне ошибки Деловая почта падает.
Решение: в ViPNet Деловой почте отключить (снять флажок) параметр «Инструменты – Настройка – Архивация – Автоматическая архивация – Размер хранилища меньше» и нажать «Применить настройки».
Если при обработке входящего письма программой ViPNet Деловая почта произошла ошибка, в зависимости от типа ошибки входящее письмо будет автоматически помещено в одну из двух основных подпапок в папке «Аудит», а на экране появится соответствующее предупреждение
Если выбрать такое письмо, вместо его текста на панели чтения будет отображаться информация о номере, теме, отправителе письма и коде ошибки.
В папку «Поврежденные» перемещаются входящие письма, если:
При обработке письма произошла критическая ошибка.
Письмо было отправлено 30 дней назад, но не доставлено, потому что программа ViPNet Деловая почта не запускалась в течение 30 дней.
Письмо в папке «Поврежденные» невозможно восстановить. Если в папке «Поврежденные» появилась новая запись, сообщите о ней администратору сети ViPNet.
В папку «Проблемные» перемещаются входящие письма, которые не удалось расшифровать. Если в папке «Проблемные» появилась новая запись, выполните одно или несколько следующих действий:
Перезапустите программу ViPNet Деловая почта. После повторного запуска программа выполнит повторную обработку проблемного письма. В случае успешной обработки письма в папке «Входящие» появится новое письмо. При этом проблемное письмо также останется в папке «Проблемные».
Если на одном сетевом узле зарегистрировано несколько пользователей, возможно, проблемное входящее письмо адресовано другому пользователю. Сообщите другому пользователю, который зарегистрирован на этом узле, чтобы он попытался открыть проблемное письмо, когда войдет в программу ViPNet Деловая почта под своим именем.
Если письмо все же не удалось открыть, возможно, на вашем сетевом узле необходимо обновить справочники и ключи. Сообщите о проблемном письме и типе ошибки администратору сети ViPNet и следуйте его рекомендациям.
Не удается выполнить аутентификацию с помощью сертификата
Если вам не удается войти в программу ViPNet Деловая почта, используя для аутентификации сертификат и соответствующий ему ключ электронной подписи, которые хранятся на внешнем устройстве, это может быть вызвано одной из следующих причин:
Внешнее устройство не обеспечивает аппаратную поддержку алгоритмов ГОСТ.
Внешнее устройство хранения данных не поддерживает стандарт PKCS#11. Проверить, поддерживает ли ваше устройство этот стандарт, можно в разделе «Внешние устройства».
Срок действия выбранного сертификата истек. При выборе недействительного сертификата появится соответствующее сообщение. В этом случае следует передать сертификат администратору вашего удостоверяющего центра для обновления.
Выбранный сертификат присутствует в списке аннулированных сертификатов, который установлен в хранилище данного узла. При выборе аннулированного сертификата появится соответствующее сообщение. В этом случае следует обратиться к администратору вашего удостоверяющего центра.
Выбранный сертификат не имеет назначения «Шифрование ключей». Это расширение должно отображаться в окне «Сертификат», на вкладке «Состав», в поле «Использование ключа». В этом случае следует обратиться к администратору вашего удостоверяющего центра для переиздания сертификата.
Вы используете внешнее устройство JaCarta с апплетом PKI. Запрос на сертификат для этого устройства следует создавать в ПО «Единый клиент JaCarta» версии 2.12 и выше, поскольку только в этом ПО возможна запись открытого ключа на устройство. Если использование «Единого клиента» невозможно, передайте устройство производителю для записи на него открытого ключа.
Источник
После установки vipnet не работает outlook
Вопрос
Внедряем s/mime подпись в outlook для всех пользователей в домене. Все клиентские ОС — Win 7. Возникли проблемы у тех пользователей, у которых установлен ViPNET. Я не специалист по vipnet и, как оказалось, что эта система интегрирует в систему свой криптопровайдер в том числе для Outlook. Сертификат для эл, почты пользователю выдался, в профиле outlook он назначается, однако при попытке отправить сообщенрие с цифровой подписью — Выскакивает окошко: «Неожиданная ощибка . «. В журнале Windows появляются error от infotecs cryptographic service provider — это как раз криптопровайдер от vipnet.
В шаблоне сертификата используется CSP Microsoft Enhanced Cryptographic Provider, дефолтный для windows систем. Не знаю почему, но получается что outlook пытается вызвать CSP именно VIPnet, а так как сертификат не по гостовскому алгоритму и т.д. — ошибка. Что странно, так то, что типы криптопровайдеров-то вообще разные: для випнетовского 2, а для RSA 1.
Как для outlook назначить CSP по умолчанию Microsoft Enhanced Cryptographic Provider ? Желательно бы групповые политиками, но не нашел параметра.
Ответы
Проверьте и отключите надстройку ViPNet в Outlook.
Выполните переустановку ViPNet, с отключением установки его криптопровайдера. Закрытый ключ Пользователя на компьютере должен устанавливаться в формате неизвлекаемости закрытого ключа, в Outlook 2010 при проверке настроек, должен сразу показываться какой сертификат и какой алгоритм используется, что у Вас в этих окнах?
Проверьте и напишите результат.
Да, я Жук, три пары лапок и фасеточные глаза :))
- Изменено Жук MVP, Moderator 25 сентября 2013 г. 9:01 корректировка
- Помечено в качестве ответа maxim315 10 октября 2013 г. 6:03
Все ответы
Дополните, Вы собираетесь одной цифровой подписью подписывать все документы?
-Какие настройки электронной почты у Вас установлены на компьютерах с ViPNet:
-Где хранится закрытый ключ Владельца сертификата;
-Установлен ли и как устанавливался Сертификат, на компьютер Владельца Сертификата.
Да, я Жук, три пары лапок и фасеточные глаза :))
- Изменено Жук MVP, Moderator 23 сентября 2013 г. 19:27 дополнение
- Помечено в качестве ответа maxim315 25 сентября 2013 г. 2:09
- Снята пометка об ответе maxim315 25 сентября 2013 г. 2:09
Дополните, Вы собираетесь одной цифровой подписью подписывать все документы?
-Какие настройки электронной почты у Вас установлены на компьютерах с ViPNet:
-Где хранится закрытый ключ Владельца сертификата;
-Установлен ли и как устанавливался Сертификат, на компьютер Владельца Сертификата.
Да, я Жук, три пары лапок и фасеточные глаза :))
Для электронной почты используется отдельный, свой сертификат и на адрес эл. почты. Закрый ключ хранится на пк пользователя, устанавливается и распространяется автоматически согласно настроенным политикам и шаблону внутреннго CA. Vipnet’овский вообще не используется как подпись и адреса электронной почты в сертификаты vipnet не присутствует.
На приведенном вами скриншоте у меня настрофки верные — первым делом проверил: сертификат выбран тот который нужен.
Проблема только на пк, где установлен VIPnet.
Проверьте и отключите надстройку ViPNet в Outlook.
Выполните переустановку ViPNet, с отключением установки его криптопровайдера. Закрытый ключ Пользователя на компьютере должен устанавливаться в формате неизвлекаемости закрытого ключа, в Outlook 2010 при проверке настроек, должен сразу показываться какой сертификат и какой алгоритм используется, что у Вас в этих окнах?
Проверьте и напишите результат.
Да, я Жук, три пары лапок и фасеточные глаза :))
- Изменено Жук MVP, Moderator 25 сентября 2013 г. 9:01 корректировка
- Помечено в качестве ответа maxim315 10 октября 2013 г. 6:03
Проверьте и отключите надстройку ViPNet в Outlook.
Выполните переустановку ViPNet, с отключением установки его криптопровайдера. Закрытый ключ Пользователя на компьютере должен устанавливаться в формате неизвлекаемости закрытого ключа, в Outlook 2010 при проверке настроек, должен сразу показываться какой сертификат и какой алгоритм используется, что у Вас в этих окнах?
Проверьте и напишите результат.
Да, я Жук, три пары лапок и фасеточные глаза :))
Про надстройку спасибо, проверю . несколько вопросов.
>Выполните переустановку ViPNet, с отключением установки его криптопровайдера.
а как же будет работать деловая почта випнета, да и мало ли понадобиться подписать в деловой почте випнетовским сертификатом?
>Закрытый ключ Пользователя на компьютере должен устанавливаться в формате неизвлекаемости закрытого ключа, в Outlook 2010 при проверке настроек, должен сразу показываться какой сертификат и какой алгоритм используется, что у Вас в этих окнах?
В Outlook сразу показывается корректный сертификат и алгоритмы. А зачем отключать экспорт закрытого ключа? По умолчанию распространяется сертификат пользовательский как раз с возможностью экспорта.
Вот и проверьте, какой Сертификат и с каким алгоритмом, устанавливается в Outlook по умолчанию.
Отключение экспорта закрытого ключа при его установке, снимает риск компрометации закрытого ключа Сертификата.
Вам выдаётся ключевой pfx-файл, содержащий закрытый ключ с возможностью его экспорта только для двух случаев:
1. Установка Личного Сертификата на компьютер;
2. Восстановление Личного Сертификата на компьютере.
Оригинал ключевого pfx-файла должен храниться отдельно и в защищённом месте .
Далее, в используемом Вами ViPNet, скорее всего используется ЭЦП ГОСТ, для правильной работы которой требуется соответствующий криптопровайдер и надстройка работающие по ГОСТ. В Outlook, как и в других программах Office, в этом случае, необходимо правильно выполнять подписание Сообщения, Документов.
Напишите Ваш пошаговый порядок подписания Сообщения Пользователем Outlook. Так как при установке первым Сертификатом, Сертификат ГОСТ, у Пользователя и будет выдаваться ошибка. Эта же ошибка будет выдаваться при использовании по умолчанию учётной записи электронной почты, не соответствующей ЭЦП.
Да, я Жук, три пары лапок и фасеточные глаза :))
Вот и проверьте, какой Сертификат и с каким алгоритмом, устанавливается в Outlook по умолчанию.
Отключение экспорта закрытого ключа при его установке, снимает риск компрометации закрытого ключа Сертификата.
Вам выдаётся ключевой pfx-файл, содержащий закрытый ключ с возможностью его экспорта только для двух случаев:
1. Установка Личного Сертификата на компьютер;
2. Восстановление Личного Сертификата на компьютере.
Оригинал ключевого pfx-файла должен храниться отдельно и в защищённом месте .
Далее, в используемом Вами ViPNet, скорее всего используется ЭЦП ГОСТ, для правильной работы которой требуется соответствующий криптопровайдер и надстройка работающие по ГОСТ. В Outlook, как и в других программах Office, в этом случае, необходимо правильно выполнять подписание Сообщения, Документов.
Напишите Ваш пошаговый порядок подписания Сообщения Пользователем Outlook. Так как при установке первым Сертификатом, Сертификат ГОСТ, у Пользователя и будет выдаваться ошибка. Эта же ошибка будет выдаваться при использовании по умолчанию учётной записи электронной почты, не соответствующей ЭЦП.
Да, я Жук, три пары лапок и фасеточные глаза :))
Проверил, что по умолчанию ставится нужный сертификат с правильным алгоритмом — sha-1, rsa (эо первым делом проверял). Однако ошибка все равно есть.
попробую установку без випнетовского криптопровайдера и с надстройками outlook поиграться.
Источник