Работа с сокетами ошибка не работает bitrixvm

comp55

Поиск по этому блогу

Битрикс: ошибка работы с сокетами

Ошибка работы с сокетами выявляется в BitrixVM при запуске инструмента «Проверка системы»:

Сообщения об этом будет выведено в нескольких разделах теста:

Осуществляется сетевое подключение с веб-сервера к самому себе. Это необходимо чтобы проверить работу сетевых функций, а также требуется для ряда последующих тестов.

А значит, если этот базовый тест не отработал, то дальнейшие тесты, где требуется создание независимого php процесса, не могут быть произведены.

Обычно проблема возникает, если подключение запрещено фаерволом, доступ к административной части запрещен по IP или для входа на сайт требуется HTTP/NTLM авторизация. На этапе тестирования необходимо отключить эти ограничения.

Подробности в журнале проверки системы.

В журнале будет следующая информация:

где IP 9. 114:80 — внешний IP адрес BitrixVM сервера.

Если доступ к серверу ограничен фаерволом, а подключение происходит только по IP-адресу (домен не привязан), то ошибка работы с сокетами исправляется следующим образом:

  • Проверяется корректность настройки DNS-сервера(ров) в панели управления виртуальной машиной (т.е. у VPS-провайдера);
  • Проверяется корректность настройки DNS-сервера(ров) на BitrixVM;
  • К серверу привязывается доменное имя;
  • Административная панель открывается по домену и тест запускается повторно.

HWADDR=00:51:52:09:05:01
NAME=eth3
GATEWAY=192.168.1.1
DEVICE=eth3
ONBOOT=yes
USERCTL=no
BOOTPROTO=static
NETMASK=255.255.255.0
IPADDR=192.168.1.2
#DNS1=192.168.1.1
#PEERDNS=yes
DNS1=8.8.8.8
DNS2=8.8.4.4
check_link_down() <
return 1;
>

Источник

Ошибка работы с сокетами

В инструментах запустил проверку системы. После завершения проверки, отображается ошибка работы с сокетами «Ошибка! Не работает».
В логе проверки вот такое выдает:

Цитата
Александр Гусев написал:
My_site.eu — в логах так и пишется?
Цитата
Scrooge написал:
домен наверно еще не знает про новый сервер?
Цитата
Scrooge написал:
Если на сайт через hosts заходите, то будет писать эту ошибку, как домен делегируете, ошибка сама исчезнет
Цитата
Александр Гусев написал:
значит покопайте, почему 404 для /bitrix/admin/site_checker.php

Особенно подчеркну предложение Александра. Кроме 404 и 302 ошибка бывает Советую внимательно посмотреть логи и какой ответ сервера. Вот на фото подчеркнуто красным. Чуть ниже надписи Работа с сокетами (check_socket): Fail . Долго искал в поисковике bitrix socket error , нашел интересную и подробную статью Bitrix. Исправляем ошибку «Работа с сокетами — Ошибка! , чтобы сформулировать правильное задание ТЗ , а то вовсе без техподдержки решить проблему после » Полного тестирования системы» /bitrix/admin/site_checker.php?lang=ru

У меня другая ошибка была, неправильный redirect Но суть в том, что эта проблема с сокетом. может быть причиной значительного увеличения нагрузки на сервер.. (фото ДО и после ))
Очень рад что есть такой полезный инструмент «Проверка системы», он позволяет не создавать лишней работы по оптимизация скриптов и вообще избежать много другого страшного гемора, например потерянные ссылки на сайте.

Цитата
Александр Гусев написал:
значит покопайте, почему 404 для /bitrix/admin/site_checker.php

Особенно подчеркну предложение Александра. Кроме 404 и 302 ошибка бывает Советую внимательно посмотреть логи и какой ответ сервера. Вот на фото подчеркнуто красным. Чуть ниже надписи Работа с сокетами (check_socket): Fail . Долго искал в поисковике bitrix socket error , нашел интересную и подробную статью Bitrix. Исправляем ошибку «Работа с сокетами — Ошибка! , чтобы сформулировать правильное задание ТЗ , а то вовсе без техподдержки решить проблему после » Полного тестирования системы» /bitrix/admin/site_checker.php?lang=ru

У меня другая ошибка была, неправильный redirect Но суть в том, что эта проблема с сокетом. может быть причиной значительного увеличения нагрузки на сервер.. (фото ДО и после ))
Очень рад что есть такой полезный инструмент «Проверка системы», он позволяет не создавать лишней работы по оптимизация скриптов и вообще избежать много другого страшного гемора, например потерянные ссылки на сайте.

Источник

Не удалось проверить из-за ошибки в работе с сокетами

Коллеги, помогите пожалуйста разобраться раз и навсегда, после установки коробки, при тестировании системы на ошибки вышло много ошибок связанных с сокетами. Вот скрин: https://prnt.sc/xo6dso

Не удалось проверить из-за ошибки в работе с сокетами. Как исправить данную ошибку, помогите пожалуйста научиться раз и навсегда. Благодарю!

Цитата
Александр Гусев написал:
Нажмите вопрос и в открывшемся окне нажмите «журнал ошибок» или что-то в этом роде, там расшифровка ошибок идёт

Я смотрел, исходя из того что написано там, я так и не понял что конкретно требуется сделать.

Осуществляется сетевое подключение с веб-сервера к самому себе. Это необходимо чтобы проверить работу сетевых функций, а также требуется для ряда последующих тестов.

А значит, если этот базовый тест не отработал, то дальнейшие тесты, где требуется создание независимого php процесса, не могут быть произведены.

Обычно проблема возникает, если подключение запрещено фаерволом, доступ к административной части запрещен по IP или для входа на сайт требуется HTTP/NTLM авторизация. На этапе тестирования необходимо отключить эти ограничения.

А в журнале ошибок написано:

2021-Jan-26 21:53:49 Работа с сокетами (check_socket): Fail Connection to 176.120.203.37:80 Fail Socket error [111]: Connection refused Ошибка! Не работает

Источник

Ошибка проверки сайта Работа с сокетами — Socket error [111]: Connection refused

в файле /etc/hosts пропишите
127.0.0.1 _ВАШ_ДОМЕН_

Битрикс то ли по текущему урлу (по которому заходите) пытается законнектиться, то ли по домену сайта.
Вообщем помогает выше написанное

Посмотрите лог проверки (что-то типа /home/bitrix/www/bitrix/site_checker_d64fb2e3f5834fc1af5d853 ­77f2c3f3c.log). В нем будет написано куда пытается подключиться скрипт:

2013-Feb-25 06:49:58 Работа с сокетами (check_socket): Fail
Connection to 123.456.789.123:80
Socket error [110]: Connection refused

В моем случае проблема была в том, что заказчик предоставил только адрес шлюза 123.456.789.123, а на нем пробросил порт 80 на хост с виртуалкой. А виртуалка ничего не знала про этот IP.

В своем локальном файле c:\Windows\System32\drivers\etc\hosts я добавил запись:
80.66.94.230 portal.localdom

А на виртуалке добавил /etc/hosts имя portal.localdom
127.0.0.1 localhost.localdom localhost localhost portal.localdom

После этого проверка сокетов прошла успешно.

Еще одна причина возникновения данной ошибки:
На сайте стоит http-авторизация через утилиту passwd и .htaccess в вышележащей папке.

Соответственно, после того, как убираем из .htaccess в папке «..»
AuthName «Private zone»
AuthType Basic
AuthUserFile .htpasswd
require valid-user

Проверка сайта проходит успешно!

У меня вот какая проблема.

При проверке системы (Рабочий стол-> Настройки-> Инструменты-> Проверка системы) происходит следующее:

Если в .htaccess в корне сайта закомментирована строка php_value mbstring.internal_encoding UTF-8, то (как и следует ожидать) выводится ошибка:

Ошибка! Сайт работает в UTF кодировке, настройки mbstring:
mbstring.func_overload=2
mbstring.internal_encoding=
требуется:
mbstring.func_overload=2
mbstring.internal_encoding=utf-8

если мы раскомментируем строку, то сообщение об ошибке кодировки не выводится, но выводится другая ошибка:
Работа с сокетами — Ошибка! Не работает

Смотрим журнал проверки. Ситуация следующая (обращаю внимание — домен кириллический):

Когда не указана кодировка utf-8, то в журнале имеется запись:
2013-Dec-19 15:25:56 Работа с сокетами (check_socket): Ok
Connection to xn——dlcdhdea0afa5acqdcd1cjk8r.xn--p1ai:80 Success

Как только мы в .htaccess указываем mbstring.internal_encoding utf-8, то в журнале просто нет хоста, к которому проверяется подключение:
2013-Dec-19 15:34:42 Работа с сокетами (check_socket): Fail
Connection to :80 Fail
Socket error [0]: php_network_getaddresses: getaddrinfo failed: Name or service not known

>Connection to xn——dlcdhdea0afa5acqdcd1cjk8r.xn--p1ai:80 Success

>Connection to :80 Fail

т.е. система не видит адреса, к которому нужно подключаться.
____________________________________________________________ ­

Есть подозрение, что проблема в кириллическом домене, т.к. на этой площадке стоят еще две системы и ничего похожего там не происходит, тестирование проходит успешно.

Источник

Работа с сокетами (check_socket): Fail Connection to ssl://mysite.net:443 Fail

Подскажите какие действия необходимо произвести, чтобы получить доступ по ssl и устранить данную ошибку (на облаке всё работало замечательно)!

p/s ВСЕМ + к карме за любое содействие и дельный совет!

Цитата
Дмитрий Василевский написал:
Добрый день!

Подскажите какие действия необходимо произвести, чтобы получить доступ по ssl и устранить данную ошибку (на облаке всё работало замечательно)!

p/s ВСЕМ + к карме за любое содействие и дельный совет!

У нас версия 5.6. В этой версии появилось требование для работы сайта по https протоколу. Сертификат должен быть указан в php:
http://php.net/manual/en/migration56.openssl.php

p/s Только ещё где именно и что прописывать.

Цитата
Дмитрий Василевский написал:
ua6em , открыт

У нас версия 5.6. В этой версии появилось требование для работы сайта по https протоколу. Сертификат должен быть указан в php:
http://php.net/manual/en/migration56.openssl.php

p/s Только ещё где именно и что прописывать.

в связке апач + инжинкс за «сертификаты» отвечает последний
Делаем как тут — http://dev.1c-bitrix.ru/support/forum/forum32/topic51594/
Туда же положить промежуточный и корневой сертификаты

Сайты с SSL требуют выделенного IP .
Правда есть расширение SNI , которое снимает техническое ограничение в сертификат на 1 ip. Новые операционные системы и новые браузеры с ним отлично работают, но вот с поддержкой старого софта все не так хорошо. Centos 5 и RHEL5 поставляются с openssl-0.9.8e и как следствие не смогут включить поддержку SNI для nginx или apache. WindowsXP еще активно используется а для него поддержки SNI не было и не будет. Еще android 2.x не дружит с SNI. Работать все будет частично.

Цитата
Дмитрий Василевский написал:
ua6em , СПАСИБО! 1,5 недели мучались. были близко. но ты помог дойти до цели.

2 часа гугления ни к чему не привела. В основном люди жалуются на VMBitrix, у меня VDS, сертификат от lets encrypt установлен корректно, через панель управления VestaCP.

в консоли curl https://svetlii-dom.ru:443 выдает исходный код сайта

почему битрикс пытается подключиться по ssl?

Цитата
Александр Косарев написал:
кто нибудь победил проблему?
Цитата
Александр Косарев написал:
кто нибудь победил проблему?

отвечу сам себе, была проблема с цепочкой сетрификата

Цитата
Антон Пашков написал:
Такая же проблема была с цепочкой сертификатов на виртуальной машине битрикс
Цитата
Центр сертификации предоставляет не просто сертификат — на деле это цепочка сертификатов (CA Bundle), каждое звено которой работает на повышение доверия конечного пользователя.
Цитата
ACHTUNG.
Т.к. Битрикс24-CRM (та что на 12 пользователей) имеет свою вирт. машину (которая устанавливается при разворачивании портала), интерфейс отличается от стандартного интерфейса Bitrix VM.
Будьте внимательны. Ниже инструкция для Битрикс24-CRM

Т.к. данный топик посвящен проблеме с уже установленным SSL-сертификатом, то предполагаем, что он уже установлен.
Как установить SSL-сертификат см. как установить SSL- сертификат
Шаг 1. копируем файл с цепочкой в туже директорию, где и лежит сертификат
для CentOS 7: /etc/nginx/ssl/ИМЯ_ДОМЕНА_com.ca
Шаг 2. Входим на сервер через SSH (putty)
Шаг 3. Запускаем интерфейс BitrixVM: /root/menu.sh
Шаг 4. Выбираем Manage pool web servers : 5

Шаг 5. Выбираем Configure certificates : 2

Шаг 6. Выбираем Configure own certificate : 2

Шаг 7. Отвечаем на запросы системы:

Шаг 8. Проверяем корректность установки сертификата, через SSL-checker

Источник

Читайте также:  Почему не работает приборка ваз 2110 инжектор 8 клапанов
Оцените статью