- Как сделать редирект 404 ошибки
- Что такое ошибка 404
- Возможные последствия для сайта
- Рекомендации по созданию страницы 404
- Примеры страниц с ошибкой 404
- Как создать страницу ошибки 404 и настроить редирект на нее в .htaccess
- Редирект с 404 на главную (не рекомендуется)
- Проверка редиректа 404
- Яндекс.Вебмастер
- Google Search Console
- Ошибка «Сайт выполнил переадресацию слишком много раз»
- Причина возникновения ошибки
- Сайт выполнил переадресацию слишком много раз или ERR TOO MANY REDIRECTS: как исправить
- ERR TOO MANY REDIRECTS: что делать, если я владелец сайта
- Что делать, если я пользователь
- Редирект через .htaccess
- В каких случаях подойдет .htaccess-редирект
- Для чего нужен 301-й редирект
- Как сделать редирект через .htaccess
Как сделать редирект 404 ошибки
Посетители сайта видят 404 ошибку, если страница, на которую они пытаются перейти, не существует или по какой-то причине сервер не может её найти. В статье рассмотрим, что это за ошибка и какое влияние она оказывает на поведенческие факторы пользователей и SEO. А также разберем, как настроить редирект 404 ошибки через .htaccess.
Что такое ошибка 404
Ошибка 404 (File not found) возникает, когда сервер не может найти запрашиваемую пользователем страницу. От ее появления не застрахован ни один сайт. Достаточно ввести в адресной строке после домена рандомный набор символов. Например:
Сервер не сможет найти страницу, и отобразится ошибка:
Ошибка 404 на сайте reg.ru
Также с ошибкой 404 можно столкнуться в следующих случаях:
- Администратор сайта удалил или переместил страницу, но не сделал редирект на актуальный материал.
- Изменилась структура сайта, а у страниц остались старые URL.
- Посетитель опечатался в адресе, когда вводил его вручную.
- Посетитель перешел по «битой» ссылке, которая ведет на несуществующую (удаленную или перемещенную) страницу.
Технически ошибка 404 связана с тем, что при открытии страницы браузер пользователя отправляет серверу запрос на контент, а сервер не находит запрашиваемой страницы и возвращает соответствующий ответ: не найдено.
Код 404 не стоит путать с другими похожими ошибками. Например, 403-й, которая означает, что доступ к ресурсу ограничен или запрещен. Подробнее о том, как ее исправить в статье.
Иногда при загрузке несуществующей страницы браузер получает ответ 200 вместо 404. Такой случай называют Ложной ошибкой (Soft 404). Он означает, что со страницей всё в порядке, хотя пользователь видит ошибку. Также проблема заключается в том, что Яндекс и Google показывают эту страницу в результатах поиска. Чтобы проверить код ошибки, воспользуйтесь проверкой URL от Google.
Наличие ложных ошибок негативно сказывается на SEO-продвижении и затрудняет видимость основного контента сайта. Чтобы это исправить, нужно вручную настроить редирект на страницу с ошибкой 404 для всех несуществующих страниц.
Возможные последствия для сайта
В самом наличии ошибок 404 на сайте нет ничего страшного. Как уже говорилось выше, посетитель может просто опечататься в адресе. Однако разработчику сайта стоит уделить внимание созданию и отладке страницы ошибки 404. О том, как это сделать, мы расскажем ниже.
Также важно следить за тем, чтобы на сайте было как можно меньше несуществующих страниц, битых ссылок и т. п. Чтобы отыскать их, можно воспользоваться веб-инструментами Яндекс и Google или другими сервисами. Найдите все, что нужно поправить, настройте 301-й редирект на актуальные материалы и замените некорректные ссылки.
Если на сайте регулярно встречается ошибка 404, это может повлиять на поведение посетителей. Пользователи, которые многократно видят сообщение о том, что страница не существует/не найдена, с большой вероятностью покинут сайт и уйдут к конкурентам.
Рекомендации по созданию страницы 404
Если сайт создавался в CMS WordPress, Joomla, Drupal и т. п., в нем, скорее всего, предусмотрена страница ошибки 404. Но она может быть неинформативной или отличаться от дизайна остальных страниц вашего веб-ресурса.
Лучше всего — создать свою страницу для ошибки 404. Если вы владеете навыками верстки и дизайна, можно сделать эту страницу красивой, шуточной и необычной. Это хорошо воспринимается пользователями и снижает негативный эффект.
Важно, чтобы страница была информативной и полезной:
- Объясните, что случилось и почему пользователю попалась ошибка;
- Посоветуйте, что пользователю стоит сделать, чтобы найти интересующий его контент;
- Оставьте каналы для связи и возможность связаться с поддержкой сайта.
Яндекс рекомендует оформлять страницу ошибки 404 так, чтобы она отличалась от остальных страниц сайта и содержала ссылку на главную страницу, поисковую строку и инструкцию с дальнейшими действиями.
Примеры страниц с ошибкой 404
СберМаркет предлагает познать мудрость котов и цены на сайте
404 ошибка в разделе «Помощь» на сайте REG.RU
Как создать страницу ошибки 404 и настроить редирект на нее в .htaccess
Создайте страницу одним из следующих способов:
Если вы знаете HTML и CSS, напишите код страницы самостоятельно и загрузите файл с названием 404.html в корневую папку сайта.
Если навыков верстки нет, в интернете можно найти бесплатные шаблоны со страницами ошибки. Скачайте файл и добавьте его в корневую папку.
Если вы используете WordPress, воспользуйтесь плагином 404page — your smart custom 404 error page по инструкции ниже. Обратите внимание! Если вы воспользовались плагином, вам не нужно прописывать путь к файлу в .htaccess.
1) Откройте админку вашего сайта в WordPress.
2) Перейдите в раздел «Плагины» и нажмите Добавить новый.
3) В строке поиска введите название 404page — your smart custom 404 error page.
4) Нажмите Установить → Активировать:
5) Перейдите в раздел Внешний вид → 404 Error Page.
6) Выберите в списке Sample Page, чтобы сменить стандартную страницу ошибки, и нажмите Edit Page:
7) Создайте страницу в открывшемся визуальном редакторе и нажмите Обновить:
Готово! После обновления страница будет использоваться автоматически.
Откройте конфигурационный файл .htaccess в корневой папке вашего сайта и добавьте в него строку:
Где вместо site.ru — домен вашего сайта.
Готово! Теперь при возникновении 404 ошибки, в браузере пользователей будет открываться созданная вами кастомная страница.
Также рекомендуется закрыть служебную страницу 404 от индексации, чтобы она не возникала в поисковой выдаче вместе с остальными страницами сайта. Для этого откройте файл robots.txt в корневой папке сайта, добавьте соответствующую команду и сохраните изменения:
Редирект с 404 на главную (не рекомендуется)
Чтобы не создавать отдельную страницу ошибки 404, некоторые веб-разработчики прописывают в .htaccess редирект на главную страницу сайта. Это нежелательно делать с точки зрения SEO-оптимизации.
Также редирект на главную страницу может ввести пользователей в заблуждение. Представьте, что вместо искомой страницы у посетителя открывается главный экран сайта. Будет непонятно, почему это произошло, ведь пользователь искал какой-то конкретный контент и не узнает, что не сможет найти его.
Рекомендуется использовать специальные страницы для ошибки 404.
Проверка редиректа 404
Проверить, корректно ли все настроено можно в Яндекс.Вебмастер и Google Search Console.
Яндекс.Вебмастер
Если вы используете его впервые, укажите домен вашего сайта и пройдите проверку валидации, добавив файл в корневую папку сайта. Это займет несколько минут.
В коде статуса HTTP должно отображаться 404 Not Found:
Google Search Console
Если вы используете этот инструмент впервые, укажите свой домен и пройдите валидацию, добавив TXT-запись/загрузив файл в корневую папку сайта или с помощью других способов.
На сайте небольшого объема можно самостоятельно следить за наличием ошибок и постараться не допускать того, чтобы на нём было много страниц, утративших актуальность. Своевременно настраивайте 301 редиректы, когда статья в справке, страница или товар теряют актуальность.
Источник
Ошибка «Сайт выполнил переадресацию слишком много раз»
Причина возникновения ошибки
Сайт, на который не установлен сертификат безопасности, работает по незащищённому протоколу HTTP. URL такого сайта выглядит так: http://your_site.ru. Чтобы сайт работал по защищённому соединению, нужно приобрести SSL-сертификат. Подробнее о HTTP читайте в статье Для чего необходим SSL-сертификат.
При установке сертификата ваш сайт становится доступен по безопасному протоколу HTTPS и URL выглядит так: https://your_site.ru. Однако одной покупки и установки SSL-сертификата недостаточно. По умолчанию сайт по-прежнему открывается по протоколу HTTP. Чтобы ваш сайт начал работать по HTTPS, необходимо настроить редирект с HTTP на HTTPS.
Вариантов сделать редирект несколько. Всё зависит от платформы, на которой сделан сайт. Проще всего сделать редирект на WordPress с помощью плагинов. Если сайт самописный, редиректы устанавливают через конфигурационные файлы .htaccess или web.config. Также можно использовать инструмент для добавления редиректа в панели управления хостингом. Все перечисленные способы вы можете найти в разделе Редиректы.
Если редирект был сделан неправильно, у пользователя может возникнуть циклическая переадресация, которая приводит к ошибке. Как это происходит? При настройке редиректа вы задаёте перенаправление http://your_site.ru —> https://your_site.ru. Если при этом в CMS или на сайте задан параметр открывать сайт строго по протоколу http, возникает замкнутый цикл: http://your_site.ru —> https://your_site.ru —>http://your_site.ru —> https://your_site.ru>… Сервер фиксирует слишком большое количество переадресаций и выдаёт ошибку ERR_TOO_MANY_REDIRECTS.
Сайт выполнил переадресацию слишком много раз или ERR TOO MANY REDIRECTS: как исправить
Как правило, ошибка переадресации вызвана проблемами на сервере, на котором находится сайт, и исправить её может только владелец ресурса. Однако, если вы пользователь и в течение нескольких дней проблема на сайте сохраняется, вам также стоит выполнить некоторые действия на своём устройстве. Ниже мы расскажем об исправлении ошибки и со стороны владельца и со стороны пользователя.
ERR TOO MANY REDIRECTS: что делать, если я владелец сайта
Подумайте, какие действия вы делали с сайтом за последнее время. Вернитесь к старой версии сайта, – если ошибка пропала, значит, новые настройки были некорректны.
Проверьте настройки HTTPS. Часто ошибка ERR_TOO_MANY_REDIRECTS появляется при неправильной настройке переадресации HTTP на HTTPS. Правильно ли вы настроили редирект, можно проверить по инструкциям:
Проверьте, не влияют ли на работу сайта плагины. Иногда плагины нарушают работу сервера и могут появляться различные ошибки, в том числе и TOO MANY REDIRECTS 310. Отключите по очереди каждый плагин или переименуйте папку plugins в каталоге файлов вашего сайта на любое другое название. Если сайт заработает, удалите плагин-виновник.
Если у вас кириллический домен, проверьте, как в настройках WordPress указан ваш домен. Кириллические домены хоть и удобны в использовании, однако они не соответствуют UNICODE-системе, поэтому для них создали Punycode. Именно в этой форме нужно добавлять название сайта во все настройки. Чтобы перевести кириллический домен в Punycode, используйте конвертер. Например, ваш сайт дачник.ру. В формате Punycode он будет выглядеть xn--80ahnin3d.xn--p1ag.
Ошибка в конфигурационном файле. Каждая CMS имеет собственный конфигурационный файл, который использует индивидуальные правила для перенаправления. Описать все способы исправления этой ошибки невозможно. Вы можете проверить все добавленные правила переадресации и устранить конфликт, обратившись за помощью к разработчикам сайта или на тематические форумы по используемой CMS. Также вам может помочь замена текущего файла .htaccess на стандартный для используемой вами CMS. Если вы используете WordPress или Joomla, можете добавить некоторые записи в конфигурационные записи по одной из инструкций ниже.
Для исправления ошибки в CMS WordPress hosting добавьте в конфигурационный файл wp-config.php, который размещён в корневой директории вашего сайта, строки:
Для решения этой проблемы на VPS и выделенных серверах добавьте в httpd.conf (конфигурационный файл Apache) строку:
Чтобы изменения вступили в силу, перезапустите веб-сервер Apache.
Для исправления ошибки в CMS Joomla в конфигурационный файл .htaccess после строки RewriteEngine On добавьте:
Что делать, если я пользователь
- Откройте сайт в другом браузере. Если ошибка сохраняется, значит есть проблема с сервером и восстановить доступ к сайту может только владелец. Если сайт загружается, значит проблема со стороны вашего устройства. Выполните шаги описанные ниже.
- Очистите cookies и кэш браузера. Временные файлы сохраняют данные посещённых сайтов, чтобы в дальнейшем не тратить время на обращение к серверу, а использовать информацию с устройства. Несмотря на пользу временных файлов, бывает, что они мешают показать новую версию сайта. Если на веб-ресурсе была ошибка и владелец её исправил, пользователь может не увидеть новый вариант. Чтобы браузер обратился к серверу сайта, а не к временным данным, очистите кеш и cookies браузера.
Проверьте расширения в браузере. Они могут влиять на связь браузера и сервера. Отключите недавно установленные расширения. Если сайт заработал, расширение придётся удалить.
В правом верхнем углу нажмите на три точки. В выпадающем списке нажмите Настройки:
В левом меню нажмите Расширения:
Чтобы отключить расширение, переведите переключатель влево. Если хотите удалить, нажмите Удалить:
Чаще всего проблема на стороне владельца ресурса и пользователь может только подождать, пока разработчики исправят ошибку на сервере.
Источник
Редирект через .htaccess
Редирект можно настроить разными способами: в панели управления хостингом, через код HTML, через PHP, с помощью web.config, через .htaccess, а также другими способами. Рассмотрим, в чём особенность редиректа через .htaccess и как настроить 301-й .htaccess-редирект с одной страницы на другую, а также Bitrix redirect.
Если вы ещё не знаете, зачем нужно перенаправление страниц сайта, читайте нашу статью Что такое редирект.
В каких случаях подойдет .htaccess-редирект
Чтобы понять, для каких целей лучше подходит .htaccess-редирект, разберёмся, что такое .htaccess.
.htaccess — этот системный файл, который принадлежит корневой структуре сайта. В отличие от главного конфигурационного файла, который позволяет выполнять настройку веб-сервера в целом, .htaccess даёт возможность изменять настройки для отдельно взятых папок и пользователей.
Файл .htaccess позволяет вариативно настроить сайт. Действие команд из .htaccess распространяется на папки и подкаталоги, расположенные в одной директории с этим файлом. Если для какой-либо вложенной директории нужны иные инструкции, в ней также можно создать .htaccess. Если .htaccess расположен в корневой директории сервера, его действие распространяется на весь сервер, кроме тех директорий, где находится другой файл .htaccess.
Таким образом, через .htaccess можно сделать перенаправление точечно, а не сразу для всего ресурса. Этот вариант отлично подойдет в том случае, если вам нужно настроить переадресацию только для одной или нескольких страниц сайта.
Для чего нужен 301-й редирект
Помимо разных способов настройки переадресации, существуют разные виды редиректов. Каждый из них имеет своё кодовое название. Основные виды:
- 300 — сообщает, что по искомому запросу можно перейти не на одну, а на несколько альтернативных страниц;
- 301 — постоянный;
- 302 — временный;
- 303 — на схожую по тематике страницу;
- 305 — отсылающий к подключению через прокси-сервер.
Также существуют 304-й, 306-й и 307-й редиректы. Однако сейчас эти виды практически никто не использует. Один из самых популярных видов — это 301-й.
301-й редирект (Moved Permanently) — это постоянный редирект. Используется для перемещения страницы на новый URL-адрес насовсем. Когда поисковые системы встречают страницу с редиректом 301, они «понимают», что теперь необходимо индексировать новую страницу, а старую можно полностью исключить из индексации. Если настроить переадресацию 301 некорректно, на странице будет отображаться ошибка 404. Индексация страниц с ошибками приводит к снижению SEO-показателей всего веб-ресурса.
Как сделать редирект через .htaccess
Чтобы сделать перенаправление 301 через .htaccess, перейдите в каталог сайта и откройте .htaccess. Если файла ещё не существует, создайте его. После этого добавьте в файл строки кода из подходящей инструкции ниже.
1С-Битрикс — популярная CMS в которой время от времени необходимо настраивать перенаправление.
- Если вы хотите переадресовать домен с WWW на без WWW, укажите:
Где www.site.ru — домен, с которого происходит редирект, а site.ru — домен, на который происходит редирект.
- Если вам нужно сделать редирект Bitrix с домена без WWW на WWW, введите комбинацию:
Где www. — домен, с которого происходит редирект, а www. — домен, на который происходит редирект.
- Если вы хотите настроить в Битрикс редирект на другую страницу с http:// на https://, пропишите:
В файл .htaccess, который находится в папке сайта, с которого необходимо сделать переадресацию, добавьте следующие строки:
- old-site.ru — домен, с которого происходит редирект;
- new-site.ru — домен, на который происходит редирект.
Добавьте в .htaccess следующие строки:
Где site.ru — имя вашего домена.
Добавьте в .htaccess следующие строки:
Где site.ru — имя вашего домена.
Добавьте в .htaccess следующие строки:
Где site.ru — имя вашего домена.
Добавьте в .htaccess следующие строки:
Где site.ru — имя вашего домена.
Добавьте в .htaccess код из нужного вам примера ниже:
- Для всех страниц с http:// на https://
Для всех страниц с http:// на https://, в том числе и с http://www на https://
Если первый вариант не поможет, воспользуйтесь вторым вариантом:
Если все варианты не помогли и возникает циклическая переадресация:
Источник