Smtp yandex com 465 не работает

Инструкции по настройке почты на Yandex

Общие правила

Вы можете получать и отсылать почту не только через веб-интерфейс, но и с помощью различных почтовых клиентов. Например:

Если вы хотите получать почту с помощью ваших почтовых клиентов, включите работу протоколов POP3 или IMAP .

Чтобы это сделать, зайдите в Настройки вашего почтового ящике на Яндексе, откройте раздел «Почтовые программы». Выберите протокол, который хотите использовать, отметив его флажком. Сохраните результат, нажав на кнопку «Сохранить изменения».

Подробнее о работе протоколов POP3 и IMAP читайте ниже.

Настройка по протоколу IMAP

По протоколу IMAP почтовая программа будет не просто скачивать новые письма, а синхронизировать информацию на вашем компьютере с данными на сервере, отображая сразу всю структуру вашего ящика — все папки, как стандартные, так и настроенные вами вручную.

Для настройки почтового клиента по протоколу IMAP, укажите следующие данные:

  • в разделе Входящие сообщения/Incoming mail (IMAP) нужно указать адрес почтового сервера imap.yandex.ru, установить SSL-защиту и порт 993. Если ваша программа по каким-то причинам не поддерживает SSL-защиту соединения, вы можете указать порт 143 и подключаться без SSL
  • в разделе Исходящие сообщения/Outgoing mail (SMTP) необходимо указать адрес сервера smtp.yandex.ru, и подключаться по безопасному соединению SSL через порт 465. В случае, если вы не можете воспользоваться безопасным соединением, вы можете подключиться к SMTP-серверу по портам 25 или 587

При настройке почтовых программ в качестве логина и пароля для доступа к почтовому серверу нужно указать ваши логин и пароль на Яндексе. В качестве логина нужно указывать полный адрес почтового ящика.

Мы не рекомендуем использовать почтовый сервер вашего провайдера для отправки почты от вашего имени на Яндексе.

Поддержка протокола IMAP включится автоматически при первой авторизации в почтовой программе.

Настройка по протоколу POP3

При использовании протокола POP3 все ваши письма (из тех папок, которые вы укажете в Настройках ящика) будут скачиваться почтовой программой на ваш компьютер в папку «Входящие», после чего их можно будет при необходимости разложить по папкам с помощью фильтров, настроенных в самой почтовой программе.

Имейте ввиду, что многие почтовые программы по умолчанию удаляют письма с сервера при скачивании. В этом случае все письма в вашем ящике будут перемещаться в папку «Удаленные», откуда будут удалены по прошествии недели. Чтобы сохранить письма в ящике, вы можете установить в настройках почтовой программы опцию сохранения копий писем на сервере при скачивании, если ваша программа позволяет это сделать. Произвести эту настройку с нашей стороны невозможно.

Читайте также:  Не могу настроить райд

При настройке почтовой программы по протоколу POP3 необходимо указать следующие данные:

  • в разделе Входящие сообщения/Incoming mail (POP3) нужно указать адрес почтового сервера pop.yandex.ru, установить SSL-защиту и порт 995. Если ваша программа по каким-то причинам не поддерживает SSL-защиту соединения, вы можете указать порт 110 и подключаться без SSL
  • в разделе Исходящие сообщения/Outgoing mail (SMTP) необходимо указать адрес сервера smtp.yandex.ru, и подключаться по безопасному соединению SSL через порт 465. В случае, если вы не можете воспользоваться безопасным соединением, вы можете подключиться к SMTP-серверу по портам 25 или 587

При настройке почтовых программ в качестве логина и пароля для доступа к почтовому серверу нужно указать ваши логин и пароль на Яндексе. В случае, если вы настраиваете доступ к ящику вида login@yandex.ru , логином является первая часть адреса — login. Если же вы пользуетесь Яндекс.Почтой для доменов, в качестве логина нужно указывать полный адрес почтового ящика.

Мы не рекомендуем использовать почтовый сервер вашего провайдера для отправки почты от вашего имени на Яндексе.

Если вы скачиваете почту при помощи почтового клиента по протоколу POP3, вы можете:

  • Оставить все настройки по умолчанию. Тогда будут скачиваться письма только из папки Входящие.
  • Настроить скачивание писем из любого набора папок, включая папку Спам или собственные папки. Выбрать папки для скачивания можно на странице «Настройки» — в разделе «Почтовые клиенты». Также вы можете установить настройку «При получении почты по POP3, письма в почтовом ящике Яндекс.Почты помечать как прочитанные», которая уже в веб-интерфейсе позволит понять, какие письма были забраны почтовым клиентом. При скачивании почты клиентами письма по умолчанию не помечаются как прочитанные.

О доступе в вашу почту через почтовые программы вы можете прочитать в следующих статьях:

Источник

OTRS.ru

Русскоязычное сообщество OTRS Helpdesk и OTRS ITSM

  • Темы без ответов
  • Активные темы
  • Поиск
  • Наша команда

smtp.yandex.ru не отправляет почту. [Решено]

Модератор: ykolesnikov

smtp.yandex.ru не отправляет почту. [Решено]

Сообщение alegator2222 » 04 окт 2018, 11:27

Re: Проблема сбора почты с yandex

Сообщение alegator2222 » 04 окт 2018, 14:21

Re: Проблема сбора почты с yandex

Сообщение alexus » 04 окт 2018, 19:24

С уважением,
Алексей Юсов

Prod: OTRS CE ITSM 6.0.28 on CentOS 7 Apache 2.4 MariaDB 10.4.13 + Radiant Customer Portal

Re: Проблема сбора почты с yandex

Сообщение alegator2222 » 05 окт 2018, 10:15

Принято спасибо, с получением почты разобрался, если кому интересно — Почта → Все настройки → Почтовые программы Там указать из каких папок забирать письма.
Не работает исходящая почта.
Передача сообщения не удалась. [04.10.2018 07:39] Can’t connect to smtp.yandex.ru: !
SendmailModule Kernel::System::Email::SMTP
SendmailModule::Host smtp.yandex.ru
SendmailModule::Port 465

В логе-
There was an error executing Execute() in Kernel::System::Console::Command::Maint::Email::MailQueue: Error: Message sending already in progress! Skipping.

Re: smtp.yandex.ru не отправляет почту.

Сообщение MArsMax » 10 окт 2018, 14:12

Похожая проблема (только с использованием внутреннего SMTP): исходящие письма помещаются в очередь «на отправку», но никуда из неё не уходят. Из ssh-консоли при этом сообщения, сформированные вручную, отправляются нормально.
В web-админке эти письма отображаются в разделе «Открытые сеансы связи»
Если через консоль почтовую очередь почистить принудительно — в админке они переходят в «Неудачные сеансы связи».
При попытке принудительной отправки из консоли (sudo -u otrs /opt/otrs/bin/otrs.Console.pl Maint::Email::MailQueue —send —force) выдаёт ошибку «Error: Message sending already in progress! Skipping. «. Очень странный получается «progress» — без какого-либо движения

Читайте также:  Сначала необходимо настроить блокировку экрана

Входящая почта при этом работает без проблем.

Re: smtp.yandex.ru не отправляет почту.

Сообщение alexus » 10 окт 2018, 17:47

С уважением,
Алексей Юсов

Prod: OTRS CE ITSM 6.0.28 on CentOS 7 Apache 2.4 MariaDB 10.4.13 + Radiant Customer Portal

Re: smtp.yandex.ru не отправляет почту.

Сообщение alegator2222 » 11 окт 2018, 15:38

SendmailModule——Kernel::System::Email::SMTP
SendmailModule::AuthUse——support@ipb01.ru
SendmailModule::Host————-smtp.yandex.ru
SendmailModule::Port—————465
Домен делегирован яндексу.
С support@ipb01.ru письма забираются нормально и заявки тоже создаются, но не отправляются.

Вот что в консоли-

715||2| support@ipb01.ru | HelpDesk@ipb01.ru | 2018-10-11 14:55:43 | -| Can’t connect to smtp.yandex.ru: ! |
716||2| support@ipb01.ru | HelpDesk@ipb01.ru | 2018-10-11 14:57:15 | -| Can’t connect to smtp.yandex.ru: ! |
717||2| support@ipb01.ru | HelpDesk@ipb01.ru | 2018-10-11 14:58:47 | -| Can’t connect to smtp.yandex.ru: ! |

Re: smtp.yandex.ru не отправляет почту.

Сообщение alegator2222 » 11 окт 2018, 15:56

Re: smtp.yandex.ru не отправляет почту.

Сообщение alexus » 11 окт 2018, 20:11

С уважением,
Алексей Юсов

Prod: OTRS CE ITSM 6.0.28 on CentOS 7 Apache 2.4 MariaDB 10.4.13 + Radiant Customer Portal

Re: smtp.yandex.ru не отправляет почту.

Сообщение alegator2222 » 12 окт 2018, 12:20

Re: smtp.yandex.ru не отправляет почту.

Сообщение led » 13 окт 2018, 08:36

Re: smtp.yandex.ru не отправляет почту.

Сообщение alegator2222 » 15 окт 2018, 11:07

Пробовал все три протокола, SMTP, SMTPS, SMTPTLS, безуспешно. Приложу логи, может по ним что то понятно. Повторюсь, сбор почты идет штатно, а вот отправка не происходит.

OTRS-otrs.Console.pl-Maint::Email::MailQueue-10 There was an error executing Execute() in Kernel::System::Console::Command::Maint::Email::MailQueue: [Mon Oct 15 11:05:07 2018] otrs.Daemon.pl: using SSL support of Net::SMTP 3.10 instead of SSLGlue at /opt/otrs/Kernel/cpan-lib/Net/SSLGlue/SMTP.pm line 12.

OTRS-otrs.Console.pl-Maint::Email::MailQueue-10 CommunicationLog(ID:9114,AccountType:-,AccountID:-,Direction:Outgoing,Transport:Email,ObjectLogType:Message,ObjectLogID:16082)::Kernel::System::MailQueue => Permanent sending problem or we reached the sending attempt limit. Message will be removed

OTRS-otrs.Console.pl-Maint::Email::MailQueue-10 CommunicationLog(ID:9114,AccountType:-,AccountID:-,Direction:Outgoing,Transport:Email,ObjectLogType:Message,ObjectLogID:16082)::Kernel::System::MailQueue => Message could not be sent! Error message: SMTP authentication failed: 535, 5.7.8 Error: authentication failed: Invalid user or password!

OTRS-otrs.Console.pl-Maint::Email::MailQueue-10 CommunicationLog(ID:9114,AccountType:-,AccountID:-,Direction:Outgoing,Transport:Email,ObjectLogType:Message,ObjectLogID:16082)::Kernel::System::Email => Error sending message using backend ‘Kernel::System::Email::SMTPS’.

OTRS-otrs.Console.pl-Maint::Email::MailQueue-10 CommunicationLog(ID:9114,AccountType:-,AccountID:-,Direction:Outgoing,Transport:Email,ObjectLogType:Connection,ObjectLogID:16083)::Kernel::System::Email::SMTP => SMTP authentication failed (SMTP code: 535, ErrorMessage: 535, 5.7.8 Error: authentication failed: Invalid user or password!

Использую пароль приложений, который генерируется в настройках почты.

Re: smtp.yandex.ru не отправляет почту.

Сообщение led » 15 окт 2018, 16:14

Возможно, у Вас в очереди сообщения, которые блокируют отправку.
Посмотрите, что находится в очереди:
shell> su otrs
shell> cd /opt/otrs/
shell> bin/otrs.Console.pl Maint::Email::MailQueue –list

Удалите ID сообщений, которые могут блокировать отправку, или, проще, удалите всю очередь:
shell> bin/otrs.Console.pl Maint::Email::MailQueue —delete-all

После этого отправьте новое письмо.
Для отправки через порт TCP/465 используйте SMTPS в SendmailModule.

Если эти действия не помогут, Вам нужно включать в OTRS дебаг обмена с почтовым сервером и смотреть в логах, почему не уходит почта.

Источник

Как исправить ошибки SMTP-сервера при отправке писем

Будучи менеджером коммерческого отдела небольшой торговой компании, я выполнял задачу по отправке нескольких сотен писем постоянным и потенциальным клиентам. Базу формировали из открытых источников мы сами, предложение было реально интересным целевой аудитории. Возникла «неожиданная» проблема – часть писем стала возвращаться. Кроме того, начали приходить сообщения с указаниями кодов ошибки SMTP. Своего IT-специалиста в штате у нас не было, потому разобраться с проблемой я решил самостоятельно. О результатах этой работы, причинах возникновения таких ошибок и методах их решения расскажу в этой статье.

Читайте также:  Как починить вилку ноутбука

Как избежать ошибок при составлении и отправке писем

Причинами возникновения ошибок и, как следствие, неполучения сообщений могут служить разные факторы. Одни из них связаны с неправильным составлением исходящих писем самим пользователем, другие относятся к более глобальным программным настройкам со стороны получателя.

Самый простой способ это понять – отправить тестовое сообщение на свой ящик. Затем следует протестировать его отправку и получение, используя разные внешние почтовые сервисы: gmail, yandex, mail, rambler и другие. Если сообщение получено, следует ответить на него, проверив корректность исполнения команды «RE» вашим почтовым сервером и принятие ответа условным отправителем.

Довольно часто проблемы с попаданием писем в папку «Спам» или программной блокировкой на стороне получателя лежат в неверном оформлении ключевых полей. Особенно это касается массовых рассылок коммерческого характера. Для отправки большого количества однотипных сообщений как минимум потребуется выполнение следующих параметров настройки:

  • выделенный IP-адрес с целью исключить блокировку на стороне сервера-ретранслятора или почтовой программы конечного получателя;
  • криптографические подписи DKIM и SPF, помогающие подтвердить подлинность домена и минимизировать количество писем, воспринимаемых как спам.

Некорректное использование бота для отправки писем может привести к блокировке отправителя и другим нежелательным последствиям. Даже если информация, которую вы отправляете потенциальным клиентам, реально интересна им, система спам-фильтрации может воспринять данную рассылку как вредоносную. Чтобы избежать этого, лучше всего воспользоваться услугами специализированных компаний.

Положительные и отрицательные сообщения SMTP-сервера

SMTP (Simple Mail Transfer Protocol) — это протокол, используемый большинством почтовых программ для отправки электронных сообщений в сети интернет. Некорректное взаимодействие между серверами, индивидуальные настройки на уровне программного обеспечения и многие другие причины приводят к появлению ошибок. В этом случае письма не доходят до получателей, возвращаются обратно или просто «пропадают». При возникновении таких ситуаций отправитель получает сообщение о наличии конкретной ошибки, отражающей SMTP-код последнего отклика сервера.

Данные коды являются трехзначными, каждая его часть несет в себе определенную информацию, расшифровывающую причину сбоя.

Первая цифра комбинации содержит информацию о качестве доставки:

  • сообщение доставлено («SMTP OK»);
  • возникла неизвестная или временная проблема («SMTP unknown»);
  • критическая ошибка («SMTP error»).

Существует четыре варианта значений для первой цифры кода:

  • 2xx – положительный результат, есть возможность передачи следующей команды;
  • 3xx – отложенный результат, необходимо осуществление дополнительных действий;
  • 4xx – сообщение не принято, но проблема носит временный характер, и запрос может быть повторен через какое-то время;
  • 5xx – категорический отказ выполнения команды, отправка запроса со стороны передающего сервера в том же виде невозможна.

Вторая цифра в коде сообщает о категории ответа:

  • 0 – синтаксические ошибки;
  • 1 – ответы на запросы информации;
  • 2 – ошибки канала передачи;
  • 3 и 4 – неизвестный тип ошибки;
  • 5 – статус почтовой системы.

Третья цифра дает более расширенную информацию о значении, указанном во второй цифре SMTP-ответа.

Помимо цифровой комбинации, SMTP-сообщение может содержать дополнительную текстовую информацию.

Полную информацию о кодах, их компоновке и значениях можно найти в спецификациях RFC 5321 и RFC 1893.

Источник

Оцените статью