Visual studio code не работает отладка

Содержание
  1. Не работает отладчик в Visual Studio Code
  2. Не работает отладка в Visual Studio Code (по F5) после установки двух версий Python
  3. Ошибки удаленной отладки и их устранение
  4. Запуск удаленного отладчика в качестве администратора
  5. Запуск удаленного отладчика как службы
  6. Запуск удаленного отладчика как приложения (обычный режим)
  7. Ошибка: не удается запустить отладку на веб-сервере
  8. Что такое подробное сообщение об ошибке?
  9. В IIS не указан веб-сайт, соответствующий URL-адресу запуска
  10. Веб-сервер настроен неправильно
  11. Не удалось подключиться к веб-серверу
  12. Веб-сервер не ответил вовремя
  13. Вероятно, монитор удаленной отладки Microsoft Visual Studio (msvsmon.exe) не запущен на удаленном компьютере
  14. Удаленный сервер вернул ошибку
  15. Не удалось запустить отладку ASP.NET
  16. Отладчику не удалось подключиться к удаленному компьютеру
  17. Сведения об общих ошибках конфигурации см. в справке. Дополнительные сведения могут быть получены при выполнении веб-страницы вне отладчика.
  18. Операция не поддерживается. Неизвестная ошибка: номер ошибки
  19. Проверьте конфигурацию IIS
  20. Другие причины
  21. Дополнительные действия по устранению неполадок

Не работает отладчик в Visual Studio Code

Пару дней вожусь с одной проблемой: при нажатии F5 / Ctrl+F5, VS Code сообщает мне, что
«Процесс адаптера отладки неожиданно завершился».

В значении переменной среды Path написано: C:\MinGW\bin;C:\MinGW\msys\1.0\bin;

Установленные расширения для VS Code:
C/C++ for Visual Studio Code
C++ Intellisense

Подскажите, пожалуйста, как разрешить эту проблему.

P.S. Не кидайтесь только помидорами, если подобная тема есть, ибо двухдневный поиск решения ни к чему не привел.

Помощь в написании контрольных, курсовых и дипломных работ здесь.

Как запустить отладчик в Visual Studio Code?
И так, столкнулся с проблемой как запустить отладчик в Visual Studio Code?

Не работает отладка в Visual Studio Code
Здравствуйте! Я программирую в Visual Studio Code под Linux Ubuntu 15.04 . Написала текст.

Зачем для создания формы на Angular использовать Visual Studio и Visual Studio Code?
Мне нужно написать форму на ангуляре, которая будет выполнять Select, Insert,Delete из базы данных.

Не работает отладка в Visual Studio Code (по F5) после установки двух версий Python
Всем привет. Возникла необходимость установить версию Python 3.7.2(x64)(на диск E:\) на рабочее.

Чем отличается Visual Studio Community и Visual Studio Code?
в чем разница Visual Studio Code или Visual Studio Community. Описание на англиском где я полный.

В VS Code не работает отладчик
Подскажите пожалуйста как настроить отладчик в VS Code? Мне все время пишет ошибку «Атрибут.

Debian 9 Visual Studio Code С++ нужно настроить VS Code
Доброго времени суток, скажите пожалуйста как настроить в VS Code Path при работе с C++.

Code First с БД PostgreSQL в Visual Studio Code на Linux
Здравствуйте! Возникла проблема с подключением к БД PostgreSQL, обо всем по порядку: Стоит.

Источник

Не работает отладка в Visual Studio Code (по F5) после установки двух версий Python

Возникла необходимость установить версию Python 3.7.2(x64)(на диск E:\) на рабочее место, где уже была версия Python 3.6.4(x86) (на диске C:\).

ОС: Windows 7 Professional (x64)
Visual Studio Code — далее VSC — 1.31.2 Полные данные:

После установки VSC «подцепил» и новую версию 3.7.2(x64), в списке выбора интерпретаторов версия также появилась.
Всё работало некоторое время исправно, потом началось: при закрытии и запуске VSC стало появляется сообщение о необходимости выбрать интерпретатор и установить pylint:

Удалил Python 3.6.4(x86), который был на диске C:\.
В настройках рабочей области VSC явно указывается, какую версию интерпретатора использовать:

VSC стал определять единственную оставшуюся на ПК версию:

После требования выбрать интерпретатор и установить pylint прекратились, но появилась следующая странная проблема: VSC перестал запускать любые сценарии в режиме отладки (F5).
После нажатия клавиши VSC, задумывается, но никаких данных о системных переменных не выводит, после второго нажатия — ничего.
Короткий видеоролик: https://yadi.sk/i/nRG9VGRtFgy3RQ

Читайте также:  Яндекс маркет настроить уведомления

При этом режим запуска сценария в VSC «Начать без отладки» (Ctrl + F5) прекрасно работает.
Короткий видеоролик: https://yadi.sk/i/zt-raI4sDoYSUw

Поиск на англоязычных форумах внятного ответа не дал.
Шесть дней назад задал вопрос на русскоязычном stackoverflow — к сожалению, никто так и не дал ответа на запрос.
Без F5 работать довольно трудно: ни тебе данных переменных, ни точек остановок.
Если кто-то сталкивался с такой ситуацией — буду рад помощи.

Помощь в написании контрольных, курсовых и дипломных работ здесь.

Источник

Ошибки удаленной отладки и их устранение

Во время удаленной отладки возможны перечисленные ниже ошибки.

Запуск удаленного отладчика в качестве администратора

Если удаленный отладчик запускается не от имени администратора, могут возникнуть проблемы. Например, возможна следующая ошибка: «У удаленного отладчика Visual Studio(MSVSMON.EXE) недостаточно привилегий для отладки этого процесса». При запуске удаленного отладчика в качестве приложения (а не службы) может возникнуть ошибка, связанная с использованием другой учетной записи пользователя.

Запуск удаленного отладчика как службы

При запуске удаленного отладчика в качестве службы рекомендуется запускать его от имени администратора по нескольким причинам.

Служба удаленного отладчика допускает подключения только от администраторов, поэтому при запуске от имени администратора не будет дополнительных рисков безопасности.

Могут предотвращаться ошибки, возникающие, когда у пользователя Visual Studio больше прав на отладку процесса, чем у самого удаленного отладчика.

Это позволяет упростить установку и настройку удаленного отладчика.

Хотя вы можете выполнять отладку, не запуская удаленный отладчик от имени администратора, для этого необходимо соблюсти ряд требований, которые часто требуют дополнительных шагов по настройке службы.

Учетная запись, используемая на удаленном компьютере, должна иметь право на вход в качестве службы. См. инструкции в разделе «Настройка входа в качестве службы» статьи с описанием ошибки Не удается подключиться.

Учетная запись должна иметь права на отладку целевого процесса. Чтобы получить эти права, необходимо запустить удаленный отладчик с той же учетной записью, что и отлаживаемый процесс. (Проще запустить службу от имени администратора.)

Учетная запись должна иметь возможность подключения к компьютеру Visual Studio по сети (то есть проверки подлинности на этом компьютере). В домене выполнить подключение проще, если удаленный отладчик выполняется со встроенной учетной записью локальной системы или сетевой службы либо с учетной записью домена. Встроенные учетные записи имеют повышенные права безопасности, из-за чего могут возникать риски для безопасности.

Запуск удаленного отладчика как приложения (обычный режим)

При попытке присоединиться к собственному процессу без повышенных привилегий (например, к обычному приложению) не имеет значения, выполняется ли удаленный отладчик от имени администратора или нет.

Удаленный отладчик желательно запускать от имени администратора в нескольких сценариях:

Необходимо присоединиться к процессу, запущенному от имени другого пользователя (например, при отладке IIS).

Вы пытаетесь запустить другой процесс от имени администратора.

Если вы хотите запустить другой процесс не от имени администратора, запускать отладчик от имени администратора не требуется.

Источник

Ошибка: не удается запустить отладку на веб-сервере

При попытке выполнить отладку приложения, запущенного на веб-сервере, может появиться следующее сообщение об ошибке: Unable to start debugging on the Web server .

Часто эта ошибка возникает из-за того, что какая-то ошибка или изменение конфигурации требуют обновления ваших пулов приложений, сброса IIS или выполнения обоих этих действий. Чтобы выполнить сброс IIS, в командной строке с повышенными привилегиями введите команду iisreset .

Что такое подробное сообщение об ошибке?

Сообщение Unable to start debugging on the Web server является универсальным. Обычно строка ошибки содержит более конкретное сообщение, которое может помочь вам определить причину проблемы или подобрать более подходящее исправление. Вот несколько самых распространенных сообщений об ошибках, добавляемых к основному сообщению об ошибке.

В IIS не указан веб-сайт, соответствующий URL-адресу запуска

Перезапустите Visual Studio от имени администратора и повторите запуск отладки. (Некоторые сценарии отладки ASP.NET требуют повышенных привилегий.)

Читайте также:  Не работает фогейм лаунчер

Можно настроить Visual Studio на запуск от имени администратора в любой ситуации. Для этого щелкните значок ярлыка Visual Studio правой кнопкой мыши и выберите Свойства > Дополнительно > Всегда запускать от имени администратора.

Веб-сервер настроен неправильно

Не удалось подключиться к веб-серверу

Вы запускаете Visual Studio и веб-сервер на одном компьютере и выполняете отладку, нажимая клавишу F5 (а не с помощью команды Присоединиться к процессу)? Откройте свойства проекта и убедитесь, что в настройках проекта указан правильный веб-сервер и URL-адрес запуска. (Откройте Свойства > Веб > Серверы или Свойства > Отладка в зависимости от типа проекта. Для проекта веб-форм откройте Страницы свойств > Параметры запуска > Сервер.)

Если это не так, перезапустите пул приложений, а затем выполните сброс IIS. Дополнительные сведения см. в статье Проверка конфигурации IIS.

Веб-сервер не ответил вовремя

  • Выполните сброс IIS и повторите запуск отладки. К процессу IIS может быть подключено сразу несколько экземпляров отладчика. Сброс завершит их работу. Дополнительные сведения см. в статье Проверка конфигурации IIS.

Вероятно, монитор удаленной отладки Microsoft Visual Studio (msvsmon.exe) не запущен на удаленном компьютере

  • Если отладка выполняется на удаленном компьютере, убедитесь, что у вас установлен и выполняется удаленный отладчик. Если в сообщении упоминается брандмауэр, убедитесь, что соответствующие порты в брандмауэре открыты, особенно если используется сторонний брандмауэр.
  • Если вы используете файл HOSTS, убедитесь, что он настроен правильно. Например, если отладка запускается нажатием клавиши F5 (а не с помощью команды Присоединиться к процессу), в файле HOSTS должен быть указан тот же URL-адрес проекта, что и в свойствах проекта (Свойства > Веб > Серверы или Свойства > Отладка в зависимости от типа проекта).

Удаленный сервер вернул ошибку

Проверьте, не содержит ли файл журнала IIS подкоды ошибок и дополнительные сведения, и изучите эту запись блога IIS 7.

Некоторые распространенные коды ошибок и рекомендации также приводятся ниже.

  • (403) Запрещено. Эта ошибка может возникать по разным причинам, поэтому проверьте файл журнала и параметры безопасности IIS для веб-сайта. Убедитесь, что элемент compilation в файле web.config сервера имеет значение debug=true . Убедитесь, что папка веб-приложения имеет необходимые разрешения, а конфигурация пула приложений верна (возможно, изменился пароль). См. раздел Проверка конфигурации IIS. Если эти параметры верны и отладка выполняется локально, также убедитесь, что вы подключаетесь к серверу правильного типа и по верному URL-адресу (см. Свойства > Веб > Серверы или Свойства > Отладка в зависимости от типа проекта).
  • (503) Сервер недоступен. Возможно, пул приложений остановился из-за ошибки или изменения конфигурации. Перезапустите пул приложений.
  • (404) Не найдено. Убедитесь, что для пула приложений задана верная версия ASP.NET.

Не удалось запустить отладку ASP.NET

  • Перезапустите пул приложений и выполните сброс IIS. Дополнительные сведения см. в статье Проверка конфигурации IIS.
  • Если выполняется переопределение URL-адресов, протестируйте базовый файл web.config без переопределения URL-адресов. См. примечание о модуле переопределения URL-адресов в разделе Проверка конфигурации IIS.

Отладчику не удалось подключиться к удаленному компьютеру

Если выполняется локальная отладка, откройте свойства проекта в Visual Studio и убедитесь, что в настройках проект указан правильный веб-сервер и URL-адрес для подключения. (Откройте Свойства > Веб > Серверы или Свойства > Отладка в зависимости от типа проекта.)

Эта ошибка может возникать при локальной отладке из-за того, что Visual Studio является 32-разрядным приложением, поэтому для отладки 64-разрядных приложений используется 64-разрядная версия удаленного отладчика. Проверьте пул приложений в IIS и убедитесь, что параметр Включать 32-разрядные приложения имеет значение true , выполните сброс IIS и запустите отладку еще раз.

Также, если вы используете файл HOSTS, убедитесь, что он настроен правильно. Например, в файле HOSTS должен быть указан тот же URL-адрес проекта, что и в свойствах проекта (Свойства > Веб > Серверы или Свойства > Отладка в зависимости от типа проекта).

Читайте также:  Как настроить индификатор гугл

Сведения об общих ошибках конфигурации см. в справке. Дополнительные сведения могут быть получены при выполнении веб-страницы вне отладчика.

Вы запускаете Visual Studio и веб-сервер на одном компьютере? Откройте свойства проекта и убедитесь, что в настройках проекта указан правильный веб-сервер и URL-адрес запуска. (Откройте Свойства > Веб > Серверы или Свойства > Отладка в зависимости от типа проекта.)

Если это не поможет или отладка выполняется удаленно, выполните действия, описанные в разделе Проверка конфигурации IIS.

Операция не поддерживается. Неизвестная ошибка: номер ошибки

Если выполняется переопределение URL-адресов, протестируйте базовый файл web.config без переопределения URL-адресов. См. примечание о модуле переопределения URL-адресов в разделе Проверка конфигурации IIS.

Проверьте конфигурацию IIS

Прежде чем запускать отладку повторно после выполнения описанных здесь шагов по решению проблемы, возможно, придется также выполнить сброс IIS. Для этого в командной строке с повышенными привилегиями введите команду iisreset .

Остановите и перезапустите пулы приложений IIS, а затем попробуйте еще раз.

Возможно, пул приложений остановился в результате ошибки. Кроме того, остановка и перезапуск пула приложений могут потребоваться из-за другого изменения, внесенного вами в конфигурацию.

Если пул приложений продолжает останавливаться, удалите модель переопределения URL-адресов через панель управления и установите ее повторно с помощью установщика веб-платформы (WebPI). Эта проблема может возникать после значительного обновления системы.

Проверьте конфигурацию пула приложений, исправьте ее при необходимости и попробуйте еще раз.

Пул приложений может быть настроен для версии ASP.NET, которая не соответствует проекту Visual Studio. Обновите версию ASP.NET в пуле приложений и перезапустите его. Дополнительные сведения см. в разделе IIS 8.0 — использование ASP.NET 3.5 и ASP.NET 4.5.

Кроме того, если учетные данные изменились, возможно, нужно обновить их в пуле приложений или на веб-сайте. В пуле приложений для обновления учетных данных выберите Дополнительные параметры > Модель процессов > Удостоверение. Для обновления учетных данных на веб-сайте выберите Основные параметры > Подключиться как. Перезапустите пул приложений.

Убедитесь, что папка веб-приложения имеет нужные разрешения.

Убедитесь, что вы предоставили IIS_IUSRS, IUSR или пользователю, связанному с пулом приложений, права на чтение и выполнение файлов в папке веб-приложения. Устраните проблему и перезапустите пул приложений.

Убедитесь, что в IIS установлена правильная версия ASP.NET.

Описанная проблема может быть вызвана несовпадением версий ASP.NET в IIS и в проекте Visual Studio. Возможно, потребуется задать версию платформы в файле web.config. Чтобы установить ASP.NET в IIS, используйте установщик веб-платформы (WebPI). См. также разделы IIS 8.0 — использование ASP.NET 3.5 и ASP.NET 4.5 или Размещение в Windows с помощью IIS (для ASP.NET Core).

Устраните ошибки проверки подлинности, если используется только IP-адрес

По умолчанию предполагается, что IP-адреса являются частью Интернет-зоны, и проверка подлинности NTLM для них не выполняется. Если настройки веб-сайта в IIS требуют обязательной проверки подлинности, проверка подлинности завершается ошибкой. Чтобы решить эту проблему, укажите вместо IP-адреса имя удаленного компьютера.

Другие причины

Если проблема не в конфигурации IIS, попробуйте выполнить следующие действия.

Перезапустите Visual Studio с правами администратора и попробуйте еще раз.

Некоторые сценарии отладки ASP.NET, такие как применение веб-развертывания, требуют повышенных привилегий для Visual Studio.

Если выполняются сразу несколько экземпляров Visual Studio, откройте проект в другом экземпляре Visual Studio (с правами администратора) и попробуйте еще раз.

Если вы используете файл HOSTS с локальными адресами, попробуйте использовать вместо IP-адреса компьютера петлевой адрес.

Если вы не используете локальные адрес, убедитесь, что в файле HOSTS должен быть указан тот же URL-адрес проекта, что и в свойствах проекта (Свойства > Веб > Серверы или Свойства > Отладка в зависимости от типа проекта).

Дополнительные действия по устранению неполадок

Откройте страницу localhost в браузере на сервере.

Источник

Оцените статью