WordPress не работает rewriterule

WordPress.org

Русский

Не работает редирект

Всем привет!
Нужно настроить редирект с olcisport.ru на olimpciti.ru
В файле .htaccess прописан редирект до меня, но он не работает. Подскажите, что нужно поправить в .htaccess, чтобы заработал редирект?

Страница, с которой нужна помощь: [войдите, чтобы увидеть ссылку]

А показать ваш .htaccess не хотите, который нужно поправить?

Не могу прикрепить файл

# BEGIN All In One WP Security
#AIOWPS_BLOCK_WP_FILE_ACCESS_START

Require all denied

Order deny,allow
Deny from all

Require all denied

Order deny,allow
Deny from all

Require all denied

Order deny,allow
Deny from all

#AIOWPS_BLOCK_WP_FILE_ACCESS_END
#AIOWPS_BASIC_HTACCESS_RULES_START

Require all denied

Order deny,allow
Deny from all

ServerSignature Off
LimitRequestBody 10240000

Require all denied

Order deny,allow
Deny from all

#AIOWPS_BASIC_HTACCESS_RULES_END
#AIOWPS_PINGBACK_HTACCESS_RULES_START

Require all denied

Order deny,allow
Deny from all

#AIOWPS_PINGBACK_HTACCESS_RULES_END
#AIOWPS_DEBUG_LOG_BLOCK_HTACCESS_RULES_START

Require all denied

Order deny,allow
Deny from all

#AIOWPS_DEBUG_LOG_BLOCK_HTACCESS_RULES_END
#AIOWPS_DISABLE_INDEX_VIEWS_START
Options -Indexes
#AIOWPS_DISABLE_INDEX_VIEWS_END
#AIOWPS_DISABLE_TRACE_TRACK_START

RewriteEngine On
RewriteCond % ^(TRACE|TRACK)
RewriteRule .* — [F]

#AIOWPS_DISABLE_TRACE_TRACK_END
#AIOWPS_FORBID_PROXY_COMMENTS_START

RewriteEngine On
RewriteCond % ^POST
RewriteCond % !^$ [OR]
RewriteCond % !^$ [OR]
RewriteCond % !^$ [OR]
RewriteCond % !^$ [OR]
RewriteCond % !^$ [OR]
RewriteCond % !^$ [OR]
RewriteCond % !^$ [OR]
RewriteCond % !^$ [OR]
RewriteCond % !^$
RewriteRule wp-comments-post\.php — [F]

#AIOWPS_FORBID_PROXY_COMMENTS_END
#AIOWPS_DENY_BAD_QUERY_STRINGS_START

RewriteEngine On
RewriteCond % ftp: [NC,OR]
RewriteCond % http: [NC,OR]
RewriteCond % https: [NC,OR]
RewriteCond % mosConfig [NC,OR]
RewriteCond % ^.*(globals|encode|localhost|loopback).* [NC,OR]
RewriteCond % (\;|’|\»|%22).*(request|insert|union|declare|drop) [NC]
RewriteRule ^(.*)$ — [F,L]

#AIOWPS_DENY_BAD_QUERY_STRINGS_END
#AIOWPS_ADVANCED_CHAR_STRING_FILTER_START

RedirectMatch 403 \,
RedirectMatch 403 \:
RedirectMatch 403 \;
RedirectMatch 403 \=
RedirectMatch 403 \[
RedirectMatch 403 \]
RedirectMatch 403 \^
RedirectMatch 403 \`

RedirectMatch 403 \ <
RedirectMatch 403 \>
RedirectMatch 403 \

RedirectMatch 403 \»
RedirectMatch 403 \$
RedirectMatch 403 \
RedirectMatch 403 \|
RedirectMatch 403 \.\.
RedirectMatch 403 \%0
RedirectMatch 403 \%A
RedirectMatch 403 \%B
RedirectMatch 403 \%C
RedirectMatch 403 \%D
RedirectMatch 403 \%E
RedirectMatch 403 \%F
RedirectMatch 403 \%22
RedirectMatch 403 \%27
RedirectMatch 403 \%28
RedirectMatch 403 \%29
RedirectMatch 403 \%3C
RedirectMatch 403 \%3E
RedirectMatch 403 \%3F
RedirectMatch 403 \%5B
RedirectMatch 403 \%5C
RedirectMatch 403 \%5D
RedirectMatch 403 \%7B
RedirectMatch 403 \%7C
RedirectMatch 403 \%7D
# COMMON PATTERNS
Redirectmatch 403 \_vpi
RedirectMatch 403 \.inc
Redirectmatch 403 xAou6
Redirectmatch 403 db\_name
Redirectmatch 403 select\(
Redirectmatch 403 convert\(
Redirectmatch 403 \/query\/
RedirectMatch 403 ImpEvData
Redirectmatch 403 \.XMLHTTP
Redirectmatch 403 proxydeny
RedirectMatch 403 function\.
Redirectmatch 403 remoteFile
Redirectmatch 403 servername
Redirectmatch 403 \&rptmode\=
Redirectmatch 403 sys\_cpanel
RedirectMatch 403 db\_connect
RedirectMatch 403 doeditconfig
RedirectMatch 403 check\_proxy
Redirectmatch 403 system\_user
Redirectmatch 403 \/\(null\)\/
Redirectmatch 403 clientrequest
Redirectmatch 403 option\_value
RedirectMatch 403 ref\.outcontrol
# SPECIFIC EXPLOITS
RedirectMatch 403 errors\.
RedirectMatch 403 config\.
RedirectMatch 403 include\.
RedirectMatch 403 display\.
RedirectMatch 403 register\.
Redirectmatch 403 password\.
RedirectMatch 403 maincore\.
RedirectMatch 403 authorize\.
Redirectmatch 403 macromates\.
RedirectMatch 403 head\_auth\.
RedirectMatch 403 submit\_links\.
RedirectMatch 403 change\_action\.
Redirectmatch 403 com\_facileforms\/
RedirectMatch 403 admin\_db\_utilities\.
RedirectMatch 403 admin\.webring\.docs\.
Redirectmatch 403 Table\/Latest\/index\.

Читайте также:  Как настроить аирподсы чтобы касанием можно сделать паузу

#AIOWPS_ADVANCED_CHAR_STRING_FILTER_END
#AIOWPS_SIX_G_BLACKLIST_START
# 6G FIREWALL/BLACKLIST
# @ https://perishablepress.com/6g/

|`| |\|) [NC,OR]
RewriteCond % (boot\.ini|etc/passwd|self/environ) [NC,OR]
RewriteCond % (thumbs?(_editor|open)?|tim(thumb)?)\.php [NC,OR]
RewriteCond % (‘|\»)(.*)(drop|insert|md5|select|union) [NC]
RewriteRule .* — [F]

# 6G:[REQUEST METHOD]

RewriteCond % ^(connect|debug|move|put|trace|track) [NC]
RewriteRule .* — [F]

# 6G:[REFERRERS]

RewriteCond % ([a-z0-9]<2000,>) [NC,OR]
RewriteCond % (semalt.com|todaperfeita) [NC]
RewriteRule .* — [F]

# 6G:[REQUEST STRINGS]

RedirectMatch 403 (?i)([a-z0-9]<2000,>)
RedirectMatch 403 (?i)(https?|ftp|php):/
RedirectMatch 403 (?i)(base64_encode)(.*)(\()
RedirectMatch 403 (?i)(=\’|=\%27|/\’/?)\.
RedirectMatch 403 (?i)/(\$(\&)?|\*|\»|\.|,|&|&?)/?$
RedirectMatch 403 (?i)(\<0\>|\(/\(|\.\.\.|\+\+\+|\\»\\»)
RedirectMatch 403 (?i)(

|`| |:|;|,|%|\|\s|\<|\>|\[|\]|\|)
RedirectMatch 403 (?i)/(=|\$&|_mm|cgi-|etc/passwd|muieblack)
RedirectMatch 403 (?i)(&pws=0|_vti_|\(null\)|\<\$itemURL\>|echo(.*)kae|etc/passwd|eval\(|self/environ)
RedirectMatch 403 (?i)\.(aspx?|bash|bak?|cfg|cgi|dll|exe|git|hg|ini|jsp|log|mdb|out|sql|svn|swp|tar|rar|rdf)$
RedirectMatch 403 (?i)/(^$|(wp-)?config|mobiquo|phpinfo|shell|sqlpatch|thumb|thumb_editor|thumbopen|timthumb|webshell)\.php

# 6G:[USER AGENTS]

SetEnvIfNoCase User-Agent ([a-z0-9]<2000,>) bad_bot
SetEnvIfNoCase User-Agent (archive.org|binlar|casper|checkpriv|choppy|clshttp|cmsworld|diavol|dotbot|extract|feedfinder|flicky|g00g1e|harvest|heritrix|httrack|kmccrew|loader|miner|nikto|nutch|planetwork|postrank|purebot|pycurl|python|seekerspider|siclab|skygrid|sqlmap|sucker|turnit|vikspider|winhttp|xxxyy|youda|zmeu|zune) bad_bot

# Apache
Order Allow,Deny
Allow from all
Deny from env=bad_bot
#AIOWPS_IP_BLACKLIST_2_3_START
Deny from 195.154.48.0/24
Deny from 213.87.145.180
Deny from 91.210.145.0/24
Deny from 95.28.112.163
#AIOWPS_IP_BLACKLIST_2_3_END

# Apache >= 2.3

Require all Granted
Require not env bad_bot
#AIOWPS_IP_BLACKLIST_2_4_START
Require not ip 195.154.48.0/24
Require not ip 213.87.145.180
Require not ip 91.210.145.0/24
Require not ip 95.28.112.163
#AIOWPS_IP_BLACKLIST_2_4_END

#AIOWPS_SIX_G_BLACKLIST_END
#AIOWPS_FIVE_G_BLACKLIST_START
# 5G BLACKLIST/FIREWALL (2013)
# @ http://perishablepress.com/5g-blacklist-2013/

# 5G:[QUERY STRINGS]

RewriteEngine On
RewriteBase /
RewriteCond % (\»|%22).*( |%3) [NC,OR]
RewriteCond % (javascript:).*(\;) [NC,OR]
RewriteCond % ( |%3) [NC,OR]
RewriteCond % (\\|\.\./|`|=’$|=%27$) [NC,OR]
RewriteCond % (\;|’|\»|%22).*(union|select|insert|drop|update|md5|benchmark|or|and|if) [NC,OR]
RewriteCond % (base64_encode|localhost|mosconfig) [NC,OR]
RewriteCond % (boot\.ini|echo.*kae|etc/passwd) [NC,OR]
RewriteCond % (GLOBALS|REQUEST)(=|\[|%) [NC]
RewriteRule .* — [F]

# 5G:[USER AGENTS]

# SetEnvIfNoCase User-Agent ^$ keep_out
SetEnvIfNoCase User-Agent (binlar|casper|cmsworldmap|comodo|diavol|dotbot|feedfinder|flicky|ia_archiver|jakarta|kmccrew|nutch|planetwork|purebot|pycurl|skygrid|sucker|turnit|vikspider|zmeu) keep_out

Order Allow,Deny
Allow from all
Deny from env=keep_out

# 5G:[REQUEST STRINGS]

RedirectMatch 403 (https?|ftp|php)\://
RedirectMatch 403 /(https?|ima|ucp)/
RedirectMatch 403 /(Permanent|Better)$
RedirectMatch 403 (\=\\\’|\=\\%27|/\\\’/?|\)\.css\()$
RedirectMatch 403 (\,|\)\+|/\,/|\<0\>|\(/\(|\.\.\.|\+\+\+|\||\\\»\\\»)
RedirectMatch 403 \.(cgi|asp|aspx|cfg|dll|exe|jsp|mdb|sql|ini|rar)$
RedirectMatch 403 /(contac|fpw|install|pingserver|register)\.php$
RedirectMatch 403 (base64|crossdomain|localhost|wwwroot|e107\_)
RedirectMatch 403 (eval\(|\_vti\_|\(null\)|echo.*kae|config\.xml)
RedirectMatch 403 \.well\-known/host\-meta
RedirectMatch 403 /function\.array\-rand
RedirectMatch 403 \)\;\$\(this\)\.html\(
RedirectMatch 403 proc/self/environ
RedirectMatch 403 msnbot\.htm\)\.\_
RedirectMatch 403 /ref\.outcontrol
RedirectMatch 403 com\_cropimage
RedirectMatch 403 indonesia\.htm
RedirectMatch 403 \<\$itemURL\>
RedirectMatch 403 function\(\)
RedirectMatch 403 labels\.rdf
RedirectMatch 403 /playing.php
RedirectMatch 403 muieblackcat

# 5G:[REQUEST METHOD]

RewriteCond % ^(TRACE|TRACK)
RewriteRule .* — [F]

#AIOWPS_FIVE_G_BLACKLIST_END
#AIOWPS_BLOCK_SPAMBOTS_START

RewriteEngine On

RewriteCond % https://olcisport.ru
RewriteRule (.*) http://www.olimpciti.ru/$1 [R=301,L]
RewriteCond % POST
RewriteCond % ^(.*)?wp-comments-post\.php(.*)$
RewriteCond % !^http(s)?://olcisport\.ru [NC,OR]
RewriteCond % ^$
RewriteRule .* http://127.0.0.1 [L]

#AIOWPS_BLOCK_SPAMBOTS_END
#AIOWPS_PREVENT_IMAGE_HOTLINKS_START

RewriteEngine On
RewriteCond % !^$
RewriteCond % -f
RewriteCond % \.(gif|jpe?g?|png)$ [NC]
RewriteCond % !^http(s)?://olcisport\.ru [NC]
RewriteRule \.(gif|jpe?g?|png)$ — [F,NC,L]

#AIOWPS_PREVENT_IMAGE_HOTLINKS_END
# END All In One WP Security

php_flag display_startup_errors off
php_flag display_errors off
php_flag html_errors off
php_flag log_errors on
php_flag ignore_repeated_errors off
php_flag ignore_repeated_source off
php_flag report_memleaks on
php_flag track_errors on
php_value docref_root 0
php_value docref_ext 0
php_value error_log /home/a/allpatf2/olcisport.ru/public_html/PHP_errors.log
php_value error_reporting 2047
php_value log_errors_max_len 0

Читайте также:  Можно ли не работать по приказу

Order allow,deny
Deny from all
Satisfy All

# BEGIN WordPress

RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ — [L]
RewriteCond % !-f
RewriteCond % !-d
RewriteRule . /index.php [L]

# END WordPress
# Wordfence WAF

php_value auto_prepend_file ‘/home/a/allpatf2/olcisport.ru/public_html/wordfence-waf.php’

Require all denied

Order deny,allow
Deny from all

# END Wordfence WAF

  • Ответ изменён 2 года назад пользователем Yui . Причина: для оформления кода есть кнопка code

Источник

.htaccess: RewriteRule не работает, используя только значение

Я провел много исследований, чтобы решить эту проблему, но до сих пор не могу понять, почему это не сработает. Первоначально я переписал свои URL, чтобы добавить .html но я хочу изменить это и сделать их простыми без суффиксов.

Вот пример оригинальной ссылки

Я использовал правило ниже, чтобы изменить ссылку выше и добавить суффикс .HTML

RewriteRule ^([^/]*)\.html$ /artist?a=$1 [L]

Я хочу переписать оригинальную ссылку на что-то вроде этого

Я пытался использовать RewriteRule ^([^/]*)$ /artist?a=$1 [L] чтобы добиться этого, но я получаю ужасную ошибку сервера

Внутренняя ошибка сервера Сервер обнаружил внутреннюю ошибку или неверную конфигурацию и не смог выполнить ваш запрос.

Пожалуйста, свяжитесь с администратором сервера webmaster@howwe.biz и сообщите им о времени возникновения ошибки и обо всех действиях, которые вы могли совершить, возможно, вызвавших ошибку.

Дополнительная информация об этой ошибке может быть доступна в журнале ошибок сервера. Кроме того, при попытке использовать ErrorDocument для обработки запроса произошла ошибка 500 Internal Server Error.

индукционный Kenzo в URL это значение. Что странно, если я добавлю имя, которое в этом случае , оно работает. Увидеть ниже:

RewriteRule ^a/([^/]*)$ /artist?a=$1 [L] действует для http://www.howwe.biz/a/bebe-cool но мне нужно вот так http://www.howwe.biz/bebe-cool

Что я делаю не так? Ваша помощь будет высоко ценится.

Извините, если это был д-р.

Решение

Это должно работать:

RewriteRule ^([^/]*)$ /artist?a=$1 [L] не удалось, потому что он переписывает любой запрос к целевому URL безоговорочно, целевой URL совпадает с шаблоном и перезаписывает сам на себя. Ваше правило будет работать при следующих условиях:

Другие решения

Он берет все из-за последнего / до конца и добавляет его к 1 доллару.

Источник

Как отлаживать.htaccess RewriteRule не работает

у меня есть RewriteRule на .htaccess файл, который ничего не делает. Как я могу устранить эту проблему?

  • как я могу проверить, если .htaccess файл даже читается и подчиняется Apache? Могу ли я написать Эхо-сообщение «это работает», если я его напишу, где эта строка будет отражена?
  • если .htaccess файл не используется, как я могу заставить Apache использовать его?
  • если .htaccess используется, но мой RewriteRule все еще не имеет эффекта, что больше могу ли я сделать отладку?
Читайте также:  Не работает компрессор пневмоподвески мерседес w220

7 ответов:

введите некоторые ненужные значения в ваш .htaccess например, foo bar , sakjnaskljdnas любое ключевое слово, не распознанное htaccess и посетите свой URL. Если он работает, вы должны получить

500 Внутренняя Ошибка Сервера

Внутренняя Ошибка Сервера

сервер обнаружил внутреннюю ошибку или неправильной настройки и не смог выполнить ваш запрос.

я предлагаю вам поставить его вскоре после RewriteEngine on .

так как вы находитесь на вашей машине. Я предполагаю, что у вас есть доступ к Apache .

открыть .conf файл, и искать строку, похожую на:

если он прокомментирован (#), раскомментируйте и перезапустите apache.

для перезаписи журнала

поставить выше 3 строки в свой virtualhost . перезапустите httpd.

RewriteLogLevel 9 использование высокого значения для уровня замедлит ваш Apache сервер резко! Используйте перезапись файла журнала на уровне выше 2 только для отладки! Уровень 9 будет регистрировать почти каждую деталь перезаписи.

обновление

все изменилось в Apache 2.4:

The RewriteLog и RewriteLogLevel директивы были удалены. Эта функция теперь предоставляется путем настройки соответствующего уровень ведения журнала для модуля mod_rewrite с помощью LogLevel. См. также раздел лесозаготовки и mod_rewrite.

для получения дополнительной информации о LogLevel, обратитесь Директива LogLevel

ответ «введите какое-то нежелательное значение» не сделал трюк для меня, мой сайт продолжал загружаться, несмотря на введенный мусор.

Я добавил следующую строку в верхней части .файл htaccess:

это быстро даст вам знать, если .htaccess является то, что подобрали или нет. Если.htaccess используется, файлы в этой папке не будут загружаться вообще.

вообще никаких изменений .htaccess должен иметь видимые эффекты. Если нет эффекта, Проверьте свои файлы конфигурации apache, что-то вроде:

следует заменить на

и вы сможете изменить директивы .htaccess файлы.

возможно, более логичным способом было бы создать файл (например, тест.html), добавьте некоторый контент, а затем попробуйте установить его в качестве индексной страницы:

для большей части .правило htaccess переопределит конфигурацию Apache, где работает на уровне каталога / файла

если у вас есть доступ к каталогу apache bin вы можете использовать,

httpd -M чтобы проверить загруженные модули.

после этого простые директивы, как Options -Indexes или deny from all будет затвердевать, что .htaccess работают правильно.

чтобы проверить правила перезаписи htaccess, просто заполните url-адрес, к которому вы применяете правила, поместите содержимое вашего htaccess в большую область ввода и нажмите кнопку «Тест».

Почему бы не положить немного мусора в вашем .htaccess файл и попробуйте перезагрузить apache. Если apache не запускается, вы знаете его работу. Удалите мусор, а затем перезагрузите apache, если он загружает поздравления, которые вы настроили .правильно реврайт.

Источник

Оцените статью