WordPress не работает загрузка

Не работает сайт на WordPress, типичные ошибки

WordPress, наверное, самая распространенная CMS в мире, но зачастую, когда сайт перестает работать, сама CMS не предоставляет никакой информации об ошибках.

Наиболее распространённые ошибки и примеры их устранения.

Белый экран смерти

Белый экран смерти [WSOD], вместо сайта отображается белый экран.

Один из вариантов решения

Включите отображение ошибок, для чего добавьте в файл wp-config.php следующую строку:

После чего на сайте должен отображаться код ошибки, обычно в коде содержится имя неработающего плагина.

Один из вариантов решения

Деактивируйте все установленные плагины, а затем включайте по одному. Если консоль управления сайтом недоступна, откройте через FTP папку wp-content/plugins и переименуйте папку, например, в wp-content/plugins_ old.

Один из вариантов решения

Увеличьте количество памяти. Для чего откройте файл wp-config.php и добавьте следующую строку:

Значение может быть любым: 64, 128 и так далее, но помните, в любом случае вы не сможете использовать памяти больше, чем предоставляется тарифным планом хостинга.

Один из вариантов решения

Ошибка в активной теме, переключитесь на стандартную тему Twenty Seventeen; если админпанель сайта недоступна, то через FTP измените папку с темой Twenty Seventeen на название активной темы. Имя активной темы также придется на время поменять.

Internal server error

Внутренняя ошибка сервера, обычно возникает из-за неправильной работы скриптов.

Один из вариантов решения

Через FTP переименуйте файл . htaccess в . htaccess_ old. Перезагрузите страницу сайта и, если он заработал, сбросьте постоянные ссылки на панели управления WordPress через «Настройки» -> «Постоянные ссылки», чтобы создать новый файл .htaccess.

Ошибка установления подключения к базе данных

Один из вариантов решения

Откройте файл wp-config.php и убедитесь, что следующие данные базы данных верны: имя базы, имя пользователя, пароль и хост.

Ошибка 404

Ошибка, из-за которой пользователь не может получить доступ к одной или нескольким страниц на сайте, в то время как все остальные разделы работают нормально.

Один из вариантов решения

Перейдите в «Настройки» -> «Постоянные ссылки» на панели управления WordPress и просто нажмите кнопку «Сохранить изменения». Это обновит ваши настройки постоянных ссылок и очистит правила перезаписи. Если это не работает, вам необходимо обновить файл .htaccess вручную. Если вы не знакомы с редактированием файлов .htaccess, обратитесь к вашему хост-провайдеру и попросите его включить mod_rewrite.

Режим обслуживания после обновления

Ошибка, возникающая после обновления, с сообщением «Коротко недоступно для планового обслуживания. Вернитесь через минуту».
Как правило, причина в неудаленном файле . maintenance, удалите его из корневого раздела сайта через FTP или менеджер файлов.

Н е получается войти в панель управления (консоль)

Возможные причины

  • Вы забыли пароль, и у вас нет доступа к электронной почте для восстановления. Откройте в phpMyAdmin базу вашего сайта, найдите таблицу wp_ uers, откройте ее, в поле » Password» выберите значение MD5 и установите новый.
  • Возможно, входу мешает плагин, отключайте по очереди плагины, как это было описано выше.
  • Ошибка скриптов: включите режим отладки, как это было описано выше.
  • Сайт взломан. В этом случае можно попробовать удалить вредоносные скрипты самостоятельно либо обратится к специалистам.
Читайте также:  Как починить бачок от унитаза чтобы вода не текла постоянно

П ереадресация на странице входа в панель управления (консоль)

При попытке зайти на страницы / wp- login, / wp- admin происходит редирект на главную страницу сайта.

Возможные причины

  • Неправильные значения полей URL сайта и домашнего URL в таблице wp-config
  • Ненастроенные постоянные ссылки
  • Ошибки в .htaccess

Варианты решения

Очистите файлы cookie и кэш браузера и убедитесь, что в вашем браузере включен прием cookie.

Перезапустите браузер и попробуйте войти снова.

Деактивировать все плагины (см. предыдущие пункты).

Использовать тему по умолчанию (см. предыдущие пункты).

Удалите файл .htaccess из корневого каталога вашего сайта. (см. предыдущие пункты).

Добавьте в файл wp-config.php и добавьте эти строки (не забудьте заменить example.com собственным URL и добавить www. если вы используете этот префикс).

Б елый текст или отсутствующие иконки в редакторе

Возможные причины: проблема с объединенными файлами JavaScript, TinyMCE или плагином.

Очистить кеш браузера.

Заменить скрипты TinyMCE. Это можно сделать, заменив папку /wp-includes/js/tinymce/ новой копией.

Если ничего из вышеперечисленного не работает, откройте файл wp-config.php и добавьте следующую строку в самом верху после открывающего тега PHP.

Если ничего не помогает

Включите запись ошибок в лог сервера, как правило, подобные ошибки уже неоднократно встречались на множестве сайтов, погуглите, и в 99,9% случаев решение будет найдено.

Источник

Исправляем ошибки при загрузке картинок в WordPress (HTTP Error и др.)

Сегодня рассмотрю несколько ситуаций, когда у вас может появиться ошибка HTTP при загрузке фото в WordPress, и заодно расскажу что в этом случае делать. Данная проблема возникает сразу после клика по кнопке «Добавить медиафайл» на странице редактирования поста либо в разделе «Медиафайлов», — как только вы выбираете файл на компьютере, который хотите использовать. При этом в окне загрузчика отобразится фраза «HTTP Error».

К сожалению, Вордпресс не может самостоятельно определить в чем собственно заключается проблема, поэтому и показывает общий ответ. С другой стороны, пользователю это сообщение также ни о чем конкретном не говорит, — ему придется попробовать несколько подходов дабы найти правильное решение задачи.

Перед тем как рассмотреть чуть более оригинальные варианты, приведу парочку общих тривиальных методов решения HTTP ошибки в WordPress, которые новичкам и не только следует применить самыми первыми.

1. Проблема с хостингом

Во-первых, еще раз повторите загрузку изображения спустя несколько минут. Не исключено, что в момент первой попытки на сервере случились какие-то временные сбои.

Если глюк никуда не делся, надо выбрать какой-то другой файл для добавления: с более простым именем (без спец.символов и русских букв) или вообще не того формата (например, PNG вместо JPG).

Иногда хостеры устанавливают ограничение по весу импортируемых на сайт объектов — 2Мб, 4Мб, 8Мб и т.п. Используйте для повторного теста изображение полегче. Внимание! Это можно легко исправить увеличив максимальный размер файла загрузки.

При загрузке картинки в WordPress ошибка HTTP может возникать, когда у определенной директории хостинга нет разрешения на запись. Заходите на FTP в каталог wp-content/uploads/ и дальше смотрите права доступа у нужной вам папки.

Если у вас в WP-проекте графика размещаются по годам и месяцам, то следует проверять соответствующий адрес, например, wp-content/uploads/2018/10. Добавление файлов на сервер допускается при значении «775» / «777», тогда как «666» или «664» данную процедуру запрещают. В последних двух ситуациях просто меняете права доступа для соответствующей папки.

2. Программная проблема

Бывает, что в определенном конкретном браузере по каким-то мифическим причинам не хотят выполняться те или иные скрипты. То ли в силу старых их версий, то ли из-за установленных дополнений, но так иногда случается. Просто попробуйте другой браузер. Еще одна фишка, связанная с этим же программным обеспечением — очистка локального кэша (желательно тоже проверить).

Читайте также:  Как настроить видимость жесткого диска

Второй важный нюанс в этом «подразделе» — старая версия PHP на сервере. Вордпресс, начиная с ветки 3.2 требует минимально PHP 5.2.4. Проверьте/обновите это ПО самостоятельно или обратитесь к своему хостеру за помощью.

3. Классические Вордпресс техники

Данные «махинации» следует выполнять практически в любых проблемах с системой. Когда в WordPress во время загрузки произошла ошибка, то первым делом отключаете все сторонние плагины.

Если этот подход не сработал, то следующим шагом будет замена вашего шаблона на одну из базовых тем. Чистый WP с макетом по умолчанию и без доп.модулей должен работать корректно.

Тоже не помогло? ищем выход дальше. Более продвинутые фишки подсмотрел тут.

4. Увеличиваем memory_limit

Пункт выделил в отдельный, так как он частенько встречается — наша CMS весьма прожорлива к ресурсам.

В общем случае вам нужно подправить файл wp-config.php, находящийся в корневом каталоге хостинга. Прописываете в нем строку:

define( ‘WP_MEMORY_LIMIT’, ‘256M’ );

Думаю, значения 128M для параметра WP_MEMORY_LIMIT также будет достаточно, особенно при использовании базовых модулей/тем. Иногда данный код не срабатывает, — смотрите как еще можно увеличить PHP Memory Limit в WordPress.

5. Библиотека GD Library по умолчанию

Комплект WP CMS содержит 2 графических библиотеки для обработки картинок — ImageMagick и GD Library. За первой из них разработчики время от времени замечали HTTP ошибки при загрузке WordPress изображений, и вроде как, она более требовательная к ресурсам сервера. Поэтому есть смысл указывать инструментом по умолчанию именно второй вариант — GD Library.

Для реализации этого подхода в functions.php пишем:

6. Настройка ImageMagick через htaccess

Если включать GD Library, то дополнив немного .htaccess, у вас получится контролировать использование библиотекой ImageMagick ресурсов сервера. Находите файл в корневом каталоге и через FTP редактируете его, добавляя строку:

SetEnv MAGICK_THREAD_LIMIT 1

Этот параметр заставляет ее применять лишь один поток для обработки картинок вместо множественных подключений. Это в свою очередь может предотвратить HTTP ошибку в Вордпресс.

Если код выше не помог, попробуйте другой:

SecFilterEngine Off SecFilterScanPOST Off

# Exclude the file upload and WP CRON scripts from authentication Satisfy Any Order allow,deny Allow from all Deny from none

7. Параметр FcgidMaxRequestLen и ошибка «Обработка изображения не удалась…»

В новых версиях WordPress пользователям может встречаться проблема при загрузке изображений в медиабиблиотеку, которая сопровождается следующим сообщением: «Обработка изображения не удалась. Если это фотография или большое изображение, пожалуйста, уменьшите его до 2500 пикселей и загрузите снова.»

При этом, как видите, максимальный размер файла для загрузки позволяет добавлять любые изображения. Более того, “подопытный сайт” находился на сервере с memory_limit под 2 Гб. То есть проблемы с ресурсами хостинга исключены.

Спустя некоторое время поиска причины ошибки я наткнулся на интересную информацию с официального форума wordpress.org:

Во вкладке админки “Здоровье сайта” я увидел, что на сервере действительно было установлено расширение mod_fcgid для Apache. Поэтому решил найти и отредактировать эту проблемную настройку – FcgidMaxRequestLen.

Сложность задачи заключалась еще в том, что работал я не с «классическим хостингом», где всегда можно попросить помощи в тех.поддержке (которая бы сделала всю работу). В моем случае пришлось разбираться самостоятельно, используя панельку ISPmanager.

1. Первым делом надо было отыскать файл конфига, т.к. по указанному в скриншоте выше адресу /etc/apache2/mods-available/fcgid.conf ничего не было. Переходим в ISPmanager в раздел System – пункт File Manager. Там воспользуемся функцией поиска:

Тут два варианта – либо искать по ключу «fcgid» или попытаться найти переменную по содержимому файлов (гораздо медленнее). Предварительно важно выйти в корневую директорию сервера (пункт 2 на картинке выше) чтобы искать по всем файлам.

Читайте также:  Как настроить оператора связи мтс

2. Как только вы обнаружили нужный конфиг (у меня он находился в директории etc/httpd/conf.d/fcgid.conf дважды кликаете по нему и переходите к редактированию. Далее просто указываете значение переменной FcgidMaxRequestLen в байтах.

По умолчанию значение равно 131072, поэтому картинки выше 100 Кб и не грузились. Сделал размер чуть выше 4 Мб. Затем сохраняетесь и важно(!) перезагружаете сервер. Только после этого можно вернуться в админку и проверить все ли ок.

На этом, в принципе, все. Начинайте с самых простых подходов, приведенных в начале, а дальше уже придется переходить на более сложные. Конечно, неприятно получать ошибку HTTP при загрузке WordPress фото или картинок, но, как видите, это не критично. Кто знает еще какие-то методы? — делитесь ими ниже.

Источник

WordPress.org

Русский

Поддержка → Проблемы и решения → Перестала загружаться «главная» страница

Перестала загружаться «главная» страница

Здравствуйте, у меня вчера во время редактирования перестала загружаться «главная» страница, она не пустая, там есть контент (много), сейчас открывается пустая белая страница! Помогите пожалуйста ее восстановить. Ссылку на страницу приложила, [del]
Спасибо, очень жду.

  • Тема изменена 2 года, 9 месяцев назад пользователем SeVlad . Причина: ссылка

Страница, с которой нужна помощь: [войдите, чтобы увидеть ссылку]

Сайт загружается. долго и тяжело, но загружается

она не пустая, там есть контент (много)

открывается пустая белая страница

Здравствуйте, спасибо за ответ, но я так и не поняла что конкретно мне нужно сделать. Извините, я не программист и все что написано (по вашим ссылкам) мне не понятно. Объясните пожалуйста простым понятным языком как мне восстановить страницу? Спасибо)))))

мне не понятно. Объясните пожалуйста простым понятным языком

ищите специалиста, который вам все восстановит за денежное вознаграждение.
На всякий случай скажу еще раз: сейчас сайт открывается нормально

но я так и не поняла что конкретно мне нужно сделать.

В первую очередь оптимизировать графику. Это лучше делать на локальном ПК и заменить в ВП уже плагинами для замены картинок. По одной. В будущем загружать уже оптимизированную.

Но это не отменяет изучения логов и мониторинга сайта. Так что может и правда лучше обратиться к специалистам.

Спасибо за ответ, сайт и до этого открывался нормально, не открывается только одна страница «главная» в консоли, чтобы редактировать! Про опимизированную графику ясно, спасибо!

не открывается только одна страница «главная» в консоли, чтобы редактировать!

А вот это может быть из-за плагинов и темы. Поэтому при таких проблемах нужно смотреть логи.

Спасибо большое за оперативные ответы!

Я получила ответ от хостинга:
Re: Timeweb> Установлено приложение

По Вашему запросу N3398557 было получено новое сообщение.
Автор сообщения: Александр Смолев
Время: 2019-01-21 15:18:10
Тип: Новое сообщение
================================
Здравствуйте! При работе с php7.1 Вашего сайта наблюдаем утечку памяти. Более подробную информацию по ошибке можно получить в логе ошибок. Включить ведение логов можно в ПУ: https://timeweb.com/ru/help/pages/viewpage.action

Для отладки работы сайта на php7.1 рекомендуем обратиться к специалисту по WordPress, либо мы можем предложить более простой вариант — переключиться на версию php5.6 — на данной версии при работе Вашего кода утечка памяти не воспроизодится.

Подскажите пожалуйста как переключиться на версию php5.6 .
Спасибо.

Подскажите пожалуйста как переключиться на версию php5.6 .

Это вопрос к хостеру.
Но правильнее — разобраться в проблеме с php7.
Наверняка Вы используете компоненты не из оф каталога. (чем чревато — см https://codex.wordpress.org/%D0%A7%D0%90%D0%92%D0%9E/%D0%A1%D0%B0%D0%B9%D1%82_%D0%B2%D0%B7%D0%BB%D0%BE%D0%BC%D0%B0%D0%BB%D0%B8 и п9)

Спасибо, проблема решена! Переключилась на версию php5.6, все открывается и работает! Благодарю за оперативную поддержку!

Переключилась на версию php5.6, все открывается и работает!

Источник

Оцените статью