Wsus не работает отчет

Произошла ошибка при создании отчета WSUS [Full Fix]

Службы обновлений Windows Server Update Services или WSUS отвечают за ваши обновления, но иногда вы можете столкнуться с ошибкой при создании отчета . Это может быть вызвано просто нестабильным сетевым подключением.

Но в большинстве случаев это связано с недавними изменениями программного обеспечения, из-за которых ваша машина находилась в состоянии ожидания перезагрузки. И перезапуск, похоже, не совсем подходит. Однако у нас есть несколько решений, которые могут вам помочь, так что давайте начнем.

Как исправить ошибку, возникшую при создании отчета об ошибке WSUS? Первое, что вы должны сделать, это сбросить Winsock и перезапустить сервер WSUS с помощью командной строки. Если это не сработает, убедитесь, что брандмауэр Windows не оказывает никакого влияния на WSUS.

Что делать, если отчеты WSUS не работают?

  1. Сброс Winsock
  2. Перезагрузите сервер WSUS
  3. Проверьте свой брандмауэр
  4. Редактирование реестра
  5. Решение для удаленного рабочего стола
  6. Обновите или переустановите сетевые драйверы

1. Сброс Winsock

Чтобы исправить ошибку, возникшую при генерации отчета , необходимо сбросить Winsock, выполнив следующие действия:

  1. Запустите Командную строку от имени администратора.
  2. Введите netsh каталог сброса winsock в Командная строка , нажмите и нажмите Enter .
  3. Введите netsh int ip reset reset.log и нажмите Enter .
  4. Перезагрузите компьютер и попробуйте снова запустить службы обновления.

2. Перезапустите сервер WSUS.

Для этого выполните следующие действия:

  1. В меню «Пуск» откройте командную строку с правами администратора.
  2. Теперь введите следующую команду:
  3. А теперь введите:
  • Теперь перезапустите сервер WSUS.
  • 3. Проверьте свой брандмауэр

    Вы можете отключить брандмауэр Windows и проверить, устраняет ли это ошибку при создании отчета .

    1. Откройте Панель управления .
    2. Затем нажмите Брандмауэр Windows .
    3. Теперь нажмите Разрешить приложение или функцию через брандмауэр Windows .
    4. Теперь откроется окно Разрешенные приложения .
    5. Нажмите кнопку Изменить настройки .
    6. Установите флажки рядом с приложениями или программами, которые вы хотите разрешить через брандмауэр Windows.
    7. Нажмите ОК , чтобы сохранить новые настройки.

    4. Редактирование реестра

    Следующее исправление включает в себя редактирование некоторых разделов реестра. Для этого выполните следующие действия:

    1. Сначала нажмите Пуск , нажмите Запустить , введите regedit , а затем нажмите ОК .
    2. Найдите и нажмите, чтобы выбрать следующий раздел реестра: HKEY_LOCAL_MACHINE> SYSTEM> CurrentControlSet> Элемент управления> Диспетчер сеансов .
    3. После выбора подключа щелкните правой кнопкой мыши PendingFileRenameOperations и выберите Удалить .
    4. Найдите следующий раздел реестра и нажмите на него: HKEY_LOCAL_MACHINE> ПРОГРАММНОЕ ОБЕСПЕЧЕНИЕ> Microsoft> Windows> CurrentVersion> WindowsUpdate> Auto Update .
    5. После выбора этого ключа нажмите правой кнопкой мыши RebootRequired и выберите Удалить .
    6. В разделе меню Файл нажмите Выход , чтобы закрыть редактор реестра.
    7. Перезагрузите машину.

    5. Решение для удаленного рабочего стола

    Это исправление работает в том случае, если вы используете сервер удаленного рабочего стола и у вас возникают проблемы с подключением. Для этого выполните следующие действия:

    1. Нажмите Пуск , затем перейдите в Администрирование и Открыть управление компьютером .
    2. В разделе консоли перейдите на вкладку Локальные пользователи и Группы .
    3. На вкладке сведений откройте Группы .
    4. Нажмите Пользователи удаленного рабочего стола , а затем нажмите Добавить .
    5. В диалоговом окне «Выбор пользователей» нажмите «Местоположения», чтобы указать местоположение поиска.
    6. Нажмите Типы объектов , чтобы указать типы объектов, которые вы хотите найти.
    7. Введите имя, которое вы хотите добавить, в поле Введите имена объектов для выбора .
    8. Нажмите Проверить имена .
    9. Найдя имя, нажмите ОК .

    6. Обновите или переустановите сетевые драйверы

    Если все остальное не удалось, вы можете исправить Ошибка при создании отчета , обновив или переустановив сетевые драйверы.

    Во-первых, чтобы обновить их, выполните следующие действия:

    1. В окне поиска на панели задач выберите Диспетчер устройств .
    2. Выберите категорию, чтобы увидеть названия устройств, затем щелкните правой кнопкой мыши ту, которую хотите обновить.
    3. Выберите Обновить драйвер .
    4. Теперь нажмите Автоматический поиск обновленного программного обеспечения драйвера .
    5. Когда обновление завершено, все готово.

    Если этот метод не работает, вы можете использовать сторонние приложения, такие как TweakBit Driver Updater . Используя этот инструмент, вы автоматически обновите все свои драйверы всего за пару кликов.

    Чтобы переустановить сетевые драйверы, выполните следующие действия.

    1. Повторите первый шаг из предыдущего обходного пути.
    2. Щелкните правой кнопкой мыши на имени устройства и выберите Удалить .
    3. Теперь перезагрузите вашу машину.
    4. Windows попытается переустановить драйвер при запуске.
    Читайте также:  Не работает блок стеклоподъемников ховер 5

    Итак, вот 6 решений, которые могут помочь вам исправить Произошла ошибка при создании отчета . Если наши решения помогли вам, не стесняйтесь сообщить нам в разделе комментариев ниже.

    Источник

    Чиним клиентов WSUS

    Клиенты WSUS не хотят обновляться после смены сервера?
    Тогда мы идем к вам. (С)

    У всех бывали ситуации, когда что-нибудь переставало работать. В данной статье речь пойдет о WSUS (более подробную информации о WSUS можно получить здесь и здесь). А точнее о том, как заставить клиентов WSUS (т.е. наши с вами компьютеры) заново получать обновления после переноса или восстановления существующего сервера обновлений.

    Итак, ситуация следующая

    Сдох сервер WSUS. Точнее RAID-контроллер аж 2000 года выпуска. Но радости этот факт не прибавил. После непродолжительной возни (с попытками восстановить RAID, загубленный помирающим контроллером), было принято решение послать все развернуть новый WSUS-сервер.

    В итоге мы получили работающий WSUS, на который почему-то не коннектились клиенты.
    Моменты: WSUS привязан с FQDN через внутренний DNS-сервер, WSUS-сервер прописан в групповых политиках и распространяется на клиентов через AD, настройки для сервера по-умолчанию, перед началом всех действий обновите сам WSUS и выполните синхронизацию обновлений.

    После анализа ситуации, было выявлено несколько ключевым моментов

    1. Клинч клиента (речь о wuauclt) при попытке соединиться с SID старого сервера WSUS.
    2. Проблема с неустановленными обновлениями, скачанными со старого WSUS-сервера.
    3. Парковка служб влияющих на работу wuauclt (речь о wuauserv, bits и cryptsvc). Парковка произошла по разным причинам, которые детально не анализировались.

    В итоге все решение вылилось в маленький скрипт, который распространяется групповыми политиками через AD или собственными руками (и ногами). Скрипт использует наиболее безопасный вариант починки и не приносил ни одного негативного результата уже на протяжении полугода использования.

    Опишу, что делается (для особо любопытных)

    Паркуем службу сервера обновлений, чистим дескриптор безопасности службы связи с WSUS, удаляем имеющиеся обновления от предыдущего WSUS, чистим реестр от упоминаний о предыдущем WSUS, стартуем службы автоматического обновления (wuauserv), фоновую интеллектуальную службу передачи (bits) и службу криптографии (cryptsvc), в самом конце принудительно стукаемся в WSUS с обнулением авторизации, обнаружением нового WSUS и генерацией отчета на сервер.

    И как всегда: все действия описанные выше и ниже вы выполняете на свой страх и риск. Пожалуйста, удостоверьтесь в том что все необходимые данные сохранены до выполнения скрипта.

    Источник

    Wsus не работает отчет

    Общие обсуждения

    Здравствуйте. возникла следующая проблема.

    Одно время на 2003 сервере был установлен всус, жил качал обновления и был счастлив. потом его удалили и через некоторое время поставили заново. Сервер установился, все нормально, обновления качает клиентские компьютеры видит, одобряет все хорошо, НО. почему то все клиентские компьютеры не передают на сервер информацию о состоянии. тоесть в графах доля установленных/непримиинимых обновлений стоит 0% и последнй отчет о состоянии — небыло отчета.

    обновления настроены через групповую политику. компьютер пытается их получить, но не получает.

    В итоге получается что на сервере обновления есть но ни один компьютер получить их не может.

    • Перемещено ILYA [ sie ] Sazonov Moderator 25 августа 2011 г. 7:41 (От:Windows Server 2003/2000/NT)
    • Изменен тип Vinokurov Yuriy Moderator 1 сентября 2011 г. 7:54 давность и отсутствие активности в теме

    Все ответы

    Очевидно, что Ваши клиентские компьютеры не видят новый WSUS сервер.

    Источник

    Нет отчета от компьютера на консоли WSUS?

    На консоли WSUS (см. картинку) 2 компьютера не синхронизируются.(не отправляют отчет)
    Логи с проблемного клиента скину посмотрите пожалуйста с чем это связанно и куда копать.

    • Вопрос задан более трёх лет назад
    • 2429 просмотров

    Знакомая проблемка. решаю ленивым образом:
    Скрипт запускается с рабочего места администратора, с повышенными правами, должен быть установлен комплект PStools, имена компьютеров с ошибками обновления можно посмотреть в консоли WSUS.

    Еще очень желательно отклонять ненужные обновления в WSUS и проводить чистку папки WsusContent — помогает избежать таких ситуаций.

    ————————————-
    Т.е. на проблемном компьютере пересоздается папка Sofrware Distribution и перезапускается клиент обновления. Через день-два все приходит в норму, можно ускорить и принудительно обновить проблемные компьютеры, но это не обязательно.

    Источник

    Устранение неполадок с агентами клиентов WSUS

    В этой статье помогают диагностировать и устранять проблемы с агентами Windows Server Update Services (WSUS).

    Оригинальная версия продукта: Windows Server Update Services
    Исходный номер КБ: 10132

    При проблемах с агентами клиентов WSUS они могут проявляться многими способами. Ниже перечислены некоторые распространенные проблемы:

    • Это может быть проблемой с настройками клиента для групповой политики.
    • Это может быть проблема с BITS.
    • Это может быть проблема со службой агентов WSUS.
    • Это может быть связано с сетевой проблемой, которая не позволяет клиенту достичь сервера.
    • Это может быть проблема с магазином агентов автоматического обновления.
    • Это может быть проблема, из-за которой у клиентов имеются дублирующиеся ID клиента WSUS, вызванные клонированием дисков.
    Читайте также:  Как отремонтировать холодильник хотпоинт аристон по гарантии

    Убедитесь, что клиент настроен правильно

    При устранении неполадок с клиентом WSUS сначала убедитесь, что клиент правильно настроен. Убедитесь, что клиент получает соответствующую групповую политику Active Directory, а также сведения о сервере WSUS. Это можно сделать, подав следующую команду:

    Откройте текстовый файл в Блокнот и найдите имя вашей политики WSUS. Например, если политика WSUS называется WSUS, ее можно найти в файле GPRESULT.TXT в разделе Computer Параметры под заголовком Объекты прикладной групповой политики. Ниже приведен пример:

    Если параметров WSUS нет, возможные причины:

    • В системе нет групповой политики из домена.
    • Групповой политика не ориентирована на клиентскую систему.

    Чтобы устранить эту проблему, убедитесь в успешном обновлении групповой политики для каждого клиента и правильной настройке параметра WSUS.

    Чтобы обновить групповую политику клиента, запустите GPUpdate /force из командной подсказки.

    Дополнительные сведения о настройке групповой политики для клиентов WSUS см. в дополнительных сведениях о настройке автоматических обновлений с помощью групповой политики.

    Проверка проблем, связанных с BITS

    Background Intelligent Transfer Service (BITS) — это служба, используемая WSUS для скачивания обновлений из Microsoft Update на основной сервер WSUS и с серверов WSUS для своих клиентов. Некоторые проблемы с загрузкой могут быть вызваны проблемами с битами на сервере или клиентских компьютерах. При устранении неполадок при загрузке необходимо убедиться, что bits работает должным образом на всех затронутых компьютерах.

    Служба BITS должна работать под учетной записью LocalSystem по умолчанию. Чтобы настроить службу для работы под правильной учетной записью, выполните следующие действия:

    Откройте командную подсказку и запустите следующую команду:

    Между obj= и LocalSystem должно возникать пространство. В случае успешной работы необходимо получить следующий вывод:

    Остановка и перезапуск BITS.

    Чтобы просмотреть состояние службы BITS, откройте командную подсказку и запустите следующую команду:

    Если биты запущены, вы должны увидеть следующий вывод:

    Если BITS не запущен, вы увидите следующий вывод:

    Обычно можно разрешить проблемы с BITS, остановив службу и перезапустив ее. Чтобы остановить и перезапустить службу BITS, запустите следующие команды из командной подсказки:

    Чтобы остановить и перезапустить BITS, необходимо войти в систему в качестве локального администратора.

    BITS не удается запустить

    Если служба BITS не запустится, в журнале событий можно найти любую ошибку, связанную с БИТС. Для диагностики причин этих ошибок можно использовать следующую таблицу.

    Имя ошибки Код ошибки Описание
    ERROR_SERVICE_DOES_NOT_EXIST 0x80070424 Ниже см. раздел о восстановлении конфигурации BITS.
    ERROR_SERVICE_NOT_IN_EXE 0x8007043B BITS не указан в качестве одной из служб в группе svchost netsvcs
    ERROR_SERVICE_DISABLED 0x80070422 Биты отключены. Включить службу BITS.
    ERROR_SERVICE_DEPENDENCY_DELETED ERROR_SERVICE_DEPENDENCY_FAIL 0x80070433, 0x8007042c Служба, появляемая в списке зависимостей службы BITS, не может быть запущена. Убедитесь, что список зависимостей для службы BITS является правильным:
    Windows Vista: RpcSs, EventSystem (также http.sys и LanManWorkstation при включенном одноранговом кэшинге)
    Windows Server 2003: Rpcss, EventSystem
    Windows XP: Rpcss
    Windows 2000 г.: Rpcss, SENS, Wmi
    ERROR_PATH_NOT_FOUND 0x80070003 Предварительная Windows Vista: %ALLUSERSPROFILE%\Microsoft\Network не существует
    ERROR_FILE_NOT_FOUND 0x80070002 Ключ Параметры отсутствует. Убедитесь, что существуют следующие ключи и значения:
    HKLM\SYSTEM\CurrentControlSet\Services\BITS\Parameters\ServiceDll = %SystemRoot%\System32\qmgr.dll
    REGDB_E_CLASSNOTREG, EVENT_E_INTERNALERROR 0x80040154, 0x80040206 Bits for Windows 2000 зависит от служб SENS и EventSystem. Если каталог COM+ поврежден, bits может привести к сбою с этим кодом ошибки.

    Задания BITS не удается

    Если клиент правильно настроен для получения обновлений, биты настроены правильно, а биты, как представляется, начинаются и работают должным образом, может возникнуть проблема, из-за которой сами задания BITS не работают. Чтобы проверить это, посмотрите в журнале событий все ошибки, связанные с BITS. Для диагностики причин этих ошибок можно использовать следующую таблицу.

    Имя ошибки Код ошибки Описание
    E_INVALIDARG 0x80070057 Неправильное имя прокси-сервера было указано в параметрах прокси-сервера Internet Explorer пользователя. Эта ошибка также рассматривается при поставке учетных данных для схем проверки подлинности, которые не являются NTLM/Negotiate, но имя пользователя или пароль являются null. Измените параметры прокси-сервера Internet Explorer пользователя на допустимый прокси-сервер. Или измените учетные данные, чтобы они не были NULL-именем пользователя или паролем для схем, помимо NTLM/Negotiate.
    ERROR_WINHTTP_NAME_NOT_RESOLVED 0x80072ee7 Сервер/прокси-сервер не удалось разрешить с помощью BITS. Internet Explorer на той же машине в контексте владельца задания будет видеть ту же проблему. Попробуйте загрузить один и тот же файл через веб-браузер с помощью контекста владельца задания.
    ERROR_HTTP_INVALID_SERVER_RESPONSE 0x80072f78 Это преходящая ошибка, и задание будет продолжать скачивать.
    BG_E_INSUFFICIENT_RANGE_SUPPORT 0x80200013 BITS использует заглавные элементы диапазона в http-запросах для запроса частей файла. Если сервер или прокси-сервер не понимают диапазон запросов и возвращает полный файл вместо запрашиваемого диапазона, BITS ставит задание в состояние ERROR с этой ошибкой. Захват сетевого трафика во время ошибки и проверьте, получают ли запросы HTTP GET с помощью заголовка Range допустимые ответы. Проверьте прокси-серверы, чтобы убедиться, что они правильно настроены для поддержки запросов range.
    BG_E_MISSING_FILE_SIZE 0x80200011 Когда BITS отправляет HEAD-запрос, а сервер/прокси-сервер не возвращает в ответ заготвку Content-Length, BITS ставит задание в состояние ERROR с этой ошибкой. Проверьте прокси-сервер и сервер WSUS, чтобы убедиться, что они настроены правильно. Известно, что это поведение проявляется в некоторых версиях прокси-сервера Apache 2.0.
    BG_E_HTTP_ERROR_403 0x80190193 Когда сервер возвращает ответ HTTP 403 в любом из запросов, BITS ставит задание в состояние ERROR с этим кодом ошибки. HTTP 403 соответствует запрету: доступ запрещен. Проверьте разрешения доступа для учетной записи, которая работает с заданием.
    ERROR_NOT_LOGGED_ON 0x800704dd Служба SENS не получает уведомления о логотипе пользователя. Bits (версия 2.0 и более поздние версии) зависит от уведомлений с логотипом от диспетчера управления службой, что, в свою очередь, зависит от службы SENS. Убедитесь, что служба SENS запущена и запущена правильно.

    Ремонт поврежденной конфигурации BITS

    Чтобы восстановить поврежденную конфигурацию службы BITS, можно ввести конфигурацию службы BITS вручную.

    Это действие следует предпринять только в тех случаях, когда все другие попытки устранения неполадок потерпели неудачу. Чтобы изменить конфигурацию BITS, необходимо быть администратором.

    Чтобы восстановить поврежденную конфигурацию BITS, выполните следующие действия:

    Откройте командную подсказку.

    Введите следующие команды, нажмите ВВОД после ввода каждой команды:

    Остановка и перезапуск BITS.

    Проблемы со службой агентов WSUS

    Убедитесь, что Windows обновления можно успешно запустить.

    Чтобы просмотреть текущее состояние службы обновления Windows, откройте командную подсказку и запустите следующую команду:

    Если WUAUSERV запущен, вы должны увидеть следующий вывод:

    Если WUAUSERV не запущен, вы увидите следующий вывод:

    Убедитесь, что вы можете успешно запустить службу WUAUSERV. Чтобы остановить и перезапустить WUAUSERV, необходимо войти в систему в качестве локального администратора.

    Чтобы запустить службу WUAUSERV, запустите следующие команды из командной подсказки:

    Если агент клиента не удается запустить и запустить должным образом, проверьте версию Windows агента обновления. Если агент не обновлен, обнови его Windows до последней версии.

    После запуска исправления или обновления агента запустите wuauclt /detectnow . Проверьте windowsupdate.log, чтобы убедиться, что нет проблем.

    Убедитесь, что сервер WSUS можно достичь от клиента

    Убедитесь, что вы можете получить доступ к URL-адресу http:// /iuident.cab и скачать файл без ошибок.

    Если сервер WSUS недостижим от клиента, наиболее вероятными причинами являются следующие:

    • У клиента есть проблема с разрешением имен.
    • Существует проблема, связанная с сетью, например проблема конфигурации прокси.

    Используйте стандартные процедуры устранения неполадок, чтобы убедиться, что разрешение имен работает в сети. Если разрешение имен работает, следующим шагом является проверка проблем с прокси-серверами. Проверьте windowsupdate.log (C:\windows), чтобы узнать, есть ли ошибки, связанные с ) прокси. Вы можете запустить proxycfg команду, чтобы проверить параметры прокси WinHTTP.

    Если есть ошибки прокси, перейдите в internet Explorer > Tools Connections LAN Параметры, настройте правильный прокси, а затем убедитесь, что вы можете получить доступ к > > указанному URL-адресу WSUS.

    После этого можно скопировать эти параметры прокси-сервера пользователя в прокси-параметры WinHTTP с помощью proxycfg -u команды. После заданных параметров прокси запустите из командного запроса и проверьте wuauclt /detectnow windowsupdate.log на факт ошибок.

    Восстановление магазина агентов автоматического обновления

    При проблемах с загрузкой обновлений и ошибках, связанных с магазином рассылки программного обеспечения, выполните следующие действия на клиенте:

    • Остановите службу автоматических обновлений, sc stop wuauserv выключив командный запрос.
    • Переименовать папку рассылки программного обеспечения (например, C:\Windows\SoftwareDistribution).
    • Перезапустите службу автоматического обновления с sc start wuauserv помощью командной подсказки.
    • Из командного запроса запустите wuauclt /resetauthorization /detectnow .
    • Из командного запроса запустите wuauclt /reportnow .

    Проверка для клиентов с тем же ИД SUSclient

    Может возникнуть проблема, из-за которой на консоли появляется только один клиент WSUS. Или вы можете заметить, что из группы клиентов на консоли одновременно появляется только один, но точный, который появится, со временем может измениться. Эта проблема может произойти, когда системы изображения и клиенты в конечном итоге с той же SUSclientID .

    Для тех клиентов, которые не работают должным образом из-за того SUSclientID же, выполните следующие действия:

    Остановите службу автоматических обновлений, sc stop wuauserv выключив командный запрос.

    Удаление SUSclientID ключа реестра из следующего расположения:

    Перезапустите службу автоматического обновления с sc start wuauserv помощью командной подсказки.

    Из командного запроса запустите wuauclt /resetauthorization /detectnow .

    Из командного запроса запустите wuauclt /reportnow .

    Источник

    Оцените статью