Zimbra не работает web интерфейс

Записки IT специалиста

Технический блог специалистов ООО»Интерфейс»

  • Главная
  • Zimbra. Настраиваем протоколы доступа к веб-интерфейсу.

Zimbra. Настраиваем протоколы доступа к веб-интерфейсу.

По умолчанию веб-интерфейс почтового сервера Zimbra настроен для доступа только по защищенному протоколу HTTPS. Это безопасно, но не совсем удобно для пользователя, так как ему нужно каждый раз набирать адрес полностью, c https://, а с учетом того, что все пользуются закладками, то это быстро забывается и при попытке получить доступ с нового клиентского устройства пользователь столкнется с недоступностью сервиса. В тоже время Zimbra предлагает большое количество вариантов протоколов доступа к веб-интерфейсу, о чем мы сегодня и расскажем.

Изменение протоколов доступа к веб-интерфейсу производится через командную строку и затрагивает только пользовательскую часть. Прежде всего войдем в консоль сервера и повышаем права до суперпользователя:

затем переключаемся на пользователя Zimbra:

Для изменения режима доступа к веб-интерфейсу служит команда:

где mode — тип необходимого режима доступа, рассмотрим их подробнее.

  • http — доступ только по протоколу HTTP, данный режим категорически не рекомендуется ввиду низкой безопасности.
  • https — доступ только по протоколу HTTPS, наиболее защищенный режим, используется по умолчанию.
  • both — возможен доступ по обоим протоколам, допустимо использовать в случаях, когда HTTP используется только клиентами локальной сети.
  • mixed — при доступе по протоколу HTTP пользователь переводится на защищенное соединение для авторизации, затем снова переводится на HTTP, HTTPS-сессия полностью проходит по защищенному протоколу.
  • redirect — принудительный редирект всех HTTP соединений на HTTPS.

Какой режим использовать? Понятно, что HTTP не удовлетворяет элементарным требованиям безопасности и за пределами локальной сети недопустим. Но даже при нахождении внутри периметра не стоит передавать открытым текстом авторизационные данные, поэтому наилучшим вариантом тут может быть режим mixed.

В тоже время, с точки зрения обеспечения высокого уровня безопасности, следует выбрать режим redirect, когда и пользователи будут довольны и админы спокойны. В этом случае можно смело открывать доступ по обоим протоколам за пределы периметра, все незащищенные соединения будут принудительно переводиться на защищенный режим.

Однако без ложки дегтя в бочке меда здесь не обошлось, данный режим позволяет выполнить атаку «человек посередине», перехватив HTTP запрос и направив пользователя на сервер злоумышленника. Поэтому постарайтесь не использовать для работы за пределами локальной сети самоподписанные сертификаты, а если используете, то обязательно сделайте импорт и установку корневого сертификата на все клиентские устройства. Не приучайте пользователей игнорировать предупреждения безопасности.

Итак, переключим наш веб интерфейс в режим redirect:

Читайте также:  Алиса почему у меня не работают наушники

Перезапустим необходимые сервисы Zimbra:

также можно полностью перезапустить все сервисы одной командой:

Проверяем, теперь если просто набрать в командной строке адрес почтового сервера должен произойти редирект на защищенное соединение.

Таким образом получилось значительно повысить удобство работы пользователей практически без ущерба для безопасности.

Дополнительные материалы:

Помогла статья? Поддержи автора и новые статьи будут выходить чаще:

Или подпишись на наш Телеграм-канал:

Источник

Проблемы с Web интерфейсом Zimbra

Доброго времени суток. С Linux на Вы. Досталась недавно по наследству Ubuntu с установленной Zimbra. Сегодня пользователи столкнулись с тем что не смогли зайти в свою почту через Web-интерфейс. Сначала просто висело на «Идет загрузка» при логине, сейчас «Время сеанса истекло. Войдите еще раз.». Были предприняты попытки увеличить максимального размера базы и логов, ничего не дало. Так же были предприняты попытки пересоздании БД, на этапе резервирования высыпал ошибку

Со стартом ldap при старте системы проблем нет. Буду благодарен за помощь и разъяснения

Я бы начал с проверки свободного места.

35 гигов. Проблему временно удалось обойти с помощью почтового клиента чтобы пользователи могли работать. Но решение так и не найдено с «Идет загрузка» при логине

Оригинальное решение — не разобравшись, что является причиной проблемы вы стали жать на все кнопки и удивляетесь, что все перестало работать.

на этапе резервирования высыпал ошибку

Сначала останавливаете ldap, потом пытаетесь сделать резервирование. Если ничего не меняется, то

Судя по всему у вас побита база LDAP

Assertion ‘IS_LEAF(mp)’ failed in mdb_cursor_next()

Находите резервную копию (вы же её делали, да?) и начиная с «data import» восстанавливаете.

LDAP соответственно был остановлен перед резервированием. Резервной копии скорее всего нет, потому что предыдущему сисадмину она так же досталась по наследству и он с этой виртуалкой на которой стоит Zimbra ничего не делал.

1. Все же поищите копии базы ldap на хосте (или посмотрите, есть ли снепшоты)

2. проверьте, что ldap действительно запускается без ошибок, как вы утверждаете, посмотрите в логи

3. если п.2 верен, то с помощью пользователя с максимальными правами и ldapsearch дампите свою базу на «рабочем» )) ldap

Источник

Zimbra Admin and Web Client not load, it is blank

Contents

Purpose

After upgrade to ZCS 8.6, or ZCS 8.7.0 or 8.7.1, the Admin UI and the Web Client only loads an empty page, it was working before without issue before the upgrade.

You can also check that you are facing the issue described here, if you also run the next commands and see this results

Another way to check and debug this error, is by trying to load the Web Client from the Zimbra Server

Resolution

Run the next simple commands to fix the issue:

Additional Content

  • Thank you to DualBoot to debug the issue and came with a solution on the Forums — https://forums.zimbra.org/viewtopic.php?f=15&t=59852&start=20#p269440
KB 23103 Last updated on 2019-06-21 Last updated by Phoenix
Verified Against: Zimbra Collaboration 8.7.1, 8.7, 8.6 Date Created: 11/06/2016
Article ID:https://wiki.zimbra.com/index.php?title=Zimbra_Admin_and_Web_Client_not_load,_it_is_blank Date Modified: 2019-06-21

Try Zimbra Collaboration with a 60-day free trial.
Get it now »

Want to get involved?

You can contribute in the Community, Wiki, Code, or development of Zimlets.
Find out more. »

Other help Resources

Looking for a Video?

Visit our YouTube channel to get the latest webinars, technology news, product overviews, and so much more.
Go to the YouTube channel »

Источник

Zimbra не работает web интерфейс

Post by yvespires » Fri May 24, 2019 10:15 pm

Release 8.7.0.GA.1659.UBUNTU12.64 UBUNTU12_64 FOSS edition

This is 4 years installation. Everything seems to be working fine, except the AJAX mode webmail loads blank page after inserting email/password

/conf$ zmprov gcf zimbraMailboxdSSLProtocols
zimbraMailboxdSSLProtocols: TLSv1
zimbraMailboxdSSLProtocols: TLSv1.1
zimbraMailboxdSSLProtocols: TLSv1.2
zimbraMailboxdSSLProtocols: SSLv2Hello

2019/05/24 18:13:02 [info] 27130#0: *213 SSL_do_handshake() failed (SSL: error:14094416:SSL routines:ssl3_read_bytes:sslv3 alert certificate unknown:SSL alert number 46) while SSL handshaking, client: 177.XXX.XXX.30, server: 0.0.0.0:443

Tried fix permissions
Regenerated zimbra certs
Server rebooted

Re: Zimbra AJAX Webmail not loading

Post by amctecnologia » Fri May 24, 2019 11:14 pm

I’m also having this same problem (started today) and was not even aware that in HTML mode it was working.

What I noticed in the zimbra logs was:

This error occurs in the /var/log/zimbra.log file:

May 24 19:41:50 mail zmconfigd [16210]: Rewrite failed: [Errno 1] Operation not permitted: ‘/opt/zimbra/mailboxd/webapps/zimbra/WEB-INF/web.xml’ ([Errno 1] Operation not permitted: ‘/opt/zimbra/mailboxd/webapps/zimbra/WEB-INF/web.xml’)
May 24 19:42:56 mail zmconfigd [16210]: Rewrite failed: [Errno 1] Operation not permitted: ‘/opt/zimbra/mailboxd/webapps/service/WEB-INF/web.xml’ ([Errno 1] Operation not permitted: ‘/opt/zimbra/mailboxd/webapps/service/WEB-INF/web.xml’)
May 24 19:42:56 mail zmconfigd [16210]: Rewrite failed: [Errno 1] Operation not permitted: ‘/opt/zimbra/mailboxd/webapps/zimbraAdmin/WEB-INF/web.xml’ ([Errno 1] Operation not permitted: ‘/opt/zimbra/mailboxd/webapps/zimbraAdmin/WEB-INF/web.xml’)

And in the /opt/zimbra/log/zmmailboxd.log file:

May 24 19:41:50 mail zmconfigd [16210]: Rewrite failed: [Errno 1] Operation not permitted: ‘/opt/zimbra/mailboxd/webapps/zimbra/WEB-INF/web.xml’ ([Errno 1] Operation not permitted: ‘/opt/zimbra/mailboxd/webapps/zimbra/WEB-INF/web.xml’)
May 24 19:42:56 mail zmconfigd [16210]: Rewrite failed: [Errno 1] Operation not permitted: ‘/opt/zimbra/mailboxd/webapps/service/WEB-INF/web.xml’ ([Errno 1] Operation not permitted: ‘/opt/zimbra/mailboxd/webapps/service/WEB-INF/web.xml’)
May 24 19:42:56 mail zmconfigd [16210]: Rewrite failed: [Errno 1] Operation not permitted: ‘/opt/zimbra/mailboxd/webapps/zimbraAdmin/WEB-INF/web.xml’ ([Errno 1] Operation not permitted: ‘/opt/zimbra/mailboxd/webapps/zimbraAdmin/WEB-INF/web.xml’)

In your case you have these entries also in the log?

Re: Zimbra AJAX Webmail not loading

Post by mikeyl » Sat May 25, 2019 12:25 am

Hi Everyone
The problem is global (I guess) because I have 4 servers with zimbra 8.6 and Webmail login is blank.
In /opt/zimbra/mailbox.log I have an error with .css not found.

I’ll still trying with some configurations.
Regards,

Re: Zimbra AJAX Webmail not loading

Post by amctecnologia » Sat May 25, 2019 12:56 am

My Zimbra version:

]$ zmcontrol -v
Release 8.7.11_GA_1854.RHEL7_64_20170531151956 RHEL7_64 FOSS edition.

but my /opt/zimbra/log/mailbox.log does not display this error you mentioned.

Does your webmail open in HTML mode?

Re: Zimbra AJAX Webmail not loading

Post by yvespires » Sat May 25, 2019 1:23 am

amctecnologia wrote: My Zimbra version:

]$ zmcontrol -v
Release 8.7.11_GA_1854.RHEL7_64_20170531151956 RHEL7_64 FOSS edition.

but my /opt/zimbra/log/mailbox.log does not display this error you mentioned.

Does your webmail open in HTML mode?

Yes, HTML mode is opening, but with all icons missing

Seems the problem is not related to distro or zimbra version

Btw, tested with 3 different browsers, all show the same problem.

Re: Zimbra AJAX Webmail not loading

Post by amctecnologia » Sat May 25, 2019 1:26 am

Re: Zimbra AJAX Webmail not loading

Post by mikeyl » Sat May 25, 2019 1:36 am

amctecnologia wrote: My Zimbra version:

]$ zmcontrol -v
Release 8.7.11_GA_1854.RHEL7_64_20170531151956 RHEL7_64 FOSS edition.

but my /opt/zimbra/log/mailbox.log does not display this error you mentioned.

Does your webmail open in HTML mode?

Yes, HTML mode is opening, but with all icons missing

Seems the problem is not related to distro or zimbra version

Btw, tested with 3 different browsers, all show the same problem.

Sorry,
the file is /opt/zimbra/zmmailboxd.out

[root@correo log]# tail zmmailboxd.out
at org.eclipse.jetty.server.handler.DebugHandler.handle(DebugHandler.java:81)
at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:97)
at org.eclipse.jetty.server.Server.handle(Server.java:462)
at org.eclipse.jetty.server.HttpChannel.handle(HttpChannel.java:279)
at org.eclipse.jetty.server.HttpConnection.onFillable(HttpConnection.java:232)
at org.eclipse.jetty.io.AbstractConnection$2.run(AbstractConnection.java:534)
at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:607)
at org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:536)
at java.lang.Thread.run(Thread.java:745)
2019-05-24 19:54:48.158:WARN:oejs.HttpChannel:qtp509886383-113: Could not send response error 500: java.io.FileNotFoundException: !/img/images.css.js

Only in html mode is working the webmail.

Re: Zimbra AJAX Webmail not loading

Post by amctecnologia » Sat May 25, 2019 1:40 am

Re: Zimbra AJAX Webmail not loading

Post by gellenb » Sat May 25, 2019 2:26 am

Having the same issues here with «Loading» message on AJAX, and on HTML a message page without the icons. Running MOBILE on the desktop is functional under Firefox. Phones still syncing, and I started up the old Zimbra Desktop that I have not used in years, and it appears to be syncing ok. Everything was working fine up to 17:15 EST, but at 21:00 this problem came up. Nothing has been changed on the box in months, been running fine. I actually have a new server here, just waiting to be moved this coming week. Firefox, Chrome, and IE exhibit the same issues. Using the generic Samsung browser on my phone in MOBILE mode appears to be fine. HTML and AJAX have the same issue as the desktop browsers.
I’m running on this server
Ubuntu 14.04.05LTS
Zimbra 8.6.0_GA_1169
ZExtras 2.6.5
SSL’s are good, and provided by AlphaSSL

Источник

Оцените статью