Apache a2dissite не работает

На сайте не существует ошибки для a2ensite

У меня есть cmsplus.dev под /etc/apache2/sites-available следующим кодом,

Теперь, когда я использую sudo /usr/sbin/a2ensite cmsplus.dev , я получаю ошибку,

Мой веб-сервер Apache/2.4.6 (Ubuntu)

Как решить эту проблему?

Решил проблему, добавив .conf расширение в файлы конфигурации сайта.

Apache a2ensite приводит к:

Проблема; Если вы обнаружили ошибку при попытке включить сайт с помощью:

но это возвращает:

Ошибка: example.com не существует

a2ensite это просто Perl-скрипт, который работает только с именами файлов, заканчивающимися .conf

Поэтому я должен переименовать мой файл настроек для того, example.com чтобы example.com.conf достичь следующего:

Вы, вероятно, обновили установку Ubuntu, и одно из обновлений включало обновление Apache до версии 2.4.x

В Apache 2.4.x файлы конфигурации vhost, расположенные в каталоге / etc / apache2 / sites-available, должны иметь расширение .conf.

Используя терминал (команда mv), переименуйте все существующие файлы конфигурации и добавьте расширение .conf ко всем из них.

Если вы получили сообщение об ошибке «Отказано в доступе», добавьте «sudo» перед командами вашего терминала.

Вам не нужно вносить какие-либо другие изменения в файлы конфигурации.

Включить vhost (s):

А затем перезагрузите Apache:

Ваши сайты должны быть запущены сейчас.

UPDATE: Как уже упоминалось здесь , дистрибутив , который вы установили изменили конфигурацию Включить * .conf только. Поэтому это не имеет ничего общего с Apache 2.2 или 2.4

Есть еще один хороший способ, просто отредактируйте файл apache2.conf в конце строки

Включить дополнительные сайты с поддержкой / *. Conf

просто удалите .conf в конце, как это

Включить дополнительные сайты с поддержкой / *

и перезапустите сервер.

(Я пробовал это только в Ubuntu 13.10, когда обновлял его.)

У меня просто была такая же проблема. Я бы сказал, что это не имеет ничего общего с apache.conf.

a2ensite, должно быть, изменился — строка 532 — это строка, которая применяет суффикс .conf:

Если вы измените его на:

. это будет работать без суффикса.

Конечно, вы не захотите менять скрипт a2ensite, но изменение суффикса файла conf является правильным способом.

Вероятно, это просто способ применения суффикса «.conf».

Итак . самый быстрый способ — переименовать имена конфигураций сайта, заканчивающиеся на «.conf»

другие примечания к предыдущим комментариям:

IncludeOptional не был представлен, пока apache 2.36 — внесение изменений выше с последующим перезапуском на 2.2 оставит ваш сервер недоступным!

Кроме того, версия 2.2 a2ensite не может быть взломана, как описано

Кроме того, поскольку файл, доступный для вашего сайта, на самом деле является файлом конфигурации, его в любом случае следует называть таким образом.

Читайте также:  Почему не работает distinct

В общем случае не перезапускайте сервисы (веб-серверы — это один из видов сервисов):

  • люди не могут найти их, если они не бегут! Думаю, Linux не MS Windows ..

Серверы могут работать в течение многих лет — обновление в режиме реального времени, перезагрузка конфигурации и т. Д.

Облако не означает, что вам нужно перезапустить, чтобы загрузить файл конфигурации.

При изменении конфигурации службы используйте «перезагрузка», а не «перезагрузка».

restart останавливает службу, затем запускает службу — если при изменении конфигурации у вас возникнут проблемы, служба не будет перезапущена.

перезагрузка выдаст ошибку, но служба никогда не отключится, что даст вам возможность исправить ошибку конфигурации, которая может быть только с плохим синтаксисом.

debian или ubunto [имя службы для этой темы — apache2]

другой ос оставлен в качестве упражнения для читателя.

Источник

sudo: a2ensite: command not found

При «включении и выключение» виртуальных хостов на платформе Apache 2 используются две команды: a2ensite your_site и a2dissite your_site.

, где «your_site» – произвольное название хоста из которого будет состоять шаблон сгенерируемый Apache’чем по адресу: /etc/apache2/sites-enabled/

У меня, при создании включения шаблона виртуального хоста,

команда не отработала :

$ sudo a2ensite sarg.conf

sudo: a2ensite: command not found

исправление данной ошибки является, что в системе под управление Ubuntu 10.10 на которую я ставил платформу, Apache 2 забыл

инсталлировать пакет: apache2.2-common.

Установим его из репозитариев :

$ sudo apt-get install apache2.2-common

Reading package lists… Done

Building dependency tree

Reading state information… Done

The following extra packages will be installed:

apache2.2-bin libaprutil1-dbd-sqlite3 libaprutil1-ldap

apache2-doc apache2-suexec apache2-suexec-custom

The following NEW packages will be installed:

apache2.2-bin apache2.2-common libaprutil1-dbd-sqlite3 libaprutil1-ldap

0 upgraded, 4 newly installed, 0 to remove and 384 not upgraded.

Need to get 2,963kB of archives.

After this operation, 9,101kB of additional disk space will be used.

Do you want to continue [Y/n]? Y

Вот собственно и всё, проблема решена, пакет до установлен в систему:

Используйте прокси ((заблокировано роскомнадзором, используйте vpn или proxy)) при использовании Telegram клиента:

Поблагодари автора и новые статьи

будут появляться чаще 🙂

Карта МКБ: 4432-7300-2472-8059

Большое спасибо тем кто благодарит автора за практические заметки небольшими пожертвованиями. С уважением, Олло Александр aka ekzorchik.

Источник

Сайт не существует ошибка для a2ensite

Я cmsplus.dev под /etc/apache2/sites-available на следующий код

теперь, когда я использую sudo /usr/sbin/a2ensite cmsplus.dev , Я получаю ошибку

сервер Apache/2.4.6 (Ubuntu)

как решить эту проблему?

9 ответов

решил проблему, добавив .conf расширение для файлов конфигурации сайта.

Apache a2ensite результаты:

проблема; если вы обнаружили ошибку при попытке включить сайт с помощью:

но он возвращает:

a2ensite — это просто скрипт perl, который работает только с именами файлов, заканчивающимися .conf

поэтому я должен переименовать файл настроек для mysite.com to mysite.com.conf как может быть достигнуто следующим образом:

Читайте также:  После обновления андроид не работает отпечаток пальца

вы, вероятно, обновили свою установку Ubuntu, и одно из обновлений включало обновление Apache до версии 2.4.x

В Apache 2.4.x файлы конфигурации vhost, расположенные в каталоге/etc/apache2 / sites-available, должны иметь .расширением conf.

используя terminal (команда mv), переименуйте все существующие файлы конфигурации и добавьте .расширение conf для всех из них.

Если вы получаете ошибку «отказано в разрешении», добавьте » sudo » перед вашими терминальными командами.

вам не нужно делать какие-либо другие изменения в файлах конфигурации.

включить vhost (ы):

а затем перезагрузите Apache:

Теперь ваши сайты должны быть запущены.

обновление: как уже упоминалось здесь, дистрибутив Linux, который вы установили, изменил конфигурацию, чтобы включить *.только конф. Поэтому он не имеет ничего общего с Apache 2.2 или 2.4

есть еще один хороший способ, просто отредактируйте файл apache2.conf в конце есть строка

просто удалить .conf в конце, вот так

и перезапустить сервер.

(Я пробовал это только в Ubuntu 13.10, когда я обновил его.)

у меня была та же проблема. Я бы сказал, что это не имеет ничего общего с Apache.conf.

a2ensite должен быть изменен-строка 532-это строка, которая обеспечивает выполнение .суффикс конфы:

Если вы измените его на:

. он будет работать без суффикса.

конечно, вы не хотели бы изменять сценарий a2ensite, но изменение суффикса файла conf является правильным способом.

это, вероятно, просто способ обеспечения соблюдения «.конф»-суффикс.

Так .. самый быстрый способ-переименовать имена конфигурации сайта, заканчивающиеся на «.conf»

другие примечания к предыдущим комментариям:

IncludeOptional не был введен до apache 2.36-внесение изменений выше с последующим перезапуском на 2.2 оставит ваш сервер вниз!

кроме того, версия 2.2 a2ensite не может быть взломан, как описано

а также, так как ваш сайт-доступный файл на самом деле является конфигурацией файл, он должен быть назван так в любом случае..

В общем не перезапустить службы (веб-серверы-это один из видов услуг):

  • люди не могут найти их, если они не работают! Думаю, linux не MS Windows..

серверы могут работать в течение многих лет-live update, reload config и т. д.

облако не означает, что вы должны перезагрузить, чтобы загрузить файл конфигурации.

при изменении конфигурация службы использует «перезагрузку», а не»перезапуск».

restart останавливает службу, затем запускает службу — если есть какие-либо проблемы в изменении конфигурации, служба не будет перезагрузка.

перезагрузка даст ошибку, но служба никогда не выключается, давая вам возможность исправить ошибку конфигурации, которая может быть только плохим синтаксисом.

debian или ubunto [имя службы для этого потока помощью apache2]

другие ОС оставлены как выдержка для читателя.

Источник

Apache2 — настройка для работы с несколькими сайтами в Debian

В большинстве случаев, если вы имеете собственный веб-сервер с «белым» ip-адресом, то после установки Apache2 в Debian 8, сайт «заливается» в директорию /var/www/html — которая прописана в файле /etc/apache2/sites-available/000-default.conf

Читайте также:  Список контроля доступа anydesk как настроить

Однако, если мы хотим разместить несколько сайтов? Допустим, что у нас есть несколько приобретенных доменных имен. Например:

и один «белый» ip-адрес. Что нужно делать?

В Apache2 такая возможность, конечно-же, предусмотрена.

Но тут нужно понимать, как работает механизм обработки запросов к серверу. Представить это можно так:

а) В соответствии со схемой, нам нужно настроить на DNS-записи на DNS-сервере.

б) Настроить Веб-сервер для работы с несколькими виртуальными хостами.

Допустим, что с первым пунктом мы разобрались, приступаем к следующему этапу:

1. Устанавливаем веб-сервер, если он еще не установлен:

2. Для того, чтобы обезопасить работу на сервере, в директориях, которые будут созданы для размещения сайтов передадим права на директории пользователю (у меня это webuser, под которым будем работать с файлами сайта). Для этого установим модуль apache2-mpm-itk:

3. Создаем директорию для нашего сайта в /var/www/ и передаем права на нее нашему пользователю webuser :

4. Создаем файл конфигурации виртуального хоста для school.ru:

И прописываем в нем:

ServerName school.ru
ServerAdmin [email protected]
ServerAlias www.school.ru
DocumentRoot /var/www/school.ru
CustomLog $/school.ru.access.log combined
ErrorLog $/school.ru.error.log
AssignUserID webuser webuser

Options -Includes -Indexes -ExecCGI

Источник

Site does not exist error for a2ensite

I have cmsplus.dev under /etc/apache2/sites-available with the following code,

Now when I use sudo /usr/sbin/a2ensite cmsplus.dev , I am getting the error,

My webserver Apache/2.4.6 (Ubuntu)

How to solve this issue?

10 Answers 10

Solved the issue by adding .conf extension to site configuration files.

Apache a2ensite results in:

Problem; If you found the error while trying to enable a site using:

Error: example.com does not exist

a2ensite is simply a Perl script that only works with filenames ending .conf

Therefore, I have to rename my setting file for example.com to example.com.conf as might be achieved as follows:

You probably updated your Ubuntu installation and one of the updates included the upgrade of Apache to version 2.4.x

In Apache 2.4.x the vhost configuration files, located in the /etc/apache2/sites-available directory, must have the .conf extension.

Using terminal (mv command), rename all your existing configuration files and add the .conf extension to all of them.

If you get a «Permission denied» error, then add «sudo » in front of your terminal commands.

You do not need to make any other changes to the configuration files.

Enable the vhost(s):

And then reload Apache:

Your sites should be up and running now.

UPDATE: As mentioned here, a Linux distribution that you installed changed the configuration to Include *.conf only. Therefore it has nothing to do with Apache 2.2 or 2.4

Источник

Оцените статью