Bitrix24 не работает push

Настройка сервера очередей Push and Pull

Сервер очередей Push and Pull служит для мгновенного взаимодействия между собой многих инструментов Битрикс24. Он используется в Задачах, в Календарях, в ленте Новостей, в Группах, в RPA, в мобильном приложения Битрикс24, в чатах, в генераторе документов, в Телефонии, в Центре продаж и в других сервисах Битрикс24.

В весной 2021 года будет выпущено обновление модуля Веб-мессенджера (im) 20.400.0. После установки данного обновления поддержка работы чатов без настроенного сервера очередей модуля Push and Pull будет прекращена.

Осенью 2021 года будет прекращена поддержка старых версий локальных серверов очередей Nginx-PushStreamModule 0.3.4/0.4.0 и Bitrix Push server 1.0.

Поэтому мы рекомендуем вам заранее настроить сервер очередей – облачный сервер «1С-Битрикс» или локальный Bitrix Push server 2.0.

Облачный сервер очередей «1С-Битрикс»

Самый простой вариант, требует только активную лицензию на продукт «1С-Битрикс». Также удобен, если продукт «1С-Битрикс» установлен на shared-хостинге или вместо виртуальной машины VMBitrix используется собственное серверное окружение.

Перейдите в административном разделе: Настройки > Настройки продукта > Настройки модулей > Push and Pull, выберите вариант Облачный сервер «1С-Битрикс» и географическое расположение сервера по желанию (можно оставить автоматический выбор). Остается только нажать на кнопку Зарегистрироваться:

Все готово, облачный сервер очередей «1С-Битрикс» настроен и активен:

Локальный Bitrix Push server

Есть случаи, когда нельзя использовать в качестве сервера очередей облачный сервер «1С-Битрикс», например закрытый контур на предприятии, без доступа сервера в интернет. Для такого случая есть возможность установить локальный сервер очередей.

Так как в скором времени будет отключена поддержка старых версий сервера очередей, то мы будем устанавливать сразу Bitrix Push server 2.0.

1. Обновление VMBitrix

Обновите виртуальную машину VMBitrix до последней стабильной версии: 2. Configure localhost settings > 6. Update server.

2. Установка Bitrix Push server 2.0

По умолчанию в виртуальной машине VMBitrix версии 7.4.4 и ниже в качестве сервера очередей используется Nginx-PushStreamModule.

Читайте также:  Vsh меню psp не работает

В главном меню виртуальной машины VMBitrix: 9. Configure Push/RTC service for the pool смотрим, какой сервер используется в качестве сервера очередей. В данном примере видим, что это действительно Nginx-PushStreamModule:

Выбираем пункт меню 1. Install/Update NodeJS RTC service, вводим название хоста Hostname и подтверждаем установку:

Дожидаемся, пока задача по установке и запуску службы NodeJS-PushServer будет закончена:

3. Bitrix Push server 2.0 в продуктах «1С-Битрикс»

Перед установкой Bitrix Push server 2.0 вам нужно предварительно сбросить настройки сервера очередей. Для этого нажмите на кнопку По умолчанию:

Далее в опции Использовать «Push server»: установленный локально выберите Виртуальная машина 7.3 и новее (Bitrix Push server 2.0) и сохраните настройки:

Все готово. Как правило, никаких настроек больше не требуется.

4. Ошибки Bitrix Push server 2.0

При установке и первом запуске Bitrix Push server 2.0 создается уникальный секретный код в файле настроек сервера очередей /etc/push-server/push-server*.json в секции security в параметре key :

В виртуальной машине BitrixVM при первом запуске Bitrix Push server 2.0 этот код автоматически прописывается в файл настроек ядра системы /bitrix/.setting.php и в базу данных, а также он виден в административном интерфейсе в поле Код-подпись для взаимодействия с сервером:

Бывают ситуации, когда по каким-либо причинам в файле настроек ядра /bitrix/.setting.php и в базе данных секретный код отличается от того, который прописан в настройках сервера очередей. Из-за этого сервер очередей работает некорректно, сообщения не доставляются.

Чтобы решить эту проблему, необходимо в меню виртуальной машины BitrixVM пересоздать роль NodeJS-PushServer: 9. Configure Push/RTC service for the pool > 1. Install/Update NodeJS RTC service

Если у вас свое серверное окружение, то можно сделать это вручную:

  1. Скопировать ключ из файла настроек сервера очередей /etc/push-server/push-server*.json.
  2. Перейти в административном интерфейсе продукта «1С-Битрикс»: Настройки > Настройки продукта > Настройки модулей > Push and Pull и сбросить настройки сервера очередей кнопкой По умолчанию.
  3. Скопированный ключ вставить в поле Код-подпись для взаимодействия с сервером и сохранить настройки.

После этого работа сервера очередей будет восстановлена.

Источник

Как включить push-уведомления?

Push-уведомления – это короткие сообщения, которые сервисы рассылает на мобильные устройства.

Push-уведомления появляются поверх мобильного приложения или на заблокированном экране мобильного устройства:

Если кликнуть на это уведомление, то вы будете перенаправлены в тот раздел или инструмент, откуда пришло это уведомление – например в задачу, в пост ленты Новостей или в чат.

Читайте также:  Логин билайн ру не работает

Как включить push-уведомления

Проверьте в настройках мобильного приложения в разделе Уведомления, включена ли опция Получать уведомления:

Далее проверьте, включена ли в настройках уведомлений 1 Битрикс24 отправка push-уведомлений 2 :

В расширенном режиме 3 вы можете настроить push-уведомления 4 для определенных действий:

Если push-уведомления не приходят, проверьте настройки вашего телефона. Уведомления могут блокироваться самой системой мобильного телефона.

Источник

не работает чат (и кое-что ещё) в мобильном приложении. Подозрение на Push and Pull

Добрый день. Пользовались облачной версией bitrix24. Перешли на коробочную. Развернул BitrixWM. Развернул предоставленный бэкап, с помощью скрипта restore.php. Была огромная куча ошибок в Настройки -> Инструменты -> Проверка системы. Сейчас проверки выполняются, есть замечания в «Отправка почтовых уведомлений», однако сообщения на почту отправляются.
И дело совсем не в почте, а в мобильном приложении, которое при подключении, не может загрузить чаты, задачи и т.п. Просто появляется «подождите немного» и висит.
По скольку описание ошибок связанных с «Бизнес Чатом в реальном времени» и «Мобильном приложении» всегда ссылаются на некорректную настройку Push&Pullб, думаю, что проблема связанна с этим модулем.

Так же после развёртывания бэкапа на ВМ провёл этапы настройки из menu.sh. В том числе активировал NodeJS-PushServer. Однако тесты не проходили, тогда
в веб админке дополнительно указал следующие настройки модуля:
— Виртуальная машина 7.3 и новее (Bitrix Push server 2.0)
— http://[реальное_доменное_имя]:8895/bitrix/pub/
— ключ указал из команды grep SECURITY_KEY /etc/sysconfig/push-server-multi

Над BitrixWM стоит apache2, на котором настроено проксирование доменного имени и портов 80, 443 (сертификаты Lets Encrypt лежат на apache2), а так же 8890, 8891, 8893, 8894, 8895, 5222, 5223, 8070 — эти порты были указаны в различных мануалах по настройке Push&Pull. Все ли порты эти нужны?

п.с.: ТП в чате со мной общаться перестали. Даже «Здравствуйте! Передаю ваш диалог техническому специалисту, который. » не отвечают. По телефону ТП не осуществляется. Форум читал.

Источник

Bitrix24 не работает push

Проблема с push-сервером

После установки из 1С-Битрикс: Веб-окружение коробочной версии Bitrix24 не работает push, не приходят уведомления через локальный сервер (красная строка Отсутствует соединение с сервером). В настройках Push and Pull был выбран локальный сервер с Виртуальной машиной 7.3 и новее (Bitrix Push server 2.0), остальные настройки по-умолчанию:

Читайте также:  Не работает сигнал опель кадет

Ошибка с функцией padStart()

В логах push-сервера (/var/log/push-server/error и /var/log/push-server/system-error) повторялась одна и та же ошибка:

Как оказалось, функция padStart появилась в node 7 версии, а с окружением установился node 6 (почему так – вопрос к разработчикам):

Замена функции padStart простым кодом

Функция padStart заполняет строку другой строкой до определенной длины и используется в push-сервере для создания уникальных идентификаторов лог-записей. Лучшим решением, конечно же, было бы обновить node до 8 версии. Но так как я не знаю, на каких модулях это может отразится, было решено заменить функцию padStart на простой код, тем более что встречается функция всего лишь два раза.

Открываем редактором /opt/push-server/lib/debug/index.js и в функции getUniqueId() заменяем ‘return process.pid + “T” + (++requestId).toString().padStart(8, “0”);’ на следующий код:

и в /opt/push-server/lib/storages/redis.js в функции getMessageId(callback) заменяем ‘const + messageCounter.toString().padStart(16, “0”), “hex”);’ на:

В обоих файлах остались закомментированные оригинальные строки.

После этого перезагружаем push-сервер:

На этом все. Сервер запустится, а в логах больше не будет ошибок связанных с функцией padStart и пропадет надоедливая строка на портале Отсутствует соединение с сервером.

Источник

Не работает Push&Pull

Добрый день! у меня такая же проблема.

Стоит VA Bitrix 7.4.0 с NodeJS.
Подскажите что надо донастроить.
Вот вывод системы:

2019-Jul-20 23:33:42 Бизнес-чат в реальном времени (check_pull_stream): Fail

Server version: 3 (Bitrix Push server)

Connection to 91.122.44.199:80 Success
Connection to 127.0.0.1:8895 Success
== Request ==

HTTP/1.0 Host: 127.0.0.1

Content-Length: 32 0c90fbcedbe6d53da456242bdb3a39f5

HTTP/1.1 301 Moved Permanently
========== == Request ==

GET /bitrix/sub/?CHANNEL_ID=e20b54efd37c812a50d90d4850eac75b.7d3ec15559d6dee3fdb16821e3955f317cd908b9
HTTP/1.0 If-Modified-Since: Fri, 19 Jul 2019 23:33:02 +0300

Host: 91.122.44.199
== Response ==
== Body ==

HTTP/1.1 304 Not Modified
Server: nginx/1.16.0

Date: Sat, 20 Jul 2019 20:33:42 GMT

Content-Type: text/plain
Connection: close
Access-Control-Allow-Origin: *
Access-Control-Expose-Headers: Last-Message-Id
Last-Message-Id:

Expires: Thu, 01 Jan 1973 11:11:01 GMT

==========
Connection to 127.0.0.1:8895 Success

Ошибка! Модуль nginx-push-stream работает некорректно 2019-Jul-20 23:33:42
Живые комментарии в ленте сообщений (check_pull_comments): Fail

Ошибка! Не настроен модуль nginx push-stream, который необходим для отображения комментариев в живой ленте в реальном режиме времени

2019-Jul-20 23:33:42 Видеозвонки (check_turn): Fail

Ошибка! Не настроен модуль nginx push-stream, который необходим для осуществления видеозвонков

2019-Jul-20 23:33:43 Мобильное приложение Битрикс24 (check_access_mobile): Ok

Источник

Оцените статью