[Решено] Не найдены команды sip
@zerox с отсутствием команды sip show peers я разобрался — оказалось, что вся проблема заключалась в том, что я из-за своей незрячести не корректно ее вводил.
Но музыка недолго играла. Теперь asterisk выел мне мозг следующей штукой:
== Using SIP RTP CoS mark 5
> 0x7fcf7c024ef0 — Strict RTP learning after remote address set to: 185.45.152.154:14936
— Executing [196082@incoming-calls:1] Dial(«SIP/196082-00000004», «SIP/303») in new stack
[Jul 15 1131] WARNING[1189][C-00000005]: app_dial.c:2598 dial_exec_full: Unable to create channel of type ‘SIP’ (cause 20 — Subscriber absent)
— No devices or endpoints to dial (technology/resource)
— Auto fallthrough, channel ‘SIP/196082-00000004’ status is ‘CHANUNAVAIL’
== Using SIP RTP CoS mark 5
> 0x7fcf7c024ef0 — Strict RTP learning after remote address set to: 185.45.152.154:11978
— Executing [196082@incoming-calls:1] Dial(«SIP/196082-00000005», «SIP/303») in new stack
[Jul 15 1131] WARNING[1191][C-00000006]: app_dial.c:2598 dial_exec_full: Unable to create channel of type ‘SIP’ (cause 20 — Subscriber absent)
— No devices or endpoints to dial (technology/resource)
— Auto fallthrough, channel ‘SIP/196082-00000005’ status is ‘CHANUNAVAIL’
В сети вычитал по этому поводу «CHANUNAVAIL — это вторичный отчет, обычно означающий, что одноранговый узел не определен, не зарегистрирован или не прошел квалификацию.», а так же, что конечный абонент отсутствует.
Попробовал варианты решения с разных форумов — без толку.
server*CLI> sip show peers
Name/username Host Dyn Forcerport Comedia ACL Port Status Description
196082/196082 185.45.152.161 Yes Yes 5060 OK (32 ms)
303 (Unspecified) D Yes Yes 0 Unmonitored
2 sip peers [Monitored: 1 online, 0 offline Unmonitored: 0 online, 1 offline]
server*CLI> sip show registry
Host dnsmgr Username Refresh State Reg.Time
sip.zadarma.com:5060 N 196082 105 Registered Thu, 15 Jul 2021 1001
1 SIP registrations.
настройки sip.conf взяты с сайта zadarma, поэтому строка «#include sip_registrations.conf» была удалена, иначе тогда отображаются две одинаковые регистрации в консоли.
Думал причина в этом, но нет.
Затем перечитав еще раз вашу статью по настройке asterisk заметил, что iptables то я настроил, но упустил настройку портов — в консоли по очереди ввел:
iptables -A INPUT -p udp -m udp —dport 5060 -j ACCEPT
и
iptables -A INPUT -p udp -m udp —dport 10000:20000 -j ACCEPT
Никаких ошибок не возникло, но и это не помогло.
Пока продолжаю поиски решения, но может здесь подскажут в чем дело.
Источник
Sip show peers не работает
Модератор: april22
Не отображаются зарегистрированные пиры
guvijur » 31 май 2018, 18:05
Доброго всем дня.
Начал я своё знакомство с Asterisk ещё с версии 1.4, потом была 1,6 и всё было гуд до тех пор, пока 1,6 не стала зависать при большом потоке разговоров, я перешёл на 1,8, которую юзаю до сих пор.
Тут начальство поставило некую задачку по телефонии и мне пришлось наливать очередной сервер. Я подумал, что было бы неплохо посмотреть на новые версии и я решил выбрать последнюю.
Я установил CentOS 6.9 x64, установил необходимые пакеты и библиотеки. В процессе сборки астериска возникло 3 новые ошибки, которые решились установкой 3 новых библиотек. Как итог — астериск работает. Я не очень люблю конфигурационные файлы для хранения настроек сипов и отчётов, поэтому изначально прикручиваю MySQL. Всё настроил. Завожу в таблицу sippeers номер, прописываю настройки на телефоне:
Re: Не отображаются зарегистрированные пиры
asterisker » 31 май 2018, 18:35
Re: Не отображаются зарегистрированные пиры
Repz » 31 май 2018, 18:39
Re: Не отображаются зарегистрированные пиры
ded » 31 май 2018, 18:45
Скорее всего Вы используете не просто MySQL, а модель работы realtime. При которой не требуется делать sip reload, и аккаунты хранятся в базе MySQL как sip_buddies — sippeers.
Источник
[Решено] Не найдены команды sip
Всем доброго времени суток!
Решил установить и пощупать asterisk 18.4.0 и все было хорошо до момента проверки пиров и регистраций.
Дело в том, что при попытке выполнения команд «sip show peers» выдает сообщение:
«Asterisk 18.4.0, Copyright (C) 1999 — 2021, Sangoma Technologies Corporation and others.
Created by Mark Spencer
Asterisk comes with ABSOLUTELY NO WARRANTY; type ‘core show warranty’ for details.
This is free software, with components licensed under the GNU General Public
License version 2 and other licenses; you are welcome to redistribute it under
certain conditions. Type ‘core show license’ for details.
=========================================================================
Running as user ‘asterisk’
Running under group ‘asterisk’
Connected to Asterisk 18.4.0 currently running on server (pid = 957)
server*CLI> SIP SHOW PEERS
No such command ‘SIP SHOW PEERS’ (type ‘core show help SIP SHOW’ for other possible commands)
«
Такая же история при попытке использовать «sip show registery».
В сети нашел совет перезагрузить модуль chan_sip.so — результат:
«server*CLI> module reload chan_sip.so
No such module ‘chan_sip.so'»
Далее попробовал загрузить модуль в ручную командой «server*CLI> module load chan_sip.so», после чего команда «sip show peers» заработала, а «sip show registery» — нет.
В файле modules.conf почему-то модуль оказался отключен «noload = chan_sip.so., После того, как была закомментирована данная строка — ситуация не изменилась, пиры показывает, а регистрации нет.
В прикрепленном файле messages из /var/log/asterisk лог моих выше описанных действий, включая полную перезагрузку виртуальной машины после комментирования строки в файле modules.conf
Ребят, где я накосячил и как это исправить?
Ребят, неужели никто не может подсказать почему при загруженном модуле chan_sip не обнаруживаются команды для работы с sip и как это исправить??
@architect Так может регистрации просто не настроены, либо настроены неправильно? Раз пиры показываются, значит модуль загружен и нормально работает.
@architect Так может регистрации просто не настроены, либо настроены неправильно? Раз пиры показываются, значит модуль загружен и нормально работает.
Я тоже так подумал, но во-первых — на сайте zadarma, в настройках подключения пишет «#XXXXXX (SIP) — online», а во-вторых — в логах asterisk:
[Jul 11 1849] NOTICE[965] chan_sip.c: Peer ‘zadarma-XXXXXX’ is now Reachable. (32ms / 400ms)
Правду сказать, была одна непонятная ситуация с регистрацией на стороне zadarma — asterisk почемуто постоянно сыпал сообщением вида:
[Jul 10 1720] NOTICE[965] chan_sip.c: Registration from ‘»105″ ‘ failed for ‘138.91.246.75:5269’ — Wrong password
[Jul 10 1720] NOTICE[965] chan_sip.c: Registration from ‘»105″ ‘ failed for ‘138.91.246.75:5269’ — Wrong password
[Jul 10 1720] NOTICE[965] chan_sip.c: Registration from ‘»105″ ‘ failed for ‘138.91.246.75:5269’ — Wrong password
[Jul 10 1720] NOTICE[965] chan_sip.c: Registration from ‘»105″ ‘ failed for ‘138.91.246.75:5269’ — Wrong password
[Jul 10 1720] NOTICE[965] chan_sip.c: Registration from ‘»105″ ‘ failed for ‘138.91.246.75:5269’ — Wrong password
Несколько раз пробовал менять пароли, но он упорно сыпал этим сообщением, а потом перестал. До сих пор ломаю голову что ему было не так.
А теперь он сыпет сообщения вида:
[Jul 11 1850] WARNING[928] chan_sip.c: chan_sip has no official maintainer and is deprecated. Migration to
[Jul 11 1850] WARNING[928] chan_sip.c: chan_pjsip is recommended. See guides at the Asterisk Wiki:
[Jul 11 1850] WARNING[928] chan_sip.c: https://wiki.asterisk.org/wiki/display/AST/Migrating+from+chan_sip+to+res_pjsip
[Jul 11 1850] WARNING[928] chan_sip.c: https://wiki.asterisk.org/wiki/display/AST/Configuring+res_pjsip
[Jul 11 1855] NOTICE[965][C-00000001] chan_sip.c: Failed to authenticate device 666 ;tag=7a10e7ca for INVITE, code = -1
[Jul 11 1808] NOTICE[965][C-00000002] chan_sip.c: Failed to authenticate device 666 ;tag=f1f98da3 for INVITE, code = -1
[Jul 11 1820] NOTICE[965][C-00000003] chan_sip.c: Failed to authenticate device 666 ;tag=b53d9853 for INVITE, code = -1
[Jul 11 1832] NOTICE[965][C-00000004] chan_sip.c: Failed to authenticate device 666 ;tag=9dc3ee32 for INVITE, code = -1
[Jul 11 1845] NOTICE[965][C-00000005] chan_sip.c: Failed to authenticate device 666 ;tag=a48f82cf for INVITE, code = -1
[Jul 11 1857] NOTICE[965][C-00000006] chan_sip.c: Failed to authenticate device 666 ;tag=8e50a5d8 for INVITE, code = -1
[Jul 11 1810] NOTICE[965][C-00000007] chan_sip.c: Failed to authenticate device 777 ;tag=e98675bd for INVITE, code = -1
[Jul 11 1820] NOTICE[965][C-00000009] chan_sip.c: Failed to authenticate device ;tag=1967633028 for INVITE, code = -1
[Jul 11 1822] NOTICE[965][C-0000000a] chan_sip.c: Failed to authenticate device 777 ;tag=a9ef0d8f for INVITE, code = -1
[Jul 11 1825] NOTICE[965][C-0000000b] chan_sip.c: Failed to authenticate device ;tag=677664245 for INVITE, code = -1
[Jul 11 1831] NOTICE[965][C-0000000c] chan_sip.c: Failed to authenticate device ;tag=2105694205 for INVITE, code = -1
[Jul 11 1834] NOTICE[965][C-0000000d] chan_sip.c: Failed to authenticate device 777 ;tag=43816328 for INVITE, code = -1
[Jul 11 1837] NOTICE[965][C-0000000e] chan_sip.c: Failed to authenticate device ;tag=1553925188 for INVITE, code = -1
[Jul 11 1839] NOTICE[965][C-0000000f] chan_sip.c: Failed to authenticate device ;tag=1636033393 for INVITE, code = -1
[Jul 11 1843] NOTICE[965][C-00000010] chan_sip.c: Failed to authenticate device ;tag=972763862 for INVITE, code = -1
[Jul 11 1847] NOTICE[965][C-00000011] chan_sip.c: Failed to authenticate device 777 ;tag=14d90c8e for INVITE, code = -1
[Jul 11 1849] NOTICE[965][C-00000012] chan_sip.c: Failed to authenticate device ;tag=1677467202 for INVITE, code = -1
[Jul 11 1851] WARNING[965] chan_sip.c: Timeout on 293103188-2060662777-1157551474 on non-critical invite transaction.
[Jul 11 1852] WARNING[965] chan_sip.c: Retransmission timeout reached on transmission 1545057029-1182150200-1107846933 for seqno 2 (Critical Response) — See https://wiki.asterisk.org/wiki/display/AST/SIP+Retransmissions
Packet timed out after 32000ms with no response
[Jul 11 1855] NOTICE[965][C-00000013] chan_sip.c: Failed to authenticate device ;tag=1966271407 for INVITE, code = -1
[Jul 11 1857] WARNING[965] chan_sip.c: Retransmission timeout reached on transmission 1455645280-202907687-1363464572 for seqno 2 (Critical Response) — See https://wiki.asterisk.org/wiki/display/AST/SIP+Retransmissions
Packet timed out after 32000ms with no response
[Jul 11 1859] NOTICE[965][C-00000014] chan_sip.c: Failed to authenticate device 777 ;tag=8db153d7 for INVITE, code = -1
[Jul 11 1801] NOTICE[965][C-00000015] chan_sip.c: Failed to authenticate device ;tag=396730919 for INVITE, code = -1
[Jul 11 1802] NOTICE[965][C-00000016] chan_sip.c: Failed to authenticate device ;tag=1503328319 for INVITE, code = -1
[Jul 11 1803] WARNING[965] chan_sip.c: Retransmission timeout reached on transmission 78087331-465191891-1920907649 for seqno 2 (Critical Response) — See https://wiki.asterisk.org/wiki/display/AST/SIP+Retransmissions
Packet timed out after 32000ms with no response
Искал решение в сети, но пока так и не понял что теперь ему не так. Я понимаю, что он не может аутентифицировать устройство и я так подозреваю, что в следствии этого возникает второе предупреждение, но вот вопрос — что не так и как поправить?
Источник
asterisk решение проблемы
С переборами паролей, флудам и проч пакастью вроде как разобрался.
Теперь в консоле у меня периодически выходят предупреждения:
что значит Unspecified, почему задействованы порты 5064, 5106 и т. д.
ведь астериск работает на порту 5060? правильно же.
вот, еще периодически выскакивает и это кстати уже давно.
Помогите люди добрый. всем спасибо.
Если еще актуально, давай разберемся. Я так понял астер у тебя голой попой в интернете смотрит?
Для начала обрати внимание на опции в sip.conf allowexternalinvites allowguest alwaysauthreject и иже с ними, в общем все те опции которые отвечают за безопасность. Почитай доку если не дойдет пиши будем копать дальше.
И да ты же используешь шифрование в sip?
Вы всё правильно поняли. 🙂
Так было вчера и позавчера. сегодня я внес некоторые изменения в правила.
По идеи, если правильно все понимаю. сип доступен только с заданной мной подсети из внутренний сети, а из интернета не получится. Может и ошибаюсь. Если ошибаюсь поправьте меня пожалуйста.
Для начала обрати внимание на опции в sip.conf allowexternalinvites allowguest alwaysauthreject и иже с ними, в общем все те опции которые отвечают за безопасность. Почитай доку если не дойдет пиши будем копать дальше.
Спасибо за советы.
sip.conf
по рекомендациям в интренте я добавил эти позиции в sip.conf
по поводу шифрования, я даже не знаю. 🙂 и пока ответить ничего не смогу.
Ок. Тогда еще не хватает указания мастеру где эти ваши внешние сети и где локальные. Например так :
Так же советую глянуть в сторону pjвsip и tls транспорт.
Далее, по поводу Unspecified и таблицы пиров, у вас там все нормально. Unspecified Говорит о том, что астер не может получить инку о данном пире но он есть в конфете. Т.е. Хост пира может быть просто отключен.
Asked to transmit frame type 64, while native formats is 0x8 (alaw)(8)
Интересно что за версия мастера? Это старый баг с транскодингом..
pri_dchannel: Hangup on bad channel 0/11 on span 2
Тут бы вам разобраться как работает dhdi в астре.
Спасибо за ваш ответ.
Я правильно понимаю это необходимо добавить в sip.conf?
И какую сеть указать рабочую? 1.0/24 или ту, на которой настроены голосовые шлюзы, шлюзы у меня настроены на 5.1/24
версия Asterisk 1.6.1.10
Тут бы вам разобраться как работает dhdi в астре
Спасибо. Буду разбираться.
И какую сеть указать рабочую? 1.0/24 или ту, на которой настроены голосовые шлюзы, шлюзы у меня настроены на 5.1/24
В в сеть с телефонами.
И Очень советую обновится до 12 астера.. там куча проблем уже решена.
Обновляться боюсь, сейчас точно, если что сламаю не уверен что получится починить. у меня астер стоит на шлюзе, поэтому я указал рабочую подсеть и подсеть сипа. Надеюсь так правильно.
Для чего если не секрет астер во внешку открыт ?
Не для чего, просто исходя из моих соображений если его закрыть невозможно будет звонить в далекие края. )
Источник